Th3_uN1Qu3

KernelEx App Compatibility Database

155 posts in this topic

I was thinking about the database Wine has, and we should make one too for KernelEx so people know exactly what works and what not. For now it could just be in this topic, then we could expand it on a site like the Wine AppDB is. One would just search for the program he wants to use and find info.

I'm a fan of bishoujo (dating sim) games, and even patched one to run properly on XP and Vista. The game engines are usually scripted, and they depend a lot on certain functions of the OS they were built on so they are very fussy when it comes to compatibility. I can provide info on lots of crappily coded games. :thumbup

Edit concerning games: Check this thread for more info. ;)

So let's start it. I'll first put in the programs reported as working by Xeno86 then put my list in. ;)

What works:

Alcohol 120% 1.9.5.3105

Notes: This is the last version working natively in 9x, without needing any patches. Why not stick with what works? I've never had any problem with this version, as a matter of fact i still use it on my dual-PIII running XP.

Adobe Flash Player Plugin for Opera/Firefox

Notes: Needs temporary replacing of [HKLM\Software\Microsoft\Windows\CurrentVersion] VersionNumber key to "5.10.2600" to install - DON'T FORGET to change it back!!!

bbLean

Firefox 3

foobar2000 0.9.4.x

Notes: Needs setting of [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion] CurrentVersion key to 5.1 DON'T FORGET to delete it afterwards!!!

K-Lite Codec Pack

Notes: DON'T let it to "correct the registry", and i prefer to just use KMPlayer.

Meedio

MSN Messenger 7.0.820

Notepad2

OpenOffice.org

Photoshop CS

PunkBuster

Skype

Triple Cheese

Visual C++ Toolkit 2003

What doesn't work:

Yahoo Messenger 9 Beta

Why: Does not want to install and says it needs Win2k or higher no matter what compatibility i set in KernelEx or registry.

Sound Forge 9.0e

Why: Doesn't install, says "The operating system does not support this application". Anyone know how to trick the new InstallShield?

Corel Paint Shop Pro Photo X2

Why: Installs from the .msi but doesn't run. No error message. Corel did nothing but bloat it anyway, so i'll stick to Paint Shop Pro 8, the last version released by Jasc. :)

Edited by Th3_uN1Qu3
0

Share this post


Link to post
Share on other sites
:whistle: Msn Messenger-all versions (*crash!);Windows Messenger-(Shaky Usage and crashes).....at least with Kex 0.3.2-0.3.4....Will test newKex0.3.5 soon next few days ; Brilliant Topic-GREAT Idea's;Wish more people could do the same ? :thumbup
0

Share this post


Link to post
Share on other sites
:whistle: Msn Messenger-all versions (*crash!);Windows Messenger-(Shaky Usage and crashes).....at least with Kex 0.3.2-0.3.4....Will test newKex0.3.5 soon next few days ; Brilliant Topic-GREAT Idea's;Wish more people could do the same ? :thumbup

MSN Messenger 7.0.820 works fine.

0

Share this post


Link to post
Share on other sites
Corel Paint Shop Pro Photo X2

Why: Installs from the .msi but doesn't run. No error message. Corel did nothing but bloat it anyway, so i'll stick to Paint Shop Pro 8, the last version released by Jasc. :)

Isn't the last version released by Jasc 9.0?

0

Share this post


Link to post
Share on other sites

Th3_uN1Qu3, I suggest you browse through the whole KernelEx topic, because there is lots of info to pull out.

The cmd.exe problem seems to be fixed by taking a copy of command.com and renaming it to cmd.exe and then placing it in \WINDOWS\COMMAND.

I did this for one game install.

0

Share this post


Link to post
Share on other sites
Isn't the last version released by Jasc 9.0?

Could be, didn't check. :P

Th3_uN1Qu3, I suggest you browse through the whole KernelEx topic, because there is lots of info to pull out.

Will do. Edit: Checked the whole topic and added to the list accordingly.

The cmd.exe problem seems to be fixed by taking a copy of command.com and renaming it to cmd.exe and then placing it in \WINDOWS\COMMAND.

I did this for one game install.

Forget that, Universal Extractor 1.6 beta works.

Edited by Th3_uN1Qu3
0

Share this post


Link to post
Share on other sites
:rolleyes: MSN 7 and up with Kex0.3.3-0.3.4 collapses daily (buggy!)I even can not use free MSN Services from My I.P.Carrier! Too much dazzle or incompatability with newer Kex's;***I use Kex 0.3.2a with only MSN7 and up is limited useage@2hours uptime.*WILL try Kex0.3.5 later in week .with a scheduled Re-install on a new and older MoBo soon. *Special Note:Some of my W2K Applications slip into my 98SE systems by accident and "oddly" enough they run "Great"on 98SE with any Kex version (usually0.3.2aKex)installed and usually these just will not run and close abruptly(***"with an improper system notification") ......though lately i integrated some of these to become TSR programs in my 98SE system-and they're still running "Great"...hmmmmmm*Noteworthy to investigate which other appl's may work with 98SE too! :whistle: *To:Marxo-Is Your MSN Messenger7 from MSN Member Center or Microsoft ?*Mine is MSN MemberCenter and this could be problem-as Skype2.5.14.140 U3-edition is "Too buggy/nosey" works with my Kex ,not MSN7 though?
0

Share this post


Link to post
Share on other sites

Well, the only version that is actually working is MSN Messenger 7.0.820, because older require to be updated to Live. You can download it from Microsoft's Download Center.

I run it daily on my WLP machine.

BTW, I don't know which K-Lite Codec Pack version you are referring to, because 3.4.5 is the last official supported, and I wouldn't count that 4.0 really works, because KEx has nothing to with particular codecs.

Edited by marxo
0

Share this post


Link to post
Share on other sites
BTW, I don't know which K-Lite Codec Pack version you are referring to, because 3.4.5 is the last official supported, and I wouldn't count that 4.0 really works, because KEx has nothing to with particular codecs.

It doesn't have to do with the codecs but it does with the installer. Latest version works without issues. Thanks for the info on MSN, added to the list.

0

Share this post


Link to post
Share on other sites
BTW, I don't know which K-Lite Codec Pack version you are referring to, because 3.4.5 is the last official supported, and I wouldn't count that 4.0 really works, because KEx has nothing to with particular codecs.

It doesn't have to do with the codecs but it does with the installer. Latest version works without issues. Thanks for the info on MSN, added to the list.

Yea, but new codecs can create a problem with Windows 98, it has nothing to do with KEx, it has to do with new versions of codecs. I hope you know what I mean, because it is pointless to make installer compatible if the codec itself won't work.

Also, MSN Messenger 7.0.820 is compatible with Windows 98 without KEx.

Edited by marxo
0

Share this post


Link to post
Share on other sites
:blushing: I use ZONEALARM and there was a "BUG" with Microsoft Update KB951748 and internet connectivity after i applied MDCU3.0e and MDIECU2,2 .....so MSN Messenger still might or not be source of Kex's problems on my other MoBo's? *AS this IntelDesktop1998-ca810e 192Ram/467mhzCeleron runs with "Great-with Kex0.3.2a/MSM Messenger7" -with MDCU3.0e and MDIECU2.1a! :rolleyes: I still believe any application W2K or XP (even Vista)can work with 98SE and Kex -it has to do with certain MS uodates and especially enough MemoryRam? :sneaky: As my 64mb/Ram MoBo;and 128mb/Ram MoBo do not like Kex above 0.3.2aversion; and my 192mb/Ram MoBo;and 256mb/Ram MoBo do like Kex 0.3.2a and 0.3.4
0

Share this post


Link to post
Share on other sites
ea, but new codecs can create a problem with Windows 98, it has nothing to do with KEx, it has to do with new versions of codecs. I hope you know what I mean, because it is pointless to make installer compatible if the codec itself won't work.

Well, my point is that the codecs work not only the installer. :)

0

Share this post


Link to post
Share on other sites
:blushing: Why would ,say Kex0.3.4-0.3.5 run with 98SE and FF3/with FlashPlayer10,and Shockwave11 on a 256mb/Ram MoBo and not with 128mb/Ram MoBo???(Same installs exactly and PentiumIII/Slot1 CPU's@500mhz <tweaked somewhat :whistle: > and ViaApollo/Shuttle Boards)
0

Share this post


Link to post
Share on other sites

Because Firefox, Flash and Shockwave are all memory hogs. I wouldn't run an internet machine with less than 256MB RAM anyway.

0

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.