Th3_uN1Qu3

KernelEx App Compatibility Database

155 posts in this topic

Thanx for starting this much needed list.

Notepad2 is broken insofar as anything that you copy to repaste elsewere is not in fact available to be pasted.

Instead get Notepad2 version 2.0.12 ANSI which doesn't need the kernelex (you may need to use the waybackmachine with http://www.flos-freeware.ch/zip/notepad2_1.0.12.zip to get it).

Calcplus.exe from XP works, although if installed via the calcplus.msi (as opposed to simply copying the binary), Orca must be used to edit the launch conditions.

Media Player Classic Unicode [HomeCinema] works with the addition of psapi.dll in its directory and the exclusion of the program itself from kexver.ini (seems strange to me).

Media Player Classic Unicode 6.4.9.1 works with the exclusion of the program itself from kexver.ini.

MS Paint works as advertised by Tiniy.

And according to Tihiy: "Google Picasa 3 beta runs very well". "Charmap from XP" and "Adobe Acrobat Reader 7 (with minor problems)".

Winamp 5.35. works but I am not sure that it needs kernelex in the first place (it is not in my kexver.ini in anycase).

Edited by cure
0

Share this post


Link to post
Share on other sites

Allright I think this is a much needed thread. As the title says, it is just meant to list applications that do not normally run under 9x systems but do with KernelEx installed. For anything else, bug reports, feature requests, etc.. please post in the original KernelEx thread.

0

Share this post


Link to post
Share on other sites

Note: There was another topic started, but is now defunct: http://www.msfn.org/board/index.php?showtopic=120479

Some that we know about already:

Mozilla Firefox 3

Adobe Flash 10 (plugin)

OpenOffice.org 3.0

Java Developer Kit 6

Java Runtime Environment 6

Google Picasa 3

PDF-XChange Viewer

Doom 3

Quake 4

Prey

Need for Speed: Most Wanted

The Chronicles of Riddick EFBB Demo

QEmu 0.9

Also Adobe Reader 7.0.9.

How to install:

Download: http://ardownload.adobe.com/pub/adobe/read...dr709_en_US.exe

- Set AdbeRdr709_en_US.exe Compatibility mode to Windows 2000

- Execute AdbeRdr709_en_US.exe

- Installer unpacks files and then fails.

- Browse to C:\Program Files\Adobe\Acrobat 7.0\Setup Files\RdrBig709\ENU

- Using Orca, make the following changes to Adobe Reader 7.0.9.msi:

- Drop row UnSupportedOS (Version9x) from both InstallExecuteSequence and InstallUISequence

- Execute setup.exe

- Remove Adobe Reader Speed Launch from the Startup menu to prevent problems.

- If Acrobat Reader 6 or Acrobat 6 is installed, then run an install repair. This is to repair the Adobe Shell Extensions. The reason for this is that pdfshell.dll from 7.x is not compatible with Windows 9x and causes long hangs in Windows Explorer anytime there are PDF files in the current folder and you click on them...

- Then repair each Acrobat Reader 6/Acrobat 6 update in order (assuming all updates are installed):

-- Adobe Acrobat - Reader 6.0.2 Update

-- Adobe Interactive Forms Update SP1

-- Adobe Acrobat and Reader 6.0.3 Update

-- Adobe Acrobat and Reader 6.0.4 Update

-- Adobe Acrobat and Reader 6.0.5 Update

-- Adobe Acrobat and Reader 6.0.6 Update

If you don't have a copy of Acrobat Reader or Acrobat already installed, then you will have to manually remove the following registry keys:

HKEY_CLASSES_ROOT\CLSID\{F9DB5320-233E-11D1-9F84-707F02C10627}

HKEY_CLASSES_ROOT\Acrobat.AcroAXDoc.1

HKEY_CLASSES_ROOT\AcroExch.Document

HKEY_CLASSES_ROOT\AcroExch.Document.7

HKEY_CLASSES_ROOT\Folder\shellex\ColumnHandlers\{F9DB5320-233E-11D1-9F84-707F02C10627}

If Adobe Reader 7.0 is not default, the use right-click Open With and select Adobe Reader 7.0 or make it the default.

Edited by RetroOS
0

Share this post


Link to post
Share on other sites

IMHO

This list of all KernelEx compatible apps/games/etc should be linked in the 1st post of the main topic:

http://www.msfn.org/board/index.php?showtopic=130936

Also, both this new topic and the old one should be [eventually merged and] organized as a nice list. Any volunteers?

Thanks for your time.

0

Share this post


Link to post
Share on other sites

Seamonkey 2.0a3 works!

Installed KernelEx 4.0 RC2 in 98SE with 98Lite (removes IE and all its components).

The Seamonkey install requires Compatibility set to Win2000SP4, as does Seamonkey.exe.

The install failed to finish, but all files were installed.

It did NOT pick up old settings, and did NOT respond to being run with -GRElocal; the profile was installed in the default \Windows\Application Data\Mozilla\etc.

I will have to do the fixups manually. This could be a bug in the Seamonkey alpha.

But it works fine, if a bit slower than Seamonkey 1.1.14. Could be it's just slower.

Thanks, guys!

0

Share this post


Link to post
Share on other sites
:whistle: Gimp1.2,Gimp2.0-Photo image viewers :thumbup Nero 7 now fully nstalls and runs properly and complete as it does in W2k/XP :blushing:
0

Share this post


Link to post
Share on other sites

Skype and Gimp should work without kernellX. At least version from 6 months ago did.

0

Share this post


Link to post
Share on other sites

Last Notepad2 - Homepage Notepad2 works OK with KernelEx!

My setting (:

[PerApp]
Notepad2.exe=win2000

(NOTE: First edit kexver.ini Notepad.exe=win2000 / replace notepad.exe with notepad2.exe!)

0

Share this post


Link to post
Share on other sites
:whistle:Skype runs from Usb-flash safer than a harddrive as it wastes important memory resources! :rolleyes: Win 98 SE with RP 9,Kex 4.0 rc 2 compatible with ZoneAlarm 4.0 Pro and older versions ;Avast 4.8 , Yahoo CA Anti-spy,and Spybot Search :thumbup Edited by thydreamwalker
0

Share this post


Link to post
Share on other sites
Skype runs

Hmm, not Skype 4.0, correct? I think 3.8 was the last one to work.

0

Share this post


Link to post
Share on other sites

Has anyone tried the latest Yahoo Messenger 9 (YM9)? In the earlier page of this thread, it was posted that the Beta version of YM9 doesn't even install.

0

Share this post


Link to post
Share on other sites

FFDSHOW Universal DirectShowDecoder works fine with KEX 4.0.

It crashes in plain W98SE.

ffdshow_rev2880_20090415 - Download:http://www.afterdawn.com/software/video_software/codecs_and_filters/ffdshow.cfm

0

Share this post


Link to post
Share on other sites
:whistle:Skype runs from Usb-flash safer than a harddrive as it wastes important memory resources! :rolleyes: Win 98 SE with RP 9,Kex 4.0 rc 2 compatible with ZoneAlarm 4.0 Pro and older versions ;Avast 4.8 , Yahoo CA Anti-spy,and Spybot Search :thumbup

Spybot Search... ??? Why with KernelEx? This program compatible with "normal" win 98. Spybot: many system resources, Tea Timer too.

0

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.