• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
Th3_uN1Qu3

KernelEx App Compatibility Database

155 posts in this topic

Guys, I've just installed Adobe Reader 7. It runs nice and seems faster /sleeker than 6 but unfortunately I have empty tooltips (no big deal), no label on tabs (a bit more annoying) and no visible text on bookmarks (very annoying).

Does someone else experience that ?

0

Share this post


Link to post
Share on other sites
Guys, I've just installed Adobe Reader 7. It runs nice and seems faster /sleeker than 6 but unfortunately I have empty tooltips (no big deal), no label on tabs (a bit more annoying) and no visible text on bookmarks (very annoying).

Does someone else experience that ?

Yes, this apparently is normal. See: http://www.msfn.org/board/index.php?s=&amp...st&p=495627

I do, however, see content in the thumbnails in the left-side panel.

Edited by EvanD
0

Share this post


Link to post
Share on other sites

Yeah I see the thumbnails as well but the lack of visible bookmarks text makes it virtually unusable for me unfortunately. Thanks for the head-up ;)

0

Share this post


Link to post
Share on other sites

Acrobat 6 Professional :

I have bought a boxed Adobe Design Collection which includes Acrobat 6 Professional on eBay last week (£20 including post and packaging, bargain of the year, no typo). I've just received it this morning. Of the 4 bundled apps only Acrobat 6 Professional don't want to install on 9x so here goes :

Copy install folder on hdd. Open msi installer with Orca and drop rows UnSupportedOS (9x) in both InstallExecuteSequence and InstallUISequence sections like you'd do for the Adobe Reader 7. Then you can run setup as normal.

The reason it is not compatible with 9x oses seems to be the bundled Preflight plugin which does not want to run because it says it wants an Unicode system.

After putting Acrobat in 2K compatibility mode with a view to enabling the Preflight plugin I found out Acrobat was crashing in msi.dll on launch. I could fix this easily by removing the file AIOD.dll (Adobe Install On Demand) from the Esl folder which is itself located in the Acrobat 6 root directory. Then Acrobat 6 Professional launches normally and the Preflight plug seems to work fine :

snap1676.png

snap1678.png

Cool!

Edited by eidenk
0

Share this post


Link to post
Share on other sites
FlashPlayer 10 - Firefox (2.0.0.20, 2.0.0.22pre, 3.0.7) and Opera /last (install with kernelEx 4 and with "regedit tricks") same problem: test imageshack.us with flash navigation - error, not browse.

Backup to old version....

I have trouble running Flash Player 10 on Firefox 2 as well using KernelEx 4.0 RC 2 on Win98SE. Is it mandatory to use Firefox 3 instead?

0

Share this post


Link to post
Share on other sites
FlashPlayer 10 - Firefox (2.0.0.20, 2.0.0.22pre, 3.0.7) and Opera /last (install with kernelEx 4 and with "regedit tricks") same problem: test imageshack.us with flash navigation - error, not browse.

Backup to old version....

I have trouble running Flash Player 10 on Firefox 2 as well using KernelEx 4.0 RC 2 on Win98SE. Is it mandatory to use Firefox 3 instead?

My "special": on FF2 and Opera old version FlashPlayer (9.0.28.0) - manual backup directory plugins (npnul32.dll and npswf32.dll). Install FlashPlayer 10 (with regedit and Kernelex) for Mozzila (this on Firefox 3), back backup dll on Firefox 2. :whistle:

0

Share this post


Link to post
Share on other sites
My "special": on FF2 and Opera old version FlashPlayer (9.0.28.0) - manual backup directory plugins (npnul32.dll and npswf32.dll). Install FlashPlayer 10 (with regedit and Kernelex) for Mozzila (this on Firefox 3), back backup dll on Firefox 2. :whistle:

Thanks, do you think it will work for Firefox 2? Namely (not installing FF3)

1. Backup the plugins (FF2+Flash9)

2. Install Flash 10 (with regedit and Kernelex) on FF2

3. Restore the plugins files

0

Share this post


Link to post
Share on other sites
My "special": on FF2 and Opera old version FlashPlayer (9.0.28.0) - manual backup directory plugins (npnul32.dll and npswf32.dll). Install FlashPlayer 10 (with regedit and Kernelex) for Mozzila (this on Firefox 3), back backup dll on Firefox 2. :whistle:

Thanks, do you think it will work for Firefox 2? Namely (not installing FF3)

1. Backup the plugins (FF2+Flash9)

2. Install Flash 10 (with regedit and Kernelex) on FF2

3. Restore the plugins files

My system: two Firefox:

old FF 2 / FlashPlayer 9.0.28.0

Firefox 3.5 with new FlashPlayer 10

0

Share this post


Link to post
Share on other sites
My system: two Firefox:

old FF 2 / FlashPlayer 9.0.28.0

Firefox 3.5 with new FlashPlayer 10

Good idea!

However, I'm still wondering whether Firefox 2 + Flash 10 will work or not?

0

Share this post


Link to post
Share on other sites
My system: two Firefox:

old FF 2 / FlashPlayer 9.0.28.0

Firefox 3.5 with new FlashPlayer 10

Good idea!

However, I'm still wondering whether Firefox 2 + Flash 10 will work or not?

Flash 10 (and last 9 (v. 128) ) work with any problem (not full function on Imageshack.us. e.g.)

0

Share this post


Link to post
Share on other sites
Flash 10 (and last 9 (v. 128) ) work with any problem (not full function on Imageshack.us. e.g.)

Do you have any idea what is wrong with me in my case? I can install Flash 10 on Firefox 2 with registry trick. However, my installed Flash 10 does not function.

0

Share this post


Link to post
Share on other sites

Free Corel Paint Shop Pro X :thumbup :

http://apps.corel.com/lp/lexar/4157/index.html

Installer fails after extracting because of not having at least 2K SP3 as an OS. I could not find what to edit in the msi so I did put setup.exe in 2k compatibility and then I could install normally after skipping an error message. Once installed I have removed all microsoft runtimes files from the install dir before I even tried running it so if it ever doesn't run for you you may want to try this. It does also install two files in the system dir, psiservice.exe and psiclient.dll. You can get rid of the exe but you must keep the dll (which can be moved to psp install dir) otherwise the soft won't run. Edit : Sorry you can get rid of psiclient.dll as well, it is psikeys.dll which must be kept and this one is already in the psp dir if I recall correctly.

I am not sure but perhaps it would run even without KernelEx. Seems like it is the full version and it appears to be just a little bit of a cosmetic update over Jasc Paint Shop Pro 9. Everything works OK as far as I can see. I have used it for several hours yesterday and it runs perfectly. There is a nag screen on exit suggesting to upgrade to the next version but this can be easily removed by following the instructions on this page :

http://www.winmatrix.com/forums/index.php?showtopic=23630

BTW, no need to leave your real details at the download page if you don't want to as you get the download link directly in your browser. Direct link for the english version actually :

http://www.corel.com/akdlm/6763/downloads/...EXAR_Retail.exe

A few extra tubes and textures etc... here as well :

http://www.corel.com/akdlm/6763/downloads/...PX_RegXtras.exe

Very cool, especially if you only have MS-Paint so far as an image editor. :hello:

Edited by eidenk
0

Share this post


Link to post
Share on other sites
Flash 10 (and last 9 (v. 128) ) work with any problem (not full function on Imageshack.us. e.g.)

Do you have any idea what is wrong with me in my case? I can install Flash 10 on Firefox 2 with registry trick. However, my installed Flash 10 does not function.

On my system, Flash 10 works with Firefox 2 as long as KernelEx is enabled for firefox.exe.

The thing is, enabling it creates a problem with mailto links (Thunderbird 2 has the inverse problem).

0

Share this post


Link to post
Share on other sites
Flash 10 (and last 9 (v. 128) ) work with any problem (not full function on Imageshack.us. e.g.)

Do you have any idea what is wrong with me in my case? I can install Flash 10 on Firefox 2 with registry trick. However, my installed Flash 10 does not function.

On my system, Flash 10 works with Firefox 2 as long as KernelEx is enabled for firefox.exe.

The thing is, enabling it creates a problem with mailto links (Thunderbird 2 has the inverse problem).

...with Firefox 2 as long as KernelEx is enabled for firefox.exe.

My problem with Flash 10 (imageshack.us) = run FF with disabled KernelEx / Firefox 2 (Enabled only on FF 3.5)

0

Share this post


Link to post
Share on other sites
anybody got opera, safari or chrome working on Win98 ?

I'm running latest Opera 10 Beta 3 build 1708 on Win98 SE without problem/s.

I've tried Chrome with KernelEx 4.0 Final but it doesn't work (I haven't tried Safari).

Edited by rainyd
0

Share this post


Link to post
Share on other sites
... I'm running latest Opera 10 Beta 3 build 1708 on Win98 SE without problem/s. ...

With KernelEx?

0

Share this post


Link to post
Share on other sites
With KernelEx?

No, without it. Opera 10 is the last modern browser (if you do not count SeaMonkey) you can run on Win9x.

Edited by rainyd
0

Share this post


Link to post
Share on other sites
My problem with Flash 10 (imageshack.us) = run FF with disabled KernelEx / Firefox 2 (Enabled only on FF 3.5)

I think this problem is flash-specific. See: this thread

...Opera 10 is the last modern browser (if you do not count SeaMonkey) you can run on Win9x.

Ahem, K-Meleon? :unsure:

0

Share this post


Link to post
Share on other sites
Ahem, K-Meleon? :unsure:

Yes, I remember about K-Meleon or Flock (in fact, I haven't tested them) but I mean just major browsers.

In that way, Opera is practically the last one.

Edited by rainyd
0

Share this post


Link to post
Share on other sites
Ahem, K-Meleon? :unsure:

Yes, I remember about K-Meleon or Flock (in fact, I haven't tested them) but I mean just major browsers.

In that way, Opera is practically the last one.

I mention it because the developers include a non-unicode build specifically for Windows 9x.

A version based on Gecko trunk 1.9 is underway. Gecko 1.9 on Windows 95... imagine...

Does the latest Flock work on 9x?

0

Share this post


Link to post
Share on other sites
Does the latest Flock work on 9x?

As I see the referenced API, it should work with KernelEx, but should not without it. So as I see only SeaMonkey, Opera and K-Meleon still support Win9x without KernelEx. With KernelEx you are able to run Firefox and Flock, and may be Wyzo - another browser on gecko engine. I'll test Wyzo later.

0

Share this post


Link to post
Share on other sites

Results with KernelEx 4.0 Final 2:

- VLC Media PLayer 1.0.1 works good

- MPC 6.4.9.1 (build 104) as above

- latest version of Haali Media Splitter, no glitches

- Real Alternative 1.90 (Lite) also without problem

- Quick Time Alternative 2.9.0 (I haven't tested latest 2.9.2) - installation goes smoothly but you can't use settings/configuration - program call control.exe from Windows/System

- ffdshow (clsid2) similar situation, after installation no access to configuration panel

Problem with ffdshow resolved: you must install latest version (build 2322) compatible with Win9x, then a recent one (in my case that was build 3054) over it.

In that way, you've latest version and you can configurate it too!

Edited by rainyd
0

Share this post


Link to post
Share on other sites

Another little program that runs with KernelEx4 Final 2 on Win98se :-)

Siteshoter 1.38 from NirSoft.

A standalone-tool that can make screenshots of LONG webpages and save as jpg, png, gif etc.

It's also used in a k-meleon macro called Page Capture Plus, although much less settings there, and it still uses a hidden window of IE to make the screenshots, not kmeleon itself. (And the macro didn't seem to save the screenshots first, but after I had started the tool alone and typed a output filename it worked, and suddenly the macro started working too, suppose that was the reason...)

Supposed not to work with Win98, and actually doesn't when kernelex disabled in compatibility tab *grin*

Love KernelEx, thanx xeno!!

-------------

Update: Am meanwhile using FastStone Capture for screenshooting long pages and other stuff, that thing is far better yet and also includes a nice editor with drawing tools!

Not sure if it even needs KernelEx, it runs with just the "default" compatibility of KEx in Win98se, and I have KEx set to be inactive by default.

Edited by siria
0

Share this post


Link to post
Share on other sites
Results with KernelEx 4.0 Final 2:

...

- MPC 6.4.9.1 (build 104) as above

...

Version MPC for win9x/ME or win2k and later with KernelEx?

0

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.