blackwingcat

KDW / FCWIN2K

409 posts in this topic

Wow, nice! Will it require KDW to run?

I bought an app for my Palm Pre that teaches some basic Kanji. It also covers Katakana and Hiragana, but I haven't gone through those yet. I've picked up a few letters, though. Every once in a while I can recognize a word here and there on your site, but I'm still relying on Google translate. I'm finding the Katakana easier to deal with since it tends to just sound out English words, but to me there are a lot of symbols to learn. My major gripe is that it teaches things like family members, 1st grade Kanji, etc. but it only teaches the English meanings, not the corresponding Japanese words. Still, it's neat to see things like dates and automatically recognize the year, month, and day Kanji.

0

Share this post


Link to post
Share on other sites

I have Safari working well under Windows 2000, but it crashes instantly as soon as I try to download something. Why is this?

Hi, SearanoX.

What version do you use ws2_32.dll wrapper ?

Chrome and Safari's webkit may crash without Chrome installer for Windows 2000 's ws2_32.dll.

0

Share this post


Link to post
Share on other sites

Hi, buckchow.

I have already tryied it.

But there are many othere problems. :(

In other words, did you try .NET Framework 3.5 SP1 for Windows 2000 ?

VS2010 requires this component.

BlackWingCat: Do you have any plans to add support for EnumerateTraceGuids in ADVAPI32.DLL?

I only ask because the "setup.exe" that is part of the Visual C++ 2010 redistributable depends on it to run. I've changed the OS and subsystem version values in the "setup.exe" header from 5.01 to 5.00 and the EnumerateTraceGuids function is the only dependency that remains on my system.

FYI, I can complete the setup process by running the "vc_red.msi" installer that is in the same directory as "setup.exe", but it would be nice to be able to run the "setup.exe" file as well. :)

0

Share this post


Link to post
Share on other sites

Hi WildBill.

OE6SP3 doesn't require KDW.

It uses KDW force link technology on inside.

But perhaps you have to make disable Windows System File Protection folder (i386) temporarily.

Yesterday MS released KB978542 and I'll intergrated it OE6Sp3.

Wow, nice! Will it require KDW to run?

0

Share this post


Link to post
Share on other sites

I have Safari working well under Windows 2000, but it crashes instantly as soon as I try to download something. Why is this?

Hi, SearanoX.

What version do you use ws2_32.dll wrapper ?

Chrome and Safari's webkit may crash without Chrome installer for Windows 2000 's ws2_32.dll.

I'm really not sure offhand, but I know I used the latest stable release of KDW at the time. But I know for a fact I never tried the Chrome Installer. If I used that, would I have to move files myself or would the installer just install the file where I need it?

Also, something else I ran into which is why I'm not using Windows 2000 anymore is I'd get a NT AUTHORITY error and my computer would automatically restart after one minute without any specific reason. Never thought of checking the log files as to why but I figured it might have to deal with Safari as that's when it usually occurred when I was using Safari.

There's also one other thing I want to get working and at least when I browsed through this thread, I saw no instructions as to how to make Windows Live Messenger 2009 work on Windows 2000. I use it extremely frequently and saw that it's possible on your website to get it working. Any suggestions as to how to get it installed and running?

Edited by SearanoX
0

Share this post


Link to post
Share on other sites

Last month I updated my ExtendAPI program, and now I'm able to use it to play at least one XP-only game on Win2k without having to patch anything (Overlord). I've posted the new version of ExtendAPI, and here is a link for anyone inclined to play with it.

http://www.mediafire.com/download.php?ozlmwgyu54o

ExtendAPI is a little experiment of mine. I wanted to see if I could write a program that could live in the system tray and automatically reroute imports of Windows API calls that aren't normally in Win2k to other DLL's. The idea is to be able to add support for XP-only API routines without having to patch anything or wrap system DLL's. I haven't tried anything beyond rerouting imports for TraceMessage, but it at least lets me play Overlord unmodified.

The program uses an .INI file that tells it which routines it can reroute, the DLL in which a program normally expects to find it, and the DLL where it can actually find it. I can't guarantee how well ExtendAPI will play with your applications (this is experimental, after all), but perhaps there is some potential if anyone wants to play with it.

0

Share this post


Link to post
Share on other sites

Something else I've been wondering. Is it possible to install and run Corel VideoStudio X2 on Windows 2000 via DLL wrappers? It's another one of my frequently used programs and another thing preventing me from actually running Windows 2000 anymore. That and Windows Movie Maker 2.6. I've been able to install it somehow (but I can't remember what I did). But I can't save videos. I just get an "Error saving movie" error. Any thoughts or suggestions?

0

Share this post


Link to post
Share on other sites

Hi, SearanoX.

*Safari

Although Safari works on Windows 2000 with KDW, Windows 2000 can't draw correctly combobox in Safari 4.x.

I wonder you had better use Chrome or Lunascape, if you want to use webkit browser.

The reason of need ws2_32.dll of chrome installer, there may be bugs in free resource function of new Webkit's dll.

If you want to install Safari on Windows 2000 with Ez Install mode, you check EzKD Registry in KDllinst.exe.

*Messenger

Why don't you use MSN Messenger 7.x or Windows Messenger 5.x ?

If Live Messenger runs, many problem occure, though it works on Windows 2000.

I have Safari working well under Windows 2000, but it crashes instantly as soon as I try to download something. Why is this?

Hi, SearanoX.

What version do you use ws2_32.dll wrapper ?

Chrome and Safari's webkit may crash without Chrome installer for Windows 2000 's ws2_32.dll.

I'm really not sure offhand, but I know I used the latest stable release of KDW at the time. But I know for a fact I never tried the Chrome Installer. If I used that, would I have to move files myself or would the installer just install the file where I need it?

Also, something else I ran into which is why I'm not using Windows 2000 anymore is I'd get a NT AUTHORITY error and my computer would automatically restart after one minute without any specific reason. Never thought of checking the log files as to why but I figured it might have to deal with Safari as that's when it usually occurred when I was using Safari.

There's also one other thing I want to get working and at least when I browsed through this thread, I saw no instructions as to how to make Windows Live Messenger 2009 work on Windows 2000. I use it extremely frequently and saw that it's possible on your website to get it working. Any suggestions as to how to get it installed and running?

0

Share this post


Link to post
Share on other sites

Hi WildBill.

Your system has a Commonality with old version KDW :).

http://blog.livedoor.jp/blackwingcat/archives/50928.html

But old version KDW's this system was instability, therefore I changed Current system. :(

Good luck. :yes:

Last month I updated my ExtendAPI program, and now I'm able to use it to play at least one XP-only game on Win2k without having to patch anything (Overlord). I've posted the new version of ExtendAPI, and here is a link for anyone inclined to play with it.

http://www.mediafire.com/download.php?ozlmwgyu54o

ExtendAPI is a little experiment of mine. I wanted to see if I could write a program that could live in the system tray and automatically reroute imports of Windows API calls that aren't normally in Win2k to other DLL's. The idea is to be able to add support for XP-only API routines without having to patch anything or wrap system DLL's.

0

Share this post


Link to post
Share on other sites

Do you have VideoStudio X2 trial ?

I fail to run VideoStudio X3 on Windows 2000.

How about Vegas Movie Studio 9 or Movie Maker 1.x ?

Something else I've been wondering. Is it possible to install and run Corel VideoStudio X2 on Windows 2000 via DLL wrappers? It's another one of my frequently used programs and another thing preventing me from actually running Windows 2000 anymore. That and Windows Movie Maker 2.6. I've been able to install it somehow (but I can't remember what I did). But I can't save videos. I just get an "Error saving movie" error. Any thoughts or suggestions?

0

Share this post


Link to post
Share on other sites

Hi blackwingcat!

First of all, thanks for all your good tips, it's nice being able to use my favorite OS a bit longer than Microsoft would like me to. XD

Anyway, I forgot to mention that I'm using Safari 3.2.1, I'm not using the new 4.0 version as I don't care for it that much. I tried using the ws2_32.dll from the chrome installer but I can't get it deployed for some reason. Is it because I don't have Chrome installed? I rather like the only 3.x.x version of Safari and for the most part it seems to work but I still get that NT Authority crap and then it reboots my computer. Can you tell me step by step what I need to check in kdllinst and what files are needed to be installed? I get confused with RSA Registry, EZ KD Registry, SHFolderExREG and all that and I'm thinking I might be getting messed up with that.

As for Messenger, I found out how to use the older versions so I can run the older version just fine. So I guess Safari is my biggest concern now as I almost hate IE now and FireFox isn't my favorite either. Chrome is okay I guess but I'd rather have Safari.

Hi, SearanoX.

*Safari

Although Safari works on Windows 2000 with KDW, Windows 2000 can't draw correctly combobox in Safari 4.x.

I wonder you had better use Chrome or Lunascape, if you want to use webkit browser.

The reason of need ws2_32.dll of chrome installer, there may be bugs in free resource function of new Webkit's dll.

If you want to install Safari on Windows 2000 with Ez Install mode, you check EzKD Registry in KDllinst.exe.

*Messenger

Why don't you use MSN Messenger 7.x or Windows Messenger 5.x ?

If Live Messenger runs, many problem occure, though it works on Windows 2000.

I have Safari working well under Windows 2000, but it crashes instantly as soon as I try to download something. Why is this?

Hi, SearanoX.

What version do you use ws2_32.dll wrapper ?

Chrome and Safari's webkit may crash without Chrome installer for Windows 2000 's ws2_32.dll.

I'm really not sure offhand, but I know I used the latest stable release of KDW at the time. But I know for a fact I never tried the Chrome Installer. If I used that, would I have to move files myself or would the installer just install the file where I need it?

Also, something else I ran into which is why I'm not using Windows 2000 anymore is I'd get a NT AUTHORITY error and my computer would automatically restart after one minute without any specific reason. Never thought of checking the log files as to why but I figured it might have to deal with Safari as that's when it usually occurred when I was using Safari.

There's also one other thing I want to get working and at least when I browsed through this thread, I saw no instructions as to how to make Windows Live Messenger 2009 work on Windows 2000. I use it extremely frequently and saw that it's possible on your website to get it working. Any suggestions as to how to get it installed and running?

0

Share this post


Link to post
Share on other sites

Hi , SearanoX

If you want to install Safari 3.2.3 for Windows.

* run kdllinst.exe

* Check Ez KD Registry and SHFolderExREG

* Set "Ez Install" target Safari Folder.

* Turn on Button Shell32 and kernel32 and ws2_32.

* Press "Ez Install" Button.

* reboot PC.

* Rename and Overwrite ws2_xp.dll to ws2_32.dll from chrome Installer into safari folder.

Sincerely.

Hi blackwingcat!

First of all, thanks for all your good tips, it's nice being able to use my favorite OS a bit longer than Microsoft would like me to. XD

Anyway, I forgot to mention that I'm using Safari 3.2.1, I'm not using the new 4.0 version as I don't care for it that much. I tried using the ws2_32.dll from the chrome installer but I can't get it deployed for some reason. Is it because I don't have Chrome installed? I rather like the only 3.x.x version of Safari and for the most part it seems to work but I still get that NT Authority crap and then it reboots my computer. Can you tell me step by step what I need to check in kdllinst and what files are needed to be installed? I get confused with RSA Registry, EZ KD Registry, SHFolderExREG and all that and I'm thinking I might be getting messed up with that.

As for Messenger, I found out how to use the older versions so I can run the older version just fine. So I guess Safari is my biggest concern now as I almost hate IE now and FireFox isn't my favorite either. Chrome is okay I guess but I'd rather have Safari.

0

Share this post


Link to post
Share on other sites

This is OT, but blackwingcat, have you seen the LNK patch I posted in the Win2k forum? If it effectively closes the vulnerability it might be useful to you since it can be slipstreamed, etc. Unfortunately I don't know how to test it to see if it closes the security hole.

0

Share this post


Link to post
Share on other sites

Hi, WildBill.

I use third party's patch.

You can find a few security patches from google search :)

And I found test code on Web.

This is OT, but blackwingcat, have you seen the LNK patch I posted in the Win2k forum? If it effectively closes the vulnerability it might be useful to you since it can be slipstreamed, etc. Unfortunately I don't know how to test it to see if it closes the security hole.

0

Share this post


Link to post
Share on other sites

Hi, WildBill.

I use third party's patch.

You can find a few security patches from google search :)

And I found test code on Web.

This is OT, but blackwingcat, have you seen the LNK patch I posted in the Win2k forum? If it effectively closes the vulnerability it might be useful to you since it can be slipstreamed, etc. Unfortunately I don't know how to test it to see if it closes the security hole.

Would you be able to determine if my patch closes the security hole?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.