• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
Jonnyboy82

[Tool] FFaM v1.0.2.11

202 posts in this topic

Considering it is an .msi file, all the normal switches should apply.

If you know them switches off of the top of your head, could you post. I have not used msi file in a couple of years. I would have to take them time, surely only a few minutes, but I have lots of other things to get finished.

BTW, don't look them up, only post if you know them.

Thank you

msi is usually /quiet /norestart or /qn for silent install.

Thank you.

It looks like only the 'full' installer is available in an msi installer, the 'slim' should be at http://fpdownload.macromedia.com/get/shockwave/default/english/win95nt/latest/sw_lic_slim_installer.msi. But, it isn't there.

0

Share this post


Link to post
Share on other sites

You can get the switches if you type msiexec into the Command Prompt; simple as that ;)

0

Share this post


Link to post
Share on other sites

Hey all,

I'm stumped. I've been trying to figure out how to display unicode characters in the console. This is required as the only know way to pin shortcuts is using an obj.verb in vbscript or jscript. I have install every language pack available and the are 7-8 languages that will not display.

I have only found one font, TerminalVector, and it leaves 8 incomplete. The built in fonts get all but 7.

Do any of you know where to locate a complete unicode font?

***EDIT***

Nevermind. To view the output of the script, I need to a complete(there isn't one) font. To run the script, it isn't necessary. I ahve most of them working. I have to go through the rest one at a time and grab the string.

***EDIT***

I have all 35 languages working.

Edited by Jonnyboy82
0

Share this post


Link to post
Share on other sites

Your the best my friend thank u verry much :thumbup

As soon as I get the updater completed, I will post the new version. Among numerous fixes, a bug was introduced this morning when Mozilla change the format of one of their webpages.

0

Share this post


Link to post
Share on other sites

Update posted. I hope I didn't break anything in the process.

If anyone is interested in making a webpage for FFaM, hosted on sourceforge, please contact me.

v1.0.2.7 - 03-09-12

-out of beta, begin versioning at 1.0.0.0, revision number will increment with every commit, not every revision will be posted as an update

-check timestamp of local Flash Player Installer, if older than that on server, download new file

-fixed "Pinned" shortcuts

-rename "Quick Launch" to "Taskbar"

-correct tab order

-strengthened reg-ex for version number after Mozilla made changes to the "www.mozilla.org/en-US/firefox/all-older.html" web page

-installer now removes public profile created within the Firefox installation path

-complete proper GPLv2 License requirements

-complete git integration @ https://github.com/jonnyboy/FFaM

-add update utility

Edited by Jonnyboy82
0

Share this post


Link to post
Share on other sites

I downloaded version 1.0.2.7 which seems to be the latest. It is not installing the shortcuts correctly on x64 Windows 7. It is directing the shortcut to "C:\Program Files (x86) (x86)\Mozilla Firefox" instead of "C:\Program Files (x86)\Mozilla Firefox".

Thanks

Edited by Shaneee
0

Share this post


Link to post
Share on other sites

I downloaded version 1.0.2.7 which seems to be the latest. It is not installing the shortcuts correctly on x64 Windows 7. It is directing the shortcut to "C:\Program Files (x86) (x86)\Mozilla Firefox" instead of "C:\Program Files (x86)\Mozilla Firefox".

Thanks

Thank you for identifying this. FFaM v1.0.2.8 posted.

-fixed bug in getting correct install path, introduced when I changed compile from "x86" to "AnyCPU", as identified by MSFN user http://www.msfn.org/board/user/281793-shaneee/

0

Share this post


Link to post
Share on other sites

Thank you for identifying this. FFaM v1.0.2.8 posted.

-fixed bug in getting correct install path, introduced when I changed compile from "x86" to "AnyCPU", as identified by MSFN user http://www.msfn.org/board/user/281793-shaneee/

Thanks for fixing it mate. What features do you have planned?

0

Share this post


Link to post
Share on other sites

@Shaneee:

I am currently working on my Inf Assistant, but these things are on the list.

TO-DO

-complete tool-tips

-add option to save installer to path specified by user

-add try, catch, finally for Exception Handling

-check local version of flash and Shockwave

-add ability to select individual bookmarks, histories, cookies, extensions, search engines

-add ability to insert additional language packs

-move vbscript files to .exe files for versioning control

-ability to select multiple profiles

-add preset for profile folder and profile name creation

-add threading

-replace Shockwave installer with msi installer

-look at encrypting the profile

-look at using compression to compress exe

-splash screen to display GPLv2 License

-add warning for passwords usage

-make app properly localizeable

-look at adding adding plugins (vlc)

-look at adding additiona versions of Firefox (Ayakawa, pigfoot, tete, Blazing Fast, Pale Moon and Waterfox)

-rewrite in WPF

It will definitely be a couple of weeks before I get back to this project, but I will fix bugs immediately.

0

Share this post


Link to post
Share on other sites

Looking forward to a final version including all this.

0

Share this post


Link to post
Share on other sites

Update posted.

v1.0.2.9 - 04-02-12

-fixed check boxes that should be unchecked when no Firefox profile is found.

-properly fixed bug in getting correct install path, introduced when I changed compile from "x86" to "AnyCPU", as identified by MSFN user http://www.msfn.org/board/user/281793-shaneee/

0

Share this post


Link to post
Share on other sites

The new website for FFaM went 'Live' today. Thanks go to Stefan Beer for his efforts in creating the page and doing all the heavy lifting to get it ready for use.

If, you have a moment, could I ask you to head over to Sourceforge and write a review or add a recommendation? It would help alot. Also, if you would check out the new website and click one of Social Networking buttons in the page footer. A little 'word of mouth' advertising would be greatly appreciated.

Thank you

~jonnyboy

Edited by Jonnyboy82
0

Share this post


Link to post
Share on other sites

Hello jhonnyboy, thanks for this great tool, i have some problems with this tool:

I used it to download the spanish version of 14.0.1

But the tool show continuosly:

MD5 does not match Downloading

MD5 does not match Downloading

....

If i used it to download the english (US) version of 14.0.1 it dont work

If i check the spanish 15.0b1 it creates sucefull the silent installer, but the extensions that i have installed does not copy into the silent installer (I have checked Include Extensions)

Can you check this?

Thanks :hello:

0

Share this post


Link to post
Share on other sites

FFaM v1.0.2.11 posted.

-disabled 'older' Firefox version, Mozilla has removed the files and the links are invalid

-disable checking MD5 sums, for now

-changed 'Plugins' groupbox text to bold

-fix bug with 0 byte files created when download flash installer

-fixed bug when deleting files that are open, by adding dialog to close explorer

-fixed bug where files named prefs.*, other htan main prefs.js were never copied

0

Share this post


Link to post
Share on other sites

I've spent the whole day making a full silent install of Firefox manually with preferences, addons and everything ... and i was about to give up because i couldn't find all the methods. So i'm very happy to have found your software which is absolutely wonderful and complete !

Thanks a million.

0

Share this post


Link to post
Share on other sites

I am currently rewriting FFaM again. This time in WPF .NET 4.0. I am in the beginning stages of the layout. If, you would like to offer your suggestions as to the UI, please post them here or email me.

This is a tool that I learn with and learn from.

You can follow me on github.

~jonnyboy

0

Share this post


Link to post
Share on other sites

Hello jonnyboy82, i have been testing the version 1.0.2.11, this months over the version of firefox 14, and found this bugs;

I have created the firefox installer in windows 7, and in Windows 7 does not apear this bug.

In Windows XP this installer ask for check compability about extensions and need click a button to continue.

I have check the option "make firefox default browser", but when finnish install, i open firefox and it ask for default browser...

Can You check this jonnyboy82?

Thanks

Edited by El_Esteban
0

Share this post


Link to post
Share on other sites

Hello,

First of all, Thank you for this application! :thumbup

I am here because I have some problems in running it. I have windows 7 Professional, Service Pack 1, 32Bits, and when I run the app I get JIT error and also is asking for "en-US" folder, and it is complaining about write access.

I have tried to run it in normal way and in as administrator way - same error(s);

I have created that folder - Nothing happen;

I have downloaded the Firefos 17 installer, and I have put it in the same folder as the application, I have extracted the files from the installer and then I put them into the same folder, as app; Then in the en-US folder, and the full installer too - Same error(s);

I don't know what is not working.

I have attached the printscreen in FFaM-1.png, and the error details in FFaM-2.txt.

post-368255-0-21006700-1355142935_thumb.

FFaM-2.txt

Thank you for any idea and any help!

0

Share this post


Link to post
Share on other sites

I am having the same issues with FFaM 1.0.2.11.

0

Share this post


Link to post
Share on other sites

I will try to do it tomorrow on windows xp... just as a test

0

Share this post


Link to post
Share on other sites

Unfortunately is not working. Same errors... I did that on windows xp sp3, dotnet 3.5.

Regards

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.