Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

[Tool] FFaM v1.0.2.11

- - - - -

  • Please log in to reply
201 replies to this topic

#51
Stoner81

Stoner81

    Advanced Member

  • Member
  • PipPipPip
  • 342 posts
I had problems with the first version it just wouldnt play ball for some reason will try the latest one and see what happens im still using the cmd based one you made (which works for me very well!) anyway thanks buddy heres hoping it works for me this time :D

Stoner81.


How to remove advertisement from MSFN

#52
Stoner81

Stoner81

    Advanced Member

  • Member
  • PipPipPip
  • 342 posts
This still wont work for me I get a script error and then it just all stops? Very strange indeed the older version still works tho... (touch wood)

Stoner81.

#53
Jonnyboy82

Jonnyboy82

    Lazzy Trucker

  • Member
  • PipPip
  • 126 posts
update posted

Changelog
v0.60 - 03-20-09
-added plugin for Foxit Reader
-updated plugins: Flash v.10.0.22.87, Shockwave v.11.0.472, WGA v1.9.0009.1, OGA v.1.7.0111.00, QuickTime v.7.60.92.0, RealPlayer v.6.0.12.69 and Live Connect v.6.0.12.69
-added status bar
-re-written to all text localizeable
-aaded off-line mode to allow for building installer from your current installation
-added script to attempt to locate your current installation folders
-removed all tooltips and replaced with "?" help screens
-fixed issues wuth 3.1.x Optimized versions
-fixed issue with 3.1.x versions branding not being removed

#54
Beezel

Beezel
  • Member
  • 1 posts

Firefox Addon Maker v0.60
Posted ImageUpdated 20 Mar 09


Firefox Addon Maker v0.60
Posted Image


MD5: 825E70A770FDA3AACF3C972C7CF24CEA
SIZE: 4.04 MB[/size]


Jonnyboy,

Maybe I'm just a confused N00b, but... Your download link goes to Wincert.net and that page says it's your Firefox Addon Maker v0.601. BUT that link points to v0.101 AND it has a different MD5
The link is http://www.hr-host.c...ools_v0.101.exe

Pls point me in the right direction. Thanks. :)

#55
Jonnyboy82

Jonnyboy82

    Lazzy Trucker

  • Member
  • PipPip
  • 126 posts
I do not update this page with every update. I link to my main pain. That page is always current. I am in the process of consolidating my tools in one app. Jonnyboy's Tools. The links you point out are all correct and will download the appropriate file. Wincert has been kind enough to host my files, so I link to the page, not the file.

Edited by Jonnyboy82, 22 March 2009 - 10:54 PM.


#56
Stoner81

Stoner81

    Advanced Member

  • Member
  • PipPipPip
  • 342 posts
Thanks for the new update dude heres hoping i have better luck with it.

EDIT - Have downloaded it and tried.... IT WORKS AT LAST!!!! thanks a million jonnyboy82 dude!!! you are da man!

Stoner81.

Edited by Stoner81, 23 March 2009 - 10:42 AM.


#57
Methanoid

Methanoid

    Junior

  • Member
  • Pip
  • 88 posts
  • OS:none specified
Big time FAIL for me... previous versions worked well (but didnt store status of addons).... this one manages to stop ALL addons from working and I cannot access the options on the addons even though they are allegedly working.

Having given up on the idea of having some addons installed but not loaded I am now just looking for an older working version of this.

I'm not ungrateful, really.

BTW, is there any way to improve the install speed? It takes about 5 mins for FF silent install to install whereas if I did it manually I could do all config and install in around 2.... Is there some strange way it installs? (C2D @ 3.2ghz)

EDIT: Rebuilt it again, as far as I can tell exactly the same (well the addons and source install were identical) and it worked fine.... whatever!??!

Edited by Methanoid, 27 March 2009 - 02:06 PM.


#58
Jonnyboy82

Jonnyboy82

    Lazzy Trucker

  • Member
  • PipPip
  • 126 posts

Big time FAIL for me... previous versions worked well (but didnt store status of addons).... this one manages to stop ALL addons from working and I cannot access the options on the addons even though they are allegedly working.

Removed in v0.602

BTW, is there any way to improve the install speed? It takes about 5 mins for FF silent install to install whereas if I did it manually I could do all config and install in around 2.... Is there some strange way it installs? (C2D @ 3.2ghz)

The installation actually creates the profile. The larger it is, the longer it takes. A normal installation does not create the profile until first run.

#59
Stoner81

Stoner81

    Advanced Member

  • Member
  • PipPipPip
  • 342 posts
I keep getting the following error though sometimes it works fine then other times I always get this.

Posted Image

#60
Jonnyboy82

Jonnyboy82

    Lazzy Trucker

  • Member
  • PipPip
  • 126 posts

I keep getting the following error though sometimes it works fine then other times I always get this.

Please send me the log file.
Thanks

#61
Jonnyboy82

Jonnyboy82

    Lazzy Trucker

  • Member
  • PipPip
  • 126 posts
update posted

Changelog
v0.603 - 04-04-09
-separated Optimized versions to type
-added Sharam's "Blazing Fast" SSE2 Optimized Firefox Versions
-removed Help Popup Windows and placed Help inside table in main page
-added German, Spanish, Norwegian, Italian, Portuguese and Dutch translations - created with freetranslation.com
-tweaked table positions for better uniformity
-added links to all programs used
-increased contextual help
-Added Real Alternative 1.90
-Added Quicktime Alternative 2.8.0
-added additional registry entries to ensure Firefox is registered as "Being" installed
-all text is now localized
-fixed issue where timer is not restarted on subsequent runs
-added script to validate saved paths when loading
-added script to invalidate a New Profile Path that is in a sub-directory of the default location
-added new Localized Firefox builds - Bulgarian, Esparanto, Occitan and Welsh
-merged RealPlayer and Live Connect
-added Adobe Reader 9.1 plugin

#62
Stoner81

Stoner81

    Advanced Member

  • Member
  • PipPipPip
  • 342 posts

I keep getting the following error though sometimes it works fine then other times I always get this.

Please send me the log file.
Thanks


Ok m8 no worries next time I get it I will send it you. Im getting the new version you have released so will be trying that.

Thanks man!

Stoner81.

#63
Jonnyboy82

Jonnyboy82

    Lazzy Trucker

  • Member
  • PipPip
  • 126 posts
quick update posted to include a Proper Dutch translation. The translation was completed by fixit.

#64
Stoner81

Stoner81

    Advanced Member

  • Member
  • PipPipPip
  • 342 posts
I think the error i get is due to my antivirus, i disable it while running the app and it seems to work fine. Will be testing this further though just to make sure.

Stoner81.

#65
Jonnyboy82

Jonnyboy82

    Lazzy Trucker

  • Member
  • PipPip
  • 126 posts

I think the error i get is due to my antivirus, i disable it while running the app and it seems to work fine. Will be testing this further though just to make sure.

Stoner81.

It probably does not like it when vbscript queries the WMI to see if Firefox is running or not. I'm curious to know, though.

#66
Stoner81

Stoner81

    Advanced Member

  • Member
  • PipPipPip
  • 342 posts

I think the error i get is due to my antivirus, i disable it while running the app and it seems to work fine. Will be testing this further though just to make sure.

Stoner81.

It probably does not like it when vbscript queries the WMI to see if Firefox is running or not. I'm curious to know, though.


No worries m8 when i get the error again i iwll send you the log file.

#67
Stoner81

Stoner81

    Advanced Member

  • Member
  • PipPipPip
  • 342 posts
Any sign of a new update to this awesome piece of kit?

#68
Jonnyboy82

Jonnyboy82

    Lazzy Trucker

  • Member
  • PipPip
  • 126 posts

Any sign of a new update to this awesome piece of kit?

I have been reading some CSS style guides and will be re-writing the html and css parts of the hta. When I complete that, I'll post an update.
But, I have been testing the script with Win7 and vbscript functions a little differently in Win7 (as it does in Vista). So, the next major update will be a rewrite in C#. I have been doing some reading there, also. But, that will take a little time.
Also, I have been working on a different method for silent installer. When that is completed, I'll add it in. It takes less than 10% of the time to install.

Edited by Jonnyboy82, 07 May 2009 - 08:51 AM.


#69
Stoner81

Stoner81

    Advanced Member

  • Member
  • PipPipPip
  • 342 posts
Fantastic m8 thanks for the info!!!

#70
Sp0iLedBrAt

Sp0iLedBrAt

    MSFN Addict

  • MSFN Sponsor
  • 1,727 posts
  • OS:XP Pro x86
  • Country: Country Flag
I made an nLite addon for Firefox 3.0.10 using the offline mode. It all worked well during the process, and I got a .7z file and nLite made no problems about it. Please see attachment.

The problem appeared when, testing it on VirtualPC with XP Pro SP3, I got an error "the system cannot find the file specified" and Firefox was not installed when Windows booted. Then I checked the SVCPACK folder with the other add-ons and I didn't see Firefox anywhere.

Any ideas?

Thanks in advance.

Edit: I have just found that the Firefox archive is in the I386 Folder, and not along with the other add-ons in I386/SVCPACK. Is this normal?

Edit: After 2 days and four VirtualPC installations, I can't get it to work as an nLite add-on. Now trying with the silent installer option.

Edit: Silent installer for Firefox 3.0.10 working perfectly if executed through a batch file! Still not sure what's the problem with the add-on maker (including plug-ins, themes and bookmarks)

Edited by Sp0iLedBrAt, 21 May 2009 - 03:51 AM.


#71
Stoner81

Stoner81

    Advanced Member

  • Member
  • PipPipPip
  • 342 posts

I made an nLite addon for Firefox 3.0.10 using the offline mode. It all worked well during the process, and I got a .7z file and nLite made no problems about it. Please see attachment.

The problem appeared when, testing it on VirtualPC with XP Pro SP3, I got an error "the system cannot find the file specified" and Firefox was not installed when Windows booted. Then I checked the SVCPACK folder with the other add-ons and I didn't see Firefox anywhere.

Any ideas?

Thanks in advance.

Edit: I have just found that the Firefox archive is in the I386 Folder, and not along with the other add-ons in I386/SVCPACK. Is this normal?

Edit: After 2 days and four VirtualPC installations, I can't get it to work as an nLite add-on. Now trying with the silent installer option.

Edit: Silent installer for Firefox 3.0.10 working perfectly if executed through a batch file! Still not sure what's the problem with the add-on maker (including plug-ins, themes and bookmarks)


Hmm this is strange could it be an issue doing it via the offline method? I have made the silent installer using downloaded files and that seems to work fine for me. Could it be an issue during the build process?

#72
Sp0iLedBrAt

Sp0iLedBrAt

    MSFN Addict

  • MSFN Sponsor
  • 1,727 posts
  • OS:XP Pro x86
  • Country: Country Flag
Stoner81, I made both my experiments with the offline installation method. The nLite add-on didn't work, but the silent installer was OK. So yes, I agree it is more than strange, and I described all the symptoms in my previous post and I attached an image of the process and the procedure I used. I'm hoping on a consult from the tool maker.

Cheers

#73
Stoner81

Stoner81

    Advanced Member

  • Member
  • PipPipPip
  • 342 posts

Stoner81, I made both my experiments with the offline installation method. The nLite add-on didn't work, but the silent installer was OK. So yes, I agree it is more than strange, and I described all the symptoms in my previous post and I attached an image of the process and the procedure I used. I'm hoping on a consult from the tool maker.

Cheers


Best thing to do then would be to redo the true addon like you have already and after it has finished building it attatch the log file for him to look at that way he will have as much info as possible to be able to help you, sorry I cant help more :(

Stoner81.

#74
Sp0iLedBrAt

Sp0iLedBrAt

    MSFN Addict

  • MSFN Sponsor
  • 1,727 posts
  • OS:XP Pro x86
  • Country: Country Flag
As proposed by Stoner81, I am attaching the log file of an offline procedure of creating an nLite add-on for Firefox 3.0.10. Hope it helps.



Edit (a month later): Any ideas?

Edited by Sp0iLedBrAt, 24 June 2009 - 02:08 AM.


#75
skavenger

skavenger

    Master of Tools

  • Member
  • Pip
  • 55 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Thank you for this great tool.

I'm german and i'm wondering about the german translation.

Sorry, but this german translation is crap.
I will translate it better and send my translatet file to you.

so long




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users



How to remove advertisement from MSFN