• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
mara-

Office 2000/XP/2003/2007 Slipstreamer - version 1.7.4

225 posts in this topic

Hi mara-, bad news,

:wacko: sorry...

Unlike the previous version, with v1.7.3. there is no way, for me, to complete an unattended setup of Office 2003 Pro.

The installation is interrupted almost at the end, with an error message: "Impossible to complete MS Office setup".... reporting the problem to Microsoft...

In Event Viewer there is an "Event ID: 5000" - Office 11 Setup, containing the following information:

P1 : (90110410-6000-11d38cfe-0150048383c9)

P2 : 11.0.8173.0

P3 : iscachelockedfeaturestates

P4 : 0

P5, 6, 7 : x

Office 2003 setup(0001).txt says:

"Successfully launched MsiExec....

16/09/2008 21.29.11 Chained install return code: 1603

Exit code was an error.

Shutting down chained setup processing.

Error returned from install, removing cache.

Using Office Source Engine at path: W:\FILES\SETUP\OSE.EXE

Successfully started Office Source Engine in stand-alone mode.

Set Verbose logging for subsequent setup.

***** Setup exits

16/09/2008 21.29.11

(return = 1603) "

and Office 2003 setup(0001)_Task.txt:

=== Fine registrazione: 16/09/2008 21.29.11 ===

MSI © (18:8C) [21:29:11:453]: Note: 1: 1708

MSI © (18:8C) [21:29:11:453]: Prodotto: Microsoft Office Professional Edition 2003 -- Impossibile completare l'operazione di installazione.

MSI © (18:8C) [21:29:11:453]: Attempting to delete file I:\Temp\882d64.mst

MSI © (18:8C) [21:29:11:453]: Unable to delete the file. LastError = 32

MSI © (18:8C) [21:29:11:468]: Grabbed execution mutex.

MSI © (18:8C) [21:29:11:468]: Cleaning up uninstalled install packages, if any exist

MSI © (18:8C) [21:29:11:468]: MainEngineThread is returning 1603

=== Verbose logging stopped: 16/09/2008 21.29.11 ===

Ciao :hello:

Lions

0

Share this post


Link to post
Share on other sites

Does only unattended way does not work, or even normal not work? Anyway, I found some issues before your report, so I think when I fix those issues everything will be fine. If you have time, I'll send you a test version tomorrow so you can try.

Cheers ;)

0

Share this post


Link to post
Share on other sites

I have tried only in unattended mode (in v. 1.7.2. was almost perfect....).

Two tests for each version, STD and PRO.

In the first case, with STD version, I had a different fault: in the middle of the setup an error message told me that the installation via "transform.mst" is not supported (strangely, because I had no problems and I have run smoothly from an admin install created with Slipstreamer v1.6.2).

Ok for the test version.

Ciao :hello:

0

Share this post


Link to post
Share on other sites

Is there a list for Office2k updates? I have SR-1 and would like to know what updates I need, and if I need client or full?

I only see 2k3 list in first post...

0

Share this post


Link to post
Share on other sites
I have tried only in unattended mode (in v. 1.7.2. was almost perfect....).

Two tests for each version, STD and PRO.

In the first case, with STD version, I had a different fault: in the middle of the setup an error message told me that the installation via "transform.mst" is not supported (strangely, because I had no problems and I have run smoothly from an admin install created with Slipstreamer v1.6.2).

Ok for the test version.

Ciao :hello:

OK, I'll PM you today, I still did not finish fixing the bug.

Cheers ;)

Edited by puntoMX
0

Share this post


Link to post
Share on other sites

It does not work with my copy of office2k, keeps asking for serial when my copy doesn't require one (pre-activated).

0

Share this post


Link to post
Share on other sites
It does not work with my copy of office2k, keeps asking for serial when my copy doesn't require one (pre-activated).

Since I don't have any original copy of Office2k, support for it is very low. But I can still try to help you. Where do you get prompt for CD key, from the Slipstreamer, or from Office 2000 setup? If from setup, then you need to enter it, since slipstreaming to Office 2k requires creation of administrative install, before slipstream.

Cheers ;)

0

Share this post


Link to post
Share on other sites

Slipstreamer won't continue without one entered, administrative install goes fine. Although maybe you could add an option for an already created one, which I did...

0

Share this post


Link to post
Share on other sites
Slipstreamer won't continue without one entered, administrative install goes fine. Although maybe you could add an option for an already created one, which I did...

I can't make it optionally when I can't detect if your install is already administrative. I already mentioned that I don't have that edition. Now, I'm not sure that I understand about this cd key problem. When Slipstreamer ask for it, after creating admin install, or before?

Cheers ;)

0

Share this post


Link to post
Share on other sites

Don't want to interfere but since I tested both I only want to say.......keep up the pace with

further developing mara-. You are doing a great job.

:thumbup

0

Share this post


Link to post
Share on other sites
Don't want to interfere but since I tested both I only want to say.......keep up the pace with

further developing mara-. You are doing a great job.

:thumbup

Thanks for the support schakan. I really appreciate it. Thanks to Nexus_06, too.

Cheers ;)

0

Share this post


Link to post
Share on other sites

Is the list of updates current (i.e. up to date) as I have collected over recent months all these Office 2003 updates that WU tells me are needed. All POST SP3

KB943983

KB943985-v2

KB945432

KB946254

KB947355

KB947944

KB949044

KB950213

KB950241

KB950380

KB951476

KB953465

KB956077

KB953404

KB954478

Always useful to know what the current list is when rebuilding an image for backup

Some of the above are redundant.. didnt notice the MANY Outlook Junkmail Filter patches :thumbup

Edited by Methanoid
0

Share this post


Link to post
Share on other sites
Is the list of updates current (i.e. up to date) as I have collected over recent months all these Office 2003 updates that WU tells me are needed. All POST SP3

Always useful to know what the current list is when rebuilding an image for backup

My list in first post is not up to date. I was busy with fixing really annoying bug with Direct Slipstream, and it seems that I finally fixed it. As soon as I publish next version of Office Slipstreamer, I'll update the list.

Cheers ;)

Edited by mara-
0

Share this post


Link to post
Share on other sites

Version 1.7.4 is out. This will be last release from me. From now I'll be working with Siginet and benners so we can make one, the best tool. Even if I work with them, you can always ask anything related to Office Slipsteamer. Also, I think I'll continue to do releases of new tool on MSFN forum and we'll provide support for it.

Cheers ;)

0

Share this post


Link to post
Share on other sites

Thanks for bug fixes mara-.

I look forward to the work on the combined efforts tool. Saves me a lot of scripting hassle.

0

Share this post


Link to post
Share on other sites

I performed the following test cross:

1) - Office Integrator 1.0 build65> Integration with CAB RVMI 1.5.3> verification of MU no upgrade required.

2) - Office Integrator 1.0 build65> Integration with CAB nLite 1.4.9.1> verification of MU no upgrade required.

3) - Slipstreamer 1.7.4> Integration with CAB nLite 1.4.9.1> verification of MU requires all updates to Office 2003 post SP3 :no:

4) - Slipstreamer 1.7.4> Integration with CAB RVMI 1.5.3> verification of MU requires all updates to Office 2003 post SP3 :no:

May have mistaken the integration? :}

This is the screen with the log

225579slipstreamer.JPG

With the release I had not had previous problem, I repeated the test twice with the same result.

I do not understand where mistake

Thank you

Edited by DMD61
0

Share this post


Link to post
Share on other sites

You did not do anything wrong. I never tried this as an addon, so I don't know will it works. As normal install everything will work fine. You can only check if .reg file is present in your addon. It should be located in folder FILES\SETUP.

Cheers ;)

0

Share this post


Link to post
Share on other sites

Hallo All!!

Little problem with version 1.7.4

slisptreaming office 2003 professional italian with sp3 and all patch, all good.

Installing the file FILE\SETUP\pro11.reg is not imported in registry

on windows xp no messages are shown during installation but patches are not found.

on windows 2000 sp4 during installation an error ocourse

Please help!

post-209606-1222418366_thumb.jpg

log.txt

0

Share this post


Link to post
Share on other sites

If I understood this good, everything is fine on Windows XP, right? Problem is with Windows 2000? Well, that could be because of command for importing the registry file. Does Windows 2000 support command regedit.exe /s ? If not that's why this problem exist.

Cheers ;)

0

Share this post


Link to post
Share on other sites
If I understood this good, everything is fine on Windows XP, right? Problem is with Windows 2000? Well, that could be because of command for importing the registry file. Does Windows 2000 support command regedit.exe /s ? If not that's why this problem exist.

Cheers ;)

Thank you for prompt reply, Regedit /s works also for win2k.

.reg file is not added also for windows xp the only difference is that xp don't throw the error.

Bye

0

Share this post


Link to post
Share on other sites
If I understood this good, everything is fine on Windows XP, right? Problem is with Windows 2000? Well, that could be because of command for importing the registry file. Does Windows 2000 support command regedit.exe /s ? If not that's why this problem exist.

Cheers ;)

Thank you for prompt reply, Regedit /s works also for win2k.

.reg file is not added also for windows xp the only difference is that xp don't throw the error.

Bye

That's strange. I did not experience that problem. Anyway, you should use Office Integrator from here since I work with other members on it now, and I'm not working on Slipstreamer anymore.

Cheers ;)

0

Share this post


Link to post
Share on other sites

Is it possible to shrink this as we used to do with office shrinker?

Thanks

0

Share this post


Link to post
Share on other sites

The reason your .reg file doesn't work is it is probably made from xp , and is unicode. (Windows Registry Editor v5.00)

make a new .reg file with notepad, copy all the registry keys with cut/paste into the new file, and put at the top REGEDIT4.

make sure you save it as ANSI.

It should work then.

Edited by Nexus_06
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.