Welcome to MSFN

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Sophy

Why does System Restore sometimes take so long to open?

4 posts in this topic

I have Windows Vista Home Premium on a Dell XPS 410 with 2 GB RAM.

Sometimes when I open System Restore it will open right up. Other times it takes forever and I'll go in and click on it again and then will get a pop up stating that it's already running but it still hasn't opened. Why is this?

0

Share this post


Link to post
Share on other sites

mine also takes quite a while to open... maybe it is trying to scan for all the restore points?

0

Share this post


Link to post
Share on other sites

If you have an external USB hard drive, some of those cause that major delay. I had a Seagate 120GB external that would lag my system restore about 3 minutes. I now have a Maxtor 320GB that does not lag at all. I sold the Seagate the instant I found the Maxtor had no lag opening System Restore.

0

Share this post


Link to post
Share on other sites

Thanks for your answers.

I do have a 320GB Iomega USB hard drive, but I don't normally have it turned on.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.