Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

How can I disable INTRANET Zone Checks and add it to nLite?

- - - - -

  • Please log in to reply
2 replies to this topic

#1
bobkat2769

bobkat2769
  • Member
  • 4 posts
  • Joined 18-September 08
Hi there =^.^=

I'm running into problems trying to automate a process to disable zone checks on my local intranet. Ever since IE 7 was put on all of my workstations it seems to think that my local network is an "internet" zone.

I have a manual fix for this that mostly works, but I found that when I took snapshots of the registry and file changes and then tested applying them that nothing had actually changed except the part where I created a new system variable.

Below is the manual procedure I've been using to mostly fix this problem:

Open System Applet (WinKey+Pause) and go to Advanced tab and create a system environment variable:

SEE_MASK_NOZONECHECKS

and give it the value 1. This will disable the zone checks and make your life easier.


Go to Internet Options | Security tab...

Select "Local Intranet"

Select "Sites" button

Uncheck "Automatically detect intranet network" as it is totally broken after IE 7 is installed.

All three checkboxes below should be checked.

Select "OK" to apply changes and close both dialogs.

--------------------------------------------------------------------------------

Here are the parts that seem to be ignored:

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
"WarnOnIntranet"=dword:00000001

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap]
"UNCAsIntranet"=dword:00000001
"AutoDetect"=dword:00000000
"ProxyByPass"=dword:00000001
"IntranetName"=dword:00000001

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\1]
"Flags"=dword:00000219


They are getting applied okay, but upon the next reboot the changes are gone and they never appear in the Internet options dialog as they should be.

Can anyone help me with this? It is a real pain in the a**. Files on my local network that are regular mapped drives should be treated just like local filesystems and not have a stupid "do I want to run it" dialog pop up every time I want to run something.

Thanks much in advance,

BobKat


How to remove advertisement from MSFN

#2
bobkat2769

bobkat2769
  • Member
  • 4 posts
  • Joined 18-September 08
I found an answer to my problem when I started searching for a script to open up the Internet Options dialog.

For anyone else looking for a solution to the zone check problem with IE 7 run the following lines at a command prompt or add to your reghacks file:

reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment" /v SEE_MASK_NOZONECHECKS /d 1

reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\1" /v "Flags" /t REG_DWORD /d 219 /f


#3
EvoLt

EvoLt
  • Member
  • 1 posts
  • Joined 27-April 15
  • OS:none specified
  • Country: Country Flag

Better late than never, thank for your solution !!  :thumbup






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users