Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



crashfly

nlite has become unstable [solved]

Recommended Posts

Nlite has become very unstable for me. I am unable to get through a full session without it crashing. Current version is v1.4.9.1. The same thing happens with v1.4.9.

The problem started with using Ryan's latest update pack (RVMUpdatePackSP3_1.0.1.7z). Nlite would crash during the "Intgrating hotfixes, packs and themes" phase. To get around that problem, I used Ryan's Integrator to integrate that update pack along with some other "Integrator Only" addons. This takes place before nlite. Now, when using nlite, I can get it to consistenly crash at random places. The most common place for it to crash is during the "Integrating drivers" phase.

I would include the error report, but unfortunately I cannot get the information from that report to copy onto the clipboard. It appears though that nlite is crashing with the 'ModName: msvcr90.dll'.

Presets file:

Removed due to length.

Edited by crashfly

Share this post


Link to post
Share on other sites

crashfly,

I doubt it!

Don't you think we would have heard from many others if that were true?

In the future, please attach your LastSession.ini and not paste it.

I would suspect the packs, myself. I have never used them and don't know how safe they are. I do know that if you nLite a source more than once you are asking for trouble. I don't know if that would include using some other integrator then nLite. Perhaps someone else will comment. I suggest you consider starting a little lower down, such as making an ISO with only the SP you need and see if that works. If so, then add something else, not just everything at once.

Enjoy, John.

Share this post


Link to post
Share on other sites

I believe this was a reported problem at RyanVM forums. Check out if people are having similar issues as you.

If you got spare time, contact nuhi about the problem and ask if he could release a maintenance version/ investigate further.

Share this post


Link to post
Share on other sites

Johnhc, the world does not revolve around you sir. The reason I could not add an attachment was due to the nlite crash I keep having. The only way it would work at *that* moment was to include the whole file into the post.

Now ... if you want to add something *constructive* to this conversation, then do so. Otherwise, I have no use for you.

@Happy-Dude: Thank you for your response. I will see about sending a note nuhi's way. Hopefully he can help me resolve why this is suddenly becoming a problem.

Share this post


Link to post
Share on other sites
Johnhc, the world does not revolve around you sir. The reason I could not add an attachment was due to the nlite crash I keep having. The only way it would work at *that* moment was to include the whole file into the post.

Now ... if you want to add something *constructive* to this conversation, then do so. Otherwise, I have no use for you.

@Happy-Dude: Thank you for your response. I will see about sending a note nuhi's way. Hopefully he can help me resolve why this is suddenly becoming a problem.

Dont know what your problem is. I personally use the ryanvm post sp3 update pack using nlite. I dont like ryans intergrater so I use nothing but nlite. I have yet to see a problem with that update pack or with nlite. Make sure your using the latest nlite version. Also try doing one update pack or addon pack at a time. Doing multi-things at a time could not only cause bad installs, but cause problems even intergrating. Narrow down your problem by doing one thing at a time and making sure you are using the latest packs/intergrater.

But one thing I can say is that the problem seems to be isolated to your computer/what your doing. I have not seen reports of unstable things at ether forums. So ether your doing something wrong or something is wrong on your computer. I doubt it is one of the major things such as the main update pack or nlite, cause then we would be seeing a lot of reports of this happening.

Edited by Spontaneous

Share this post


Link to post
Share on other sites

If it helps any, I think I solved the riddle to my nlite acting unstable. Although I allowed nlite to act as a "trusted" application, it appears the only item that changed from previous nlite sessions and the current ones were using a different firewall. I had recently began using COMODO Firewall Pro. It is a wonderful *free* program all in itself, however I had some options set that limit some of what nlite tries to do. The option "Defense+ Security Level" set to 'Clean PC Mode' or above appears to have intefered with the nlite process at different stages. To work around the problem, setting the "Defense+ Security Level" to 'Training Mode' appears to have solved the problem at this time.

I suppose I should have realized sooner that COMODO was "acting hostile" to nlite. It is now behaving much nicer in that I know what was causing the problem. Thank you for your informative replay Spontaneous. Problem solved for now. :thumbup

Share this post


Link to post
Share on other sites

crashfly,

Glad you tracked it down. I also have Comodo (currently running in Safe Mode) and when I get a complaint (popup from Comodo) while nLiteing, I put Comodo in Installation Mode and have seen no problems.

Enjoy, John.

Share this post


Link to post
Share on other sites

I have nLite 1.4.9 and using ryanvm 1.0.1 SP3 and I never had issues to make iso files. Now when I boot with my ISO I have a BSOD. What the hell is this?

My nlite integrates some networkdrivers (intel & broadcom) and ryanvm sp3. That's all

Do I have to download SP3 full (.exe) and put it in nlite -> service packs and after that put ryanvm SP3 1.0.1 in updates?

Edited by Kingskawn

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×