Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


NSLookup can resolve domain names, Ping can not resolve. Can ping IP.

- - - - -

  • Please log in to reply
3 replies to this topic


  • Member
  • 4 posts
  • Joined 11-October 08
Hello ,All

I am fixing a XP SP2 problem.
It is connect to a cable modem. No router. standalone, in a windows group(not domain). No proxy. I verified the following:

1. Network is getting correct info via DHCP including DNS addresses
2. NSLookup is resolving names correctly
3. I can ping machines on the internet by IP address
4. I can ping local machines by name and IP
5. When I try to ping an external machine by name (e.g., www.excite.com), I get the following error: Ping command could not find host www.excite.com. Please check the name ....
6. Pinging excite by IP ( works correctly.
7. Use the resolved IP by nslookup (e.g., can open the web page.
8. Use network packet capture tool, Microsoft network monitor, found that when I use ping to resolve a name, it did not send DNS package, but NetBios Package.

I tried uninstalling and reconfiguring NIC
I tried ipconfig /flushdns
The DNS client is running and I don't see any errors in the event log
I tried to uninstall the anti-virus soft, disable the firewall.

Thank you!

Edited by finnce, 11 October 2008 - 11:32 AM.

How to remove advertisement from MSFN



    Have you tried turning it off and on again?

  • Member
  • PipPipPipPipPipPip
  • 1,147 posts
  • Joined 28-October 05
try reinstalling TCP/IP in network connection properties and see if that works.
btw have you scanned for spyware/viruses at all?


  • Member
  • 4 posts
  • Joined 11-October 08
Thanks for your reply.

I tried these, but not working.
1. "netsh int ip reset resetlog.txt" to reset TCP/IP
2. "netsh winsock reset" to reset Winsock 2

I have an anti-virus software, which is uptodate.

Edited by finnce, 14 October 2008 - 08:08 AM.


  • Member
  • 4 posts
  • Joined 11-October 08
somebody tell me it's KB951748 problem.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users