Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Need help Scripting Drive Mapping in PE

- - - - -

  • Please log in to reply
6 replies to this topic

#1
campbrs

campbrs

    Newbie

  • Member
  • 24 posts
  • Joined 19-December 03
How do I script a drive mapping in WinPE? I can map a drive manually with the net use command but the net use command in PE doesn't appear to support the passing of a password and username.

Is there anyway this can be scripted? Am I doing anything wrong?

NET USE [devicename] [\\computername\sharename [password] [/user:[domain\]username - does not work

net use [devicename] [\\computername\sharename]
prompts for username and then password - does work


TIA!
-RC


How to remove advertisement from MSFN

#2
scankurban

scankurban

    F_s_M

  • Member
  • PipPip
  • 240 posts
  • Joined 29-August 03
IF YOU HAVE USE ERD COMMANDER 2003.BETTER ANY WINPE SYSTEM
Posted Image

#3
BetaDroidâ„¢

BetaDroidâ„¢

    Beta Be Good

  • Member
  • 35 posts
  • Joined 16-December 03
Should that porn link be in your signature? I think its against the rules...
Posted Image
Ne0win, the site that ponces everyone else's stories,
continually nick INQUIRER stories and obviously can't
write for toffee. - The Inquirer.

#4
gosh

gosh

    gosh 2.0

  • Patrons
  • 2,347 posts
  • Joined 03-October 03
  • OS:none specified
  • Country: Country Flag
Porn? Where? I want some

The net use command is different in winpe (syntax). The OPK help file should give the exact syntax. If you don't have the xp opk i could dig around and look for it for you.

-gosh

#5
campbrs

campbrs

    Newbie

  • Member
  • 24 posts
  • Joined 19-December 03
I only have PE - I work for an enterprise licensed corp but the global IT dept only has released a PE ISO.

BTW - TIA = Thanks In Advanced!

-RC

#6
baliktad

baliktad

    Stellar Underachiever

  • Member
  • PipPip
  • 155 posts
  • Joined 24-October 03
The net use syntax in WinPE is exactly the same as you are used to in WinXP and what you are attempting to do is technically correct. The problem is you are not logged into WinPE with a user account - you are running as the system. This is why we cannot script a network drive mapping. I've also run into this problem but it hasn't been too bad as I only use WinPE for occasional repair work or a new install. It may be possible to pipe the input from a file - I've never been bothered enough to investigate though.

#7
Shadowpp

Shadowpp

    Newbie

  • Member
  • 41 posts
  • Joined 24-October 03
I use this method and it works perfectly everytime........

Use this:
NET USE [devicename] [\\computername\sharename [/user:[domain\]username [password]

the syntax you had is incorrect.....specifically, the placement of the password.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users