strel

Silent .NET Maker synthesized 20100118 - W2K/XP/2K3 x86

1,004 posts in this topic

Nop. I don't use it. But the basis of the script are the same old admin installs. After having a quick reading on HFSLIP basis, and take a quick look to the HFSLIP script, I think resultant installers from synthesized version should work too without problems in HFSLIP.

Any of you using it can confirm it. So, please...

I realize switchless feature is intended for using installers with HFSLIP, as I suspected. For future updates, I'll keep this feature to maintain compatibility with HFSLIP, but optionally, this is, people who don't use HFSLIP will can have unique set of installers that could be switched from silent to passive.

Edited by strel
0

Share this post


Link to post
Share on other sites
2 Jediron

Depends on the software you run. .NET is only for software that is made for using this frameworks ("managed code" in MS jargon). Not all software use .NET and not all software that use .NET, use the same #.# version. Maybe the software you use, needs only 2.0, but for ongoing updates of that software, the developer may update the code to a later .NET version. For example, paint .NET have changed its framework needs from 2.0 to 3.5 in recent versions. Up to you.

Thx.

Well, i want to install it so that NET will always work, with everything. No hassle about version, NET is there; always. Is this possible ?

0

Share this post


Link to post
Share on other sites

Use intallers for all the frameworks in your unattended set. You can rarely use an application that needs 1.1 but if you want to be sure include all. You can use the full merged installer or individual installers, read the install rules.

0

Share this post


Link to post
Share on other sites

So i use those three i already have and NEt 1.1 , then i have all ?

0

Share this post


Link to post
Share on other sites

Yes, until MS releases .NET 4.0, probably during this year.

Edited by strel
0

Share this post


Link to post
Share on other sites
I really have no idea of what this last langpack is made for,

I think because it contains only 3.0 SP2 LangPack alone. You can see it's date is the same when the 2.0/3.0/3.5 Langpack released. (2008. 11. 13.)

Now i've installed a clean XP on VMware again, i've installed .NET 3.5 SP1 full redistributable (231Mbytes) without internet access. After that i tried to install .NET 3.0 SP2 Language Pack from Microsoft Update Website, but it failed!! It have throwed me error code 0x13EC.

So i installed .NET 3.5 SP1 langpack.

After that i've visited MU website, 2.0 LangPack disappeared, but 3.0 SP2 LangPack still remains!!

I've searched the whole C:\ for the 4 files you mentioned, but i found nothing.

These files are truly not exist in any of the 3.0 SP2 hungarian Language Packs.

This (the lack of these 4 files) must be the real reason why MU website offers me continually the .NET 3.0 SP2 LangPack.

So microsoft screwed up again...

I bet i can't use these files from other languages... :)

Anyway, i want to thank you for your excellent support! I really appreciate it.

Thank you!

0

Share this post


Link to post
Share on other sites

These 4 files exists only in the admin install of languages other than magyar, not after intalling in the OS.

About the stand alone 3.0 SP2 langpack, to me it's a nonsense, why some languages have it and some others not? I'm not confident in any way with that packet.

0

Share this post


Link to post
Share on other sites
These 4 files exists only in the admin install of languages other than magyar, not after intalling in the OS.

Ouh. OK. Then why MU website continually offers me 3.0 SP2 Langpack? And what these 4 files need for?

About the stand alone 3.0 SP2 langpack, to me it's a nonsense, why some languages have it and some others not? I'm not confident in any way with that packet.

Micro$oft logic. :)

0

Share this post


Link to post
Share on other sites

I think continually if we don't manage the way for they to appear in the admin install of 3.5 SP2 language from 3.5 SP1 langpack.

And I don't think MS earns nothing with this. I though it was for updating stand alone 3.0 or 3.0 SP1 installations, but this doesn't explain the absence of some languages.

0

Share this post


Link to post
Share on other sites
I think continually if we don't manage the way for they to appear in the admin install of 3.5 SP2 language from 3.5 SP1 langpack.

???

You mean we can get those files from previous LangPacks?

0

Share this post


Link to post
Share on other sites

I could check that both dotnetfx35langpack_x86hu.exe (SP1 version) and NetFx30SP2_x86hu.exe have the same structure in patch.cab inside

..\netfx30lp\WCF_HUN.msp

..\netfx30lp\WPF1_HUN.msp

files resulting from both extractions of language packs above (3.0 SP2 portion is almost equal); patch.cab files that doesn't contain files correponding to these 2 pair of files respectively.

Moreover NetFx30SP2_x86hu.exe lacks file XPSEPSCLANGPACK-x86-hu-HU-langpack.exe. This file is installed when 3.0 SP2 language is installed from dotnetfx35langpack_x86hu.exe (SP1 version) langpack. But the install size indicated under Add/remove programs is not affected by this file, thus 3.0 SP2 language installed from NetFx30SP2_x86hu.exe shows the same install sizes, 3,8 MB and 10 MB, installing it through admin install (aka SNM installers) or directly, respectively. So NetFx30SP2_x86hu.exe, is not offering any advantage, rather the opposite.

But now this doesn't seem relevant to me since I could check there's other dotnetfx35langpack_x86XX.exe (SP1 version) langpacks that lacks the files of the first paragraph, for the 3.0 SP2 language portion, like turkish, italian, russian, chinese simplified... And installing 3.0 SP2 language from this langpacks, indicates the same install size when installed from admin install (aka SNM installers) as well as when installed directly from the langpack.

So I didn't checked all langpacks with this structure, but it seems the wrong behavior only happens with hungarian language admin install for 3.0 SP2.

Anybody want to add something?

I should add that the file fenyo was prompted to download from MS Update, when 3.0 SP2 language is installed from admin install (aka SNM installers), this is, showing 3.8 MB installed; wasn't the same 3.0 SP2 language standalone, as stated before, but 3.0 SP0 language standalone. This happened only under hungarian XP, not under english XP (with .NET hungarian languages), to make things even more strange.

EDIT: Check post #59 for updated info.

Edited by strel
0

Share this post


Link to post
Share on other sites
Nop. I don't use it. But the basis of the script are the same old admin installs. After having a quick reading on HFSLIP basis, and take a quick look to the HFSLIP script, I think resultant installers from synthesized version should work too without problems in HFSLIP.

Any of you using it can confirm it. So, please...

I realize switchless feature is intended for using installers with HFSLIP, as I suspected. For future updates, I'll keep this feature to maintain compatibility with HFSLIP, but optionally, this is, people who don't use HFSLIP will can have unique set of installers that could be switched from silent to passive.

I have not yet tried the installers with HFSLIP. However, I have noticed, that Tomcat76 used the utility msistub.exe, apparently to make it work with HFSLIP and Win2k, at least at some point, and this quote is from his original readme:
msistub.exe

Windows 2000 doesn't handle direct calls to MSIEXEC.EXE at T-13, but

msistub.exe can communicate with it. This tool is used to install the

.NET 1.1 and .NET 2.0 components.

Author: Oleg_Sch.

Now I see, that the synthesized script does not refer to this utility, as Tomcat76's original script does, nor is the utility included.

So, I wonder if it might be correct to assume, that the script would not work with HFSLIP on Win2k, or does it include some other method to achieve the same result?

0

Share this post


Link to post
Share on other sites

7-zip SFX modified and msistub.exe are authored by Oleg_Sch who include the function of the second in the first, so it shouldn't be a problem.

0

Share this post


Link to post
Share on other sites
I've got to do more tests tomorrow.

Thank you!

Edited by fenyo
0

Share this post


Link to post
Share on other sites

Hello,

I'm getting a bit confused by the instructions, I've obviously missed something or did something incorrect. Here is what I've done:

I downloaded all of the files to a working directory along with the .net packs. Here is the contents of that directory:

7-zip.chm
7za.exe
7zSD.sfx
copying.txt
dotnetfx.exe
dotnetfx35.exe
dotnetfx35a.exe
license.txt
NDP1.1sp1-KB867460-X86.exe
NDP1.1sp1-KB928366-X86.exe
NDP20SP2-KB958481-x86.exe
NDP30SP2-KB958483-x86.exe
NDP35SP1-KB958484-x86.exe
NetFx20SP1_x86.exe
readme.txt
SNMsynth.cmd
SNMsynth_loud.cmd
_SNMsynth.ini

For my first attempt I modified the _SNMsynth.ini with the following:

MERGE_FRAMEWORKS=FULL
COMPRESSION_RATIO=LOW

And then tried both using both the SNMsynth_loud.cmd and SNMsynth.cmd and both produced this error:

ERROR: You have to choose what file is .NET 2.0 SP# going to be processed from.

Press any key to continue . . .

I can't seem to find where to specify this parameter? Or possibly I'm misunderstanding how to use this.

Any help is appreciated,

C

Edit:

Second attempt I tried by additionally modifying the following because there are no language packs that I know of for English:

PROCESS_LNG_DNF1=NO
PROCESS_LNG_DNF2=NO
PROCESS_LNG_DNF35_DNF2=NO
PROCESS_LNG_DNF35_DNF3=NO
PROCESS_LNG_DNF35_DNF35=NO

I get the same error message. I'm not really sure what I'm doing incorrectly.

Edited by Caspean
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.