strel

Silent .NET Maker synthesized 20100118 - W2K/XP/2K3 x86

1,004 posts in this topic

I can't seem to find where to specify this parameter? Or possibly I'm misunderstanding how to use this.

I think this is because you have some unnecessary files.

For example you don't need NetFx20SP1_x86.exe when you have dotnetfx35.exe.

dotnetfx35.exe is .NET 3.5 full redistributable, which contains .NET 3.0 and .NET 2.0 too.

And what is dotnetfx35a.exe ?

Edited by fenyo
0

Share this post


Link to post
Share on other sites

Thanks for the quick response,

I get totally confused by which files I need if I want an all in one installer. The file that ends in a is the second download of the dotnetfx35a.exe is the the second file I downloaded that was named dotnetfx35.exe, I changed the name because I wasn't quite sure what to do with it.

It supports the following files:

This may sound like a stupid question but could someone just clarify for me which of the files listed above should go into a "FULL" synthesis? I'm really new at this.

Thanks,

C

Edit:

So to be clear the:

.NET 3.5 full redistributable

.NET 3.5 SP1 full redistributable

Have the same name when downloaded, so I changed the second on to dotnetfx35a.exe.

Edit 2:

I think maybe I'm just reading the list incorrectly.

.NET 3.5 SP1 full redistributable (dotnetfx35.exe -- note it's the same filename as 3.5 but this is 231 MB), contains .NET 2.0 SP2, .NET 3.0 SP2 and .NET 3.5 SP1. For XP/2003 only.

I take this as saying that it contains 3.5, 2.0 SP2 (but not 2.0 or SP1), 3.0 SP2 (but not 3.0 or 3.0 SP1), and 3.5 SP1.

Should I instead read it to say:

3.5, 3.5 SP1, 2.0, 2.0 SP 1, 2.0, SP2, 3.0, 3.0 SP1, and 3.0SP2 ?

If that's the case then all I need to do a full synthesis is:

.NET 1.1 Redistributable Package (dotnetfx.exe) for windows 2000, XP, x86 only.
NDP1.1sp1-KB867460-X86.exe hotfix for 2000/XP only.
NDP1.1sp1-KB928366-X86.exe hotfix for 2000/XP only .
.NET 3.5 SP1 full redistributable (dotnetfx35.exe -- note it's the same filename as 3.5 but this is 231 MB), contains .NET 2.0 SP2, .NET 3.0 SP2 and .NET 3.5 SP1. For XP/2003 only.
NDP20SP2-KB958481-x86.exe, NDP30SP2-KB958483-x86.exe and NDP35SP1-KB958484-x86.exe hotfixes for XP/2003 only.

Is this correct?

Edited by Caspean
0

Share this post


Link to post
Share on other sites

Caspean, you need to feed the process with only 1 SP# of each .NET #.# version. So you have to find the correct matching of packets-in-work-folder/settings-in-.ini-file that feed the process correctly. Only packets with it's original filename can be processed. Read carefully the notes in the .ini file that explain what trigger each setting.

Edited by strel
0

Share this post


Link to post
Share on other sites

Thanks for the response,

I have read it several times, very carefully. I think there is a bit of a language gap is all. It's a bit difficult for me to understand. Don't get me wrong I'm not complaining, I'm just trying to clarify. I'm an Midwest born and raised US citizen, heck sometimes we can't even understand people on the east coast of our own country. :whistle:

I think I added some comments to the end of the post above at the same time you were posting. They might help clarify my confusion.

Thanks,

C

Edit: If I read it the way I mention above should I also read it as

NDP1.1sp1-KB928366-X86.exe Contains NDP1.1sp1-KB867460-X86.exe (because its a later update)

and

.NET 3.5 SP1 full redistributable Contains NDP20SP2-KB958481-x86.exe, NDP30SP2-KB958483-x86.exe and NDP35SP1-KB958484-x86.exe

So really all I need for a full synthesis is:

.NET 1.1 Redistributable Package (dotnetfx.exe) for windows 2000, XP, x86 only.
NDP1.1sp1-KB928366-X86.exe hotfix for 2000/XP only .
.NET 3.5 SP1 full redistributable (dotnetfx35.exe -- note it's the same filename as 3.5 but this is 231 MB), contains .NET 2.0 SP2, .NET 3.0 SP2 and .NET 3.5 SP1. For XP/2003 only.

Edited by Caspean
0

Share this post


Link to post
Share on other sites

3.5 SP1 packet=3.5 SP1+3.0 SP2+2.0 SP2, that's all. Better to include updates for this.

0

Share this post


Link to post
Share on other sites

Ok I'm getting really confused. :wacko: I did a search to find what exactly is contained in .net 3.5 redistributable. And there is basically no documentation I can find on it. According to fenyo it contains all of 2.0 and 3.0. Which would make sense because I don't see a link provided to download 2.0, only hotfixes and service packs.

I can't seem to find where to specify this parameter? Or possibly I'm misunderstanding how to use this.

I think this is because you have some unnecessary files.

For example you don't need NetFx20SP1_x86.exe when you have dotnetfx35.exe.

dotnetfx35.exe is .NET 3.5 full redistributable, which contains .NET 3.0 and .NET 2.0 too.

And what is dotnetfx35a.exe ?

So can someone clarify that 3.5 redistributable contains all of 2.0 and 3.0 and not just the service packs?

3.5 SP1 packet=3.5 SP1+3.0 SP2+2.0 SP2, that's all. Better to include updates for this.

So I take this to say that .NET 3.5 SP1 full redistributable does not contain the .net 2.0 or .net 3.0? This is confusing because if it only contains the service packs why is it so huge? Those service packs are like 16MB aren't they?

If I look at 3.5 redistributable and break it down based on the same grammar syntax then you are saying that it does not contain full installs for 2.0 and 3.0, but only the service packs for them. If that's the case where do I get 2.0 from?

If someone who does a FULL synthesis could please share the actual _SNMsynth.ini and directory contents this would help shed some light on this for me.

I don't understand how I can download both the 3.5 redistributable and 3.5 SP1 redistributable and have them in the same directory without modifying at least one file name.

Thanks,

C

Edited by Caspean
1

Share this post


Link to post
Share on other sites

2.0 SP#, 3.0 SP# and 3.5 SP# are not SPs are full frameworks versions (each one) updated to this SP# (of its own). You probably are trying to build updated installers for XP. Download 3.5 SP1 redistributable and updates for 2.0 SP2, 3.0 SP2 and 3.5 SP1, you don't need 3.5 redistributable (2.0 SP1, 3.0 SP1 and 3.5) unless you want any of the versions outdated. You don't need need NetFx20SP1_x86.exe because you have one 2.0 in .NET 3.5 SP1 redistributable. OK?

It's easy believe me.

0

Share this post


Link to post
Share on other sites

I want to start by saying thank you. I know it can be very frustrating trying to explain something to someone of a different native langauge, made even harder when the material is of a technical nature. Again, thanks for not getting to frustrated with me.

2.0 SP#, 3.0 SP# and 3.5 SP# are not SPs are full frameworks versions (each one) updated to this SP# (of its own). You probably are trying to build updated installers for XP. Download 3.5 SP1 redistributable and updates for 2.0 SP2, 3.0 SP2 and 3.5 SP1, you don't need 3.5 redistributable (2.0 SP1, 3.0 SP1 and 3.5) unless you want any of the versions outdated. You don't need need NetFx20SP1_x86.exe because you have one 2.0 in .NET 3.5 SP1 redistributable. OK?

It's easy believe me.

So can I also download .net 1.1 redistributable and its two hotfixes (NDP1.1sp1-KB928366-X86.exe and NDP1.1sp1-KB947742-X86.exe hotfix) and synthesize/integrate into a single installer in one shot? This was my assumption several post ago and nobody said it was correct, so I'm worried it is not correct.

If that's the case then all I need to do a full synthesis is:

.NET 1.1 Redistributable Package (dotnetfx.exe) for windows 2000, XP, x86 only.
NDP1.1sp1-KB867460-X86.exe hotfix for 2000/XP only.
NDP1.1sp1-KB928366-X86.exe hotfix for 2000/XP only .
.NET 3.5 SP1 full redistributable (dotnetfx35.exe -- note it's the same filename as 3.5 but this is 231 MB), contains .NET 2.0 SP2, .NET 3.0 SP2 and .NET 3.5 SP1. For XP/2003 only.
NDP20SP2-KB958481-x86.exe, NDP30SP2-KB958483-x86.exe and NDP35SP1-KB958484-x86.exe hotfixes for XP/2003 only.

Is this correct?

Thanks Again,

C

EDIT:

My directory now contains:
7-zip.chm
7za.exe
7zSD.sfx
copying.txt
dotnetfx.exe
dotnetfx35.exe
license.txt
NDP1.1sp1-KB867460-X86.exe
NDP1.1sp1-KB928366-X86.exe
NDP20SP2-KB958481-x86.exe
NDP30SP2-KB958483-x86.exe
NDP35SP1-KB958484-x86.exe
readme.txt
SNMsynth.cmd
SNMsynth_loud.cmd
_SNMsynth.ini

I have attached my _SNMsynth.ini file. Now I get this:

Processing .NET 1.1 installer...
Processing NDP1.1sp1-KB867460-X86.exe...
Processing NDP1.1sp1-KB928366-X86.exe...

Processing .NET 3.5 SP1 installer...
Processing .NET 2.0 SP2 portion...
Processing NDP20SP2-KB958481-x86.exe...
Processing .NET 3.0 SP2 portion...
Processing NDP30SP2-KB958483-x86.exe...
Processing .NET 3.5 SP1 portion...
Processing NDP35SP1-KB958484-x86.exe...


Creating merged .NET 1.1, .NET 2.0 SP2, .NET 3.0 SP2, .NET 3.5 SP1 installer...

Done!

Press any key to quit...

I'm going to assume I did this correctly and test the install of it now.

C

_SNMsynth.ini

Edited by Caspean
0

Share this post


Link to post
Share on other sites

Yes, correctly for updated complete set of .NET frameworks for XP or 2003. This merged installer should be used on first logon.

0

Share this post


Link to post
Share on other sites

Thank you very much for your help and your patience. :thumbup

I've tested it as a standalone on a couple systems and it seems to work perfectly. I'll now use HFSLIP and test it in the HFGUIRUNONCE folder to see if it I can successfully integrate it into my XP disc.

Thanks again,

ss3

0

Share this post


Link to post
Share on other sites
I should add that the file fenyo was prompted to download by MS Update when 3.0 SP2 language is installed from admin install (aka SNM installers),

Not just with admin install.

If i install the original pack (not admin install), it's showed size 10MB, but MS Update offers me 3.0 Langpack again! So it seems it's not just an admin-install problem.

wasn't the same 3.0 SP2 language standalone, as stated before, but 3.0 SP0 language standalone
:blink:
This happened only under hungarian XP, not under english XP (with .NET hungarian languages), to make things even more strange.

I think this is because English XP doesn't need any language packs at all, so if an installed langpack is corrupted, it won't offer any, because it doesn't need one.

So what's happening? I think 3.0 SP2 hungarian language files for XP/2003 may be corrupted, causing installing though administrative install (aka SNM installlers), not to complete correctly

As i mentioned above, the standalone 3.0 SP2 Langpack install (not admin install; and i've installed xpsepsclangpack manually) does the same(MS Update problem) with installed size 10MB.

Any ideas?

You've said, that the 4 lacking file actually does not get into the system. What happens, if we just copy these files from an other language to hungarian Admin install? I think i'll try it...

0

Share this post


Link to post
Share on other sites

These 4 are not present in many other langpacks with the same structure, and don't generate problems. I don't think they are culprit of anything.

0

Share this post


Link to post
Share on other sites
These 4 are not present in many other langpacks with the same structure, and don't generate problems. I don't think they are culprit of anything.

Ok.

Then we have to tell M$ to repair their package.

(but i'm afraid it can take months...)

0

Share this post


Link to post
Share on other sites

.NET 3.0 SP2 language (for some languages)

There's problems when installing 3.0 SP2 from .NET 3.5 SP1 redistributable under some XP x86 localized versions:

- If you install english version (dotnetfx35.exe /lang:ENU), windows/ms update prompts you to download 3.0 SP0 langpack standalone.

- If you install some language to the english version windows/ms update prompts you to download the same 3.0 SP0 langpack standalone KB928416:

---> when installing dotnetfx35.exe normally, the installer downloads the language files, if you're connected, obviously

---> or when you install it from .NET 3.5 SP1 langpack standalone

---> or when you install it from a 3.0 SP2 language administrative install (aka SNM installers) generated from standalone langpack

In all install scenarios of 3.0 SP2 under hungarian XP are the same.

So, what's happening?

I think there's a problem with 3.0 SP2 framework under some XP X86 (maybe 2003 too).

It doesn't matter how you install it (with or without language), windows/ms update prompts you to download 3.0 SP0 langpack standalone.

And if you're going to use SNMSynth 3.0 SP2 installers under some localized XP (and maybe 2003, this has to be checked) and you want to get freed of win/ms update prompting to install 3.0 SP0 standalone language KB928416, I recommend you to use the method described in the "Obtain a Clean or Customized DataStore.edb File" section of this guide.

EDIT: I recommend to use the latests version the script that fixes this issue.

At least until MS fix all this.

Thx 4 your help fenyo.

Anymore ideas?

Edited by strel
0

Share this post


Link to post
Share on other sites
Thx 4 your help fenyo.

No, it is I who should thank you!

BTW, your summary is good. :)

And i've written a mail to the hungarian M$ group about this problem.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.