strel

Silent .NET Maker synthesized 20100118 - W2K/XP/2K3 x86

1,004 posts in this topic

New version released!

A major bug has been solved. Custom installers/add-ons containing 3.5 SP# and applying any hotfix on it, built with SNMsynth versions from 20091029 to 20091229, both included, must be rebuilt. The fix file to apply YumeYao's method for slimming down 3.5 SP# frameworks was applied late making appear the problem described here:

... .NET 3.5 SP1 and its language pack are offline msi installers indeed. They are different than regular installers therefore once you use "msiexec.exe /a" to deploy it, the output dir is much bigger than before and both msi and cab files are still there. Even updated files are useless as the msi file is totally same as before so it only regard the cab file as a valid source...
So this means those who are using 3.5 SP# from custom installers/add-ons built with those versions are not getting this framework version updated with the files from the hotfixes applied.

So sorry folks! :blushing:

Also a bug breaking 3.5 SP# frameworks error messages for languages with codepages different than 1252 (ANSI Latin I) has ben solved. I had adopted a very bad solution to apply transforms over .msi files with missmatching codepages.

These bugs were both inserted in 20091029 version.

And last, bug inserted in 20091224 causing error 2727 boxes for those who were removing ClickOnce while having KB963707 in the work folder, has been fixed.

I also added restricted NDP1.1sp1-KB974762-X86.exe to the guide.

Happy new year folks!! And thx for your help.

Enjoy! :thumbup

shiouliang

I'm sorry, you advised me about that 20091029 errors almost 2 months ago but when I quickly read your post those days, I thought you were referring to that issues as been solved, because of the recent changes made those days inserting YumeYao's method and the codepage solution I had just adopted, and didn't pay further attention to it until now.

Edited by strel
0

Share this post


Link to post
Share on other sites

Thanks for the fix strel!

tested 3.5sp1 t-13 adddon, seems to works fine.

Happy New Year !

Edited by mooms
0

Share this post


Link to post
Share on other sites

Hello and happy new year.

I use 20091231 and i have a problem.

The process goes well untill it starts processing 3.5 sp1.I get error 1308 /TMP/TMP5/ADMIN35/Win/Microsoft.NET/Framework/v3.5/WindowsPresentation Foundation/DotNetAssistantExtension/MicrosoftDotNetFrameworkAssistant.xp1

0

Share this post


Link to post
Share on other sites

Checking...

Edited by strel
0

Share this post


Link to post
Share on other sites
Hello and happy new year.

I use 20091231 and i have a problem.

The process goes well untill it starts processing 3.5 sp1.I get error 1308 /TMP/TMP5/ADMIN35/Win/Microsoft.NET/Framework/v3.5/WindowsPresentation Foundation/DotNetAssistantExtension/MicrosoftDotNetFrameworkAssistant.xp1

Me Too~

0

Share this post


Link to post
Share on other sites

New version released!

It seems KB963707 (clickonce update) is an exception among 3.5 SP1 hotfixes and require the cab file or the INSTALLLEVEL=2 (before slimming down) to get applied correctly, contrary to the rest of 3.5 SP1 hotfixes behavior. That's what I did to fix this bug.

Also fixed a bug getting 3.5 SP# applied hotfixes identifiers for A/R Programs list removal, inserted with the changes made in 20091224, but it only affects very few cases.

Happy hangover day!

Edited by strel
0

Share this post


Link to post
Share on other sites

Strel,

Just tested your 20100101 version. Seemed to work find but no longer see "Proceesing ...kb963707..." message. Is that by design now?

Just wondering. Thanks for all your hard work.

M2GD

0

Share this post


Link to post
Share on other sites

Good point! ;)

I forgot it. Fixed now.

New version released!

0

Share this post


Link to post
Share on other sites

Worked like a charm Strel!

Thanks for the quick fix.

M2GD

0

Share this post


Link to post
Share on other sites

I have a problem to report after 20100102 update kb951847 shows in microsoft update

Edit. i attached processdata

Thank you

PROCESSDATA.TXT

Edited by kalaeimaigr
0

Share this post


Link to post
Share on other sites

Can you attach your processdata.txt ?

Anyone else?

Edited by strel
0

Share this post


Link to post
Share on other sites

2.0sp2+3.0sp2+3.5sp1+RuLng, WIC, debugger, VC (both), FF plugs (both) removed.

20091231 - installer size - 33 Mb

20100102 - 42 Mb

DNF35 folder size:

20091231 - 33 Mb, 20100102 - 54 Mb

DNF35 - 20091231

Program Files
ruLNG
vs_setup.msi
Win

DNF35 - 20100102

baseline.dat
deffactory.dat
DeleteTemp.exe
dlmgr.dll
eula.1025.rtf
eula.1028.rtf
eula.1029.rtf
eula.1030.rtf
eula.1031.rtf
eula.1032.rtf
eula.1033.rtf
eula.1035.rtf
eula.1036.rtf
eula.1037.rtf
eula.1038.rtf
eula.1040.rtf
eula.1041.rtf
eula.1042.rtf
eula.1043.rtf
eula.1044.rtf
eula.1045.rtf
eula.1046.rtf
eula.1049.rtf
eula.1053.rtf
eula.1055.rtf
eula.2052.rtf
eula.2070.rtf
eula.3082.rtf
gencomp.dll
HtmlLite.dll
locdata.1025.ini
locdata.1028.ini
locdata.1029.ini
locdata.1030.ini
locdata.1031.ini
locdata.1032.ini
locdata.1035.ini
locdata.1036.ini
locdata.1037.ini
locdata.1038.ini
locdata.1040.ini
locdata.1041.ini
locdata.1042.ini
locdata.1043.ini
locdata.1044.ini
locdata.1045.ini
locdata.1046.ini
locdata.1049.ini
locdata.1053.ini
locdata.1055.ini
locdata.2052.ini
locdata.2070.ini
locdata.3082.ini
locdata.ini
logo.bmp
Program Files
ruLNG
setup.exe
setup.sdb
setupres.1025.dll
setupres.1028.dll
setupres.1029.dll
setupres.1030.dll
setupres.1031.dll
setupres.1032.dll
setupres.1035.dll
setupres.1036.dll
setupres.1037.dll
setupres.1038.dll
setupres.1040.dll
setupres.1041.dll
setupres.1042.dll
setupres.1043.dll
setupres.1044.dll
setupres.1045.dll
setupres.1046.dll
setupres.1049.dll
setupres.1053.dll
setupres.1055.dll
setupres.2052.dll
setupres.2070.dll
setupres.3082.dll
setupres.dll
SITSetup.dll
vs70uimgr.dll
vsbasereqs.dll
vsscenario.dll
vs_setup.cab
vs_setup.dll
vs_setup.msi
vs_setup.pdi
WapRes.1025.dll
WapRes.1028.dll
WapRes.1029.dll
WapRes.1030.dll
WapRes.1031.dll
WapRes.1032.dll
WapRes.1035.dll
WapRes.1036.dll
WapRes.1037.dll
WapRes.1038.dll
WapRes.1040.dll
WapRes.1041.dll
WapRes.1042.dll
WapRes.1043.dll
WapRes.1044.dll
WapRes.1045.dll
WapRes.1046.dll
WapRes.1049.dll
WapRes.1053.dll
WapRes.1055.dll
WapRes.2052.dll
WapRes.2070.dll
WapRes.3082.dll
WapRes.dll
WapUI.dll
Win

0

Share this post


Link to post
Share on other sites

New version relesased.

Thx for your help folks! :thumbup

A couple of trivial errors, fix applied in the wrong folder, and some fixes files not included in its packet and that was all, fortunately.

Edited by strel
0

Share this post


Link to post
Share on other sites

BTW, maybe add new option into INI file, which says SNM synth to launch all installers/updates minimized? Something like

SET STARTMIN=
IF <INI_option_check> SET STARTMIN=/MIN

START /WAIT %STARTMIN% blah-blah-blah.exe

Now installer windows become foreground & take input focus...

0

Share this post


Link to post
Share on other sites

P.S.: Version 20100103.

_SNMsynth.cmd:

::		Silent .NET Maker synthesized 20100102		  ::

_SNMsynth.ini:

; _SNMsynth.cmd 20100102 PROCESS SETTINGS.   ----

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.