strel

Silent .NET Maker synthesized 20100118 - W2K/XP/2K3 x86

1,004 posts in this topic

strel, if you replace /qb with /qb! switch, Cancel button will be removed from install windows

0

Share this post


Link to post
Share on other sites

Pasha_ZZZ, I'll include minimize option for building process .NET admin install launch in the next version, it's a good idea. I fixed version # for the current files. And about /qb!, you're referring to the building process, but it's not my to intention to ocult it there, is useful in case process is aborted.

Thx for your suggestions.

0

Share this post


Link to post
Share on other sites

Maybe add /qb! as option into INI too? Best way to cancel process is closing CMD window.We must press Cancel too many-many times in MSI if CMD is active...

Edited by Pasha_ZZZ
0

Share this post


Link to post
Share on other sites

Pasha_ZZZ, I really think /qb! is not needed, I don't think there's a real risk with the user running the building process pressing the cancel button mistakenly, specially if I add /MIN switch as an option, and I prefer not close options. Also the building process is not supposed to be run by a user in a managed environment, but by the administrator, so doesn't seem to be an issue. All this make me think /qb! in the building process is not a good idea, and in addition everyone can change the script to their needs.

And obviously I was referring to use the cancel button after closing the command line window or after aborting building process with CTRL+C (or double one) waiting for started subprocess to end, period that can be shortened by pressing the cancel button.

0

Share this post


Link to post
Share on other sites

I'm having a problem installing Silent .NET Maker synthesized for Win2k and WinXP using HFSLIP. I've put the EXE file in the HFSVCPACK folder in both instances.

For Win2k, neither version is installed. Should the EXE be put in HFGUIRUNONCE or am I doing something else wrong?

For WinXP, only Net v1.1SP1 is installed, not the others. Should the EXE be put in HFGUIRUNONCE here also.

I am little bit confused now so I need some guidance.

Thank you.

M2GD

0

Share this post


Link to post
Share on other sites

Not sure what's happening, I'm not an HFSLIP user, you may need to post in HFSLIP subforum giving further details. As long as you apparently seem to be using AIO custom installer (so intall priorities are handled by install script), what you did seems OK to me selecting only one of the folders (hence install method) to drop your custom installers. I'd check the windows source to see whether or not HFSLIP applied the installers correctly using the install method selected.

You can test the custom installers on your system or apply them to you win source manually to discard a problem with them.

I just discovered you can use add-ons also with HFSLIP using HFAAO folder (see guidelines/extras in hfslip.org), didn't know it and don't think it makes any difference, but it's an extra option to apply them.

0

Share this post


Link to post
Share on other sites
I'm having a problem installing Silent .NET Maker synthesized for Win2k and WinXP using HFSLIP. I've put the EXE file in the HFSVCPACK folder in both instances.

For Win2k, neither version is installed. Should the EXE be put in HFGUIRUNONCE or am I doing something else wrong?

For WinXP, only Net v1.1SP1 is installed, not the others. Should the EXE be put in HFGUIRUNONCE here also.

Same problem for me (only used 2.0, 3.0 and 3.5, nothing installed at the end, i.e. after Windows setup was completed), used version 20100102 for creation of the installers. But I got an error message during T-13 phase, saying something similar to "Use %FILENAME -h for help" with just an okay button (that's right, only one '%' sign). This has worked before, but I cannot tell you which was the last version I tested it successfully.

If required I can re-do this later in a virtual machine to provide a screenshot. By the way, running the same installers after Windows installation was fine, no messages (except the missing KB951847 problem in MU for that specific SNM version, but this was fixed meanwhile). So this is something specific to the T-13 phase I guess.

Tomalak

0

Share this post


Link to post
Share on other sites

This messages come from the install script "error boxes for wrong switches" part of the code, so I'd like to discard you'd were using switches to run your custom installers at T-13 (or may you have repacked T-13 add-ons applying switches to change default behavior).

But if you're using switches at T-13, what's exactly the command with switches you're running? Is that exact command generating that broken error box only on T-13?

0

Share this post


Link to post
Share on other sites

Strel,

As with Tomalak, this is new for me also as it did work before.

I"m not modifying anything. I take the EXE from your script and put it in HFSVCPACK. I do not change anything.

Here's the only change I make and it's in the ini file of your script.

TARGETOS=XP

T13ADDONS=

ROEADDONS=

ALSOINSTALLERS=

MERGEFXS=YES

SILENT=YES

COMPRATIO=

Will try your HFAAO suggestion and report back.

Thanks

M2GD

0

Share this post


Link to post
Share on other sites

Hi strel,

with latest snmsynth (20100103, installed from svcpack), i have an error message when i uninstall .net 3 langpack (french)

Same error when i uninstall .net2.0sp2

100103073736111910.png

"Problem detected in this Windows install package.

A script required for this installation can't be lanched.

Contact the technical support or the editor"

when i click OK, a second popup appear with the following message:

100103073744848903.png

" irrecoverable error when installing"

in the event viewer i have two errors 11720 with this content:

Produit : Microsoft .NET Framework 3.0 Service Pack 2 Language Pack - FRA -- Erreur 1720. Problème détecté dans ce package d’installation Windows. Un script requis pour cette installation n’a pas pu être lancé. Contactez votre support technique ou l’éditeur du package. Action personnalisée CA_KB928416FIX2, erreur de script -2147024894, WshShell.RegDelete : Impossible de supprimer la clé de Registre "HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.0\Setup\1036\". ligne 81, colonne 3,
Produit : Microsoft .NET Framework 2.0 Service Pack 2 -- Error 1720.Problème détecté dans ce package d’installation Windows. Un script requis pour cette installation n’a pas pu être lancé. Contactez votre support technique ou l’éditeur du package. Action personnalisée CA_KB974417FIX2, erreur de script -2147024894, WshShell.RegDelete : Racine incorrecte dans la clé de Registre "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\DC3BF90CC0D3D2F398A9A6D1762F70F3\Patches\9E0DE89293FE9BB33898F24ED18CCF08\". ligne 31, colonne 3,

I have attached processdata.

Edit:

when checking event viewer, i realized i have a lot of errors due to .net :

in chronological order:

100103081041465803.png

At install time:

error 10005:

Produit : Microsoft .NET Framework 3.0 Service Pack 2 Language Pack - FRA -- Windows Installer a rencontré une erreur inattendue lors de l’installation de ce package. Il s’agit peut-être d’un problème lié au package. Le code d’erreur est 2721. Les arguments sont : CA_KB951847FIX3b, ,

error 1111:

La description pour l'ID d'événement ( 1111 ) dans la source (.NET Runtime Optimization Service) est introuvable. L'ordinateur local n'a peut-être pas les informations de Registre ou les librairies requises pour afficher les messages émanant d'un ordinateur distant. Vous pourrez peut-être utiliser l'option /AUXSOURCE= pour récupérer cette description. Reportez-vous aux rubriques Aide et support pour plus de détails. Les informations suivantes font partie de l'événement : .NET Runtime Optimization Service (clr_optimization_v2.0.50727_32) - Service reached limit of transient errors. Will shut down. Last error returned from Service Manager: 0x800736b1.

Error 4: (3times)

Impossible de charge le fichier MOF C:\WINDOWS\MICROSOFT.NET\FRAMEWORK\V2.0.50727\CLR.MOF lors de la récupération du fichier de stockage.
Impossible de charge le fichier MOF C:\WINDOWS\MICROSOFT.NET\FRAMEWORK\V2.0.50727\ASPNET.MOF lors de la récupération du fichier de stockage.
Impossible de charge le fichier MOF C:\WINDOWS\MICROSOFT.NET\FRAMEWORK\V3.0\WINDOWS COMMUNICATION FOUNDATION\SERVICEMODEL.MOF lors de la récupération du fichier de stockage.

at uninstall time:

Error 11720:

Produit : Microsoft .NET Framework 3.0 Service Pack 2 Language Pack - FRA -- Erreur 1720. Problème détecté dans ce package d’installation Windows. Un script requis pour cette installation n’a pas pu être lancé. Contactez votre support technique ou l’éditeur du package. Action personnalisée CA_KB928416FIX2, erreur de script -2147024894, WshShell.RegDelete : Impossible de supprimer la clé de Registre "HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.0\Setup\1036\". ligne 81, colonne 3,

Error 3011:

Le déchargement des chaînes de compteurs de performances pour le service WmiApRpl (WmiApRpl) a échoué. Le code d'erreur est le premier DWORD de la section Data.

Error 3013: (2 times)

Impossible de mettre à jour les chaînes du compteur de performance pour l'ID de langue 009. Le statut Wind32 renvoyé par l'appel est le premier DWORD de la section Données.
Impossible de mettre à jour les chaînes du compteur de performance pour l'ID de langue 00C. Le statut Wind32 renvoyé par l'appel est le premier DWORD de la section Données.

Error 11720:

Produit : Microsoft .NET Framework 2.0 Service Pack 2 -- Error 1720.Problème détecté dans ce package d’installation Windows. Un script requis pour cette installation n’a pas pu être lancé. Contactez votre support technique ou l’éditeur du package. Action personnalisée CA_KB974417FIX2, erreur de script -2147024894, WshShell.RegDelete : Racine incorrecte dans la clé de Registre "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\DC3BF90CC0D3D2F398A9A6D1762F70F3\Patches\9E0DE89293FE9BB33898F24ED18CCF08\". ligne 31, colonne 3,

i have uninstalled in this order: .net3.5 langpack; .net 3.5; .net3 langpack; .net3; .net2 langpack; .net2

PROCESSDATA.TXT

Edited by mooms
0

Share this post


Link to post
Share on other sites
But if you're using switches at T-13, what's exactly the command with switches you're running? Is that exact command generating that broken error box only on T-13?

I use the packages as generated by SNM, no further modifications. If put into the HFSVCPACK_SW1 folder of hslip, they are exectued at T-13 via svcpack.inf with the following parameters: "/quiet /norestart". This has always been the case, no change on hfslip side here. When installing them after Windows setup, I just execute the files without parameters, and this works without a problem.

No time left now, so I can continue testing only next weekend. Maybe someone else can try meanwhile what happens if the packages are run with the above parameters, but on an already installed Windows (instead of T-13 during setup)? Thanks!

Regards,

Tomalak

0

Share this post


Link to post
Share on other sites

I just tried in HFAAO on Win2k with no luck.

Will now try in HFSVCPACKSW1 then HFGUIRUNONCE and will report back.

M2GD

0

Share this post


Link to post
Share on other sites

hi Tomalak & M2GD! it's strange for it not to work in in HFSVCPACK (posted here 1 of my trials before) ... these were some of my settings though:

TARGETOS=XP

T13ADDONS=YES

ROEADDONS=

ALSOINSTALLERS=YES

MERGE_FRAMEWORKS=YES

having this in mind:

ALSOINSTALLERS setting only works if any XXXADDONS=YES, otherwise is not used.
... & i don't use any lang pack ... i'll try to do a run again & see :) Edited by Kiki Burgh
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.