• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
Gradius2

The Solution for Seagate 7200.11 HDDs

4,858 posts in this topic

Ok, the drives are 100%. :w00t::thumbup

I didn't loss anything, it went back to it were before BSY error (and I almost had a heart attack!).

This is a direct guide for BSY error, for details and more, check the 1st msg on this topic.

I received the stuff at 14:30h today as you can see here:

fix01.jpg

The one circled in red isn't necessary at all. In fact, is so tiny to connect those pins on Seagate, I was forced to give up on those plastics.

Here is the kit fully assembled it took me 20min, mounting those cables is really a pain:

fix02.jpg

Another angle:

fix03.jpg

With HDD connected (note I giving up on plastic connectores [circled in red on 1st photo):

fix04.jpg

The whole stuff complete to fire up:

fix05.jpg

And on this photo (above) is the TRICK here, see that little paper card (CR2032) ?

Yes! Just unscrew those around, and put a paper card or something to isolate the area (is the spin motor) like plastic, don't use anything that is an electric-conductor, after that you can turn ON everything.

You can work with just 1 screw, like on this photo (square in red):

fix06.jpg

On terminal you'll see nothing, just press CTRL+Z. And you'll get F3 T> prompt.

With PCB disconnected from HDA with a paper card (or similar), you'll see:

On terminal press CTRL+Z:

F3 T>

F3 T>/2

F3 2>Z

Spin Down Complete

Elapsed Time 0.147 msecs

F3 2>

Wait 5sec and remove the paper card, this will connect the PCB to HDA (spin motor), but since is in Spin Down state (from cmd), you'll feel nothing.

Now screw just enough to make a good contact between PCB and HDA (be real careful here, don't drop the screw, just be calm, relax!).

Then press CTRL+Z again:

F3 2>U

Spin Up Complete

Elapsed Time 7.457 secs (if you get this msg you did everything fine until here)

F3 2>/1

F3 1>N1

F3 1>/T

F3 T> <<< At this step you'll need to POWER OFF your HD for 10sec, and then POWER ON again. By power off, remove the SATA power (not PCB!).

When done, press CTRL+Z.

F3 T>

F3 T>i4,1,22

F3 T>

F3 T>m0,2,2,,,,,22 <<< This command takes a little over a minute to complete!

Max Wr Retries = 00, Max Rd Retries = 00, Max ECC T-Level = 14, Max Certify Rewrite Retries = 00C8

User Partition Format 5% complete, Zone 00, Pass 00, LBA 00004339, ErrCode 00000080, Elapsed Time 0 mins 05 secs

User Partition Format Successful - Elapsed Time 0 mins 05 secs

F3 T>

You did it! Congratulations! :ph34r:

Just turn off everything, and put your HDD on your lovely PC. :thumbup

Keep in mind TX and RX from Seagate are exactly like that, but on Seagate side.

Connect it this way:

PC (TX) > RX on Seagate

PC (RX) > TX on Seagate

The wires was inverted to me and I didn't get nothing, so I just reverted and finally got a terminal answer.

Gradius

http://www.kwikpiks.com/files/18/MSFN%20Se...%20topic/01.jpg

http://www.kwikpiks.com/files/18/MSFN%20Se...%20topic/02.jpg

http://www.kwikpiks.com/files/18/MSFN%20Se...c/connector.jpg

http://www.kwikpiks.com/files/18/MSFN%20Se...%20topic/05.jpg

http://www.kwikpiks.com/files/18/MSFN%20Se...%20topic/04.jpg

Edited by puntoMX
0

Share this post


Link to post
Share on other sites

Hey all,

I have a "friend" from these boards coming over tomorrow with a bricked drive. I will get him to film the process and I'll post a video. It should make things much clearer to everyone as to the "power on/off", when and how long etc.

If you are unsure of what you are doing, STOP NOW and wait. It will be worth it.

Check back around 7PM MST Wednesday Jan 21st.

Thanks,

Fatlip

Edited by fatlip
0

Share this post


Link to post
Share on other sites

Nobody has an idea what will help against my problem described in #56 ? I can't imagine it's a hardware fault.

It just won't regenerate the partition successfully...

Edited by kadolf
0

Share this post


Link to post
Share on other sites
Nobody has an idea what will help against my problem described in #56 ? I can't imagine it's a hardware fault.

It just won't regenerate the partition successfully...

Connect the HD on terminal, you should be able to see which error is (if CC or not).

Gradius

0

Share this post


Link to post
Share on other sites

I just flashed both drives with the newer SD1A, so far all good.

Gradius

Edited by Gradius2
0

Share this post


Link to post
Share on other sites
I just flashed both drives with the newer SD1A, so far all good.

Gradius

what models?

0

Share this post


Link to post
Share on other sites

Gradius2-

Let me start off and personally thank you for the work you have done in putting together this guide for us all. I haven't performed the fix yet, but am planning to very soon.

I am wondering if it would be at all possible to give a part list with links to a site where you purchased your materials. I already saw your RS232 link but I want to make sure I get the right connectors, wires, battery holders, etc. I hope I am not being to forward.

Also I'd like to make a suggestion for you to set up some way that others, including myself, can possibly send a donation as a sign of appreciation for what you have done. If it wasn't for this guide, many people might be forced to pay hundreds of dollars in data recovery fees. .. just a thought.

0

Share this post


Link to post
Share on other sites
I just flashed both drives with the newer SD1A, so far all good.

Gradius

what models?

ST3750330AS

0

Share this post


Link to post
Share on other sites
Gradius2-

Let me start off and personally thank you for the work you have done in putting together this guide for us all. I haven't performed the fix yet, but am planning to very soon.

I am wondering if it would be at all possible to give a part list with links to a site where you purchased your materials. I already saw your RS232 link but I want to make sure I get the right connectors, wires, battery holders, etc. I hope I am not being to forward.

Also I'd like to make a suggestion for you to set up some way that others, including myself, can possibly send a donation as a sign of appreciation for what you have done. If it wasn't for this guide, many people might be forced to pay hundreds of dollars in data recovery fees. .. just a thought.

I would also like to thank Gradius2 for the tenacity, persistence, and willingness to share his work with the rest of us. I too would like to thank with more than words.

It would be nice if someone would start making these cables and selling them on eBay maybe...

0

Share this post


Link to post
Share on other sites

Hey guys! :hello:

Trying to find components here in Sweden to build me my own interface. Since Seagate are giving us the silent treatment I don't have to much hope in them saving my data (atleast not within reasonable time).

The problem is that I'm having a hard time finding the RS232 to TTL converter. I have emailed the biggest electronic component store and asked, but they are probably sleeping at the moment. =) SO thought I'd check with you guys if you think that any of the pasted names links below could do it?

FT232BL USB - seriellt if LQFP32

https://www1.elfa.se/data1/wwwroot/webroot/...TA/07320658.pdf

FT232RL USB - seriellt if SSOP28

https://www1.elfa.se/data1/wwwroot/webroot/...TA/07320659.pdf

FT232RQ USB - seriellt if QFN32

https://www1.elfa.se/data1/wwwroot/webroot/...TA/07320659.pdf

FT2232D 2x combined FT232/245 LQFP48

https://www1.elfa.se/data1/wwwroot/webroot/...TA/07320666.pdf

Cheers!

The problem is that none there is in clear text RS232 to TTL. But maybe TTL is referred to as something else also?

Edited by NEO_AMiGA
0

Share this post


Link to post
Share on other sites

Guys I'm new here.. I've got 10 DiamondMax22 1TB drives with MX15 in a RAID-6 and I'm hoping when I next power cycle them they come back up..

I just thought this might come in handy. It's a USB->3.3v TTL converter used to program the Parallax Propeller chip. It has a standard FTDI USB interface on it and by clipping 2 pins off the TTL connector it will plug right into the back of the seagate drives perfectly.

http://www.parallax.com/Store/Microcontrol...98/Default.aspx

I know Parallax have distributors across the globe, so I thought those of you looking for USB->TTL converts might find this handy.

I'm taking one home with me just in case my drives fail when I shut the machine down to firmware upgrade them (provided Seagate actually gets a fix out anyway).

Hope this might help someone.

Cheers..

<edit> Oh friggin 'eck. I've just read the Seagate forums. I'm not that BradC!

Edited by BradC
0

Share this post


Link to post
Share on other sites
Hey all,

I have a "friend" from these boards coming over tomorrow with a bricked drive. I will get him to film the process and I'll post a video. It should make things much clearer to everyone as to the "power on/off", when and how long etc.

If you are unsure of what you are doing, STOP NOW and wait. It will be worth it.

Check back around 7PM MST Wednesday Jan 21st.

Thanks,

Fatlip

Thanks fatlip. will eagerly await the video. Right now I'm understandably confused by the 5V and 3.3V and which ones I should be doing etc etc. On top of that finding that RS232 chippy thingy is harder than I thought (buying from eBay is not an option for me I live on the other side of the planet). If possible can we get a clear footage on removing the connector since that part seemed to be a delicate part of the process.

Thanks again, you the man, man!

Edited by spankerer
0

Share this post


Link to post
Share on other sites
Nobody has an idea what will help against my problem described in #56 ? I can't imagine it's a hardware fault.

It just won't regenerate the partition successfully...

Connect the HD on terminal, you should be able to see which error is (if CC or not).

Gradius

I don't get the CC message, but the method of "unbricking" 0LBA-drives does not work. Seems like I have to wait for any news or for an answer from Seagate.

0

Share this post


Link to post
Share on other sites

Umm.... :huh:

I connected my rs232 board's TX to Seagate's TX [ oo*o ] [ ......] [...................]

and rs232's RX to Seagate's RX [ooo*] [ ......] [...................]

Did I wrong or Did I disunderstand?

Anyway It worked. I succeed in solving a "Not Detecting" problem. :o

Thanks.

Keep in mind TX and RX from Seagate are exactly like that, but on Seagate side.

Connect it this way:

PC (TX) > RX on Seagate

PC (RX) > TX on Seagate

The wires was inverted to me and I didn't get nothing, so I just reverted and finally got a terminal answer.

Gradius

Edited by killerB
0

Share this post


Link to post
Share on other sites

Look at my post here:

Post #30

http://www.msfn.org/board/index.php?showto...28092&st=20

This is all you need and it will take the confusion out of the voltage issue.

Hey all,

I have a "friend" from these boards coming over tomorrow with a bricked drive. I will get him to film the process and I'll post a video. It should make things much clearer to everyone as to the "power on/off", when and how long etc.

If you are unsure of what you are doing, STOP NOW and wait. It will be worth it.

Check back around 7PM MST Wednesday Jan 21st.

Thanks,

Fatlip

Thanks fatlip. will eagerly await the video. Right now I'm understandably confused by the 5V and 3.3V and which ones I should be doing etc etc. On top of that finding that RS232 chippy thingy is harder than I thought (buying from eBay is not an option for me I live on the other side of the planet). If possible can we get a clear footage on removing the connector since that part seemed to be a delicate part of the process.

Thanks again, you the man, man!

You didn't do anything like sticking your HD in the freezer or anything extreme did you? Some people went to desperate measures to figure out what was up with their drive. Sadly, one suggestion out there is to stick it in the freezer.

I seriously think you have a regular failed drive. The 1-2% normal failure rate.

Nobody has an idea what will help against my problem described in #56 ? I can't imagine it's a hardware fault.

It just won't regenerate the partition successfully...

Connect the HD on terminal, you should be able to see which error is (if CC or not).

Gradius

I don't get the CC message, but the method of "unbricking" 0LBA-drives does not work. Seems like I have to wait for any news or for an answer from Seagate.

0

Share this post


Link to post
Share on other sites
[...]

I just thought this might come in handy. It's a USB->3.3v TTL converter used to program the Parallax Propeller chip. It has a standard FTDI USB interface on it and by clipping 2 pins off the TTL connector it will plug right into the back of the seagate drives perfectly.

http://www.parallax.com/Store/Microcontrol...98/Default.aspx

I know Parallax have distributors across the globe, so I thought those of you looking for USB->TTL converts might find this handy.

[...]

Thanks for sharing this information! Can anyone confirm that this will work for hooking up drives to a terminal?

The guides and help from Gradius2, pichi and fatlip are great, I'm willing to give it a try as well but I want to be sure to order the right converter.

0

Share this post


Link to post
Share on other sites
Umm.... :huh:

I connected my rs232 board's TX to Seagate's TX [ oo*o ] [ ......] [...................]

and rs232's RX to Seagate's RX [ooo*] [ ......] [...................]

Did I wrong or Did I disunderstand?

Anyway It worked. I succeed in solving a "Not Detecting" problem. :o

Thanks.

The guide has been updated serevals times, just check here: ;)

http://www.msfn.org/board/index.php?showtopic=128807

Gradius

Gradius2-

Let me start off and personally thank you for the work you have done in putting together this guide for us all. I haven't performed the fix yet, but am planning to very soon.

I am wondering if it would be at all possible to give a part list with links to a site where you purchased your materials. I already saw your RS232 link but I want to make sure I get the right connectors, wires, battery holders, etc. I hope I am not being to forward.

Also I'd like to make a suggestion for you to set up some way that others, including myself, can possibly send a donation as a sign of appreciation for what you have done. If it wasn't for this guide, many people might be forced to pay hundreds of dollars in data recovery fees. .. just a thought.

barakaspeed,

I'll update the guide (once more) with links for the materials. So far, you'll spend $20 or less in all them.

About donation, I created this link

Does this look like it would work?

http://alldav.com/index.php?main_page=prod...d6ba656f1d26c58

Looks like only $4 in US shipped.

Yes, it will. I used a more expensive one, yet more simple:

http://www.sparkfun.com/commerce/product_i...products_id=449

Includes full pics and schematic.

Gradius

I would also like to thank Gradius2 for the tenacity, persistence, and willingness to share his work with the rest of us. I too would like to thank with more than words.

It would be nice if someone would start making these cables and selling them on eBay maybe...

They sell jumpers (wires), but since I'm on Chile and I couldn't wait too long importing them, I just made them myself. :blushing:

http://www.hobbyengineering.com/H2362.html

You only need 4 (four), but they sell 10 (minimum). Includes 20 headers too.

Gradius

Hey guys! :hello:

Trying to find components here in Sweden to build me my own interface. Since Seagate are giving us the silent treatment I don't have to much hope in them saving my data (atleast not within reasonable time).

The problem is that I'm having a hard time finding the RS232 to TTL converter. I have emailed the biggest electronic component store and asked, but they are probably sleeping at the moment. =) SO thought I'd check with you guys if you think that any of the pasted names links below could do it?

FT232BL USB - seriellt if LQFP32

https://www1.elfa.se/data1/wwwroot/webroot/...TA/07320658.pdf

Cheers!

The problem is that none there is in clear text RS232 to TTL. But maybe TTL is referred to as something else also?

FT232BL will works just fine, the problem it looks like IC only, and not mounted (ready to use).

Like this one:

http://shop.ebay.com/items/_W0QQ_dmptZMaga...B&_osacat=0

Gradius

Edited by puntoMX
0

Share this post


Link to post
Share on other sites

Will I be able to recover my data using the method stated in Post#1? I think my drive is in BSY mode at the moment.

Edited by robintay
0

Share this post


Link to post
Share on other sites
Guys I'm new here.. I've got 10 DiamondMax22 1TB drives with MX15 in a RAID-6 and I'm hoping when I next power cycle them they come back up..

I just thought this might come in handy. It's a USB->3.3v TTL converter used to program the Parallax Propeller chip. It has a standard FTDI USB interface on it and by clipping 2 pins off the TTL connector it will plug right into the back of the seagate drives perfectly.

http://www.parallax.com/Store/Microcontrol...98/Default.aspx

I know Parallax have distributors across the globe, so I thought those of you looking for USB->TTL converts might find this handy.

I'm taking one home with me just in case my drives fail when I shut the machine down to firmware upgrade them (provided Seagate actually gets a fix out anyway).

Hope this might help someone.

Cheers..

<edit> Oh friggin 'eck. I've just read the Seagate forums. I'm not that BradC!

$25 is too expensive though.

This one does the same thing for 50% off. :blink:

http://shop.ebay.com/items/_W0QQ_dmptZMaga...B&_osacat=0

Will I be able to recover my data using the method stated in Post#1?

Depends.

If you're getting CC, BSY and/or 0 LBA error, then yes.

Gradius

0

Share this post


Link to post
Share on other sites
I don't get the CC message, but the method of "unbricking" 0LBA-drives does not work. Seems like I have to wait for any news or for an answer from Seagate.

Is because the error you're getting when you try to write a new partition information (regenerating them) is different from the rest of us here.

Since your HD is recognized by BIOS, you'll need to wait until Seagate put a new firmware available to your drive.

Gradius

0

Share this post


Link to post
Share on other sites
The whole stuff complete to fire up:

fix05.jpg

And on this photo (above) is the TRICK here, see that little paper card (CR2032) ?

You can even put someting just between motor contact / pcb without removing any screw. Just need a 1cm large paper card, and unscrew a bit the screw near that point. This way, no fear to let anything move, let fall a screw on the pcb ...

Anyway nice tuto. Having been seeking like a mad on hddguru this solution for weeks. Still needs my TTL adapter :(

Edited by CoRpO
0

Share this post


Link to post
Share on other sites
You can even put someting just between motor contact / pcb without removing any screw. Just need a 1cm large paper card, and unscrew a bit the screw near that point. This way, no fear to let anything move, let fall a screw on the pcb ...

Anyway nice tuto. Having been seeking like a mad on hddguru this solution for weeks. Still needs my TTL adapter :(

Yes, but is a lot less intrusive and forceless just to unscrew 1 or 2 screws. :)

After putting the paper card, you can work with just 1 screw, after the entire job is done, you can screw the last one (in case of 2 screws).

Here is the photo, you only need to work with this screw (the one in red):

fix06.jpg

Gradius

Edited by Gradius2
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.