pichi

Reparacion del ST3500320AS SD15 en ESPAÑOL

120 posts in this topic

Menudo regalito nos han hecho a los afortunados poseedores del st3500320as .Sacan la solucion y lo unico que hacen es sacar un fw destructivo ¡es que no tienen nombre! Pues no voy a tirar la toalla .Antes intente de esto intente probar a bajar al fw AD14 y seguia en lba0 asi que volvi a subir a SD1A.

Conclusion :Se me ocurre ver las tablas en fw AD14 ¿que os parece chicos?

Gracias de antemano por vuestro interes Gradius2 & pichi. :thumbup

0

Share this post


Link to post
Share on other sites
Menudo regalito nos han hecho a los afortunados poseedores del st3500320as .Sacan la solucion y lo unico que hacen es sacar un fw destructivo ¡es que no tienen nombre! Pues no voy a tirar la toalla .Antes intente de esto intente probar a bajar al fw AD14 y seguia en lba0 asi que volvi a subir a SD1A.

Conclusion :Se me ocurre ver las tablas en fw AD14 ¿que os parece chicos?

Gracias de antemano por vuestro interes Gradius2 & pichi. :thumbup

Si te deja estaria bien, ya que en AD14 las tablas deben de ser las mismas que en SD15.

SD15:

Level T 'i': Rev 0001.0000, Overlay, InitDefectList, i[DefectListSelect],[saveListOpt],[ValidKey]

Level T 'm': Rev 0001.0000, Flash, FormatPartition,

m[Partition],[FormatOpts],[DefectListOpts],[MaxWrRetryCnt],[MaxRdRetryCnt],[MaxEccTLevel],[MaxCertif

yTrkRewrites],[ValidKey]

SD1A:

Level T 'i': Rev 0011.0000, Overlay, InitDefectList, i[DefectListSelect],[saveListOpt],[ValidKey]

Level T 'm': Rev 0012.0000, Flash, FormatPartition, m[Partition],[FormatOpts],[DefectListOpts],[MaxWrRetryCnt],[MaxRdRetryCnt],[MaxEccTLevel],[MaxCertif

yTrkRewrites],[ValidKey],[DataPattern]

¿Ahora para que ponen los de Seagate [DataPattern]?

0

Share this post


Link to post
Share on other sites

Hey , este es el ultimo parrafo del "log" con AD14

Level L 'd': Rev 0001.0000, Overlay, DeleteLogFile, d[Log]

Level L 'i': Rev 0001.0000, Overlay, InitLogFile, i[Log]

Level T 'B': Rev 0001.0000, Flash, SetBaudRate, B[baudRate],[MsecDelay]

Level T 'E': Rev 0001.0000, Overlay, DisplayEditLog, E[LogNum],[ErrCodeOrSpecial

FuncKey],[specialFunc]

Level T 'F': Rev 0001.0000, Overlay, SetCongenParmCmdHelpMsg, F[ValueRef],[Data]

,[ResetEnable]

Level T 'O': Rev 0001.0000, Overlay, SelectDataOutputMode, O[Mode],[VerboseOpts]

Level T 'P': Rev 0001.0000, Overlay, DownloadGenericFile, P[FileBytes]

Level T 'R': Rev 0001.0000, Overlay, RdNonVolatileAdaptiveParms, R[Opts]

Level T 'T': Rev 0001.0000, Overlay, OddEvenEncroachmentTest, T[strt tk],[end tk

],[hd],[thrshold]

Level T 'V': Rev 0001.0000, Overlay, DisplayDefectLists, V[DefectListSelect],[Hd

],[startCyl],[NumCyls],[DisplaySummaryOpt]

Level T 'W': Rev 0001.0000, Overlay, WrNonVolatileAdaptiveParms, W[]

Level T '[': Rev 0001.0000, Overlay, AsciiLogControl, [[LogFunction],[Log]

Level T 'i': Rev 0001.0000, Overlay, InitDefectList, i[DefectListSelect],[saveLi

stOpt],[ValidKey]

Level T 'm': Rev 0001.0000, Flash, FormatPartition, m[Partition],[FormatOpts],

[DefectListOpts],[MaxWrRetryCnt],[MaxRdRetryCnt],[MaxEccTLevel],[MaxCertifyTrkRe

writes],[ValidKey]

F3 C>

mmm ¿jugamos a la ruleta rusa? :crazy:

0

Share this post


Link to post
Share on other sites
mmm ¿jugamos a la ruleta rusa? :crazy:

G-List Erase:

---------------

(Power on = encender disco duro)

Ctrl+z

F3 T>i4,1,22

F3 T>

(Power off = apagar disco duro)

Translator regeneration:

----------------------------

(Nota: puedes utilizar este comando F3 T>m0,2,2,,,,,22 en vez de este F3 T>m0,2,2,0,0,0,0,22)

(Power on = encender disco duro)

Ctrl+z

F3 T>m0,2,2,0,0,0,0,22

Max Wr Retries = 00, Max Rd Retries = 00, Max ECC T-Level = 00, Max Certify Rewrite Retries = 0000

User Partition Format Successful - Elapsed Time 0 mins 00 secs

F3 T>/2

F3 2>Z

Spin Down Complete

Elapsed Time 0.147 msecs

F3 2>

(Power off = apagar disco duro)

Edited by pichi
0

Share this post


Link to post
Share on other sites

Sorprendente! Que velocidad de respuesta la tuya.Por hoy me doy por satisfecho ,mañana lo pruebo ¡si saliera algo mal no podria dormir y tengo que madrugar!

De funcionar podria ser una solucion a unidades brickeadas de 500gb por fw SD1A

:zzz:

Saludos

0

Share this post


Link to post
Share on other sites

Una pregunta. Como no encuentro por ningún sitio el RS232-TTL me voy a comprar un cable de Nokia. Según dicen eso hace las cosas más fáciles aún, puesto que sólo hace falta conectar los dos cables TXy RX. ¿Tengo que poner una resistencia de 1k en cada uno de ellos también?

0

Share this post


Link to post
Share on other sites
Una pregunta. Como no encuentro por ningún sitio el RS232-TTL me voy a comprar un cable de Nokia. Según dicen eso hace las cosas más fáciles aún, puesto que sólo hace falta conectar los dos cables TXy RX. ¿Tengo que poner una resistencia de 1k en cada uno de ellos también?

Si puedes ponerla mejor, pero si no la encuentras no pasa nada, ya que estos cables funcionan a 3V y el riesgo es menor.

0

Share this post


Link to post
Share on other sites

POSIBLE SOLUCION BRICK ST3500320AS CON SD1A

Siiiiii MISION CUMPLIDA :thumbup

Explico como resolvi mi problema ,gracias a pichi y Gradius2

Tenia el disco ST3500320AS con firmware SD15 en principio con el problema BSY

Me construi un conversor RS232/TTL con integrado max232 ,sin resistencias de 1k ,eso fue facil ,trabajo en electronica y cualquier "maño" puede hacerlo.Con mucho cuidain ,claro.

Elimine el fallo de BSY (indetectable por BIOS) ,descubriendo despues otro fallo:el LBA0 (disco detectable pero "no hay datos")

Entonces tuve la genial idea de resolverlo con el nuevo firmware SD1A pensando que actualizaria y eliminaria LBA0 todo a la vez: CRASO ERROR, No solo no elimina el fallo de LBA0 ;precisamente en el modelo ST3500320AS el de 500GB ;sino que cambian las tablas lo cual es peligroso de tratar de recuperar otra vez con RS232/TTL "yo no lo haria".

Resulta que el firmware AD14 es anterior al SD15 y por tanto similar en tablas e instrucciones,aunque no totalmente funcional.

Bueno ,desde SD1A con problema LBA0

1 . Le meto el firmware AD14

2 . Corrijo el problema LBA0 con RS232/TTL igual que si fuera el firmware SD15 >>>Entonces ya apareceria en la bios la total capacidad

3 . Surge otro problema: Disk error >>>Ademas es ilegible desde windows ,USB y lo que sea.Esto es porque el fw AD14 no es compatible

4 . Le doy otra oportunidad vuelvo a ponerle el fw SD1A

5 . El disco funciona de nuevo, con todos los archivos ,particiones ,y sistemas operativos.Hooray

Sirvanse a la peña que tenga este problema y agradecer al foro de Lituania, a pichi, a Gradius2 y, como no,a Seaungatillazo por su gran "ayuda" despues de 3 meses.

:hello:

Edited by Valenciano
0

Share this post


Link to post
Share on other sites

:hello: Hola que tal espero que anden bien todos los del foro y los que participan en este tema, pues les cuento mi situacion en pocas palabras hoy murio mi disco duro ST3500320AS con el firm SD15, buscando informacion en internet he logrado dar con el foro.

De ante mano agradesco a todos la informacion y les doy las gracias por compartirla, ya me he leido varias veces el tutorial de pichi y las experiencias de los miembros del foro en este tema pero hay un par de cosas que no me quedan claras y me imagino que si otras personas llegan con en mismo problema que yo seria bueno que nos explicaran un par de cosas.

1- Cuento con un cable DKU5 de datos para Nokia, la pregunta que tengo es no importa que el cable sea generico?

2-Realizando la coneccion con este cable DKU5 al disco duro no me queda muy claro de donde se toma la alimentacion.

3- En si no es una pregunta es una pequeña curiosidad me pueden explicar para que ayuda quitarle los tornillos a la PCB que hay debajo del HDD y si hay que quitarla por completo o solo con quitar los tornillos basta.

Bueno espero no molestarlos con mis preguntas tal vez sean muy obias pero creo que no todos tenemos muchos conocimientos en electronica solo los basicos.

Saludos y gracias por compartir su informacion.

0

Share this post


Link to post
Share on other sites
:hello: Hola que tal espero que anden bien todos los del foro y los que participan en este tema, pues les cuento mi situacion en pocas palabras hoy murio mi disco duro ST3500320AS con el firm SD15, buscando informacion en internet he logrado dar con el foro.

De ante mano agradesco a todos la informacion y les doy las gracias por compartirla, ya me he leido varias veces el tutorial de pichi y las experiencias de los miembros del foro en este tema pero hay un par de cosas que no me quedan claras y me imagino que si otras personas llegan con en mismo problema que yo seria bueno que nos explicaran un par de cosas.

1- Cuento con un cable DKU5 de datos para Nokia, la pregunta que tengo es no importa que el cable sea generico?

2-Realizando la coneccion con este cable DKU5 al disco duro no me queda muy claro de donde se toma la alimentacion.

3- En si no es una pregunta es una pequeña curiosidad me pueden explicar para que ayuda quitarle los tornillos a la PCB que hay debajo del HDD y si hay que quitarla por completo o solo con quitar los tornillos basta.

Bueno espero no molestarlos con mis preguntas tal vez sean muy obias pero creo que no todos tenemos muchos conocimientos en electronica solo los basicos.

Saludos y gracias por compartir su informacion.

1.- Da igual que sea generico el cable DKU-5, siempre y cuando sea un adaptador con chip, y no lleve una conexion de cables unicamente, ya que entonces seria un modelo falso que utiliza las lineas D+ y D- del puerto USB directamente, en lugar de las lineas RX y TX del adaptador original (esto se puede verificar al conectar el cable USB, ya que añade un nuevo dispositivo USB, y si estan los drivers instalados aparecera un puerto COM mas, probablemente COM3).

2.- Con este cable no hace falta adaptadores TTL o alimentacion para estos adaptadores, ya que este cable se alimenta del propio bus USB. De todas formas hay que conectar la alimentacion del disco duro al conector sata de alimentacion (la fuente de alimentacion del PC puede tener este conector o utilizar un adaptador molex de 4 pines).

3.- Al quitar los tornillos (llave torx 6) se anula la comunicacion entre la placa PCB y el disco duro de aluminio, no quedandose la placa PCB bloqueada al arrancar (esto ocurre con el problema BUSY). Sin los tornillos la placa no arranca y se mantiene desbloqueada (permitiendo el arreglo del problema BUSY).

Edited by pichi
0

Share this post


Link to post
Share on other sites

:blink: wo gracias por contestar, si de hecho el cable que tengo tiene una parte en la mitad del cable donde tiene un integrado y unos chips supongo con ese puedo hacer el procedimiento, ya veo.

Gracias por tu respuesta estoy casi listo para hacerlo solo me falta conseguir el destornillador torx 6 espero poder grabar el procedimiento aunque sea con el celular o hacer un par de fotos de todo este proceso , para aportar algo a todas las personas que tienen este mismo problema.

Con respecto al cable DKU5 he visto el conector y le he quitado la tapa y veo que solo maneja 3 cables esto es correcto? son los cables que hay que conectar a RX y TX y a NGD?

Saludos y gracias.

0

Share this post


Link to post
Share on other sites
:blink: wo gracias por contestar, si de hecho el cable que tengo tiene una parte en la mitad del cable donde tiene un integrado y unos chips supongo con ese puedo hacer el procedimiento, ya veo.

Gracias por tu respuesta estoy casi listo para hacerlo solo me falta conseguir el destornillador torx 6 espero poder grabar el procedimiento aunque sea con el celular o hacer un par de fotos de todo este proceso , para aportar algo a todas las personas que tienen este mismo problema.

Con respecto al cable DKU5 he visto el conector y le he quitado la tapa y veo que solo maneja 3 cables esto es correcto? son los cables que hay que conectar a RX y TX y a NGD?

Saludos y gracias.

Si son los tres cables, aunque en principio podrias utilizar solo RX y TX si la masa/chasis del disco duro esta conectada a la misma masa del ordenador que estas utilizando para desbloquearlo.

Si te aparece un puerto COM nuevo (conectando unicamente el cable DKU5), pruebalo uniendo el cable RX con el TX. En el hiperterminal debe de llegar todo lo que teclees. Al desconectar RX de TX dejarian de llegar las teclas que estas pulsando.

0

Share this post


Link to post
Share on other sites

:sneaky: ya veo creo que lo intentare solo con el cable para hacer las pruebas de los comandos como tu dices conectando el RX con el TX del cable DKU5.

Haber si entendi bien con respecto a GND, si tengo el disco duro por ejemplo en una mesa pero lo tengo conectado a la corriente de la fuente del ordenador con el cual estoy desbloqueando el disco duro no es necesario poner el GND?

No se como agradecerle Sr. Pichi su tiempo y sus explicaciones.

0

Share this post


Link to post
Share on other sites
Haber si entendi bien con respecto a GND, si tengo el disco duro por ejemplo en una mesa pero lo tengo conectado a la corriente de la fuente del ordenador con el cual estoy desbloqueando el disco duro no es necesario poner el GND?

No es necesario poner el GND, ya que esa masa es la misma que la del cable DKU-5.

Nota: esto no es del todo correcto, no me voy a meter en detalles de electronica, pero a efectos practicos funciona.

0

Share this post


Link to post
Share on other sites

Seeeeehhhh !!! Volvio a la vida !!!!! :w00t:

Muchas gracias a Pichi y Gradius2 por la inmejorable ayuda !!! :thumbup

Yo compre el cable CA-42, que segun tengo entendido es lo mismo que el DKU-5, y segui los pasos de la guia de Gradius2

http://www.msfn.org/board/index.php?showtopic=128807

y

http://www.msfn.org/board/index.php?showto...8807&st=100 (aqui es donde esta mejor explicado el procedimiento paso a paso)

Use solo los cables de TX(Blanco) y RX(Azul) y al XP le puse estos drivers

Segui los pasos de la guia al pie de la letra y no tuve mayores inconvenientes. Al principio no tenia conexion pero inverti el TX con el RX y todo empezo a funcionar.

Yo se que no es recomendable pero yo use el cable de SATA power de la misma PCy por suerte no queme nada.... :lol:

Ahora bien, la pregunta es la siguiente: Actualizo el firmware a SD1A o no ?! En varios lugares dicen que el SD1A rompe mas de lo que arregla...

Saludos

0

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.