Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

Guide - Install WinXP From HDD or USB Drive Or CD


  • Please log in to reply
54 replies to this topic

#26
victor888

victor888

    Member

  • Member
  • PipPip
  • 155 posts
You give a special example which is difficult to deal with.
For fresh instll xp on a new partition, boot.ini is simple and easy to revise by grldr.


How to remove advertisement from MSFN

#27
jaclaz

jaclaz

    The Finder

  • Developer
  • 14,026 posts
  • OS:none specified
  • Country: Country Flag

You give a special example which is difficult to deal with.
For fresh instll xp on a new partition, boot.ini is simple and easy to revise by grldr.


Yep. :)

But it would be a little limitative, as I see it, being comaptible ONLY with a newly formatted drive and with ONLY one NT/2K/XP/2003 and no multibooting.

jaclaz

#28
mawi

mawi

    Newbie

  • Member
  • 14 posts
I am testing your method.

I am curious about what is to be renamed in TXTSETUP.SIF - i386. Is this what is supposed to be renamed?

[SourceDisksNames.x86]
1 = %cdname%,%cdtagfilei%,,"\$WIN_NT$.~BT"
2 = %cd2name%,%cd2tagfilei%,,"\cmpnents\tabletpc\$WIN_NT$.~BT"
3 = %cd2name%,%cd2tagfilei%,,"\cmpnents\mediactr\$WIN_NT$.~BT"
4 = %cd2name%,%cd2tagfilei%,,"\cmpnents\netfx\$WIN_NT$.~BT"
100 = %spcdname%,%spcdtagfilei%,,"\$WIN_NT$.~BT",1
_1 = %bootname1%,%boottagfile1%,,""
_2 = %bootname2%,%boottagfile2%,,""
_3 = %bootname3%,%boottagfile3%,,""
_4 = %bootname4%,%boottagfile4%,,""
_5 = %bootname5%,%boottagfile5%,,""
_6 = %bootname6%,%boottagfile6%,,""
1_ = %bootname1%,%boottagfile1%,,""
2_ = %bootname2%,%boottagfile2%,,""
3_ = %bootname3%,%boottagfile3%,,""
4_ = %bootname4%,%boottagfile4%,,""
5_ = %bootname5%,%boottagfile5%,,""
6_ = %bootname6%,%boottagfile6%,,""
7 = %cdname%,%cdtagfilei%,,"\$WIN_NT$.~BT\lang"
107 = %spcdname%,%spcdtagfilei%,,"\$WIN_NT$.~BT\lang",1
8 = %cdname%,%cdtagfilei%,,"\$WIN_NT$.~BT\lang"
9 = %cdname%,%cdtagfilei%,,"\$WIN_NT$.~BT\lang"
10 = %cdname%,%cdtagfilei%,,"\$WIN_NT$.~BT\lang"
11 = %cdname%,%cdtagfilei%,,"\$WIN_NT$.~BT"
12 = %cdname%,%cdtagfilei%,,"\$WIN_NT$.~BT"
13 = %cdname%,%cdtagfilei%,,"\$WIN_NT$.~BT"
14 = %cdname%,%cdtagfilei%,,"\$WIN_NT$.~BT"
15 = %cdname%,%cdtagfilei%,,"\$WIN_NT$.~BT"


#29
mawi

mawi

    Newbie

  • Member
  • 14 posts
I've tried a couple of times, and I can't get it to work correctly.

Regardless of what I do, I get a boot error message after reboot after initial (textmode, the grey on blue) install phase.

Depending on BIOS I get:

* USB drive highest prio. Textmode install lists hard drive as C.
* USB drive lower prio, use F12 to manually select USB to boot from. Textmode install lists hard drive as E or something.

One thing, I am using

SetupSourceDevice = \device\harddisk1\partition1

I am not sure how things are related here, so if that affects anything.

/mawi

#30
aviv00

aviv00

    Windowaizer

  • Member
  • PipPipPipPipPip
  • 974 posts
  • OS:none specified
  • Country: Country Flag
in [winnt] subject u have i386 folder too that should be unrenamed

#31
mawi

mawi

    Newbie

  • Member
  • 14 posts

in [winnt] subject u have i386 folder too that should be unrenamed


Hmm, do you mean [winntdirectories]? I can't find a [winnt] section.

Winntdirectories has one occurence of i386:

[WinntDirectories]
1980 = PCHealth\HelpCtr\Binaries
1 = "\"
2 = system32
3 = "system32\config"
4 = "system32\drivers"
...
39 = "Driver Cache\i386"
40 = security
...


#32
aviv00

aviv00

    Windowaizer

  • Member
  • PipPipPipPipPip
  • 974 posts
  • OS:none specified
  • Country: Country Flag
yep only them

#33
mawi

mawi

    Newbie

  • Member
  • 14 posts

yep only them


OK, I have changed from the above to this (only one line, the one with 40 at the beginning):


[WinntDirectories]
1980 = PCHealth\HelpCtr\Binaries
1 = "\"
2 = system32
3 = "system32\config"
4 = "system32\drivers"
...
39 = "Driver Cache\$WIN_NT$.~BT"
40 = security
...


I also discovered that I must use harddisk1, as you mentioned:

[SetupData]
SetupSourceDevice = \device\harddisk1\partition1
SetupSourcePath = "\"

So, as a side note, if I try SetupSourceDevice with harddisk0, it tells me "No previous version of Windows NT can be found..." [press F3], like so:
Attached File  NoPreviousVersion.JPG   18.7KB   13 downloads


I have two problems that I will see if I can solve now:

(1) Reboot after "blue"/text phase doesn't continue install
(2) I get (E:) as letter for the harddrive

/mawi

Edited by mawi, 19 March 2009 - 01:30 PM.


#34
mawi

mawi

    Newbie

  • Member
  • 14 posts

I have two problems that I will see if I can solve now:

(1) Reboot after "blue"/text phase doesn't continue install
(2) I get (E:) as letter for the harddrive


So, here I continue.

Problem (2) above depends on my own doing:
- I have two partitions on the harddrive, and
- as I repartitioned and reformatted the first - so I could retry installing - the second partition got assigned letter C: and the first partition got E:, for some reason. Bah.


But problem (1) is left. What happens is this:

* Boot from USB goes fine, I use F12 to temporarily select USB
* The first part of setup (blue, text phase) goes nicely.
* I reboot after partitioning and the copying is done, then:

* I think it tries to boot from harddrive, but it doesn't seem to work, for some reason.

I get the following screen with the text starting with
"Windows could not start because of a computer disk hardware configuration problem.
Could not read from the seleected boot disk. Check boiot path and disk hardware.
Please check the windows documentation about hardware..."


Attached File  DiskHardConfigProblem.jpg   23.85KB   11 downloads



What could the problem be?
What can I do about it?
Have I missed some step?


Thanks for your replies and your time!

/mawi

#35
ilko_t

ilko_t

    MSFN Addict

  • Super Moderator
  • 1,705 posts
  • OS:none specified
  • Country: Country Flag

I get the following screen with the text starting with
"Windows could not start because of a computer disk hardware configuration problem.
Could not read from the seleected boot disk. Check boiot path and disk hardware.
Please check the windows documentation about hardware..."

Wrong rdisk value in boot.ini on the internal disk...

Install Windows from USB, boot Linux, multiboot and a lot more with WinSetupFromUSB


#36
mawi

mawi

    Newbie

  • Member
  • 14 posts
OK, so I used a PE boot disk (on another, small USB disk) to check what was on the harddrive, and it had accumulated different installs.

After erasing, I decided to clear all partitions and start from scratch.

After first phase (blue/text mode) reboot, I then get a new error message:

"Windows could not start because the following file is missing or corrupt:
<Windows root>\system32\hal.dll
Please reinstall a copy of the file.
"

Attached File  HalDllMissing.jpg   19.58KB   5 downloads

I have tried this twice now, and I get the same error message.


It seems that I may have missed some edit in TXTSETUP.SIF?
If so, what?


Thanks again!

/mawi

PS
Here is my complete TXTSETUP.SIF:
Attached File  TXTSETUP.zip   74.65KB   10 downloads

Edited by mawi, 19 March 2009 - 02:11 PM.


#37
ilko_t

ilko_t

    MSFN Addict

  • Super Moderator
  • 1,705 posts
  • OS:none specified
  • Country: Country Flag
This one should be because of wrong partition(X) value in boot.ini. Did you start from USB the second time? Does partition number in boot.ini match the partition number you installed to?
Do rdisk values in boot.ini on the internal hard disk match?

Since you can boot from PE disk you should post the relevant information, this would save both parties time.

In other hand- what are you trying to accomplish? Need one-off install or you are willing to experiment?

Install Windows from USB, boot Linux, multiboot and a lot more with WinSetupFromUSB


#38
mawi

mawi

    Newbie

  • Member
  • 14 posts

This one should be because of wrong partition(X) value in boot.ini. Did you start from USB the second time? Does partition number in boot.ini match the partition number you installed to?


After reboot, I try to boot from hard drive.
That is how I interpreted the instructions. Should I start from USB disk the second time?
I am assuming for this procedure, that I should not, is that false?

About boot.ini: I don't know, right now I just have one partition on the harddrive, so it should work, I guess...

Do rdisk values in boot.ini on the internal hard disk match?


How do I check this, these so called rdisk values - boot.ini on hard drive or USB drive? Do I match that against values in some other file?

Since you can boot from PE disk you should post the relevant information, this would save both parties time.

In other hand- what are you trying to accomplish? Need one-off install or you are willing to experiment?


I would like to get this install to work. I dont have access to CD right now. I have tried many methods, this one seems to be close.

It would be nice to not have to experiment. But like one poster said, many instructions are complicated or large. I have tried the GUI, but I didn't get it to work either, I posted about the 16 bit CONFIG.NT problem. Maybe I will retry using it.


Again, thanks for all your help and time.

/mawi

#39
ilko_t

ilko_t

    MSFN Addict

  • Super Moderator
  • 1,705 posts
  • OS:none specified
  • Country: Country Flag

How do I check this, these so called rdisk values - boot.ini on hard drive or USB drive? Do I match that against values in some other file?

From PE disk, boot.ini on the hard drive. When you open it there are 2 lines with rdisk in it. Both values should be the same.

It would be nice to not have to experiment.

Well, you have hit a thread with a method, which is relatively new and barely tested. Unless you have the time and willingness to experiment I'd suggest you to stay with the proven to work and well tested methods:

http://www.msfn.org/...howtopic=111406
http://www.msfn.org/...howtopic=120444
http://www.msfn.org/...howtopic=121446

Using (heavily) modified sources makes the things trickier, but I do not remember a case in this subforum, which has not been resolved.

Setup started by WINNT.EXE from DOS and WINNT32.EXE from PE environment are always an option too.

I posted about the 16 bit CONFIG.NT problem

And you got reply. Rebuilding the USB disk in order to gather the required information would have not costed you much time, would it? I guess not more than 10-15 minutes with USB hard drive formatted in NTFS.

Install Windows from USB, boot Linux, multiboot and a lot more with WinSetupFromUSB


#40
mawi

mawi

    Newbie

  • Member
  • 14 posts
[quote name='ilko_t' post='843835' date='Mar 19 2009, 11:40 PM'][quote]How do I check this, these so called rdisk values - boot.ini on hard drive or USB drive? Do I match that against values in some other file?[/quote]
From PE disk, boot.ini on the hard drive. When you open it there are 2 lines with rdisk in it. Both values should be the same.
[/quote]
I'll check this as soon as I get time (which sadly means tomorrow). Could this really be the culprit for the hal.dll not found problem?

[quote name='ilko_t' post='843835' date='Mar 19 2009, 11:40 PM'][quote]It would be nice to not have to experiment.[/quote]Well, you have hit a thread with a method, which is relatively new and barely tested.
[/quote]
I do realize that this is newer. I meant that I would have preferred to not have to experiment. The reason for trying this method is simply that the others I tried did not work.

[quote name='ilko_t' post='843835' date='Mar 19 2009, 11:40 PM']Unless you have the time and willingness to experiment I'd suggest you to stay with the proven to work and well tested methods:[/quote]

The one proven that I tried didn't work in my situation.

I don't know which of these are more proven than the next. It may be obvious, to you, that one is better than another, but as one new here, looking for a solution, it is really not that obvious.

One proven would be easy to get started with. These first and last look experimental to me. I tried the GUI one, second link.

[quote name='ilko_t' post='843835' date='Mar 19 2009, 11:40 PM']http://www.msfn.org/...howtopic=111406
http://www.msfn.org/...howtopic=120444
http://www.msfn.org/...howtopic=121446[/quote]


[quote name='ilko_t' post='843835' date='Mar 19 2009, 11:40 PM']Using (heavily) modified sources makes the things trickier, but I do not remember a case in this subforum, which has not been resolved.[/quote]

The only modification I have is added driver, without which setup wont recognize my disks. I never doubted anyones ability or good intentions. I am sure the answer is out there, somewhere.

[quote name='ilko_t' post='843835' date='Mar 19 2009, 11:40 PM']Setup started by WINNT.EXE from DOS and WINNT32.EXE from PE environment are always an option too.[/quote]

I tried this but I made some mistake and didn't get far.

[quote name='ilko_t' post='843835' date='Mar 19 2009, 11:40 PM'][quote]I posted about the 16 bit CONFIG.NT problem[/quote]And you got reply.
[/quote]

Yes I got a reply, I never said I did not. I'm merely answering your question, explaining where I ran into a snag.

[quote name='ilko_t' post='843835' date='Mar 19 2009, 11:40 PM']Rebuilding the USB disk in order to gather the required information would have not costed you much time, would it?[/quote]

Hmm, what is the point of this? (Shall I say: "Oh, I did wrong. I repent, I am sorry. I will not ask anymore questions." ? Silly.) I am trying the best I can, I hope you see that.


I will retry, tomorrow!

Again, I do appreciate your and everyone elses help and time. And I understand that you must get frustrated at times! I sure do.


/mawi

#41
aviv00

aviv00

    Windowaizer

  • Member
  • PipPipPipPipPip
  • 974 posts
  • OS:none specified
  • Country: Country Flag
ok one things ur txtsetup is not right u changed it

39 = "Driver Cache\$WIN_NT$.~BT"

try use f12 button when the system start to load the bios boot menu

and choose directly the hdd / usb that have the setup files

if its not working try change back to hdd(0)

"No previous version of Windows NT can be found..." [press F3], like so: "

i had that problem while making this but i solve it

maybe u missed do something try to make it from the guide from start

Attached Files


Edited by aviv00, 21 March 2009 - 11:46 AM.


#42
jaclaz

jaclaz

    The Finder

  • Developer
  • 14,026 posts
  • OS:none specified
  • Country: Country Flag
aviv00

Maybe you could edit your initial post adding in it some more explicit instructions, like which exact lines need to be edited, instead of this:

a. Open TXTSETUP.SIF and rename I386 folder to $WIN_NT$.~BT
WARNING!!!!! don't rename the folders in winnt dir just those are relevant to setup


or possibly attach an already edited and known to be working TXTSETUP.SIF, I could put together a simple batch to do "automagically" just the needed edits....

jaclaz

#43
aviv00

aviv00

    Windowaizer

  • Member
  • PipPipPipPipPip
  • 974 posts
  • OS:none specified
  • Country: Country Flag

Hi,

I use a USB-stick (Sandisk Cruzer)

Jaclaz is right. Making a bootable USB-stick with "HP Windows Format Utility for USB Drive Key" works
I used version 2.00 and formatted NTFS.
I had no success with FAT32.

Changing BIOS-settings did not solve the asking for "missing" SP3-files

Screenshot shows file names of "missing" files.

After setting BIOS-setting back to HD-boot something strange happened.

I can not install XP now from the same USB-stick!!.
Booting is OK, files are transfered, but at reboot HAL.DLL is missing.


i found the problem DOSNET.INF should rename there too

i will post good list soon

edited:

i didnt find the problem so i find way to bypass it check in post number #1

and post a better method to solve it check method 2

Edited by aviv00, 18 April 2009 - 01:27 PM.


#44
Spewk

Spewk
  • Member
  • 2 posts
None of this is getting me anywhere..
It boots, it loads all files, and when "starting windows" I just get the good ol' BSOD everytime....

I used DBAN on the HDD after several attempts, and now that the drive is wiped clean, I'm still getting the BSOD.

I tried changing the Setup data, by adding this line :
SetupSourceDevice = \device\harddisk1\partition1
And even tried changing from 1 to 0 and back, to no avail....
I don't believe the actual HDD is even being seen, honestly - but I don't get far enough to know......

#45
ilko_t

ilko_t

    MSFN Addict

  • Super Moderator
  • 1,705 posts
  • OS:none specified
  • Country: Country Flag
What does the blue screen say? This is the interesting part, not the blue screen itself ;)
If it's the 0x0000007B error try the modified ntdetect.com as mentioned in the pinned FAQs topic. Cure for other error messages are also mentioned there.

Install Windows from USB, boot Linux, multiboot and a lot more with WinSetupFromUSB


#46
Spewk

Spewk
  • Member
  • 2 posts

What does the blue screen say? This is the interesting part, not the blue screen itself ;)
If it's the 0x0000007B error try the modified ntdetect.com as mentioned in the pinned FAQs topic. Cure for other error messages are also mentioned there.


I can't test it at the moment because I'm formatting the HDD ( Well, "C" drive, anyway - I hope that's the **** hard drive or I'll be making the USB bootable again, lol...)

Got a quick link to that FAQ, by chance ? ( sorry, I'm doing 3 things here at once...)

EDIT : OK, that didn't help ( modified NTDETECT.COM )........

I have an empty C: drive with a dos partition on it now, but booting to it no other drives show up.

Edited by Spewk, 18 April 2009 - 06:52 AM.


#47
aviv00

aviv00

    Windowaizer

  • Member
  • PipPipPipPipPip
  • 974 posts
  • OS:none specified
  • Country: Country Flag

Hi,

I use a USB-stick (Sandisk Cruzer)

Jaclaz is right. Making a bootable USB-stick with "HP Windows Format Utility for USB Drive Key" works
I used version 2.00 and formatted NTFS.
I had no success with FAT32.

Changing BIOS-settings did not solve the asking for "missing" SP3-files

Screenshot shows file names of "missing" files.

After setting BIOS-setting back to HD-boot something strange happened.

I can not install XP now from the same USB-stick!!.
Booting is OK, files are transfered, but at reboot HAL.DLL is missing.


someone pm and told me he had the same problem

he change the volume of the cd so that what happend

i think the volume of the hdd need to be the same of the disk

btw he burned with the original volume and its got fixed
so pretty sure its the problem

anyway to fix it ?

#48
pSycho-Y2K

pSycho-Y2K

    Newbie

  • Member
  • 44 posts
  • OS:Windows 7 x64
  • Country: Country Flag

Here already such dd example in Chinese: http://bbs.znpc.net/...0...t=dd&page=4

The 60th topic.

I translate here

dd is a strong command, personally I think this is anoter most powerfull command after map command of grub4dos.

By using the switch of "bs, skip, seek" we can copy file to file, sector to sector and the byte to byte of file, any position can be wittern (wether the file is read only or have NTFS right, Added by victor888).

Note:
1. for a complete write, the byte of target file must be more than or equal to source file.
2. The target file should be in device, no matter what the file content is.

Example:

This is a dos batch on (fd0) name path.bat:

set string=abcdefghijklmnopqrstuvwxyz
set path=¥:
goto main
:main
...
...
....
goto end
...
:end

The first line is 37 bytes (in fact, there ENTER or SHIFTLINE charactor bytes at the end of line, for the sake of demonstrating the use of dd command, the bytes are omitted.)
The second line is 11 bytes.

Then we could write any charactor to the second line.
e.x replacy ¥ in the second line to certain letter, juse do the following:

dd if=(fd0)/path.bat of=(fd0)/path.bat bs=1 skip=11 count=1 seek=46

hence, the second line was replace to set path=a:

(bs=1 means one byte as read unite,count=1 means only write one block defined by bs switch, here is one byte. skip=11 means skip 11 bytes including space. seek=46 means skip 46 bytes when write, that is write the 47 byte ¥)

Certainly, we can do booting disk this way:
dd if=/pe.img of=(fd0) or
dd if=(cd0) of=/cd.iso

Writing boot sector to imge fiel is also convenient:
dd if=(hd0,0)+1 of=/dos.img


We can study above to chang boot.ini without dificculty.

Is there any progress on this yet? I tried your dd command approach to change the rdisk value in boot.ini, but it gives me a fatal error screaming something about "Cannot write resident/small file! Enlarge it to 2KB and try again" :(

I just know you guys are on to something as I can fully understand the problem here and also searching for alternatives and manipulating the boot process for the GUI mode to start correctly without editing the boot.ini manually.

Just a quick test where I got the error:
title Windows XP SP3 - Phase 2
root (hd1,0)
dd if=(hd1,0)/boot.ini of=(hd1,0)/boot.ini bs=1 skip=22 count=1 seek=69
chainloader (hd1,0)+1

Edited by pSycho-Y2K, 16 June 2009 - 07:45 AM.


#49
jaclaz

jaclaz

    The Finder

  • Developer
  • 14,026 posts
  • OS:none specified
  • Country: Country Flag

it gives me a fatal error screaming something about "Cannot write resident/small file! Enlarge it to 2KB and try again" :(

Have you tried enlarging it?

See this example by Mdgx on how a boot.ini can be
http://www.msfn.org/...o...129604&st=8
"enlarged" by adding lines of text BEFORE first section.

BTW, WHICH version are you using?

Get LATEST here:
http://nufans.net/grub4dos/


Just a quick test where I got the error:

title Windows XP SP3 - Phase 2
root (hd1,0)
dd if=(hd1,0)/boot.ini of=(hd1,0)/boot.ini bs=1 skip=22 count=1 seek=69
chainloader (hd1,0)+1


Absolutely NOT relevant to the problem you are experiencing, but you can use relative paths:
title Windows XP SP3 - Phase 2
root (hd1,0)
dd if=/boot.ini of=/boot.ini bs=1 skip=22 count=1 seek=69
chainloader +1

jaclaz

#50
doveman

doveman

    Advanced Member

  • Member
  • PipPipPip
  • 362 posts
Is it right that I don't need to expand the files copied to I386 (IMS.CAT, NTPRINT.CAT and SP3.CAT are already expanded but the rest are .CA_)?

Is there any need to delete the TXTSETUP.SIF in $WIN_NT$.~BT after copying it to the root?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN