Xeno86

KernelEx 4.5.2

1,561 posts in this topic

Problem with KernelEx 4.0 Final 2 here: it is breaking FastStone Image Viewer.

When I open a Jpg picture in it browser or windowed view, I can rotate it from: 'Edit' -> 'Rotate (right or left)',

but it is impossible to do it from the arrows in the tools bar!

I get a crash with an error message: <UNKNOWN> caused an invalid page fault in module <unknown>.

(see attached file). :}

With gif, png or bmp, there is no glitch at all!

BTW, the image is not read-only.

Last version of FSIV is 4.0, but I get the same thing with the previous one 3.9.

Because I use this soft a lot, I reinstall Windows and have checked step-by-step from where come the bug.

It appears only after the install of last KernelEx. :blushing:

I never had problem with this program before.

0

Share this post


Link to post
Share on other sites
Problem with KernelEx 4.0 Final 2 here: it is breaking FastStone Image Viewer.

...

If FastStone Image Viewer does not need KernelEx, then go to Properties (right-click) on the shortcut or directly from the executable (browse), and select the Compatibility tab.

Then tick the check box for Disable KernelEx extensions for this program.

OK out and test again.

0

Share this post


Link to post
Share on other sites
Problem with KernelEx 4.0 Final 2 here: it is breaking FastStone Image Viewer.

...

If FastStone Image Viewer does not need KernelEx, then go to Properties (right-click) on the shortcut or directly from the executable (browse), and select the Compatibility tab.

Then tick the check box for Disable KernelEx extensions for this program.

OK out and test again.

17.gif i try portable FastStone and with (or without) KernelEx same problem....

Edited by Philco
0

Share this post


Link to post
Share on other sites

@ RetroOS:

Then tick the check box for Disable KernelEx extensions for this program.
I had tried it before posting, and afterwards reboot,

but it doesn't help :(

I even had tried several compatibility modes, but same thing :angry: .

@ Philco:

i try portable FastStone and with (or without) KernelEx same problem...
'without KernelEx', do you mean disabled from Compatibility tab?

Before install of KernelEx, I never had any glitch with this program under Win 98SE.

BTW, I also use Portable version of FSIV.

EDIT : this could help, I have put in attached files a piece of log from Dr Watson and FileMon. :rolleyes:

BTW, the file 'C:\Program Files\FSViewer\fsplugin02.dll' is actually here.

EDIT 2 : The bug appears every time you try to make a lossless conversion for Jpeg format.

Third capture with Dr Watson when doing a lossless crop.

Edited by CharlesF
0

Share this post


Link to post
Share on other sites

Hey is anyone having trouble with images and toolbar rendering in Firefox 3.5 with KernelEX installed? Firefox doesn't want to display images (I am sure images are enabled and set to display) and often parts of the toolbar (the refresh button, the home button, the little logo to the left of the URL, the back/fwd buttons, or the thin gray area separating the tabs from the bar above them) turn a smoke/dark gray color. Everything else works fine. I cannot see the picture for Google on its main page, google images displays nothing, facebook shows no pictures, and I couldn't find the "Add Reply" button on this site (after 10 minutes, I used Opera to show me where it was so I could move my mouse until the hand showed up.

This started happening a few months ago after an update, and the most recent one (3.5.6) didn't change anything. I did try a clean install a month ago with no luck. Experience with IE showed me images don't display if there is insufficient memory or a slow connection (very annoying, because it IE liked to just "give up" after awhile) but I have 640MB ram and ethernet. This puzzles me. Any ideas?

0

Share this post


Link to post
Share on other sites

Did anyone find a solution to Firefox 3 printing? Just read a long thread but doesn't seem any solution, as yet??

0

Share this post


Link to post
Share on other sites
Sorry haven't read all here lately, hoping not too talk to much nonsense now... Just to throw in two little notes: SumatraPDF 101 works fine on my win98se, even without enabling kernelex for it... And someone told me his flash10 started working when he switched his monitor to 32bit colors. It certainly isn't that easy, but perhaps the last missing puzzle part for someone, no idea ;-)

I'm glad to hear that Sumatra works...natively!? (that's kind of a surprise)

You may be on to something with the color bits. My old PC that I gave to a friend has a video adapter that is only capable of 24 bit color. VLC (latest) with KernelEx wouldn't play videos until I switched it to 16 bit. I also have never had any success with Flash 10.

Edited by Steven W
0

Share this post


Link to post
Share on other sites

I want to report a problem:

Win98SE

KernelEx 4.0 Final 2

Codec Tweak Tool 4.1.0, MediaInfo Lite 0.7.26 and ffdshow r3176 2010-01-02 (clsid) give an error: "Stream read error" and then e.g. "Exception EAccessViolation in module CodecTweakTool_410.TMP at 0002B902".

"Access violation at adress 004B902 in module CodecTweakTool_410.TMP. Write of adress 80000002."

0

Share this post


Link to post
Share on other sites

First of all, thanks a lot to Xeno86 for this so stable version ! It's nice to be able to enjoy the last version of VLC and MPlayer Classic... :thumbup

Just two small notes :

- I couldn't find anything about it in the whole thread so, I'm sorry if this has been stated before : Zone Alarm 2.6 Pro doesn't work with KernelEx extensions activated. That's probably normal since it's tightly linked to Windows Core. -> Disabling the extensions for that program solves the problem.

- Connectix Virtual PC doesn't work anymore, even with extensions unchecked in compatibility tab (KernelEx is in paranoid mode - disabled by default). It complains it can't work in 'compatibility mode' so I guess it mistakes KernelEx for Windows XP compatibility mode. I tried bypassing this check but the executable is protected so I can't use it for now.

Keep up the good work !

Edited by glocK_94
0

Share this post


Link to post
Share on other sites

Result: Win98 SE with last KernelEx

Run Firefox 3.5 - OK. Run Outlook Express - small error an transparent icons on program OE (black background).

Run OE without FF 3 - properly, icons OK.

Conflict layers?

(nVidia GF 5200 / last unofficial drivers MSFN) - complet uninstall driver and new install. OK

Edited by Philco
0

Share this post


Link to post
Share on other sites

:thumbup :thumbup :thumbup

I try Flock 2.0.3 with compatibility KernelEx / Windows 2003 (only unpack exe with TotalCommander without install.

First run - crash. Freeze on dialog Check default browser...

I edit manual prefs.js:

user_pref("browser.shell.checkDefaultBrowser", false);

user_pref("app.update.enabled", false);

This post i writing with this version Flock (slovak) :rolleyes:

flock203win98.th.jpg

Thx Xeno!

0

Share this post


Link to post
Share on other sites
Did anyone find a solution to Firefox 3 printing? Just read a long thread but doesn't seem any solution, as yet??

Don't know if anyone is looking at this, but here's maybe a clue. It's culled from FF3 support group: "I digged through the code of firefox and found out they use gtk_print_job_new for printing, which takes a pdf file as a parameter.

But how was that PDF file created from the HTML page is not yet clear

to me."

source: NG: moxilla.support.firefox (Help required on printing web page in firefox)

0

Share this post


Link to post
Share on other sites
Zone Alarm 2.6 doesn't work with KernelEx extensions activated.
Hi glocK_94,

FWIW last version of ZA working with Win 98Se is 6.1.744.001 (even without KernelEx).

I'm using version 5.5.062.004 (working without and with KernelEx),

because I've found it has more features than the above,

and because it is a 'non-phoning home' version :D .

0

Share this post


Link to post
Share on other sites

I have tried installing Adobe Flash Player 10 with Firefox seveal times now with no success. I tried Firefox 2, 3, and 3.5. I have tried installing Flash by visiting a site like Youtube and following the link and by downloading the whole installer package. It seems to install fine but visiting a flash site like Youtube will result in a crash every time. What Am I doing wrong?

Thanks,

Chris

0

Share this post


Link to post
Share on other sites
I have tried installing Adobe Flash Player 10 with Firefox seveal times now with no success. I tried Firefox 2, 3, and 3.5. I have tried installing Flash by visiting a site like Youtube and following the link and by downloading the whole installer package. It seems to install fine but visiting a flash site like Youtube will result in a crash every time. What Am I doing wrong?

Thanks,

Chris

Chris,

did you disable the "next generation plugin" in control pannel/java/securityadvanced/plugin ?

It's explained in more details somewhere in this thread or in the other KEX Thread, didn't find it back now !

Roger

Edited by RodgerOver
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.