Xeno86

KernelEx 4.5.2

1,561 posts in this topic

Will it help you if I tell you that it works perfectly for me?

Please write if it is a patched system, what other extensions from this forum you use, what language it is, etc. And it would be *very* useful if you could provide Dr.Watson log. Also check if 4.0 final 2 works for you.

Otherwise I can't help you, sorry.

4.0 Final 2 works. The system is English and unpatched I believe, and no other extensions used yet.

Watson log attached.

This crash is a bug in error message display procedure.

Instead of crashing it should tell you that for some reason your system lacks a backup for kernel32.dll (c:\windows\kernelex\kernel32.bak) so it's not possible to upgrade. You need to copy this file from install media otherwise you won't be able to upgrade or downgrade KernelEx.

KernelEx 4.5 series has revamped uninstall procedure a bit so it's less likely to lose this backup file.

0

Share this post


Link to post
Share on other sites

KernelEx 4.5 series has revamped uninstall procedure a bit so it's less likely to lose this backup file.

Well, there are many ways to lose it. For example - there were many third-party cleaners which free HDD space by deleting unnecessary files in the time of Windows 98, some of them choose files by extension and *.bck, *.bak were considered unnecessary.

0

Share this post


Link to post
Share on other sites

Can KernelEx be used to allow NT4.0 File Manager (Winfile.exe, 32-bit, LFNs compliant) to run under Win98SE? If so, are there any special steps that must be done?

lelandaust

no, lelandaust! Running NT4 File Manager under 98se/ME WITH KernelEx installed results in error message "The WINFILE.EXE file is linked to missing export SHELL32.DLL:StrChrW". I've checked this myself and confirmed it.

Looks like KernelEx will need to be updated to include StrChrW function for SHELL32.DLL file, which the Win98/ME versions do NOT have (AND KernelEx will need to "patch" 98se/ME's shell32.dll file to make that possible).

erpdude8,

Would it be possible to copy NT4 SHELL32.DLL to Win98se, and thereby allow NT4 file manager to run? Is NT4 SHELL32.DLL incompatible with Win98se?

lelandaust

0

Share this post


Link to post
Share on other sites

I installed KernelEx 4.5 beta 2.

I had previously installed 4.0 but couldn't get anything to work. I uninstalled it and then installed 4.5 beta 2.

When I started up I got a message that said Kernelex installed and sucessfully and functional.

However, from then on, I get a dialog box saying "The kexbasen.dll cannot start. Check the file to determine the problem."

Needless to say, I don't know how to check the file.

System: Win 98 SE with SP2.0.

0

Share this post


Link to post
Share on other sites

Rainyd at said he got Opera 10.6 to work.

I tried it tonight, build 3433, and got nothing but crashes from Opera.

I had set both the install program and opera.exe for XP SP2 compatibility.

I just installed it today, and so far nothing has worked for me on my system.

System: Win 98 SE, SP 2.0.

0

Share this post


Link to post
Share on other sites

I wanted to see if Corel Draw 12 might work.

I put the first CD ROM in my computer.

I searched the CD for .exe files and set them all to XP SP2 compatibility.

I then started setup.exe.

I immediately got an error message: 1607 Unable to install InstallShield scripting runtime.

System: Win 98 SE SP 2.0

0

Share this post


Link to post
Share on other sites

I installed 4.5 beta 2.

I installed VLC player 1.1.0, with compatibility mode to XP SP2. The install seemed to work.

However, when I try to execute the program, nothing happens. I see my disk activity light come on once, and my cpu activity goes from 1 % to 5% and quickly back to zero. I don't get any error messages.

System: Win 98 SE SP 2.0

0

Share this post


Link to post
Share on other sites

I installed 4.5 beta 2.

I installed VLC player 1.1.0, with compatibility mode to XP SP2. The install seemed to work.

However, when I try to execute the program, nothing happens.

System: Win 98 SE SP 2.0

Hi fortcollins,

VLC 1.0.5 & 1.1.0 are NOT working. :no:

Read posts #491 & #531 - #532 in this thread.

Last version I am using with KernelEx is 1.0.3

0

Share this post


Link to post
Share on other sites

Rainyd at said he got Opera 10.6 to work.

I tried it tonight, build 3433, and got nothing but crashes from Opera.

I had set both the install program and opera.exe for XP SP2 compatibility.

I just installed it today, and so far nothing has worked for me on my system.

System: Win 98 SE, SP 2.0.

You don't need to set compatibility for Opera 10.60.

Did you tried Firefox 2 or 3?

0

Share this post


Link to post
Share on other sites

Can someone that uses KernelEx on Windows 98 S.E please give me step by step instructions on how to configure it to fool windows to think I have XP, and is it safe to try it for Vista?

Also do I need to install the Firefox user agent switch, and if so what are the best setting configurations to use?

Edited by frogman
0

Share this post


Link to post
Share on other sites

First post, so I'll start with a big thanks to Xeno86 for this useful software.

Just wanted to report that Firefox 3.6.4 is showing 100% CPU with KernelEx 4.5beta2 on Win98SE. Was installed in XP SP2 compatibility mode. No errors on command line or in the console. The browser works but hogs CPU. Reverting to FF3.6.3 for the moment.

Regards.

0

Share this post


Link to post
Share on other sites

First post, so I'll start with a big thanks to Xeno86 for this useful software.

Just wanted to report that Firefox 3.6.4 is showing 100% CPU with KernelEx 4.5beta2 on Win98SE. Was installed in XP SP2 compatibility mode. No errors on command line or in the console. The browser works but hogs CPU. Reverting to FF3.6.3 for the moment.

Regards.

Yes, I notice that too since the first build of Firefox 3.6.4 ;

and I notice when I browse a web page with flash contained, Firefox crash :(

(if I disable OOPP by changing all the "dom.ipc.plugins.enabled" value in "about:config" to "false" there is no crash and I can see the flash contained, but the CPU stay at 100%)

It seems like the "plugin-container.exe" don't run on W98SE even with XP SP2 compatibility set :}

Firefox 3.6.3 work fine but, I revert to Firefox 3.5.10 do to security issue .

;)

Edited by patclash
0

Share this post


Link to post
Share on other sites

As this is to do with KernelEx, can I ask you to look at my thread on the link I have placed below, then come back here and reply if there is an answer to it, many thanks.

0

Share this post


Link to post
Share on other sites

First post, so I'll start with a big thanks to Xeno86 for this useful software.

Just wanted to report that Firefox 3.6.4 is showing 100% CPU with KernelEx 4.5beta2 on Win98SE. Was installed in XP SP2 compatibility mode. No errors on command line or in the console. The browser works but hogs CPU. Reverting to FF3.6.3 for the moment.

Regards.

Yes, I notice that too since the first build of Firefox 3.6.4 ;

and I notice when I browse a web page with flash contained, Firefox crash :(

(if I disable OOPP by changing all the "dom.ipc.plugins.enabled" value in "about:config" to "false" there is no crash and I can see the flash contained, but the CPU stay at 100%)

;)

I too, can confirm this. Also, has anyone tried to install flash player 10.1? Installer crashes.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.