Xeno86

KernelEx 4.5.2

1,561 posts in this topic

Installed the latest KernelEx version and unfortunately, my USB flash stick problem, that was gone with the RC1, is back :(

0

Share this post


Link to post
Share on other sites

I have a couple of questions on KernelEx and some applications.

Does VLC need any specific compatibility mode? When I don't set any compatibility mode it shows me an "This program has performed an illegal operation and will be shut down" error when opening my DVD disk. However I may watch it if I don't close this message but move its window out of the screen. I always had this error with VLC 1 and 1.1 and all tested KernelEx versions.

I have russian Windows 98 SE, and VLC uses russian language. When I enable Win2K or WinXP compatibility for it, all letters become black squares. I don't really care about it, because I don't use a compatibility mode for VLC, however QtWeb browser gives me the same black squares instead of menus and labels in its dialogs, and it is not usable without Win2K compatibility mode. Is there any way to fix it?

0

Share this post


Link to post
Share on other sites

Hello everyone,

recently I found a new program and new problems. But they appear not to be so "hardcore"..

The program is called "Pure Data" (Pd), a free modular audio-, video- and everything-environment. ( http://puredata.info/ )

I tried 2 versions: "0.43 test3" (~4Mb) a slim version without "externals". This simply works (at least as far as I tested).

And the official version "0.42.5-externals" (~30Mb). This is the full package..

...But this version uses a "startup script" and this is where the error occurs..

To me it seems that the script just searches for some paths that are not there in win98se or in the reg; but this is just one possibility since I don't know what exactly is going on there.

This is the error-message:

__________________________________________________

"Error in startup script"

no such variable

(read trace on "::env(CommonProgramFiles)")

invoked from within

"set externalsdir "$::env(CommonProgramFiles)/Pd""

invoked from within

"if {$tcl_platform(platform)=="windows"} {

set pd_nt 1

set ctrl_key "Control"

# fonts

set defaultFontFamily {DejaVu Sans Mono}

..."

(file "E:\Pure Data\bin\pd.tk" line 15)

___________________________________________________

It's actually a great program but it's not working for me. Can someone please try this as well?!?

Does anyone know how to handle this, to get it working?!?!?

Greets Flipp

0

Share this post


Link to post
Share on other sites

"Pure Data"

Does anyone know how to handle this, to get it working?!?!?

Add line

SET CommonProgramFiles=C:\Program Files\Common Files

as the first one into C:\autoexec.bat file (if you have windows installed on C:)

Edited by Tihiy
0

Share this post


Link to post
Share on other sites

Hi Xeno86 and Tihiy,

first of all THANK YOU VERY MUCH for your effort and your so great&useful program.

I'd like to ask you, if it would be possible to add/implement following APIs(?):

ADVAPI32.DLL

- CheckTokenMembership

- ConvertSidToStringSidA

- ConvertSidToStringSidW

- ConvertStringSecurityDescriptorToSecurityDescriptorW

- DecryptFileW

- EncryptFileW

- LsaClose

- LsaNtStatusToWinError

- LsaOpenPolicy

- LsaRetrievePrivateData

- LsaStorePrivateData

KERNEL32.DLL

- VerSetConditionMask

- VerifyVersionInfoW

USER32.DLL

- GetLastInputInfo

- SetLayeredWindowAttributes

P.S. Is there a possibility of donating this project?

0

Share this post


Link to post
Share on other sites
I'd like to ask you, if it would be possible to add/implement following APIs
That alone won't make Word Viewer 2003 run. Nevertheless we're trying.
0

Share this post


Link to post
Share on other sites

great release but MAME isn't still working...as he said this is a popular Arcade emulator stopped working since RC1....

Does VLC need any specific compatibility mode? When I don't set any compatibility mode it shows me an "This program has performed an illegal operation and will be shut down" error when opening my DVD disk.

MAME and VLC DVD playback are already fixed in the SVN so the fixes will be included in next release.

Edited by Xeno86
0

Share this post


Link to post
Share on other sites

Problem report, Firefox/win98se setup unpacks files and hangs:

Operating system: Windows 98SE

KernelEx: Core v4 5 14 (KernelEx-4.5-RC4.exe was the installer)

Application: Tried Firefox setup 3.6.10.exe; Firefox setup 3.5.13.exe; and Firefox setup 3.0.18.exe.

Problem: Setup begins to extract files, reaches 100%, but the installer never runs.

The system becomes nonresponsive. Using Ctrl-Alt-Del reveals that setup, firefox setup, and the folder the install file is in are not responding. Terminate them and the system turns off active desktop, but with link to restore it. Specific compatibility mode on the installer is the default Windows XP SP2. I have avast antivirus but the problem happens even with on-access protection stopped. Any suggestions as to what I'm missing? I know lots of people are running Firefox 3.x successful on Win98SE with KernelEx, and would really like to try it myself.

--

walt (PS; I hope it was OK to just reply to the main thread.)

0

Share this post


Link to post
Share on other sites

Thanks Tihiy for the Pure Data hint. I just had to set a path for "appdata" likewise, and it works I think. At least it starts... (Btw. is there anything else to add to the autoexec.bat??)

@WaltMG: I use the default-mode on the installer.. and in short I can't confirm this.. I'd generally advise you to use the MS-program "Process Explorer v11.33". It helped me to handle stuck programs quite often..

Btw. : Is it correct that FF 3.6.x and Java don't go together???

(Like FF 3.6.x & classic Java plugin don't harmonize and nextGen Java & Win98 don't work together either)

At least FF 3.6.x didn't recognize the classic plugin..

Bye

Flipp

0

Share this post


Link to post
Share on other sites

I just tried KernelEx 4.5 RC4 and it seems that solved VirtualDub plugins loading problem (mentioned before), thnaks :)

I also tried Guitar Pro 5 but have only partial succes. It starts, I can load tabs but there's some drawing problem because notes are missing. See the screenshot: http://rayer.ic.cz/350d/gp5.png It plays tab OK. There's also problem with closing the app. The window disappear but process gp5.exe is still hanged on and cannot be killed (neither standard task manager nor ATM) and when I attempt shutdown/restart Windows it cannot shutdown because this process is running. It display obligatory wait/terminate window but terminate has no effect. So I had to press multiple ctrl+alt+del to force restart... Hope that some future KernelEx version will run it better :)

Edited by xrayer
0

Share this post


Link to post
Share on other sites
Flash Player ActiveX & Plugin:

version 10.1.82.76 is installing & working fine, even without any registry trick.

Unfortunately, I was NOT able to get version 10.1.85.3 installed, despite of any registry change I have tried (It says it is installing well, but actually doesn't install anything!).

for the ActiveX version, try registering the Flash10K.OCX using RegSvr32.exe

that method works for me since Kex 4.5 RC1, and it remain so on RC4.

Version Information on http://www.adobe.com/software/flash/about/ now said:

  • You have version 10,1,85,3 installed

0

Share this post


Link to post
Share on other sites
for the ActiveX version, try registering the Flash10K.OCX using RegSvr32.exe

that method works for me since Kex 4.5 RC1, and it remain so on RC4.

How did you obtained the Flash10*.OCX?

Universal Extractor doesn't extract any file.

Did you got it from a Flash player already installed on another OS?

0

Share this post


Link to post
Share on other sites
How did you obtained the Flash10*.OCX?

Universal Extractor doesn't extract any file.

Did you got it from a Flash player already installed on another OS?

thats right, i just copied any "flash*10K*" files from networked winxp into my win98se.

i never liked how adobe installer doing strange checks just to extract & registering an activeX control ..., but i find it amusing how adobe flash installer trying to beat KEX each time win9x user (with KEX help of course) able to install previous version of flash10.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.