Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

KernelEx 4.5.2

- - - - -

  • Please log in to reply
1532 replies to this topic

#326
Juan

Juan

    Newbie

  • Members
  • 11 posts

2. Edit GoogleSketchUp7.msi with Orca, delete "VersionNT>=501" in LaunchCondition

3. Run GoogleSketchUp7.msi. During installation there was a warning "Could not write value SketchUpModule to a key". I just ignored it

When running SketchUp the first time, I encountered "Create File failed for C:\windows\Temp\skpB154.TMP" too. Also the toolbars are corrupted. However these problems did not affect the functioning of the program


slhk are you using MSInstaller version2 with this MSI file?


How to remove advertisement from MSFN

#327
Fredledingue

Fredledingue

    MSFN Expert

  • Members
  • PipPipPipPipPipPip
  • 1,264 posts
  • OS:98SE
  • Country: Country Flag

Could this possibly allow me to run the Quicklink Mobile software for two usb modems I use? (Pantech UM150, and UM175)

The dlls complain about needing a newer version of Windows, and this is after manually installing the software and drivers. I looked the software up in Dependancy Walker, but with the exception of the errors reported in the lower pane, I have no idea what this stuff is all about. :blushing:

KernelX doesn't fix drivers. The software runs or don't run with KernelX on a random basis.
Unfortunately.

#328
slhk

slhk

    Junior

  • Members
  • Pip
  • 68 posts

2. Edit GoogleSketchUp7.msi with Orca, delete "VersionNT>=501" in LaunchCondition

3. Run GoogleSketchUp7.msi. During installation there was a warning "Could not write value SketchUpModule to a key". I just ignored it

When running SketchUp the first time, I encountered "Create File failed for C:\windows\Temp\skpB154.TMP" too. Also the toolbars are corrupted. However these problems did not affect the functioning of the program


slhk are you using MSInstaller version2 with this MSI file?

Yes, I have Windows Installer 2.0 installed in my system

#329
alexeyL

alexeyL
  • Members
  • 9 posts

This is the punishment for using unofficial Add/Remove applets.

1) What do you mean by "unofficial Add/Remove applets"?
2) How can I install 4.0 Final2?

#330
Tihiy

Tihiy

    the creator

  • Members
  • PipPipPipPipPipPipPip
  • 1,910 posts
  • OS:Windows 7 x64
  • Country: Country Flag

Donator

You need to restore kernel32.dll with sfc.exe or manually.

#331
M()zart

M()zart

    Member

  • Members
  • PipPip
  • 271 posts
Xeno86, Tihiy. I think, KernelEx needs a small walkthrough on how to add your own API or stub to its sources, then build it, and install your own build.

Where to add API code, if there is a need to add a new file - into which project to add it, what changes to other files should be made to add an API or stub?
Which are the naming rules?
If you want to "patch" other dll, how to do it?
What is the difference between the kexbases and kexbasen, and where to add your code?
After the successful build how to install the result?

If you made such thing, I think, you may find more contributors. Unfortunately, I'm not so good at system programming, but I want to try.

#332
alexeyL

alexeyL
  • Members
  • 9 posts

You need to restore kernel32.dll with sfc.exe or manually.


Thank you very much!!!
1) I restored KERNEL32.DLL manually;
2) Run the KernelEx 4.0 Final2 installer;
- Installation was Ok;
- I see now KERNEL32.BAK in windows/kernelex directory.

#333
Juan

Juan

    Newbie

  • Members
  • 11 posts

2. Edit GoogleSketchUp7.msi with Orca, delete "VersionNT>=501" in LaunchCondition

3. Run GoogleSketchUp7.msi. During installation there was a warning "Could not write value SketchUpModule to a key". I just ignored it

When running SketchUp the first time, I encountered "Create File failed for C:\windows\Temp\skpB154.TMP" too. Also the toolbars are corrupted. However these problems did not affect the functioning of the program


slhk are you using MSInstaller version2 with this MSI file?

Yes, I have Windows Installer 2.0 installed in my system


How do you install if the MSI package requires version 3 of Windows Installer? :S

#334
slhk

slhk

    Junior

  • Members
  • Pip
  • 68 posts

How do you install if the MSI package requires version 3 of Windows Installer? :S

Sorry I did not have such experience, but I guess it would be impossible to install. Which software do you have problem with?

#335
Tihiy

Tihiy

    the creator

  • Members
  • PipPipPipPipPipPipPip
  • 1,910 posts
  • OS:Windows 7 x64
  • Country: Country Flag

Donator

How do you install if the MSI package requires version 3 of Windows Installer?

http://tihiy.ahanix.org/NotesMSI.html

#336
Juan

Juan

    Newbie

  • Members
  • 11 posts

How do you install if the MSI package requires version 3 of Windows Installer?

http://tihiy.ahanix.org/NotesMSI.html

Thank you Tihy!! what other resourses about KernelEX are there?

#337
jim2029

jim2029

    Newbie

  • Members
  • 46 posts
I can't get flash player 10 to install.... I even did the Reg mod and after running it, it will come up saying information was enter into the system reg. But the flash player setup still will not run. When I look in the reg. there is no entry made in the current version key (Folder)... so I was woundering what type of value is
"CurrentVersion"="5.1"

So I can put it in manually???

UPDATE: Never mind, I made a string called CurrentVersion and put the value as 5.1 and all installed.

Edited by jim2029, 06 October 2009 - 08:15 PM.


#338
Xeno86

Xeno86

    KernelEx Creator

  • Members
  • PipPip
  • 250 posts
  • OS:98SE
  • Country: Country Flag

I tried Flash 10.0.22.87 and Firefox 2&3 & Netscape & Opera9&10.

Could you try more recent flash plugin?
I've tested Firefox 2.0.0.20 with Flash 10.0.32.18 and it works fine.

#339
rainyd

rainyd

    Advanced Member

  • Members
  • PipPipPip
  • 407 posts
  • OS:98SE
  • Country: Country Flag

I've tested Firefox 2.0.0.20 with Flash 10.0.32.18 and it works fine.


I can confirm that the same version of Flash works fine with Firefox 2.0.0.22pre too.

#340
Juan

Juan

    Newbie

  • Members
  • 11 posts

How do you install if the MSI package requires version 3 of Windows Installer? :S

Sorry I did not have such experience, but I guess it would be impossible to install. Which software do you have problem with?

It is Acrobat Profesional 8 , the MSI keeps saying that the OS (win98) is incompatible after launching. I did edit this MSI with Orca.exe to remove all instances of Version9X EXCEPT those in Component table, there are many "downlevel_payload","downlevel_manifest","nosxs" instances with "Version9X" as condition there. It has to be deleted too?
Best Regards...

#341
szakacsze

szakacsze
  • Members
  • 1 posts
Hi!
Firefox 3.5.3 and flock 2.5.2 try running on hugarian windows 98se, with KernelEx 4.0final2.
Following result(see the pics):
Posted Image

Posted Image

Buttons menus characters, and website texts not shown.

Solution ?

Edited by szakacsze, 10 October 2009 - 11:32 AM.


#342
Philco

Philco

    Member

  • Members
  • PipPip
  • 273 posts
  • OS:98SE
  • Country: Country Flag

Hi!
Firefox 3.5.3 and flock 2.5.2 try running on hugarian windows 98se, with KernelEx 4.0final2.
Following result(see the pics):
Posted Image

Posted Image

Buttons menus characters, and website texts not shown.

Solution ?


Problem with graphics card or memory? Same problem with emergency mode / Firefox?

#343
AndrewNi

AndrewNi

    Newbie

  • Members
  • 15 posts
That same problem also happens to me inside Virtual PC with Windows 98SE.

It seems that running the DirectX Diagnostics Tool (dxdiag) before running Firefox fixes the issue, at least temporarily. I don't know why it does, though.

Before / After dxdiag:

Posted Image Posted Image

I didn't give it any more thought since it's only a VM, but maybe szakacsze can try it and see if it helps.

#344
Philco

Philco

    Member

  • Members
  • PipPip
  • 273 posts
  • OS:98SE
  • Country: Country Flag

That same problem also happens to me inside Virtual PC with Windows 98SE.

It seems that running the DirectX Diagnostics Tool (dxdiag) before running Firefox fixes the issue, at least temporarily. I don't know why it does, though.

Before / After dxdiag:

Posted Image Posted Image

I didn't give it any more thought since it's only a VM, but maybe szakacsze can try it and see if it helps.


??? Problem with fonts solution only with run dxdiag? Or reinstall DirectX?

#345
Jerry K

Jerry K
  • Members
  • 8 posts
  • OS:XP Home
  • Country: Country Flag
@ szakacsze & AndrewNi

Could it be that after installing KernelEx and Firefox something you installed has overwritten your version of unicows?
I had some similar problem earlier this year and after reinstalling KernelEx this problem still existed.
Then I checked unicows and noticed that some other programme I installed afterwards must have overwritten unicows with some older version. After changing that everything worked fine again.

#346
M()zart

M()zart

    Member

  • Members
  • PipPip
  • 271 posts
Still no reply about walkthrough on adding API. :(

I have created userenv.dll for Windows 98 which allows to run X-Moto open-source game ( http://xmoto.sourceforge.net/ ) on Windows 98 with KernelEx. Please download here http://www.msfn.org/...9x-t138911.html

#347
trevor89

trevor89

    Junior

  • Members
  • Pip
  • 58 posts
  • OS:98SE
OK, I know you don't like requests but could someone find out what is required to stop a program from making an illegal Operation.

The program is The GoldenEye Setup Editor Developed by Subdrag and Zoinkity of the Rare Witch Project.

The program starts ok (found out it requires KEX because without it it complains about missinfg refrences such as windowsdir in dlls)
The program does not need to be set to a particular OS Version, justy the extencions will do.

Everything works untill you use the Visual Editor (Using Direct X) where the menues load and the background music loads but then it crashes with this message.

GOLDENEYESETUPEDITORV2 caused an invalid page fault in
module <unknown> at 0000:00000000.
Registers:
EAX=00000003 CS=017f EIP=00000000 EFLGS=00010202
EBX=012f6428 SS=0187 ESP=010a765c EBP=010a77a8
ECX=00009b30 DS=0187 ESI=00000000 FS=c1cf
EDX=00000003 ES=0187 EDI=00000000 GS=0000
Bytes at CS:EIP:
00 00 00 00 65 04 70 00 16 00 19 0c 65 04 70 00
Stack dump:
00a6ff45 000016c2 00000003 00000001 00000000 010a7680 00000027 06c9f69c 06c9f8cc 01d30000 00000000 00000027 0909ff7c 06c9f8cc 00000000 010a76e4

Trev

#348
mikefitzvw

mikefitzvw

    Newbie

  • Members
  • 15 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Hi, I'm new to this forum so I hope this ends up in the right place. I installed KernelEX on a 98FE Dell computer and was able to run Firefox 3.5, but cannot for the life of me get Flash 10 to install. I did try changing the registry like the 2nd post said, and changing the compatibility mode. You see, the first time I tried changing the registry I typed this:

REGEDIT4
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\5.1]

instead of:

REGEDIT4
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion]
"CurrentVersion"="5.1"

I am able to download Flash 10 fine (I'm not directed to the Flash 9 site, so KernelEX worked) but whenever I try to install it says that I'm attempting to install on an old version of Windows (duh Adobe!). This computer is more than capable of running Flash 10, let alone XP (It's an XPS Dell) so I am stuck. Did my mistaken registry change screw up everything? If so what do I do? I see no use getting rid of a perfectly nice computer. Also, by any chance is there a way to upgrade to 98SE? "Upgrade" discs are for 95 and below, and I can't find any "update" CDs.

#349
gg41

gg41

    Newbie

  • Members
  • 10 posts
Hello mikefitzvw,

Create "xp.reg" file in notepad with following contents:

REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion]
"Version"="Windows NT"
"VersionNumber"="5.10.2600"

Double click on "xp.reg" file.

Install the program Flash 10.

Create "unxp.reg" file in notepad with following contents:

REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion]
"Version"="..........."
"VersionNumber"="..........."

Double click on "unxp.reg" file.

#350
dencorso

dencorso

    Adiuvat plus qui nihil obstat

  • Super Moderator
  • 5,560 posts
  • OS:98SE
  • Country: Country Flag

Donator

Actually, a better "unxp.reg" file ought to be::

REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion]
"Version"="Windows 98"
"VersionNumber"="4.10.2222"

Dont forget to leave a blank line at the end of the reg file.




2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users



How to remove advertisement from MSFN