Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

KernelEx 4.5.2

- - - - -

  • Please log in to reply
1532 replies to this topic

#701
esotericmaniac

esotericmaniac
  • Members
  • 5 posts
---------- For the developers ----------

Here is the file required about WoW.exe dependencies.

Attached Files




How to remove advertisement from MSFN

#702
Tihiy

Tihiy

    the creator

  • Members
  • PipPipPipPipPipPipPip
  • 1,910 posts
  • OS:Windows 7 x64
  • Country: Country Flag

Donator

support for World of Warcraft (after patch 3.3.5a)

Unfortunately support for WoW battle.net.dll is complicated because of its heavy use of code obfuscation. This is the target for future KernelEx version.

#703
FlippX

FlippX

    Junior

  • Members
  • Pip
  • 60 posts
  • OS:none specified
  • Country: Country Flag
Heyho,
I just dropped in because I've recently had some problems with some programs...
To be more precise,
its a 3d-surface-generator, "k3dsurf" ( k3dsurf.sourceforge.net ) , is someone willing to try it, plz??
for me it works best with the win2000-config. but not always... after a restart I sometimes get graphical problems, and it seems I am missing some fonts, can someone confirm that??


other things are
Inkscape and Synfig ,two drawing-progs..
they work best in win2000-mode as well.
in XP-mode I get errors causing a crash. For example just try a right-click in Inkscape..
Its a Gtk+ error, thats all I can say. Might there be a solution?? Or what is this telling me, since I'm not a programer..
Btw. whats you guys favourite drawing-program (2d-, 3d, CAD-)??

Greets Flipp

#704
loblo

loblo

    Oldbie

  • Members
  • PipPipPipPipPip
  • 729 posts
  • OS:ME
  • Country: Country Flag
K3DSurf is a buggy application who never worked too properly AFAIK, I am not sure it can be fixed with KernelEx tbh, version 0.6 which I have installed is sort of workable though.

Edited by loblo, 08 September 2010 - 01:44 PM.


#705
Xeno86

Xeno86

    KernelEx Creator

  • Members
  • PipPip
  • 250 posts
  • OS:98SE
  • Country: Country Flag
KernelEx v4.5 RC 2
Release announcement

Okay, so here comes a new release. This time it mainly fixes reported bugs.
Hope you enjoy this release.

In case you didn't know yet... KernelEx has now a real webpage instead of the ugly default one.
http://kernelex.sourceforge.net/


What's new:
  • Implemented SysLink common control class
Apps fixed / now working:
  • Fixed: Google Picasa options dialog (empty tabs)
  • Fixed: Adobe Flash Player crashes (reported by mailcat via sf.net forum)
  • Fixed: Adobe Flash Player 10.1 volume control
  • Fixed: Wizard101 game crash (bug #3041092)
  • Fixed: Maxthon browser (freezing)
  • Now working: Maxthon 1.6.7
  • Now working: VLC 1.1.2 (without RP9)


#706
rainyd

rainyd

    Advanced Member

  • Members
  • PipPipPip
  • 407 posts
  • OS:98SE
  • Country: Country Flag
Xeno/Tihiy, thank you warmly guys for another RC of KernelEx 4.5 :thumbup

I can confirm, that I have no more problem with latest Flash on YouTube. :)

#707
loblo

loblo

    Oldbie

  • Members
  • PipPipPipPipPip
  • 729 posts
  • OS:ME
  • Country: Country Flag
Running great here aside from perhaps a regression (already in the previous build actually) with Apophysis 2 which doesn't display rendered images on its main screen again, a big hourglass remaining indefinitely instead.

http://sourceforge.n...09.exe/download

#708
CyberyogiCoWindler

CyberyogiCoWindler

    Junior

  • Members
  • Pip
  • 77 posts
  • OS:98SE
  • Country: Country Flag
Bug-Report: KernelEx 4.5 RC2 *CRASHES* Thinkpad 760XD laptop!


I just tried out the new KernelEx 4.5 RC2. While on my normal PC it installed flawlessly, any attempts of installing it on my IBM Thinkpad 760XD laptop (Pentium MMX 166MHz, 106MB RAM, 2GB HDD) result in such a deep crash that I can only uninstall it in safe mode of Windows 98SE.

When I attempt to install it on the 760XD, everything behaves normal until I reboot Windows. When Windoze starts and I leave the login screen, an error requester pops up, telling that EXPLORER caused a stack error. When I close it, Windows simply locks up with only the empty desktop background and mouse pointer visible. :realmad:

The error message says (handtyped from my digicam photo, I hope without typos):

Explorer

Diese Anwendung wird aufgrund eines ungültigen
Vorgangs geschlossen.

Wenden Sie sich an den Hersteller, falls das Problem
weiterhin besteht.
-
EXPLORER verursachte einen Stapelfehler in Modul
<Unbekannt> bei 0000:bfa53390.
Register:
EAX=0059fc50 CS=0187 EIP=bfa53390 EFLGS=00010282
EBX=00550000 SS=018f ESP=00562000 EBP=00562000
ECX=0059fc50 DS=018f ESI=00000000 FS=2407
EDX=0059fc50 ES=018f EDI=00000000 GS=238e
Bytes bei CS:EIP:
52 ff 15 9c 8a a7 bf 5d c2 04 00 cc cc cc cc cc
Stapelwerte:
0056200c bfa53397 0059fc50 00562018 bfa53397
0059fc50 00562024 bfa53397 0059fc50 00562030
bfa53397 0059fc50 0056203c bfa53397 0059fc50
00562048


translated into English:

Explorer

This application was closed by an invalid process[?].

Contact the manufacturer so far the problem still exists.
-
EXPLORER caused a stack error in module
<unknown> at 0000:bfa53390.
register:
EAX=0059fc50 CS=0187 EIP=bfa53390 EFLGS=00010282
EBX=00550000 SS=018f ESP=00562000 EBP=00562000
ECX=0059fc50 DS=018f ESI=00000000 FS=2407
EDX=0059fc50 ES=018f EDI=00000000 GS=238e
bytes at CS:EIP:
52 ff 15 9c 8a a7 bf 5d c2 04 00 cc cc cc cc cc
stack values:
0056200c bfa53397 0059fc50 00562018 bfa53397
0059fc50 00562024 bfa53397 0059fc50 00562030
bfa53397 0059fc50 0056203c bfa53397 0059fc50
00562048

When I restart Windows, the boot process turns very slow and cooks pea soup on the harddisk (disk treashing). Once Windows starts, it locks up the same way again. I can only get back to normal by booting into safe mode (which also seems to take unusually long) and uninstalling KernelEx. :angry: I also tried to reinstall with all KernelEx settings set to default, but it doesn't help. The previous KernelEx 4.5 RC1 ran fine on the 760XD without problem and still installs well (after manually uninstalling RC2).

On my normal PC RC2 works well. (But it still displays in Firefox 3.6.9 a "|" instead of "..." which looks ugly. This is likely a simple unicode translation flaw - please fix this.)

#709
FlippX

FlippX

    Junior

  • Members
  • Pip
  • 60 posts
  • OS:none specified
  • Country: Country Flag
Thanks for the new KEX!!
No new problems, and less old ones..
While Flash 10.1 works well now (the sound-problem is gone),
I still get the playlist-"error" in vlc 1.1.2 (radiostations (shoutcast.com) are placed at the end of vlcs playlist)...(I just thought that this might be a problem of the tray-icon als well, but I didnt try this..)

BUT WITH vlc 1.1.4 THERE IS NO PROBLEM!!! <--- if you cant open files sometimes, go to vlcs options and deactivate the systray-icon!!! It seems to not shut down properly..

Thats it for now,
Flipp

#710
Xeno86

Xeno86

    KernelEx Creator

  • Members
  • PipPip
  • 250 posts
  • OS:98SE
  • Country: Country Flag
KernelEx v4.5 RC 3
Release announcement

Unfortunately, last release has a bug that could cause bootup system crashes on certain configurations. This is a hotfix release that only fixes mentioned bug. It is recommended to update from RC 2.

This release fixes bootup crash problem reported by CyberyogiCoWindler.

In case you already have this problem and can't start the system to uninstall that release, start the system in Safe Mode and uninstall 4.5 RC 2 from there.

#711
CyberyogiCoWindler

CyberyogiCoWindler

    Junior

  • Members
  • Pip
  • 77 posts
  • OS:98SE
  • Country: Country Flag

Bug-Report: KernelEx 4.5 RC2 *CRASHES* Thinkpad 760XD laptop!

Xeno86 sent me a hotfix => My old rocket science laptop rocks again!

He said the bug was a circular reference.

#712
slhk

slhk

    Junior

  • Members
  • Pip
  • 68 posts
RC3 is not okay for me. When Lingoes is running, there is invalid page fault in KERNELEX.DLL whenever I do anything related to Explorer (e.g. move my mouse pointer over the Taskbar, press Windows+R to call the Run window, etc). Downgraded to RC1 solved the problem. Hope this can be fixed in next RC

#713
Xeno86

Xeno86

    KernelEx Creator

  • Members
  • PipPip
  • 250 posts
  • OS:98SE
  • Country: Country Flag

RC3 is not okay for me. When Lingoes is running, there is invalid page fault in KERNELEX.DLL whenever I do anything related to Explorer (e.g. move my mouse pointer over the Taskbar, press Windows+R to call the Run window, etc). Downgraded to RC1 solved the problem. Hope this can be fixed in next RC


I need your Windows version, Lingoes version, compatibility settings used by you, MFC42U.dll version
and most importantly Dr Watson crash log.
I haven't noticed the described behaviour with Lingoes 2.7.1 working under 98SE with 4.5 RC3.

#714
FlippX

FlippX

    Junior

  • Members
  • Pip
  • 60 posts
  • OS:none specified
  • Country: Country Flag
Heyho,
I just wanted to say that assigning media-files in vlc 1.1.4 via the vlc-options doesn't work. But it works with the explorer dialog.. (like if no EXE is assigned to a file and you double-click it..or go to the "folderoptions" and assign vlc there) Btw. I noticed some new files in the "file-type" dialog of the "folderoptions". Those are obviously put there by vlc, but are not working...for me.
Can someone confirm this??
Flipp

#715
supem

supem

    Junior

  • Members
  • Pip
  • 50 posts
Hi,
There must be a bug in latest version. First I noticed Flashget from my autostart folder (98SE) didn't start properly and executed its own bug report window.
Then explorer.exe (4.72.3612.1700) and other apps (K-meleon, Groupwise) caused DrWatson to appear.

Attached Files



#716
halohalo

halohalo

    Member

  • Members
  • PipPip
  • 185 posts
  • OS:98SE
  • Country: Country Flag

But there will be an error message when I close QtWeb, and it occurs at both XP and 2000 mode:

QTWEB caused an invalid page fault in
module USER.EXE at 0004:00006307.
Registers:
EAX=0002bb38 CS=1777 EIP=00006307 EFLGS=00000202
EBX=00010002 SS=5db7 ESP=00000000 EBP=00000012
ECX=0002001e DS=167f ESI=0002bb28 FS=587f
EDX=00000002 ES=0aaf EDI=000000a8 GS=0000
Bytes at CS:EIP:
52 50 89 76 f4 89 5e f6 9a 02 0f 8f 17 52 50 57
Stack dump:
0002bb28 ffff00a8 00101ed3 d7b3d431 00367d60 177763a3 00000000 00a8001e 0002bb28 0002bb28 bb2800a8 02360002 00c92365 005ad419 177763a3 00000000

With latest KernelEx, the problem is solved and I can close QtWeb normally. :D

#717
schwups

schwups

    schwups

  • Members
  • PipPipPip
  • 401 posts
  • OS:ME
  • Country: Country Flag
KEX 4.5 RC3: I noticed an Error in KernelEx.dll on two machines. OS: Win ME RP9.6.6

Attached Files



#718
FlippX

FlippX

    Junior

  • Members
  • Pip
  • 60 posts
  • OS:none specified
  • Country: Country Flag
Hello,
Does anybody know if there is something known about BattleEye and KEX compability??
Flipp

#719
patclash

patclash

    Newbie

  • Members
  • 41 posts
  • OS:98SE
  • Country: Country Flag

KEX 4.5 RC3: I noticed an Error in KernelEx.dll on two machines. OS: Win ME RP9.6.6


Hi,
I have the same error with KernellEX 4.5 RC3 on my Win98SE french version 4.10.2222A,
Explorer exe version 4.72.3612.1700
EXPLORER a causé une défaillance de page dans
 le module KERNELEX.DLL à 016f:bfa07d96.
Registres :
EAX=00000000 CS=016f EIP=bfa07d96 EFLGS=00010246
EBX=0080396c SS=0177 ESP=01a3c9b8 EBP=01a3ca00
ECX=2530c766 DS=0177 ESI=00803944 FS=3fef
EDX=00000000 ES=0177 EDI=008030e0 GS=0000
Octets à CS : EIP :
8b 14 81 03 55 e4 89 55 dc 8b 45 10 89 45 d8 8b 
État de la pile :
637d9238 01a3c9e8 636a3264 02569008 000000f0 00000013 637e5080 00000013 00000128 00000000 000008ad 7f2d0000 7f3069e0 2530c766 637e5080 00000128

I uninstall it and reinstall the 4.5 RC2 version that work for me ;)

here my Dr Watson log :

Attached Files


Edited by patclash, 10 September 2010 - 01:07 PM.


#720
Xeno86

Xeno86

    KernelEx Creator

  • Members
  • PipPip
  • 250 posts
  • OS:98SE
  • Country: Country Flag
Given recent crash reports with RC 2 and RC 3 I have decided to pull down those releases until these issues are resolved.

Please downgrade to RC 1. Sorry for inconvenience.

#721
slhk

slhk

    Junior

  • Members
  • Pip
  • 68 posts


RC3 is not okay for me. When Lingoes is running, there is invalid page fault in KERNELEX.DLL whenever I do anything related to Explorer (e.g. move my mouse pointer over the Taskbar, press Windows+R to call the Run window, etc). Downgraded to RC1 solved the problem. Hope this can be fixed in next RC


I need your Windows version, Lingoes version, compatibility settings used by you, MFC42U.dll version
and most importantly Dr Watson crash log.
I haven't noticed the described behaviour with Lingoes 2.7.1 working under 98SE with 4.5 RC3.

1. My Windows is Simplified Chinese 98SE with RP 9.6.6. Lingoes is 2.7.1, compatibility set to XP SP2. MFC42U.dll is 6.02.8071.0

2. Failed to get Dr Watson crash log because the dumping process freezed

3. I have found a workaround to the "invalid page fault" problem: Keep closing the invalid page fault windows repeatedly until Explorer finally crashs and restarts. Then the Explorer runs normally with Lingoes

4. The "invalid page fault" problem also occurred when I tried to open some folders with Explorer (Lingoes was not running at that time)

5. Downgraded to RC1 for the time being

#722
TmEE

TmEE

    Mega Drive Modding Master

  • Members
  • PipPipPip
  • 353 posts
  • OS:98SE
  • Country: Country Flag
KernelEx 4.5 RC3 causes lot of GFX elements to be black in Gimp 2.2

First I thought it was caused by RP9 but after uninstalling it, things did not change... then I uninstalled KEX and everything was normal, after installing RP9 things remained OK aswell.

So far other than that, I have not had problems with KEX.

If needed I can provide some screenshots of the problem aswell.

EDIT: I installed KEX again and I started getting errors on WMIEXE, if I moved the mouse over something I got an error... I could navigate between folders ando pen programs, after clicking close on the error windows many times, and I could uninstall KEX then.

After reboot, shortcuts became ineffective and quicklaunch was gone. I had it before, and fix was to reinstall KEX and uninstall it, and when I reinstalled I still got the error. I did an install/uninstall with an older version and shortcuts became working again, and I had to manually enable quicklaunch...

Now I got another problem which prevents me from installing any version of KEX. ERROR: Disable_platform_check:pattern not found

:(

EDIT: I forgot one detial... one install of KEX failed, it gave an error that install failed, and thus I uninstalled it and tried again, at form nothing works.

EDIT: Seems I got KEX'ed KERNEL32.DLL in the system without DLL... I reverted it to KERNEL32.DLL form Win98 setup files, and now KEX install says it cannot open KERNEL32.BAK file, and suggests me to get the DLL from install media, so I copied the DLL to KEX dir in win folder and renamed it to the BAK hoping it works and I get the error I got before.
Kinda makes me think KEX thinks its still installed...... ?

Edited by TmEE, 11 September 2010 - 01:10 PM.


#723
dencorso

dencorso

    Adiuvat plus qui nihil obstat

  • Super Moderator
  • 5,560 posts
  • OS:98SE
  • Country: Country Flag

Donator

@CyberyogiCoWindler, RLoew, and all others involved, myself included: :)
It just dawned on me we were actively hijacking this thread, so I've decided to remedy this.
All relevant posts are now moved and incorporated to this other thread, where they fit best, and will be easier to find, instead of ending-up buried in a ton of KEx posts, as would inevitably happen here.

@Xeno86, and everybody trying to keep to the main subject of the present thread: Sorry for the (now solved) hijack! :yes:

#724
loblo

loblo

    Oldbie

  • Members
  • PipPipPipPipPip
  • 729 posts
  • OS:ME
  • Country: Country Flag

EDIT: Seems I got KEX'ed KERNEL32.DLL in the system without DLL... I reverted it to KERNEL32.DLL form Win98 setup files, and now KEX install says it cannot open KERNEL32.BAK file, and suggests me to get the DLL from install media, so I copied the DLL to KEX dir in win folder and renamed it to the BAK hoping it works and I get the error I got before.
Kinda makes me think KEX thinks its still installed...... ?


If you delete KernelEx startup key in the registry it won't think it is still installed anymore as it won't try to load at all.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\MPRServices\KernelEx

#725
TmEE

TmEE

    Mega Drive Modding Master

  • Members
  • PipPipPip
  • 353 posts
  • OS:98SE
  • Country: Country Flag
Hmm, there was nothing in there in the registry....

Only KEX related thing I found in the registry was this :
HKEY_LOCAL_MACHINE\Software\CLASSES\*\shellex\PropertySheetHandlers\KernelEx




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN