Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

KernelEx 4.5.2

- - - - -

  • Please log in to reply
1551 replies to this topic

#976
CharlesF

CharlesF

    Advanced Member

  • Member
  • PipPipPip
  • 461 posts
  • OS:98SE
  • Country: Country Flag

Look around, you have NT drivers! In filemon and drwatson logs, there are mention of dlls which don't belong to drivers you posted: SDIMF32.DLL, QDPRINT.DLL, SD32.DLL, SDDM32.DLL, SR32.DLL, ZGDI32.DLL, ZSPOOL.DLL, etc.
Tell me where to get these files

You are right, all those 7 files are located on my HD in C:\WINDOWS\SYSTEM\

After search, they are coming from the first version of driver I had installed, straight from the install CD that is coming with the printer.
I have uploaded this driver at this link if you are interested: http://dl.free.fr/g5OmglG9D

The driver I have posted before was installed "on the top", when I had found a newer version on the HP site.

Now, may I ask 2 questions:
- why did all this stuff was working all that time if they are not 'good' drivers? What is so different with last build of KernelEx?

- what do you suggest I would do now? In Control Panel->Add/Remove programs, I don't have any item to uninstall HP drivers.

Thanks in advance for your efforts, Tihiy :hello:

Edited by CharlesF, 01 December 2010 - 06:39 PM.



How to remove advertisement from MSFN

#977
Dave-H

Dave-H

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 769 posts
  • OS:98SE
  • Country: Country Flag
Probably if you put the HP driver CD in again and run the installer, it should give you the option to uninstall the drivers.
I have an HP printer too, a Photosmart 370 photo printer, as well as my main Epson A4 printer.
The software that came with the HP printer was an absolute pig to install and get working, especially in Windows 98, although the Image Zone software that came with it is really good.
:)

Dual boot Windows 98SE SP2.1a and Windows XP Professional SP3.
Dual 3.2GHz Xeons with 4GB RAM. ATI Radeon X850 Graphics 1920x1080 32 Bit Colour with Large Fonts.


#978
Tihiy

Tihiy

    the creator

  • Member
  • PipPipPipPipPipPipPip
  • 1,922 posts
  • OS:Windows 7 x64
  • Country: Country Flag

Donator

CharlesF, we need to figure out what happened during RC4-RC5 path. Only you [and similar poor souls?] can help us.
[download removed]
This file contains 18 key revisions between RC4 and RC5. Start with installing RC4 and trying lowest revision. Install by right-clicking install.inf and reboot. Test if your bug appears.
You can skip revisions to save time ('binary' search) but don't jump between < 260 and >=260 revisions as they contain different sheet.dll.
Good luck :hello:

Edited by Tihiy, 05 December 2010 - 03:34 PM.


#979
supem

supem

    Junior

  • Member
  • Pip
  • 50 posts
Hi,
I reported my printing problem here
Today I've tested all revision of RC4-5.rar twice nearly.
First I decided to print Excel sheet and printing went well for all revision up to finally installed KeX 4.5
Than I started printing *.doc file and the bug appeared with revision #263 andfurther ones.
That text file has been printed from MsOffice and OO 3.21 where distinctly showed on the screen its frozen process

HTH

Edited by supem, 03 December 2010 - 05:29 PM.


#980
Tihiy

Tihiy

    the creator

  • Member
  • PipPipPipPipPipPipPip
  • 1,922 posts
  • OS:Windows 7 x64
  • Country: Country Flag

Donator

First I decided to print Excel sheet and printing went well for all revision up to finally installed KeX 4.5
Than I started printing *.doc file and the bug appeared with revision #263 andfurther ones.
That text file has been printed from MsOffice and OO 3.21 where distinctly showed on the screen its frozen process

Thank you very much. CoWaitForMultipleHandles was culprit #1 (since its the only new function which does wait), but the problem is - it's not used by printer drivers i've seen and Office 2000/XP/OOo, which prints fine for me and xeno86. Can you please run a search for files you run which use it (with Far for example; files containing 'cowait'; not case sensitive; all character tables; in \windows and \program files with subfolders, then filter out things you don't use).

#981
supem

supem

    Junior

  • Member
  • Pip
  • 50 posts
Tihiy,
that's what I've found in my 98 unit

Attached Files



#982
Tihiy

Tihiy

    the creator

  • Member
  • PipPipPipPipPipPipPip
  • 1,922 posts
  • OS:Windows 7 x64
  • Country: Country Flag

Donator

supem, thank you again. Can you also test rev 262 to be 100% sure it's 263+ at fault? It's in updated RC4-5.rar. Thank you again :>

#983
supem

supem

    Junior

  • Member
  • Pip
  • 50 posts

supem, thank you again. Can you also test rev 262 to be 100% sure it's 263+ at fault? It's in updated RC4-5.rar. Thank you again :>


1. I did test revision 263 of previous RC4-5.rar twice at least
2. revision 262 from the updated RC4-5 is buggy as 263+ ones

#984
Tihiy

Tihiy

    the creator

  • Member
  • PipPipPipPipPipPipPip
  • 1,922 posts
  • OS:Windows 7 x64
  • Country: Country Flag

Donator

2. revision 262 from the updated RC4-5 is buggy as 263+ ones

That must mean hang is hard; everything locks up and the only way to exit is to bring Ctrl-Alt-Del dialog, right?

#985
CharlesF

CharlesF

    Advanced Member

  • Member
  • PipPipPip
  • 461 posts
  • OS:98SE
  • Country: Country Flag

CharlesF, we need to figure out what happened during RC4-RC5 path.

Hi Tihiy,

I was about to do your tests this WE (probably sunday afternoon).
After the nice helping hand of supem, do you want me to do the same anymore?
I'm still available. ;)

BTW, I have done the same seach on my HD (with the search function of Windows) for files containing 'cowait' in \Windows and \Program Files with subfolders.
Here is what I have found:

C:\WINDOWS\SYSTEM\atl.dll, Version 3.00.9782, 30 novembre 2005 16:27:54
C:\WINDOWS\SYSTEM\mfc42.dll, Version 6.02.4131.0, 4 août 2004 00:56:44
C:\WINDOWS\SYSTEM\MFC42U.DLL, Version 6.02.8071.0, 14 décembre 2006 14:45:54
C:\WINDOWS\SYSTEM\MSJAVA.DLL, Version 5.00.3810, 28 février 2003 18:26:26
C:\WINDOWS\SYSTEM\SHDOCVW.DLL, Version 6.00.2800.2006 (xpsp2.100414-1536), 14 avril 2010 16:53:44
C:\WINDOWS\SYSTEM\SHLWAPI.DLL, Version 6.00.2800.2006 (xpsp2.100414-1536), 14 avril 2010 16:53:46
[I do not have any .NET version installed.]
C:\Program Files\WinMerge\mfc71.dll, Version 7.10.3077.0, 9 juin 2009 14:28:36
C:\Program Files\WinMerge\mfc71u.dll, Version 7.10.3077.0, 9 juin 2009 14:28:36 [Could be that this Dll is not used in Windows 9x.]
C:\Program Files\Spybot - Search & Destroy\Plugins\Chai.dll, No version, 4 mars 2008 14:52:00
C:\Program Files\Spybot - Search & Destroy\SDFiles.exe, Version 1.6.1.7, 26 janvier 2009 15:29:26 [I almost don't run Spybot anymore.]

HTH
Charles. :)

#986
Tihiy

Tihiy

    the creator

  • Member
  • PipPipPipPipPipPipPip
  • 1,922 posts
  • OS:Windows 7 x64
  • Country: Country Flag

Donator

After the nice helping hand of supem, do you want me to do the same anymore?
I'm still available. ;)

Would be very nice. 261-262-263 are the revisions likely should be enough.

#987
Tihiy

Tihiy

    the creator

  • Member
  • PipPipPipPipPipPipPip
  • 1,922 posts
  • OS:Windows 7 x64
  • Country: Country Flag

Donator

CharlesF, supem: please test this revision, it contains rev. 262 bug fix
[download removed]

Edited by Tihiy, 05 December 2010 - 03:34 PM.


#988
supem

supem

    Junior

  • Member
  • Pip
  • 50 posts

CharlesF, supem: please test this revision, it contains rev. 262 bug fix


It works without a doubt. :thumbup

#989
CharlesF

CharlesF

    Advanced Member

  • Member
  • PipPipPip
  • 461 posts
  • OS:98SE
  • Country: Country Flag

CharlesF, supem: please test this revision, it contains rev. 262 bug fix

I have installed the RC6 'on the top' of RC4, without going through the other revision builds
(that means, the sheet.dll is still the RC4's).

I've tested in Work 2000 with HP LJ 1022
... and it is definitely working smooth and instant! :thumbup Bravo Tihiy! :thumbup

Edited by CharlesF, 05 December 2010 - 03:17 PM.


#990
Tihiy

Tihiy

    the creator

  • Member
  • PipPipPipPipPipPipPip
  • 1,922 posts
  • OS:Windows 7 x64
  • Country: Country Flag

Donator

supem, CharlesF , thank you for your patience and efforts!

#991
CharlesF

CharlesF

    Advanced Member

  • Member
  • PipPipPip
  • 461 posts
  • OS:98SE
  • Country: Country Flag

supem, CharlesF , thank you for your patience and efforts!

You're very welcome :D .
We thank you for your efforts to keep this OS alive. :yes:

#992
loblo

loblo

    Oldbie

  • Member
  • PipPipPipPipPip
  • 754 posts
  • OS:ME
  • Country: Country Flag


supem, CharlesF , thank you for your patience and efforts!

You're very welcome :D .
We thank you for your efforts to keep this OS alive. :yes:

+1

Cheers

:hello:

#993
Prozactive

Prozactive

    Member

  • Member
  • PipPip
  • 209 posts
  • OS:98SE
  • Country: Country Flag

System Safety Monitor Free for 98/ME causes EXPLORER.EXE to stop responding upon closing SSM and exiting and freezes Win 98/ME

AVZ fails to read KEX kernel.


I can confirm problems with KernelEx and SSM Free 2.0.8.583. I installed SSM several months ago and immediately started having various crashes and errors. I'm pretty sure they were associated with Explorer but I'll check my logs later to see. I was able to stop the errors by disabling KernelEx extensions for all SSM exe and dll files. I was running KernelEx RC 1 at the time. I meant to report the problem in this thread or herbalist's SSM thread but failed to do so. This post reminded me of the problem.

Hm, I have AVZ installed but have not run it after installing KernelEx. I may have to try running it to see if I have the same problem.

EDIT: This is the error I repeatedly got after installing SSM with KernelEx RC 1.

EXPLORER caused an invalid page fault in
module <unknown> at 0000:9eff049c.
Registers:
EAX=fffccead CS=0177 EIP=9eff049c EFLGS=00010246
EBX=00000000 SS=017f ESP=00d4f7ec EBP=00d4f844
ECX=00430b94 DS=017f ESI=00430b94 FS=227f
EDX=00d4f850 ES=017f EDI=00000000 GS=0000
Bytes at CS:EIP:

Stack dump:
71567288 00000003 71567093 71500000 fffccead 70aa03cb 00430b94 00430adc 71567334 00000001 00000000 00430adc 00000000 7156c82b 00430adc 00000000

Edited by Prozactive, 07 December 2010 - 10:37 AM.


#994
FlippX

FlippX

    Junior

  • Member
  • Pip
  • 60 posts
  • OS:none specified
  • Country: Country Flag
Hey,
there is this powerful CAD-Software...
( http://www.plm.autom..._response.shtml )
...but I can't make it install on my pc.
Would you guys please give it a try as well and report your results?!
Is there any hope to make it run on a win98se (+everything unofficial) ??

For those who are interested:
"Draft It 3" works (min winME-mode at installer, disable KEX for program)
"Cademia" ...java...is nice...

#995
WIN98SE

WIN98SE

    Newbie

  • Member
  • 12 posts
  • OS:none specified
  • Country: Country Flag
Java SE 6u23 Runtime is out there
http://www.oracle.co...oads/index.html

If there any problems/crashes with the install-routine
just use the Silent-parameter in a Windows-DOS-Shell(command-line?) or Start-->RUN

jre-6u23-windows-i586.exe /s

#996
rainyd

rainyd

    Advanced Member

  • Member
  • PipPipPip
  • 407 posts
  • OS:98SE
  • Country: Country Flag

Java SE 6u23 Runtime is out there
http://www.oracle.co...oads/index.html

If there any problems/crashes with the install-routine
just use the Silent-parameter in a Windows-DOS-Shell(command-line?) or Start-->RUN

jre-6u23-windows-i586.exe /s


Have you installed successfully update 23?

I can't because of some stack error in kernel32.dll, and the way which you've mentioned, doesn't help (KernelEx 4.5 RC 5).

#997
frogman

frogman

    Senior Member

  • Member
  • PipPipPipPip
  • 554 posts
  • OS:98SE
  • Country: Country Flag

Java SE 6u23 Runtime is out there
http://www.oracle.co...oads/index.html

If there any problems/crashes with the install-routine
just use the Silent-parameter in a Windows-DOS-Shell(command-line?) or Start-->RUN

jre-6u23-windows-i586.exe /s


Can you explain how this is done please?
Windows 98 S.E - Opera 12.02 - Firefox 3.6.28 - Kernel-Ex 4.5.2 - Internet Explorer 6

#998
schwups

schwups

    schwups

  • Member
  • PipPipPip
  • 410 posts
  • OS:ME
  • Country: Country Flag
WinME ; KEX 4.5 RC5 ; RP9.7.0

I've installed new Java update 23 silent without errors. But there is a problem with Firefox (3.5.15) (Opera 10.1 OK).

Java tester at java.com: Test shows that Java 23 works but it gives an error message: TypeError: document.commandDispatcher.focusedWindow is null

After closing Firefox follows an error message. After downgrade to 22 the error doesn't appear.

Attached Files

  • Attached File  FF1.png   4.84KB   13 downloads
  • Attached File  FF.png   5.17KB   9 downloads

Edited by schwups, 08 December 2010 - 08:58 AM.


#999
rainyd

rainyd

    Advanced Member

  • Member
  • PipPipPip
  • 407 posts
  • OS:98SE
  • Country: Country Flag
Judging by those screenshots, I've got exactly the same problem but before installation of Java.
Maybe in your case installation was successfull because you have Windows ME + RP 9.7.0.

#1000
WIN98SE

WIN98SE

    Newbie

  • Member
  • 12 posts
  • OS:none specified
  • Country: Country Flag

Judging by those screenshots, I've got exactly the same problem but before installation of Java.
Maybe in your case installation was successfull because you have Windows ME + RP 9.7.0.



Hi,
I uninstalled java 6 u22, then I used CCleaner the Cleaner option (Java box ticked) and the Registry-option.
Then reboot. Copied the jre-6u23-windows-i586.exe file to c:\
Then Start-->RUN

c:\jre-6u23-windows-i586.exe /s
after the installation i unticked the Java NEXT Gen-Plugin box in the Java-Preferences?
then renaming the java nextgen-plugin-folder in program files\Java\jre6\bin

then testing
http://img577.images.../7053/dude2.png


I am using Win98SE German
IE6 SP1
Unofficial IE6 SP1 Update Pack 3.4
DirectX 9 Dec 2006 and Nov 2007 and a security update from Windows Update
Windows 98 SE Service Pack 3 (BETA 4)

changed all Fonts for Menu, Symbols to Tahoma(Western)
I installed this programs

7-Zip 9.20
Adobe Flash Player Plugin Adobe Systems Incorporated 9.0.280.0
Allgemeine Runtime Files (x86) Sereby Corporation 1.0.3.2
CCleaner Piriform 2.36
Foxit Reader
Inoffizielles Service Pack Tweaks (nur entfernen)
Internet Explorer 6 Q982381
IrfanView (remove only) Irfan Skiljan 4.27
Java™ 6 Update 23 Oracle 6.0.230
KernelEx 4.5 RC 5
Microsoft .NET Framework 2.0 Microsoft Corporation
Microsoft Internet Explorer 6 SP1 und Internettools
Microsoft Visual C++ 2005 Redistributable Microsoft Corporation 8.0.59193
Mozilla Firefox (3.5.15) Mozilla 3.5.15 (de)
SciTech Display Doctor
Virtual Machine Additions Microsoft Corporation 13.823.0.0
VLC media player 1.1.5 VideoLAN 1.1.5


I have no Windows ME and RP 9.7.0.
But in my case I would bet on IE6 SP1 with unofficial Updatepack and Win98SE Service Pack 3(another;patched kernel32.dll).
Sorry for the problems but it worked so smoothly, I thought there is only a problem with the Installer.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN