Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

[SOLVED] USBstick take letter D and not U


  • Please log in to reply
97 replies to this topic

#26
pipster

pipster

    Newbie

  • Member
  • 40 posts
  • Joined 02-June 07
Hello, I tried both my usb sticks on other 2 computers: a brand new HP dv5 1120 laptop and a P4 3Ghz (MoBo = Gigabyte GA-8IPE775-G) but I get always and always letter D. It seems it's impossible to get U letter in any way.
Maybe are really the sticks...
Any news by reading at the files reg and migrate?


How to remove advertisement from MSFN

#27
ilko_t

ilko_t

    MSFN Addict

  • Super Moderator
  • 1,725 posts
  • Joined 06-December 06
  • OS:none specified
  • Country: Country Flag
Hi, everything seems correct in the posted files. I am really clueless as of what maybe causing this behavior. It still could be the USB stick(s)...

Install Windows from USB, boot Linux, multiboot and a lot more with WinSetupFromUSB


#28
jaclaz

jaclaz

    The Finder

  • Developer
  • 14,812 posts
  • Joined 23-July 04
  • OS:none specified
  • Country: Country Flag
I find improbable that the stick is the problem. :unsure:

Try reading these:
http://www.msfn.org/...howtopic=125945
http://www.msfn.org/...me-t125819.html

and use the MakeMigrateInf.exe:
http://www.msfn.org/...t...st&id=23940

Run it TWO times, one with the stick inserted and mounted:

makemigrateinf.exe>with_stick.txt

and one without it:
makemigrateinf.exe>no_stick.txt

Attach the two resulting files, together with the output of mkmigrateinf.cmd.



jaclaz

#29
pipster

pipster

    Newbie

  • Member
  • 40 posts
  • Joined 02-June 07
Hi, sorry for late.
Ciao Jaclaz,
here's the files you requested.
migrate_inf.txt is the output of MkMigrateInf2.cmd (the only that I found in the USB_MultiBoot_10 pack)
Thanks for your support.
Attached File  Output.zip   4.96KB   10 downloads

#30
ilko_t

ilko_t

    MSFN Addict

  • Super Moderator
  • 1,725 posts
  • Joined 06-December 06
  • OS:none specified
  • Country: Country Flag

...migrate_inf.txt is the output of MkMigrateInf2.cmd

Did you run it with options?

To keep things together use MkMigrateInf2.cmd from WinSetupFromUSB folder\files\winsetup\.
Use in command line:

MkMigrateInf2.cmd H: c:\migrate_inf.txt

Where H: is drive letter of the USB stick. Re-attach c:\migrate_inf.txt.

Install Windows from USB, boot Linux, multiboot and a lot more with WinSetupFromUSB


#31
jaclaz

jaclaz

    The Finder

  • Developer
  • 14,812 posts
  • Joined 23-July 04
  • OS:none specified
  • Country: Country Flag
Yep, right now the migrate.inf you produced with mkmigrateinf2.cmd is that of your Hard disk (normally C:\).

I'll check the output files of MakeMigrateInf.exe, anyway.

The only other (similar but not exactly the same) problem related with not working migrate.inf I can remember is on this thread:
http://www.911cd.net...showtopic=21682

Though I don't think you are in ANY of the situations that caused the problem, have a look at it, and see if you can spot any similarities with your setup/harware/whatever.

jaclaz

#32
pipster

pipster

    Newbie

  • Member
  • 40 posts
  • Joined 02-June 07

...migrate_inf.txt is the output of MkMigrateInf2.cmd

Did you run it with options?

No, without options. Now I used your command to run it. Here it is:
Attached File  migrate_inf.txt   940bytes   6 downloads

Yep, right now the migrate.inf you produced with mkmigrateinf2.cmd is that of your Hard disk (normally C:\).

I'll check the output files of MakeMigrateInf.exe, anyway.

The only other (similar but not exactly the same) problem related with not working migrate.inf I can remember is on this thread:
http://www.911cd.net...showtopic=21682

Though I don't think you are in ANY of the situations that caused the problem, have a look at it, and see if you can spot any similarities with your setup/harware/whatever.

jaclaz

Hi Jaclaz and grazie. I read the thread you linked but it's too much complicated for me to understand... I'm sorry :blushing:
Anyway now I posted the migrate.inf produced by running the ilko_t's command.
Hope can be useful, but I think it's just the same as the previous I posted.. :}

#33
jaclaz

jaclaz

    The Finder

  • Developer
  • 14,812 posts
  • Joined 23-July 04
  • OS:none specified
  • Country: Country Flag

Anyway now I posted the migrate.inf produced by running the ilko_t's command.
Hope can be useful, but I think it's just the same as the previous I posted.. :}


No, it's not the same.
This last one is "right". :)

I see no reasons why it shouldn't work, unless something else prevents it to be working.

Are you using some "unattended" settings?

Your "complete" output from MakeMigrateInf.exe lists a great number of removable devices, do you have one of those multi-card readers?

Sometimes they can be a royal PITA.


However, I am attaching a "right" one for your "H:\" device, try using this one.

For the sake of experimenting, you should (momentarily) forget about "unattended" and ANY other "custom" setting you may have introduced, my guess is that you added/modify "something" which is simply escaping all of our current ideas/checks and that causes the migrate.inf not to be applied.

jaclaz

Attached Files



#34
pipster

pipster

    Newbie

  • Member
  • 40 posts
  • Joined 02-June 07

Are you using some "unattended" settings?

Your "complete" output from MakeMigrateInf.exe lists a great number of removable devices, do you have one of those multi-card readers?

However, I am attaching a "right" one for your "H:\" device, try using this one.

For the sake of experimenting, you should (momentarily) forget about "unattended" and ANY other "custom" setting you may have introduced, my guess is that you added/modify "something" which is simply escaping all of our current ideas/checks and that causes the migrate.inf not to be applied.

jaclaz


Yes, for both the questions.
I use unattended settings made with nLite and RunOnceEx. These are my nLite configs:
Attached File  ULTIMA_SESS.INI   49.05KB   4 downloads

And Yes, I use a multi-card reader but only on the notebook on which I'm working to make the usb stick bootable.

Anyway these are the settings for my 4gb usb key (Imation Nano).
Ilko_t suggested me to try with a clean Windows with just BTS mass storage drivers slipstreamed. I tried that on another 2gb Verbatim drive but it didn't work too..

Same problem with your migrate.inf Jaclaz. I'm sorry, what can I try now?

Edited by pipster, 20 April 2009 - 10:10 AM.


#35
jaclaz

jaclaz

    The Finder

  • Developer
  • 14,812 posts
  • Joined 23-July 04
  • OS:none specified
  • Country: Country Flag

Ilko_t suggested me to try with a clean Windows with just BTS mass storage drivers slipstreamed. I tried that on another 2gb Verbatim drive but it didn't work too..

Same problem with your migrate.inf Jaclaz. I'm sorry, what can I try now?


I am short of ideas. :(

Clearly there must be a reason.

It is simply escaping us.

I mean, this feature worked for several thousands of people, thus it can be considered "fully tested".

If you used a "clean" UNMODIFIED source WITHOUT unattended, it cannot be anything connected with mods like nlite (which however was never reported as causing problems or other similar "source modifying" apps/scripts).

:blink:

jaclaz

#36
cdob

cdob

    MSFN Expert

  • Member
  • PipPipPipPipPipPip
  • 1,006 posts
  • Joined 29-September 05
Does anyone have a fine MountedDevices explanation?
How does windows build RemovableMedia string?


Lets investigate:

MountedDevices value contains at XP machine RemovableMedia:
H: \??\STORAGE#RemovableMedia#8&141a0a73&0&RM#{53f5630d-b6bf-11d0-94f2-00a0c91efb8b}
I: \??\STORAGE#RemovableMedia#9&1d9465bd&0&RM#{53f5630d-b6bf-11d0-94f2-00a0c91efb8b}
J: \??\STORAGE#RemovableMedia#8&207c63a1&0&RM#{53f5630d-b6bf-11d0-94f2-00a0c91efb8b}
K: \??\STORAGE#RemovableMedia#9&25791fbe&0&RM#{53f5630d-b6bf-11d0-94f2-00a0c91efb8b}
L: \??\STORAGE#RemovableMedia#9&1fde2770&0&RM#{53f5630d-b6bf-11d0-94f2-00a0c91efb8b}
I'm used to RemovableMedia#7.
There is a example http://www.forensics...History_Viewing

RemovableMedia#8 and RemovableMedia#9 is strange.
Does a notebook multi-card cause this?

Another idea:
USB serial number may cause this.

Windows does use USB serial number. The USB hardware or a windows setting maybe involved.
Read section 'USB serial number' http://www.uwe-siebe...btrouble_e.html

@pipster
Does your hardware use a USB serial number?
USBDeview http://www.nirsoft.n...vices_view.html
UWe does offer a tool too.

What about your setting HKLM\SYSTEM\CurrentControlSet\Control\UsbFlags\GlobalDisableSerNumGen ?

Did you made a windows full install?
Which MountedDevices goes to USB stick at new installed windows?

#37
ilko_t

ilko_t

    MSFN Addict

  • Super Moderator
  • 1,725 posts
  • Joined 06-December 06
  • OS:none specified
  • Country: Country Flag
Thanks cdob, quite interesting, as usual.

Reading http://www.uwe-siebe...btrouble_e.html it appears that if no serials are present upon change of USB port stick will be detected as a new one. This would explain why getting another USB stick helped the other user with the same problem- the second one had USB serial number.

Maybe OP had bad luck with the second stick he tried, not having serial number as the first one :unsure:

Will be waiting for pipster's results from USBDeview, hopefully this will reveal the mystery.

Install Windows from USB, boot Linux, multiboot and a lot more with WinSetupFromUSB


#38
jaclaz

jaclaz

    The Finder

  • Developer
  • 14,812 posts
  • Joined 23-July 04
  • OS:none specified
  • Country: Country Flag

I'm used to RemovableMedia#7.
....
Does a notebook multi-card cause this?
.....


Good catch! :)

I have a Desktop with a multicard reader and everything is #7 type. :wacko:

@pipster
You may want to try running this thingie:
http://sourceforge.n...cts/usbhistory/
as follows:
usbhistory.exe>C:\USB_rep.txt

and post the USB_rep.txt

jaclaz

#39
pipster

pipster

    Newbie

  • Member
  • 40 posts
  • Joined 02-June 07

...
@pipster
Does your hardware use a USB serial number?
USBDeview http://www.nirsoft.n...vices_view.html
UWe does offer a tool too.
Attached File  USBDeview_report.html   65.12KB   7 downloads
What about your setting HKLM\SYSTEM\CurrentControlSet\Control\UsbFlags\GlobalDisableSerNumGen ?

Did you made a windows full install?
Which MountedDevices goes to USB stick at new installed windows?

Yes, I see serial number in USBDeview.
GlobalDisableSerNumGen doesn't exist in my registry.


Thanks cdob, quite interesting, as usual.
...
Will be waiting for pipster's results from USBDeview, hopefully this will reveal the mystery.

Here it is:
Attached File  USBDeview_report.html   65.12KB   7 downloads

...
@pipster
You may want to try running this thingie:
http://sourceforge.n...cts/usbhistory/
as follows:

usbhistory.exe>C:\USB_rep.txt

and post the USB_rep.txt

jaclaz

Here it is:
Attached File  USB_rep.txt   9.07KB   10 downloads


Thank you all guys for your great support. Hope we can find the trick... :)

#40
jaclaz

jaclaz

    The Finder

  • Developer
  • 14,812 posts
  • Joined 23-July 04
  • OS:none specified
  • Country: Country Flag
I guess we could have saved a lot of bandwith if pipster just listed the only USB device available in a 2.43 Km radius from the PC he NEVER connected to it. :whistle:

:P

23rd October 2008 must have been a busy day. ;)

I would try to disconnect all USB devices and delete all keys under:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USBSTOR\

Then try reconnecting one stick and see what happens.

Maybe something made the 7& being available and start with 8& and 9&....:unsure:

jaclaz

#41
cdob

cdob

    MSFN Expert

  • Member
  • PipPipPipPipPipPip
  • 1,006 posts
  • Joined 29-September 05
At first glance USB serial stick dosn't cause the behaviour.
Maybe there is another windows setting?

Does windows install files contain a ignore USB serial setting.
Hence new installed windows ignore MountedDevices?


migrate_XPproSp3.inf
\??\STORAGE#RemovableMedia#8&141a0a73&0&RM#{53f5630d-b6bf-11d0-94f2-00a0c91efb8b}

migrate_Win2003.inf
\??\STORAGE#RemovableMedia#8&157ad62&0&RM#{53f5630d-b6bf-11d0-94f2-00a0c91efb8b}

RemovableMedia#8 is very seldom used.
Does this relate to hardware or windows?

If you boot windows at another machine, does windows use RemovableMedia#7 or RemovableMedia#8 for the USB stick?

@pipster
Can you install windows again?
Which MountedDevices goes to USB stick at new installed windows?

If new installed windows use RemovableMedia#7 then a adjusted migrate.inf should work.

@jaclaz
Uwe offers DriveCleanup to remove USB devices from registry.
http://www.uwe-siebe...ivetools_e.html

#42
pipster

pipster

    Newbie

  • Member
  • 40 posts
  • Joined 02-June 07

I guess we could have saved a lot of bandwith if pipster just listed the only USB device available in a 2.43 Km radius from the PC he NEVER connected to it.

:P

23rd October 2008 must have been a busy day.

I would try to disconnect all USB devices and delete all keys under:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USBSTOR\

Then try reconnecting one stick and see what happens.

Maybe something made the 7& being available and start with 8& and 9&....

jaclaz

Eheheh! :thumbup
I have tested 3-4 mouses, and everyone coming here is plugging their usb stick.
I have 3 sticks, 1 external hd (dead some days ago with his 320gb of data :( ), webcam, card reader, ... so many devices :D
But is such a strange thing 95% of that have born on 23rd October 2008!! :blink:

...
@pipster
Can you install windows again?
Which MountedDevices goes to USB stick at new installed windows?

If new installed windows use RemovableMedia#7 then a adjusted migrate.inf should work.

@jaclaz
Uwe offers DriveCleanup to remove USB devices from registry.
http://www.uwe-siebe...ivetools_e.html


:no: No, please don't ask me to install windows again... I did it for about 10 times in a few days and I don't have my new pc fully working yet. I bought it 2 months ago... :blushing: . Now I would just to use it.
Anyway I have Windows installed from just 2-3 days on that new pc so it has just few usb devices already mounted.
Here is the reports:
Attached File  NewPC_USBDeview_report.html   21.66KB   6 downloads
Attached File  NewPC_USB_rep.txt   317bytes   6 downloads

I'm sorry but I lost all of you in the technical details... Where do I can find the strings RemovableMedia#8, RemovableMedia#7, ....???

And... what devices I have to sweep with DriveCleanup?
Usage:
	  DriveCleanup [-t] [-n] [-u] [-h] [-d] [-c] [-f] [-v]
	  
	  -t		test mode
	  -n		no wait when finished
	  -h		only USB hubs
	  -u		only USB mass storage devices 
	  -d		only Disk devices
	  -c		only CDROM devices
	  -f		only Floppy devices
	  -v		only Storage Volume devices

EDIT----------------------------------------------------------
Ok cdob, maybe you are in the right way. I think this can be useful:
On the notebook, where I prepare the stick:
USB History Dump
   by nabiy (c)2008
   (13) --- Imation Nano USB Device
   
		   instanceID: 078B142D0BB2&0
		   ParentIdPrefix: 8&141a0a73&0
		   Driver:{4D36E967-E325-11CE-BFC1-08002BE10318}\0039
		   Disk Stamp: 04/21/2009 13:08
		   Volume Stamp: 04/21/2009 13:08
   
   (14) --- Kingston DataTraveler 2.0 USB Device
   
		   instanceID: 2008012500000000000002E4&0
		   ParentIdPrefix: 8&207c63a1&0
		   Last Mounted As: \DosDevices\J:
		   Driver:{4D36E967-E325-11CE-BFC1-08002BE10318}\0027
		   Disk Stamp: 04/22/2009 20:47
		   Volume Stamp: 04/22/2009 20:47
On the new PC, where I'm trying to use that stick:
USB History Dump
   by nabiy (c)2008
   
   (1) --- Imation Nano USB Device
   
		   instanceID: 078B142D0BB2&0
		   ParentIdPrefix: 7&141a0a73&0
		   Last Mounted As: \DosDevices\H:
		   Driver:{4D36E967-E325-11CE-BFC1-08002BE10318}\0002
		   Disk Stamp: 04/24/2009 00:08
		   Volume Stamp: 04/24/2009 00:08
   
   (2) --- Kingston DataTraveler 2.0 USB Device
   
		   instanceID: 2008012500000000000002E4&0
		   ParentIdPrefix: 7&207c63a1&0
		   Driver:{4D36E967-E325-11CE-BFC1-08002BE10318}\0001
		   Disk Stamp: 04/23/2009 03:12
		   Volume Stamp: 04/23/2009 03:12

Edited by pipster, 23 April 2009 - 04:32 PM.


#43
pipster

pipster

    Newbie

  • Member
  • 40 posts
  • Joined 02-June 07
And finally it works! WOW!
I replaced the old migrate.inf: Attached File  migrateOLD.inf   940bytes   6 downloads
with this one: Attached File  migrate.inf   940bytes   17 downloads
The second one cames from the new PC, exported \DosDevice\H: from the key HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices
I just copied the value of that key \DosDevice\H: into the migrate.inf.

I want really to thanks all of you for your continuos support. I learned so many new things just reading your posts.
Thank you!

#44
ilko_t

ilko_t

    MSFN Addict

  • Super Moderator
  • 1,725 posts
  • Joined 06-December 06
  • OS:none specified
  • Country: Country Flag
Quite interesting, thanks for all the reports.
So RemovableMedia#8 made the difference. In old windows it's 8, in the new install it's 7.
Reading this and cdob's link reveals the bolded part is ParentIdPrefix.
\??\STORAGE#RemovableMedia#8&141a0a73&0&RM#{53f5630d-b6bf-11d0-94f2-00a0c91efb8b}

Cdob raised the question:

I'm used to RemovableMedia#7.
There is a example http://www.forensics...History_Viewing

RemovableMedia#8 and RemovableMedia#9 is strange.
Does a notebook multi-card cause this?

Search at microsoft.com shows no clues for the changing number, a lot to be read from Google results.

Another interesting quite from the links above:

If the second character of the unique instance ID is a '&', then the ID was generated by the system, as the device did not have a serial number.


So by detecting the latter we may know that migrate.inf drive lettering may not be applied and by putting in it multiple entries for RemovableMedia#7 , 8 (any others used for USB mass storage devices?) we might get around similar issues.

@pipster
Does the new PC have any card readers?
As far as I remember you tried the USB stick on other computers, did any of them have USB card reader or any similar USB mass storage device- USB MP3 player, printer with card reader, phone connected via USB etc. etc. ?
Do you have on the old computer an USB hub or PCI USB card? Where do you connect the USB stick to?

Edited by ilko_t, 23 April 2009 - 06:59 PM.

Install Windows from USB, boot Linux, multiboot and a lot more with WinSetupFromUSB


#45
jaclaz

jaclaz

    The Finder

  • Developer
  • 14,812 posts
  • Joined 23-July 04
  • OS:none specified
  • Country: Country Flag

Another interesting quite from the links above:

If the second character of the unique instance ID is a '&', then the ID was generated by the system, as the device did not have a serial number.


So by detecting the latter we may know that migrate.inf drive lettering may not be applied and by putting in it multiple entries for RemovableMedia#7 , 8 (any others used for USB mass storage devices?) we might get around similar issues.


Yep, but the "ID" is not the "ParentIDPrefix".

I would say that the issue at hand is not related to Serial (or lack of it) :blink: or maybe by something connected to it but not really "it".

There are a number of entries in the USB_rep.txt that look suspicious, as they have no "ParentIDPrefix", some have "autogenerated-second-letter-&" ID's, some don't.


@jaclaz
Uwe offers DriveCleanup to remove USB devices from registry.
http://www.uwe-siebe...ivetools_e.html


Thanks for the reminder. :)

And finally it works! WOW!
....
I want really to thanks all of you for your continuos support. I learned so many new things just reading your posts.
Thank you!


We also learned something new, so I guess we are even. :)

jaclaz

#46
pipster

pipster

    Newbie

  • Member
  • 40 posts
  • Joined 02-June 07

@pipster
Does the new PC have any card readers?
As far as I remember you tried the USB stick on other computers, did any of them have USB card reader or any similar USB mass storage device- USB MP3 player, printer with card reader, phone connected via USB etc. etc. ?
Do you have on the old computer an USB hub or PCI USB card? Where do you connect the USB stick to?

The new pc has no card reader. Just the USB on top of the case, connected on the mb. As you can see here: http://techgage.com/..._master_cm_690/
But on the old notebook I connected an external Hama multi card reader, maybe it is the culprit.
On my father PC there's another external multi card reader but I didn't look at registry..


...
We also learned something new, so I guess we are even. :)

jaclaz


Di questo non posso che essere contento :yes:

So how do you think I can fix that usb entries on the notebook?
I have to use DriveCleanup?
What command I have to use?
-h only USB hubs
-u only USB mass storage devices
-d only Disk devices
-c only CDROM devices
-f only Floppy devices
-v only Storage Volume devices
Maybe -h -u -v ??

#47
ilko_t

ilko_t

    MSFN Addict

  • Super Moderator
  • 1,725 posts
  • Joined 06-December 06
  • OS:none specified
  • Country: Country Flag

Yep, but the "ID" is not the "ParentIDPrefix".

I would say that the issue at hand is not related to Serial (or lack of it) :blink: or maybe by something connected to it but not really "it".

Sorry, my bad, a lot of information after midnight...

Install Windows from USB, boot Linux, multiboot and a lot more with WinSetupFromUSB


#48
jaclaz

jaclaz

    The Finder

  • Developer
  • 14,812 posts
  • Joined 23-July 04
  • OS:none specified
  • Country: Country Flag

So how do you think I can fix that usb entries on the notebook?
I have to use DriveCleanup?
What command I have to use?
-h only USB hubs
-u only USB mass storage devices
-d only Disk devices
-c only CDROM devices
-f only Floppy devices
-v only Storage Volume devices
Maybe -h -u -v ??


drivecleanup -t
(list all devices that will be "affected" by the command - just to be sure)
then
drivecleanup
(without parameters), that will get rid of:

- USB mass storage devices
- Disk devices
- CDROM devices
- Floppy devices
- Storage Volumes


:hello:

jaclaz

#49
pipster

pipster

    Newbie

  • Member
  • 40 posts
  • Joined 02-June 07

drivecleanup -t
(list all devices that will be "affected" by the command - just to be sure)
then
drivecleanup
(without parameters), that will get rid of:

- USB mass storage devices
- Disk devices
- CDROM devices
- Floppy devices
- Storage Volumes


:hello:

jaclaz

Thanks
Did it. It removed a lot of things..
Then I plugged the Nano stick and... it gets parentID similar to the previous one (8&141a0a73&0):
8&141a0a73&1

With 1 at the end but always starting with 8&
I have to format this notebook when I have some time... :yes:

#50
jaclaz

jaclaz

    The Finder

  • Developer
  • 14,812 posts
  • Joined 23-July 04
  • OS:none specified
  • Country: Country Flag

Thanks
Did it. It removed a lot of things..
Then I plugged the Nano stick and... it gets parentID similar to the previous one (8&141a0a73&0):
8&141a0a73&1

With 1 at the end but always starting with 8&
I have to format this notebook when I have some time... :yes:


Which means obviously that the proggie did not remove the "something" that makes it get the "wrong" ParentID. :(

Can you do a Regedit search on that machine Registry for string:

8&141a0a73&

And post results, or better yet, get Regfind.exe
http://www.petri.co....eskit_tools.htm

and run:
regfind "8&141a0a73&">foundreg.txt

You should get something similar to this (I used "7&2c889678&"):
\Registry
	Machine
		SYSTEM
			ControlSet001
				Control
					DeviceClasses
						{53f5630a-b6bf-11d0-94f2-00a0c91efb8b}
							##?#STORAGE#RemovableMedia#7&2c889678&0&RM#{53f5630a-b6bf-11d0-94f2-00a0c91efb8b}
								DeviceInstance = STORAGE\RemovableMedia\7&2c889678&0&RM
								#
									SymbolicLink = \\?\STORAGE#RemovableMedia#7&2c889678&0&RM#{53f5630a-b6bf-11d0-94f2-00a0c91efb8b}
						{53f5630d-b6bf-11d0-94f2-00a0c91efb8b}
							##?#STORAGE#RemovableMedia#7&2c889678&0&RM#{53f5630d-b6bf-11d0-94f2-00a0c91efb8b}
								DeviceInstance = STORAGE\RemovableMedia\7&2c889678&0&RM
								#
									SymbolicLink = \\?\STORAGE#RemovableMedia#7&2c889678&0&RM#{53f5630d-b6bf-11d0-94f2-00a0c91efb8b}
				Enum
					USBSTOR
						Disk&Ven_Generic&Prod_USB_CF_Reader&Rev_1.01
							058F312D81B&1
								ParentIdPrefix = 7&2c889678&0

It is possible that the tool only clears the \USBSTOR\? :unsure:

jaclaz




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users