Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



Sign in to follow this  
Bejje

WDS unattend WinPE [solved]

Recommended Posts

I have created an unattend.xml file to unattend my boot image. The problem is that I have two boot images, one for booting up to select an install image and another one for capturing and creating an install image. When I put the unattend.xml file in RemoteInstall\WDSClientUnattend it automatically choses one of my boot images so I no longer have the possibility to choose. The one that is automatically chosen is the capture image.

When I remove the unattend.xml file from the folder the option to choose boot image is back.

In the xml file there is an option to automatically select an install image, but thats not the case here. I can't find an option to NOT select a boot image.

Here's my file:

<?xml version="1.0" encoding="utf-8" ?>

- <unattend xmlns="urn:schemas-microsoft-com:unattend">

- <settings pass="windowsPE">

- <component name="Microsoft-Windows-Setup" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" processorArchitecture="x86">

- <WindowsDeploymentServices>

- <Login>

<WillShowUI>OnError</WillShowUI>

- <Credentials>

<Username>myusername</Username>

<Domain>mydomain.com</Domain>

<Password>mypassword</Password>

</Credentials>

</Login>

- <ImageSelection>

<WillShowUI>OnError</WillShowUI>

- <InstallImage>

<ImageName />

<ImageGroup />

<Filename />

</InstallImage>

- <InstallTo>

<DiskID>0</DiskID>

<PartitionID>1</PartitionID>

</InstallTo>

</ImageSelection>

</WindowsDeploymentServices>

- <DiskConfiguration>

<WillShowUI>OnError</WillShowUI>

- <Disk>

<DiskID>0</DiskID>

<WillWipeDisk>false</WillWipeDisk>

- <ModifyPartitions>

- <ModifyPartition>

<Order>1</Order>

<PartitionID>1</PartitionID>

<Letter>C</Letter>

<Label>Windows</Label>

<Format>NTFS</Format>

<Active>true</Active>

<Extend>false</Extend>

</ModifyPartition>

</ModifyPartitions>

</Disk>

</DiskConfiguration>

</component>

- <component name="Microsoft-Windows-International-Core-WinPE" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" processorArchitecture="x86">

- <SetupUILanguage>

<WillShowUI>OnError</WillShowUI>

<UILanguage>en-US</UILanguage>

</SetupUILanguage>

<UILanguage>en-US</UILanguage>

</component>

</settings>

<cpi:offlineImage cpi:source="" xmlns:cpi="urn:schemas-microsoft-com:cpi" />

</unattend>

Edited by Bejje

Share this post


Link to post
Share on other sites

I have created an unattend.xml file to unattend my boot image. The problem is that I have two boot images, one for booting up to select an install image and another one for capturing and creating an install image. When I put the unattend.xml file in RemoteInstall\WDSClientUnattend it automatically choses one of my boot images so I no longer have the possibility to choose. The one that is automatically chosen is the capture image.

When I remove the unattend.xml file from the folder the option to choose boot image is back.

In the xml file there is an option to automatically select an install image, but thats not the case here. I can't find an option to NOT select a boot image.

Here's my file:

<?xml version="1.0" encoding="utf-8" ?>

- <unattend xmlns="urn:schemas-microsoft-com:unattend">

- <settings pass="windowsPE">

- <component name="Microsoft-Windows-Setup" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" processorArchitecture="x86">

- <WindowsDeploymentServices>

- <Login>

<WillShowUI>OnError</WillShowUI>

- <Credentials>

<Username>myusername</Username>

<Domain>mydomain.com</Domain>

<Password>mypassword</Password>

</Credentials>

</Login>

- <ImageSelection>

<WillShowUI>OnError</WillShowUI>

- <InstallImage>

<ImageName />

<ImageGroup />

<Filename />

</InstallImage>

- <InstallTo>

<DiskID>0</DiskID>

<PartitionID>1</PartitionID>

</InstallTo>

</ImageSelection>

</WindowsDeploymentServices>

- <DiskConfiguration>

<WillShowUI>OnError</WillShowUI>

- <Disk>

<DiskID>0</DiskID>

<WillWipeDisk>false</WillWipeDisk>

- <ModifyPartitions>

- <ModifyPartition>

<Order>1</Order>

<PartitionID>1</PartitionID>

<Letter>C</Letter>

<Label>Windows</Label>

<Format>NTFS</Format>

<Active>true</Active>

<Extend>false</Extend>

</ModifyPartition>

</ModifyPartitions>

</Disk>

</DiskConfiguration>

</component>

- <component name="Microsoft-Windows-International-Core-WinPE" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" processorArchitecture="x86">

- <SetupUILanguage>

<WillShowUI>OnError</WillShowUI>

<UILanguage>en-US</UILanguage>

</SetupUILanguage>

<UILanguage>en-US</UILanguage>

</component>

</settings>

<cpi:offlineImage cpi:source="" xmlns:cpi="urn:schemas-microsoft-com:cpi" />

</unattend>

Please remove section as below. The section pointed to installation image without choose boot image.

- <ImageSelection>

<WillShowUI>OnError</WillShowUI>

- <InstallImage>

<ImageName />

<ImageGroup />

<Filename />

</InstallImage>

Edited by ryanloo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×