Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

XPCREATE Project

- - - - -

  • This topic is locked This topic is locked
844 replies to this topic

#826
boehmri

boehmri

    Newbie

  • Member
  • 14 posts
  • Joined 17-December 03
@Geezer

Good Day -

I integrated IE6 using Iexpress. I'll work on "publishing" what I've accomplished. I have not had complete success as q832843 (Jscript) and q330994 (OE) don't seem to want to take. This work has been done with the old version of xpcreate (Release 22.01.2004).

I didn't post my work as: it is not entirely complete, it is based on a dated version, it manipulates a version of the OS which seems to be of minimal interest to the majority of the users of this forum, and I'm not so arrogant that I think my feeble efforts are anything special.

I will try to post my setup later today. I've a fluid leak under my car and THAT is my current priority.

I apologize for not being in a postion to immediately assist you. I hope you can understand my pre-occupation with tending to my transportation.
There's no sense in being stupid if you can't show it - Stephen Senecal
Courtesy is the oil for the machinery of civilization - Unknown


How to remove advertisement from MSFN

#827
shareef59

shareef59

    Member

  • Member
  • PipPip
  • 209 posts
  • Joined 21-November 03

I'll give a test WIN2K run here, and let you know where it stands. As for service pack 5 ... forget about it. But perhaps you could compile a list of critical / recommended SP4 hotfixes? Perhaps someone else already has one?....

I was intending to install a box with WIN2K w/SP4 sometime today, will make a list of CRI/REC hotties needed and post them here, unless ofcourse some kind soul beats me to it!! :rolleyes:
Looking forward to the new XPC release!! :)
Read the rules.

#828
shareef59

shareef59

    Member

  • Member
  • PipPip
  • 209 posts
  • Joined 21-November 03
As the hardware intended for the WIN2K installation is not going to be ready today (as mentioned in my post above), I used MS Virtual PC 2004 instead.
After the first run of MS Update, the following show as required hotties.
Microsoft Windows 2000 Professional
5.0.2195 Service Pack 4 Build 2195

CRITICAL UPDATES

Microsoft Internet Explorer 6 Service Pack 1 (Windows 2000)
Cumulative Security Update for Internet Explorer 5.01 Service Pack 4 (KB832894)
Critical Update for Windows Media Player Script Commands (KB828026)
Security Update for Microsoft Data Access Components (KB832483)
Security Update for Windows 2000 (KB828028)
Security Update for Microsoft Windows (KB828749)
Security Update for Microsoft Windows 2000 (KB828035)
Security Update for Microsoft Windows 2000 (KB825119)
Security Update for Microsoft Windows 2000 (KB826232)
Security Update for Microsoft Windows (KB824105)
Security Update for Windows 2000 (KB823182)
Security Update for Microsoft Windows (KB824141)
Security Update for Windows 2000 (KB824146)
823559: Security Update for Microsoft Windows
814078: Security Update (Microsoft Jscript version 5.1, Windows 2000)


RECOMMENDATED UPDATES

818043: Recommended Update for Windows 2000
Update for Windows 2000 (KB820888)
Update for Jet 4.0 Service Pack 8 (KB829558)
Recommended Update for Windows 2000 (822831)
Microsoft Windows Journal Viewer (Windows 2000)
Microsoft .NET Framework version 1.1
Root Certificates Update
DirectX 9.0b End-User Runtime
Windows Media Player 9 Series

VALID AS OF 16 FEB 2004
Hope this helps in some small way!
Read the rules.

#829
GreenMachine

GreenMachine

    ineXPlicable

  • Developer
  • 3,062 posts
  • Joined 22-August 03
Beat me ... but I did find my 2K CD and SP4, so I'll try that list, and see what happens. Your help is always appreciated.

#830
Geezer

Geezer

    Newbie

  • Member
  • 15 posts
  • Joined 14-February 04
I was going to say we could have a separate thread for XPC-W2k, since the audience is smaller, and this thread is already long, but it looks like you may
have already answered that.

@boehmri. Thanks for the fast reply. No problem. Just thought it would be of interest.

Thanks, shareef59. I compared to my list and it's almost the same. My list was from about a month ago, yes I see 828028 is since then. I had KB329115, maybe its now included in something else? These things do change often, which is really why I want to automate the build with this script instead of just doing it manually. Lazy, (and a perfectionist).

By the way, it seems to me that the earlier thread, called "Hotfix Slipstreaming", which ran from Oct 7 2003 to Jan 4 2004, ought to be linked on the XPCREATE project page, so the whole history is available in one place. - Edit: it's there now, maybe I just missed it.

- Geezer

#831
headspin

headspin
  • Member
  • 4 posts
  • Joined 15-February 04
GreenMachine: Thanks for your reply earlier.

I have just manually downloaded all the hotfixes from the "Current Hotfixes" page and put them in the directories as indicated on the same page. I manually downloaded them using FlashGet cos it's much quicker on my 56k.

I had to create some of the directories, is this normal?

Eg. SVC-HF1 & SVC-HF2. Do I put my manually downloaded hotfixes into these directories or HFTYPE1 & HFTYPE2 which is where the downloader seems to want to put some of them?

I have a feeling because my HFTYPE1 & HFTYPE2 directories are empty that none of the hotfixes were integrated. Is this correct?

Also, the directories such as SVC-DAH and SVC-MSX, don't exist, so I created them and put in the appropriate files as indicated by "current hotfixes" page. Will XPCREATE automatically check these locations and integrate all the hotfixes?

Sorry for the really basic questions, but I'm confused about these directories.

Finally, you say you changed XPCREATE.CRI 'reluctantly', but I look at the file and it still dosn't have all the hotfixes from the "current hotfixes" page. Why is this?

Another look at XPCREATE.CRI and I notice it places a file in REPACK\MDAC and RO-HF1 directories. These are not mentioned on the "current hotfixes" page as directories to put anything. I'm very confused about which directories to place my files. :)

#832
shareef59

shareef59

    Member

  • Member
  • PipPip
  • 209 posts
  • Joined 21-November 03
@headspin

I fear you are working with the "old" version of XPC!!! The "new and improved" version is available for download in this thread (page 27), please search for it. Once downloaded please read dirlist.txt and readme.txt for further explanations.
The SVC-DAH and other "missing" folders are to be implemented on the NEXT release of XPC, I gather.
Read the rules.

#833
headspin

headspin
  • Member
  • 4 posts
  • Joined 15-February 04
Oops! Yeah I was using the old version! Thanks shareef59 :)

#834
GreenMachine

GreenMachine

    ineXPlicable

  • Developer
  • 3,062 posts
  • Joined 22-August 03
First tests of XPCREATE on WIN2K look pretty good. I need to install IE early on, in order to apply the IE hotfixes after. To do that, the best solution seems to be to pack the IE distrtibution with IExpress, and place it SVC-PRE. However, I'm having trouble making a silent installation from the IEAK files. Does someone care to enlighten me on this? It seems I cannot find the correct switches to call the ie6setup.exe installer to supress reboot, and use the local directory for the source. I tried the ie6wzd /C: S:""#e"" (What ever that syntax was ... ), and that failed installation.

If someone could PM or post the missing pieces, or the IEAK template and command line, I will try late this afternoon.

@headspin: You're getting the hang of it ... let me know where you stand now, and I'll check in on you later.

#835
MaaR

MaaR

    Junior

  • Member
  • Pip
  • 63 posts
  • Joined 07-October 03
hi there!
I've succesefuly made w2k disk using old xpcreate :rolleyes:
like aKaFrEE, I used xpcreate to slipstreem hotfixes,
I changed svcpack.ini and winnt.sif to work with w2k,
added .net, dx9, msjava, wmv9 decoder, divx, xvid & ac3, flash and some apps.
added ie6sp1, run it from cmdlines. after ie I applied hotfixes 329115 and 823559
and ie updates after restart.
works great :)

#836
MaaR

MaaR

    Junior

  • Member
  • Pip
  • 63 posts
  • Joined 07-October 03
Internet Explorer 6 Install

start /wait "Apps\ie6sp1\ie6setup.exe" /C:"IE6WZD /S:""#e"" /Q:A /R:N"

#837
boehmri

boehmri

    Newbie

  • Member
  • 14 posts
  • Joined 17-December 03
Good day -

When I inquired about support for W2k, I never imagined I would be kicking over an anthill. I'm surprised at the amount of interest shown.

@GreenMachine
I packed IE6 into an Iexpress package with the command "ie6setup /Q:A /R:N"
When Iexpress, further on in the packaging, displays selections of: always reboot, never reboot, reboot as needed, I chose reboot as needed. My rationale was to not have two sets of instructions for the package. My rationale may be full of holes, but the methodology worked for me.

@MaaR
I like integrating IE from cmdlines. I tried doing that, and also tried integrating from SVC-PRE, and had problems. I currently integrate IE from SVC-EXE. In retrospect, I think my problem was caused by q330994. I'm going to try rebuilding using cmdlines.txt again, as you say you've had success doing it.

@Geezer
My directory structure follows:

CDSOURCE
w2K PRO

HFTYPE1
Windows2000-KB823182-x86-ENU.exe
Windows2000-KB823559-x86-ENU.exe
Windows2000-KB824105-x86-ENU.exe
Windows2000-KB824141-x86-ENU.exe
Windows2000-KB824146-x86-ENU.exe
Windows2000-KB825119-x86-ENU.exe
Windows2000-KB826232-x86-ENU.exe
Windows2000-KB828035-x86-ENU.exe
Windows2000-KB828749-x86-ENU.exe
WindowsMedia-KB828026-x86-ENU.exe

HFTYPE2
Empty

REPACK\FLASH
Empty

REPACK\JAVANEW
msjavwu.exe

REPACK\JAVAOLD
msjavx86.exe

REPACK\MDAC
ENU_Q832843_MDAC_x86.exe

REPACK\WMP
MPSetup.exe

RO-EXE
qchain.exe ; Extracted from hotfix. I hoped it would fix q330994. It didn't

RO-HF1
Windows2000-KB329115-x86-ENU.exe
Windows2000-KB823559-x86-ENU.exe

RO-HF2
js56nen.exe ; Is not detected by Windows Update after completion

RO-MSX
Empty

RO-X2M
jviewer.exe

SPACKS
W2KSP4_EN.EXE

svc-cus
Empty

SVC-EXE
IE6.exe ; My Iexpress package
qchain.exe ; Extracted from the hotfix

SVC-PRE
DX9NTopk.exe

SVC-REG
Empty

SVC-X2M
dotnetfx.exe


N.B. - The above does not contain any recommended hotfixes. Some of the patches may be dated, as I have done this over time. That being said, I THINK everything is correct. I'm having problems, so some patches are missing. I believe 832894 and 828028 can safely be put in RO-HF1. The lack of completeness is because this is where I'm playing, trying to get things "right."


Below is my xpcreate.ini


; Edit the XPCREATE section below to suit your needs.

[XPCREATE]
AUTOUPDATESPK=NO
AUTOUPDATECRI=NO
AUTOUPDATEREC=NO
AUTOUPDATEXPC=YES
OVERWRITEOEM=YES
DELTEMP=YES
SAVELOG=NO
DOISO=NO
DOBURN=NO
CDSPEED="MAX"
ALTCDIMAGE=NO
CLEANSPTEMP=NO
REBOOT=NO
ISOPATH="NULL"
CDERASE=NO
REBOOTTO="60"
CDBURNER="D:"
XPSOURCE="CDSOURCE"
BOOTIMGFILE="BOOT\BOOTIMG.BIN"
SLIPSPK=YES
SLIPMDC=NO
SLIPFLA=NO
DOSVCPACK=YES
DOSATA=NO
SILENTINSTALL=YES
SLIPHF1=YES
SLIPHF2=YES
DOCABS=NO
DORUNONCE=YES
ROINSVC=YES


I hope this can be of assistance.
There's no sense in being stupid if you can't show it - Stephen Senecal
Courtesy is the oil for the machinery of civilization - Unknown

#838
MaaR

MaaR

    Junior

  • Member
  • Pip
  • 63 posts
  • Joined 07-October 03
boehmri
To install IE I tried svcpack and ieexpress, but I have luck only with cmdlines...
I've tried aplying ie paches from cmdlines too, right after ie but had strange problem - after restart there goes, you know, "starting services", etc., and after that nothing happended - I mean eaven explorer didn't start.... I started it manualy by typing in task manager-> new task: explorer...
didn't see any other problems :)

#839
boehmri

boehmri

    Newbie

  • Member
  • 14 posts
  • Joined 17-December 03
@MaaR

You seem to be describing the problem that I believe is related to q330994.

When your machine reboots into final setup you have a pale blue screen and IE indicates it is configuring: Browsing Services, Internet Tools, System Services. After that everything goes away except the pale blue screen . . . forever!

Is this the problem?
There's no sense in being stupid if you can't show it - Stephen Senecal
Courtesy is the oil for the machinery of civilization - Unknown

#840
shareef59

shareef59

    Member

  • Member
  • PipPip
  • 209 posts
  • Joined 21-November 03
@boehmri

Unless I am not awake yet, the DIR structure that you have posted, seems to be relevant to the "old" XCP and thus (I feel) a mute point, as XPC has taken a few steps forward! Have you tried the newer versions (downloadable via this thread NOT the website) to work with WIN2K? :)
Read the rules.

#841
MaaR

MaaR

    Junior

  • Member
  • Pip
  • 63 posts
  • Joined 07-October 03
@boehmri
yep, that's it

@shareef59
I had this problem erlier too, before I started to use XC.
I'believe new version will not help :/

there is only one solution I see - installing ie updates after restart.

#842
boehmri

boehmri

    Newbie

  • Member
  • 14 posts
  • Joined 17-December 03
@shareef59
Yes, I am using the old version of XPC. I mentioned this in my previous post, and did not mention it in my most recent post. Sorry to be remiss. I will, in the future, always specify that I am referring to the old version of XPC.

No, I have not tried the new version of XPC as I require RunOnce functionality. Also, my cycle time for rebuilds is extremely long. I am trying, perhaps futilely, to gain an inkling as to the spceific cause of my difficulties rather than just lily-pad hopping around and trying anything randomly to see if things get fixed. Experience tells me I don't get lucky that way :)

@MaaR
Try removing q330994 from the mix, and see what happens. I've found that the lack of completion is directly related to the presence/absence of this hotfix. I've applied this hotfix in RunOnce, and things blow up. It seems to want TWO reboots!
Passing strange.
There's no sense in being stupid if you can't show it - Stephen Senecal
Courtesy is the oil for the machinery of civilization - Unknown

#843
shareef59

shareef59

    Member

  • Member
  • PipPip
  • 209 posts
  • Joined 21-November 03

@shareef59
Yes, I am using the old version of XPC.  I mentioned this in my previous post, and did not mention it in my most recent post.  Sorry to be remiss.  I will, in the future, always specify that I am referring to the old version of XPC.

I am sorry, I probably missed reading that! :rolleyes: Anyways, good thing, you kicked this "anthill", given me another issue to have sleepless nights over! :)
Read the rules.

#844
AirMaleDFW

AirMaleDFW

    Junior

  • Member
  • Pip
  • 54 posts
  • Joined 11-February 04
Beginning with an XP SP1 source and XPCreating (adding in) all the critical and recommended updates... I am currently experiencing 1:35 (an hour and 35 minutes) to 1:45 install times. Is everybody else experiencing about the same with an SP1+ install CD?

If so, I'm wondering about possible alternative methods. I had once installed Win98 on a machine and then fully updated it. Afterwards, I went into Device Manager and uninstalled ALL of the discovered hardware. After shutting down, I Ghost copied the installation and when cloned onto a different PC (different hardware, etc), it would boot, discover all new devices and install drivers accordingly. This might take 10 minutes instead of 1:40.

Maybe something with SysPrep (which i've not used before)? I do see that SysPrep mentions the IDE or SCSI controllers between different systems must be identical.

Any thoughts, recommendations, alternatives?

Thanx

#845
GreenMachine

GreenMachine

    ineXPlicable

  • Developer
  • 3,062 posts
  • Joined 22-August 03
That seems awfully slow. On a P III 1 Ghz, I need about 45 minutes. There are alternatives, but unless your park is very big, the updateing of images is soon tiresome ...

And so ends XPCREATE The Elder ... A Newer Version has replaced it, and this thread has been put to rest ...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN