Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

XPCREATE Project

- - - - -

  • This topic is locked This topic is locked
844 replies to this topic

#201
Wraith

Wraith

    Dr. Nick

  • Member
  • PipPipPipPipPipPip
  • 1,256 posts
Just realised, hpt3xx.sy_ wasn't in I386 for the SP1-only CD, but it didn't complain. Maybe it was a one-off thing (hope so :))

logs/inis/infs etc. for SP1 + type1 hotfixes coming up.

EDIT:
Intriguing. It didn't pause after making the ISO like it usually did. So much for copying out the files...

It seems to hang this time, sits there at the "Setup is starting Windows"

I'll try building one without type 1, but with type 2...
Posted ImagePosted Image
Posted ImagePosted Image
Posted ImagePosted Image


How to remove advertisement from MSFN

#202
GreenMachine

GreenMachine

    ineXPlicable

  • Developer
  • 3,062 posts
hpt3xx.sy_ is in the DRIVER.CAB. If it cannot find that ... who knows what other dirver files it cannot find ... might hang on startup ... It never needs to be directly in I386.

No pause after ISO because it is not deleting that extra gb of files.

At the "Setup is starting ..." is there a file name on the bottom?

Anyway ... I'm off for the next 12 hours ... add things little at a time to the good config. Turn off the auto stuff, and go one by one, and you shold find it. Still very strange why you have this: nobody else seems to, and the code is the same. May be a below the equator problem ... Good luck, post your results with a final zip of all the logs that may help me. ... 'night ...

#203
Wraith

Wraith

    Dr. Nick

  • Member
  • PipPipPipPipPipPip
  • 1,256 posts
hmmm. well this is getting curiouser and curiouser.

The problem is the type 1 hotfixes.

So I removed half of them, installer still won't get past.

I switched the hotfixes to the other half I removed, installer still won't get past.

There doesn't seem to be a problem with XPCREATE. All the logs look fine, they're normal for what I would imagine logs without type 1 hotfixes to be.

I just burnt a copy with Nero, same problem, so I guess we can scratch CDIMAGE off the suspects.

I've no idea what's going on... It's getting late, so I'll go to bed.

I guess I'll test it with one single type 1 hotfix in the morning.

/me wanders off puzzled.
Posted ImagePosted Image
Posted ImagePosted Image
Posted ImagePosted Image

#204
leo2003

leo2003

    Newbie

  • Member
  • 28 posts
I have problem with hpt3xx.sy_. How to correct?

#205
Wraith

Wraith

    Dr. Nick

  • Member
  • PipPipPipPipPipPip
  • 1,256 posts

I have problem with hpt3xx.sy_. How to correct?

I just rebuilt the CD... there was no problem afterward...
It seems XPCREATE is temperamental... :/
Posted ImagePosted Image
Posted ImagePosted Image
Posted ImagePosted Image

#206
Ogre

Ogre

    They call me Ogre cause i'm hairy.

  • Member
  • 44 posts
wow... i'm in way over my head. i looked thorugh all 6 pages and now my eyes hurt.

i downladed the XPCREATE.ZIP files and extracted it to a folder. when i click on the XPCREATE.CMD. i then get the following command window:

Posted Image

and it runs in an ifinite loop. so i looked at everything and tried changing XPCREATE.MNU to XPMENU.BAT and i get:

Posted Image

can someone tell me what the hell i'm doing wrong? :)

#207
Wraith

Wraith

    Dr. Nick

  • Member
  • PipPipPipPipPipPip
  • 1,256 posts
@Ogre:

I would imagine the simplest solution would be to put it into a directory without spaces, folder names <8 etc.

They're old DOS programs, so they'd probably not be happy with those things...




@GreenMachine:

Well, I've tested a few more things, it's definitely one of the type 1 hotfixes that is killing it, I've tried it with one hotfix only and it worked...
Now I just have to go through and find out which. :/
Posted ImagePosted Image
Posted ImagePosted Image
Posted ImagePosted Image

#208
GreenMachine

GreenMachine

    ineXPlicable

  • Developer
  • 3,062 posts

... It seems XPCREATE is temperamental...  :/

Like the author ...

Strange them hotfixes ... Try at a mates house on his box with his CD ... too strange ... Let me know if you find the culprit.

@Ogre:
Yes they are old DOS programs, but actually this one runs in long file names. But DOUGMENU is definatly the problem. What are you running on? That program should work on almost anything post 1992. I can only suggest playing with the file placement, That part of the code is very simple. The problem, and solution, must be as well.

Wish I could tell you more ...

#209
Ogre

Ogre

    They call me Ogre cause i'm hairy.

  • Member
  • 44 posts
thanks guys.... removed the space from the folder and fired right up... :)

#210
JoJa15

JoJa15

    Newbie

  • Member
  • 11 posts
What is the recommended way to install Applications and/or drivers using XPCREATE?

For example I want to install NERO unattended. To do so I need to use the following reg file register.reg first:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Ahead\Nero - Burning Rom\Info]
"User"="InsertName"
"Company"="InsertCompanyName"
"Serial6"="InsertSerial"

And then the following command to execute the application install:

ECHO.
ECHO Registering Nero Burning ROM...
REGEDIT /S %systemdrive%\PROGRAMS\NERO6302\register.reg
ECHO.
ECHO Installing Nero Burning ROM v6.3.0.2
ECHO Please wait...
start /wait %systemdrive%\PROGRAMS\NERO6302\Nero6302.exe /silent /noreboot

I see that there are a number of folders that I can use to accomplish the above but I am unsure which is the best. I also have some questions about how each works.

Maybe someone could help me a little further with what each of the following folders do:

CMDLINES: I assume that any executable file placed here will be executed by the CMDLINES.TXT file.
Can you supply any command line arguments?
When is CMDLINES.TXT executed?

CMDLREG: I assume any reg file placed here will be executed by the CMDLINES.TXT file.
Are CMDLREG files executed before or after files place in the CMDLINES folder?

CLEANUP: These files are executed from a CMD file placed in the users Start Menu / Startup directory.
How do I supply command line arguments for these files?
Can I control the order they are executed? For example say I wanted to execute the NERO reg file and then the install file in that order?

There seem to be other folders like ROEXE, ROHF1, ROHF2, ROMSI, ROMSX, ROX2M, FILESCD, and HFTYPE4 but none of them seem appropriate for executing a reg file and an install file.

Am I missing some other folder or method to install the NERO application?

I am going to need to do something similar for WINZIP but it requires the following switches:

/noqp /autoinstall

[EDIT]
One other question, do the folder/file names under %OEM% need to be in 8.3 format or can they be longer?

If anyone can help with the above or has experience installing applications using XPCREATE please let me know.

Thanks,
John

#211
leo2003

leo2003

    Newbie

  • Member
  • 28 posts
After installing the COMPACT DISC of win XP made with XPCREATE, following hotfixes they had not been installed:
KB828035
KB824105
KB829558
KB822603
KB821253
Q820223


Some suggestion.

#212
mdes

mdes

    Advanced Member

  • Member
  • PipPipPip
  • 343 posts
Q810243 Should be renamed to KB810243
Comparing what is downloaded by the GreenMachine with my Windows Update list, I remark that GreeMachine download Q810243_WXP_SP2_x86_ENU.exe; on the other end, I had downloaded WindowsXP-KB810243-x86-FRA.exe.

Searching thru the Web, I sa the following mail [Unattended] Update for winxpsp1-updates.bat :

Also, for what it's worth, it looks like MSoft updated the file name for 810243... in the current winxpsp1-updates.bat it reads:
todo.pl "%Z%\updates\winxpsp1\Q810243_WXP_SP2.exe /u /n /z"
it should now read:
todo.pl "%Z%\updates\winxpsp1\WindowsXP-KB810243-x86-%WINLANG%.exe /u /n /z"


@GreenMachine : Bonne Année !
  • You should change your download list :rolleyes: except if there is no WindowsXP-KB810243-x86-ENU.exe :D
  • You could perhaps include the language in downloading the HF :)

Windows XP Pro French + SP2 Many Thanks to GreenMachine XPCREATE
Michel Dessaintes (nick: mdes) FlashList for genealogy, CongésRFV for Pocket PC

#213
GreenMachine

GreenMachine

    ineXPlicable

  • Developer
  • 3,062 posts
@mdes:
Bonne Année, and Bonne Nouvelle: XPCRÉATE will be out with the next release!

I noticed that with Q810243, but only in the French version: I never had a problem in the English version, so I'll leave it as is. Perhaps I don't even need it.

In the next version, which is working for me, I recognize French CDs because of the LISEZMOI file, and download the list for French updates. It is not a one to one translatoin of the US version: there are more updates, and dotnet needs language packs. I have tested the list, and WU reports nothing missing. Except DX9, which I do not have a French OPK version for. I am also rewriting the RunOnceEx code, so language will no longer be a problem, and I will need less reboots.

Change the code =ENU to =FRA, and that should work for now...

@leo2003:
No idea! Where did you put them? Are they English or Brazilian? Try again, and post a zipped copy of the log when finished.

@JoJa15:
There are hooks to add applications to XPCREATE, but most of these do not permit custom switches nor order. I suggest either you repack your applications into switchless installers, or customize the completed XPCREATE files and then run Create ISO. My main concern is with XP, not the additional applications. HFTYPE0, HFTYPE3 and ROEXE all accept switchless executables. Files in CMDLINES are added to CMDLLINES.TXT, after any user defined entries, CMDLREG files are merged after CMDLINES commands.. Don't worry about CLEANUP, it and the start menu CMD file are on the way out. I don't remember if $OEM$ files must be 8.3. I never get that error for some reason ... There is a lot of reading on the site about Directory Descriptions.


If anyone is interested in adding local support for their language, try to compile a list of the hotfixes, critical and recommended, and the SP (with links, of course ... ), as well as the local name of the README file in the root of the CD, and we can add support for that language. Perhaps a XPKREÄTE for our German friends? XPKRAATE for the Dutch? XPCRIOTE in Rio?

#214
mdes

mdes

    Advanced Member

  • Member
  • PipPipPip
  • 343 posts
Thanks a lot GM : I noticed that I may change setting to FRA... and now I am busy to try it :) :rolleyes: :D

Just 1 remark (until now), the file "HFTYPE1\Q819696_WXP_SP2_x86_FRA.exe" is always downloaded although it is already there :D
Windows XP Pro French + SP2 Many Thanks to GreenMachine XPCREATE
Michel Dessaintes (nick: mdes) FlashList for genealogy, CongésRFV for Pocket PC

#215
GreenMachine

GreenMachine

    ineXPlicable

  • Developer
  • 3,062 posts

... "HFTYPE1\Q819696_WXP_SP2_x86_FRA.exe" is always downloaded although it is already there :)

Not for me ... I'll look

#216
mdes

mdes

    Advanced Member

  • Member
  • PipPipPip
  • 343 posts

Except DX9, which I do not have a French OPK version for

Someone told me in this forum that DX9NTopk.exe or contains some language, or is language independant, I don't remember anymore & I didn't try it.
Windows XP Pro French + SP2 Many Thanks to GreenMachine XPCREATE
Michel Dessaintes (nick: mdes) FlashList for genealogy, CongésRFV for Pocket PC

#217
GreenMachine

GreenMachine

    ineXPlicable

  • Developer
  • 3,062 posts

..."HFTYPE1\Q819696_WXP_SP2_x86_FRA.exe" is always downloaded although it is already there :)

Problem solved: it was in the list on the server.

I don't know about that OPK. I did install it, and I think I remember seeing something in English. Unacceptable on a French machine ... The other is 35 Mb, but I use it anyway.

... Pretty cool not to need to look for the hotfixes, non?

#218
mdes

mdes

    Advanced Member

  • Member
  • PipPipPip
  • 343 posts
Oh yes ! Very practical :) :rolleyes: :D
Windows XP Pro French + SP2 Many Thanks to GreenMachine XPCREATE
Michel Dessaintes (nick: mdes) FlashList for genealogy, CongésRFV for Pocket PC

#219
JoJa15

JoJa15

    Newbie

  • Member
  • 11 posts
@GreenMachine
OK, this is what I did for applications. I used the method described here:

http://unattended.MS...p/runonceex.htm

I placed the .cmd file I created in the CMDLINES folder. I placed all the files under the $OEM$ folder. It worked like a charm. Now all I need to do is figure out the command line switches for certain programs. My next attempt is going to be getting SATA/RAID and other drivers working.

Your program definitely saved me a lot of time and hair pulling! :-)

- John

#220
leo2003

leo2003

    Newbie

  • Member
  • 28 posts
GreenMachine here my log file.

Attached Files



#221
GreenMachine

GreenMachine

    ineXPlicable

  • Developer
  • 3,062 posts
Got it ... you can take it down.

#222
GreenMachine

GreenMachine

    ineXPlicable

  • Developer
  • 3,062 posts
Nothing interesting in the log ... How do you know they were not installed? Windows Update? Add/Remove Components? HFNETCHK? Are these files in I386\SVCPACK on the CD? Are they in SVCPACK.INF? I really don't see anything ...

#223
GreenMachine

GreenMachine

    ineXPlicable

  • Developer
  • 3,062 posts

... OK, this is what I did for applications. I used the method described here:

http://unattended.MS...p/runonceex.htm

I placed the .cmd file I created in the CMDLINES folder. I placed all the files under the $OEM$ folder. It worked like a charm. ...

That wasn't too bad now, was it! Just one thing to remember: XPCREATE also uses the RunOnceEx to install hotfixes, starting at number 100 (will become 500-650). You may want to adjust your script accordingly.

Glad it worked out. Please let me know what you come up with concerning SATA/RAID.

#224
leo2003

leo2003

    Newbie

  • Member
  • 28 posts
I connected to windows update and perceived that they were not installed.

#225
GreenMachine

GreenMachine

    ineXPlicable

  • Developer
  • 3,062 posts
The hotfixes should leave a log file in C:\Windows\KB??????.LOG for each hotfix. It may report erros. It maybe language dependent. It may that they are installed, but not correctly reported. Try MS tools QFECHECK and HFNETCHK. Try installing from WU and see if they really go away. I don't know ...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN