Sign in to follow this  
Followers 0
mobiusonline

Load BartPE from Grub4DOS on a CD

16 posts in this topic

As you might have seen from my other posts, I am converting my CDShell over to Grub4Dos. I know it kind of figures, but I have a new issue I can not figure out.

I am trying to get my BartPE to run.

Here is the original command I had in my CDShell

chain /bootsect.bin

In Grub4Dos, I have tried using "chainloader /bootsect.bin", and it just comes up with the error in the screenshot.

What am I doing wrong, and how can I make just work?

M

post-159398-1240955813_thumb.png

Edited by mobiusonline
0

Share this post


Link to post
Share on other sites
As you might have seen from my other posts, I am converting my CDShell over to Grub4Dos. I know it kind of figures, but I have a new issue I can not figure out.

I am trying to get my BartPE to run.

Here is the original command I had in my CDShell

chain /bootsect.bin

In Grub4Dos, I have tried using "chainloader /bootsect.bin", and it just comes up with the error in the screenshot.

What am I doing wrong, and how can I make just work?

M

What is "bootsect.bin"?

Is it a "CD no-emulation bootsector"? (A 2048 bytes file)?

Or is it a HD-like bootsector? (A 512 bytes file)?

IN BOTH CASES, you do not use bootsectors to load a BartPE. :whistle:

Grub4dos has some advantages over other bootloaders, as it can completely bypass ANY bootsector. :thumbup

You directly chainload the OS loader. :)

I.e. and this should have been clear enough on the Forums and docs I pointed you to, here are a couple examples:

title some flavour of BartPE
root (cd)
chainloader /I386/SETUPLDR.BIN

or

title some flavour of BartPE found
find --set-root /I386/SETUPLDR.BIN
chainloader /I386/SETUPLDR.BIN

Please take note that grub4dos is CaSe SeNsItIvE on CDFS filesystem!

however check these:

http://www.911cd.net/forums//index.php?showtopic=19124

http://www.boot-land.net/forums/index.php?showtopic=7173

http://www.911cd.net/forums//index.php?sho...18045&st=25

jaclaz

Edited by jaclaz
0

Share this post


Link to post
Share on other sites

Sorry for the interruption guys

when i try to boot bartpe from grub4dos multiboot cd with these entries

title XPE
find --set-root /I386/SETUPLDR.BIN
chainloader /I386/SETUPLDR.BIN

well it boots up but i get these errors

xpe_g4d_error-1.jpg

xpe_g4d_error2-1.jpg

& finally i checked in the multiboot cd the file names are changed with 8 characters

xpe_g4d_error3.jpg

can someone tell me how do i boot bartpe[xpe] without grub4dos's 8 character limit

0

Share this post


Link to post
Share on other sites
can someone tell me how do i boot bartpe[xpe] without grub4dos's 8 character limit

There neither a 8 character limit at BartPE nor at grub4dos.

How do you build the ISO image?

Change your ISO creating tool settings to create long file names.

0

Share this post


Link to post
Share on other sites
can someone tell me how do i boot bartpe[xpe] without grub4dos's 8 character limit

There neither a 8 character limit at BartPE nor at grub4dos.

How do you build the ISO image?

Change your ISO creating tool settings to create long file names.

Ya! there's an 8 character limit in GRUB4DOS iso and

I tried grub4dos's bootable cd-rom method with mkisofs

mkisofs -R -b grldr -no-emul-boot -boot-load-size 4 -o grldr.iso iso_root

& i don't know how to create an iso with long file names. If i create an iso with long file names with these settings will it boot?

i've done it with diddy's grub4dos help file

Can someone tell me/help me in creating a grub4dos multiboot iso with long file name support (using MKISOFS same entry by modifying it to support long file names or some other help) :rolleyes:

0

Share this post


Link to post
Share on other sites
Can someone tell me/help me in creating a grub4dos multiboot iso with long file name support (using MKISOFS same entry by modifying it to support long file names

Remember plain ISO9660 Level 1 allows 8.3 names only. Hence the current limitation.

You have to allow long names to get long names.

Bart himself use ISO-9660:1999 http://www.nu2.nu/pebuilder/#intro

Try

mkisofs -iso-level 4 -r -b grldr -no-emul-boot -boot-load-size 4 -o grldr.iso iso_root

File case is used from readed files at hard disk.

This assumes uppercase core boot file names at hard disk. PEBuilder uppercase reqiured files, if you build a ISO image.

Or use

mkisofs -iso-level 4 -force-uppercase -r -b grldr -no-emul-boot -boot-load-size 4 -o grldr.iso iso_root

All ISO9660 names are uppercased at CD.

0

Share this post


Link to post
Share on other sites

I tried grub4dos's bootable cd-rom method with mkisofs

mkisofs -R -b grldr -no-emul-boot -boot-load-size 4 -o grldr.iso iso_root

... taking the generic - actually Linux derived - example given on diddy's guide and assuming that it will be the "right" syntax for a PE 1.x .... ;)

The good news are that you are not the first one to do so:

http://reboot.pro/9696/

http://reboot.pro/9696/page__hl__mkisofs__st__26

jaclaz

Edited by jaclaz
0

Share this post


Link to post
Share on other sites
Can someone tell me/help me in creating a grub4dos multiboot iso with long file name support (using MKISOFS same entry by modifying it to support long file names

Remember plain ISO9660 Level 1 allows 8.3 names only. Hence the current limitation.

You have to allow long names to get long names.

Bart himself use ISO-9660:1999 http://www.nu2.nu/pebuilder/#intro

Try

mkisofs -iso-level 4 -r -b grldr -no-emul-boot -boot-load-size 4 -o grldr.iso iso_root

File case is used from readed files at hard disk.

This assumes uppercase core boot file names at hard disk. PEBuilder uppercase reqiured files, if you build a ISO image.

Or use

mkisofs -iso-level 4 -force-uppercase -r -b grldr -no-emul-boot -boot-load-size 4 -o grldr.iso iso_root

All ISO9660 names are uppercased at CD.

I tried your code

mkisofs -iso-level 4 -r -b grldr -no-emul-boot -boot-load-size 4 -o grldr.iso iso_root

but its the same problem [8character limit] still persist

0

Share this post


Link to post
Share on other sites
but its the same problem [8character limit] still persist

Which files are limited to 8characters still?

0

Share this post


Link to post
Share on other sites
but its the same problem [8character limit] still persist

Which files are limited to 8characters still?

Everything inside the iso :whistle::wacko:

Can you tell me did you got loaded bartpe via grub4dos successfully ie:multiboot dvd/cd :lol: & can you show me a working image/screenshot :D

0

Share this post


Link to post
Share on other sites
Everything inside the iso
"Mkisofs -iso-level 4 -r" allows names up to 193 chars. There is no way this result 8.3 names at DVD.

I doubt the new created ISO image is limited to 8.3 chars.

Did you create a new ISO image?

Can you tell me did you got loaded bartpe via grub4dos successfully ie:multiboot dvd/cd :lol:
Yes, above command.
can you show me a working image/screenshot :D
No pictures, text only. You may trust my words or not, your choice.

Don't you trust the author Bart himself?

Why did Bart choose 'mkisofs -iso-level 4' as default for BartPE?

Why does long names work at countless machines since 2003?

Add verbose output "-v" and post the messages.

How do you create the DVD? Do you edit the ISO image after?

Edited by cdob
0

Share this post


Link to post
Share on other sites
Everything inside the iso
"Mkisofs -iso-level 4 -r" allows names up to 193 chars. There is no way this result 8.3 names at DVD.

I doubt the new created ISO image is limited to 8.3 chars.

Did you create a new ISO image?

Can you tell me did you got loaded bartpe via grub4dos successfully ie:multiboot dvd/cd :lol:
Yes, above command.
can you show me a working image/screenshot :D
No pictures, text only. You may trust my words or not, your choice.

Don't you trust the author Bart himself?

Why did Bart choose 'mkisofs -iso-level 4' as default for BartPE?

Why does long names work at countless machines since 2003?

Add verbose output "-v" and post the messages.

How do you create the DVD? Do you edit the ISO image after?

Hey i tried your code:

mkisofs -iso-level 4 -r -b grldr -no-emul-boot -boot-load-size 4 -o grldr.iso iso_root

to create the iso & it boots correctly

This was my fault

I've created a dummy/empty iso with this code & then updated the grldr.iso with bartpe and all my bootables using ultraiso checked it in vm it gave me the same problem.

& then i changed the method like this

moved all my bootables including bartpe files to the iso_root directory & then created the iso & verified it in vm voila!! :thumbup it worked including all my bootables :thumbup i think updating the dummy/empty iso is my problem :whistle::D thank you verymuch cdob for sparing me your precious time in solving my problem :thumbup

0

Share this post


Link to post
Share on other sites

i think updating the dummy/empty iso is my problem :whistle:

Yes, NEVER edit a bootable .iso.

If you are into experimenting, you can try the pesort approach and you can probably shave a few (several) seconds at boot time:

http://www.911cd.net/forums//index.php?showtopic=6869

OT :ph34r: I don't recall anyone publishing or testing a list for "normal" install, but maybe the same increase of speed can be achieved. :unsure:

jaclaz

Edited by jaclaz
0

Share this post


Link to post
Share on other sites
Do you edit the ISO image after?

i think updating the dummy/empty iso is my problem

My crystal ball lost another life. Yes, editing ISO images may truncate names.

Thanks for report.

I don't recall anyone publishing or testing a list for "normal" install

Why a fixed list? This match selected "normal" install only.

What about a dynamically created list?

0

Share this post


Link to post
Share on other sites
I don't recall anyone publishing or testing a list for "normal" install

Why a fixed list? This match selected "normal" install only.

What about a dynamically created list?

I do like people proving me wrong :unsure:, expecially when they are right. ;)

:thumbup

jaclaz

0

Share this post


Link to post
Share on other sites

i think updating the dummy/empty iso is my problem :whistle:

Yes, NEVER edit a bootable .iso.

If you are into experimenting, you can try the pesort approach and you can probably shave a few (several) seconds at boot time:

http://www.911cd.net/forums//index.php?showtopic=6869

OT :ph34r: I don't recall anyone publishing or testing a list for "normal" install, but maybe the same increase of speed can be achieved. :unsure:

jaclaz

But now i've updated the grldr/multiboot iso with acronis true image 2010 iso using ultraiso & then it boots correctly

3.jpg

2.jpg

See :whistle:

The "iso-level-4" option made this stuff i think

1.jpg

:whistle:

and once again thanks to cdob for solving the 8character limit

and thank you jaclaz for warning me in editing the iso :)

i appreciate your seniority aswell.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.