Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

Windows 7 & vLite *DEPRECATED*

- - - - -

  • Please log in to reply
657 replies to this topic

#651
itw4089

itw4089
  • Member
  • 4 posts

but i can't understand what to do with this line

from a cmd prompt, run install_wim_tweak.exe /m & then type c:\s2

You can provide a patch to mouted install.wim as a parameter (type "install_wim_tweak.exe /p c:\s2 /m" without quotes) it is not nesesary to type it after program started.

You can send any ideas/problems with install_wim_tweak.exe to me ;) (i wote this tool)

By the way, i am working on one app... here is a screen (because people like screens ;p, note that is a early development stage):
Posted Image

Planned functionality :
-Integrate drivers
-Integrate windows patches
-Remove packages
-Expandable tweaking system
-No need to install WAIK
As the holidays are coming i will probably find some time to finish it ;)

Visit My Website
This picture what is a software?


How to remove advertisement from MSFN

#652
itw4089

itw4089
  • Member
  • 4 posts

here's a temporary guide:

tools required: WAIK 1.1, gimagex (optional), vlite 1.2
all must be installed!
nb. this method has been tested on windows 7 build 7201 x86

Stage 1:

1) create 2 folders such as c:\s1 & c:\s2
2) copy/extract the contents of iso/disc to s1
3) mount install.wim (image 5) to s2 folder using gimagex or imagex
4) from a cmd prompt, run install_wim_tweak.exe /m & then type c:\s2

to take ownership of reg hive, created by & credit to BM wnuku
5) commit changes & unmount


Stage 2:

1) first download this:
2) extract the batch file to the sources directory ie. c:\s1\sources
3) mount install.wim (image 5) to s2 folder using gimagex or imagex
4) run rem7201.bat from the sources directory (which has s2 folder already selected)
optional: while the batch file is running, you could delete the Recovery folder from c:\s2\windows\system32 directory, delete the contents of c:\s2\windows\winsxs\backup (you may need unlocker as the files are locked; do not delete the backup folder itself), also delete the folders & its contents from c:\s2\windows\web\wallpaper except for the windows folder which contains the default wallpaper, again you will need the unlocker tool)
5) once done, commit changes & unmount

then use vlite with my last session:
before you create the iso in vlite, make sure you delete every file in the sources folder except for boot.wim & install.wim. also, you will need to extract from the original iso, setup.exe from the sources folder to c:\s1\sources otherwise you will get a cd driver not found error when trying to install!!!

i've just installed this in vmware, set my paging file to 512mb, installed vmware tools, ran windows update to install the sound driver, restarted & my hd usage space is showing up as just under 2.5gb! :D

nb. as the sources folder already includes dism, you do not need to download & install waik for windows 7! the bat file uses dism from the sources folder to remove the packages from windows.

How to identify whether Windows XP Service Pack 2 with KB926044?

What is KB926044 ?

Where to downloads KB926044 ? Why Windows XP Service Pack 3 can't install WAIK 1.1?

Modify Windows 7 to be possible in Windows XP Service the Pack 3 environment?

#653
MitsuMan

MitsuMan

    Member

  • Member
  • PipPip
  • 149 posts
Hello

i have read alot today, about how to install my danish Language pack in my win 7 and i try to use VLite but i says error and dosent work. it says missing need files is there anyone here that can help me. and i try to install hotfix to but the same error

#654
Grom51

Grom51
  • Member
  • 2 posts

4) from a cmd prompt, run install_wim_tweak.exe /m & then type c:\s2

to take ownership of reg hive, created by & credit to BM wnuku
5) commit changes & unmount


This part not function for Windows 7 RTM x86 Professional ..

#655
jayank2000

jayank2000

    Newbie

  • Member
  • 13 posts
  • OS:Windows 7 x64
  • Country: Country Flag
I have windows xp 32-bit installed on my desktop. recently i got 64-bit windows 7 DVD. How can I reduce windows 7 install size since I have xp as my OS. Or do i need to follow some other method. I downloaded WAIK for vista and win7, but cannot install as i have xp. i think i shud install win7 and then install waik and then follow this method. any suggestions, please help. thanks in advance.<br /><br />Edit: Problem sorted out. Downloaded WAIK for Vista, installed on Win7 64-bit and followed the guide. No problem. Testing and updating the system is pending.<br /><br />Thanks a lot for your help.

Update: Not able to download and install ATI card drivers. aborted the project for now. May be will check again after 1 year, by then somebody have might have sorted out the problem and it will be tested by many users.

Edited by jayank2000, 24 July 2010 - 02:35 PM.


#656
richardpearman

richardpearman
  • Member
  • 1 posts
  • OS:Windows 7 x64
  • Country: Country Flag
I've created the 7media32 iso and it all work fine....apart from one little problem.

I'm using window media centre and Microsofts media centre keyboard/remote control (as found here http://www.amazon.co...r/dp/B000B78GD0).

I'm unable to use the play/stop/fast forward/volume (and othere) keys.

What driver/package do I need to include to get these to function.

Cheers all.


** Since posting this I have found the answer.

**Need to start up the Human Interface Device Access service (mine was disabled). Works like a charm!

Edited by richardpearman, 02 December 2010 - 02:58 AM.


#657
marcusj0015

marcusj0015

    Member

  • Member
  • PipPip
  • 154 posts
can anyone upload installwimtweak x64?

the link is broken

#658
Madhits45

Madhits45

    MSFN Indulger

  • Member
  • PipPipPip
  • 364 posts
Hi all. Just read about 25 pages here, been out of the scene a while.

What I am trying to understand is I have a list of packages I want to remove for a language in windows 7 ultimate x86. The list is complete and when I input it into DISM I get errors after about the second package. I think this has to do with the packages/registery being locked. Whatever this install_win_tweak.exe does I think I need it or whatever tool is evolutionaryly better. I tried it and nullify which did not work same DISM errors. So either I'm doing something wrong or there is an evolutionary better way I have yet to find. Also the link for install_win_tweak.exe is broken here. I got a copy from another site but not sure if its working.

The error I get in DISM is the specified image is no longer serviceable 800f0830

I am trying to remove the following packages:
/PackageName:Microsoft-Media-Foundation-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-Branding-Ultimate-Client-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-Client-Drivers-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-Client-Features-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-Client-LanguagePack-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-Client-Refresh-LanguagePack-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-Client-Wired-Network-Drivers-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-ClipsInTheLibrary-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-CodecPack-Basic-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-Common-Drivers-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-Disk-Diagnosis-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-Gadget-Platform-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-GPUPipeline-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-GroupPolicy-ClientExtensions-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-GroupPolicy-ClientTools-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-ICM-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-Media-Format-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-MediaPlayback-OC-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-MediaPlayer-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-NetFx3-OC-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-PeerToPeer-Full-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-PhotoPremiumPackage~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-Printing-Foundation-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-RemoteAssistance-Package-Client~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-SearchEngine-Client-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-SecureStartup-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-ShareMedia-ControlPanel-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-Shell-HomeGroup-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-SnippingTool-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-TerminalServices-CommandLineTools-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-TerminalServices-MiscRedirection-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-TerminalServices-Publishing-WMIProvider-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-TerminalServices-RemoteApplications-Client-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-TerminalServices-UsbRedirector-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-TerminalServices-WMIProvider-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-WindowsFoundation-LanguagePack-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514
/PackageName:Microsoft-Windows-WMPNetworkSharingService-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514

Why do I get this error and what tool will help. Believe me I have searched high and low for an answer on this and I keep finding new tools but nothing that actually does what the good old Dism command line tool can do. Ive tried them all and removing this language either fails or never starts. I believe this has to do with the servicable error that I see when I do this manually that I dont see when using jim jim dism tool or RT seven lite etc.

I hope someone can shed some light or point me in the right direction. Been looking at this same problem for over a week now. I hate posting as usually can find stuff but no such luck with this.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN