Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

FAQ: What is the UAC? - Part2

- - - - -

  • Please log in to reply
54 replies to this topic

#26
rayg

rayg
  • Member
  • 1 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Hi Andre

This is may be too late for the thread but shortcut works fine from desktop (THANKS) but not from Startup
I've checked it in there from both the link above and also / All Programs / Startup
Not sure if you have had this problem before with any of your programs


How to remove advertisement from MSFN

#27
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,951 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

Hi,

I have no issues with the startup folder. What is not working?

André
Posted Image

#28
lee911

lee911
  • Member
  • 2 posts
  • OS:Vista Home x86
  • Country: Country Flag
With a bit of trial and error, this works for me. And it worked inside the Startup folder as well. One question though and I suspect this may be a problem with the software I'm launching. In properties, I have "run/Minimized" selected but it does not minimize. Is there any fix for this? Or it is what it is?

I'm running Vista Home. And the software is called Active Home Pro (X10 Home Automation software0.

Thanks
Lee

#29
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,951 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

the minimize belongs to the cmd window of schtask.exe not the tool your are running. Does it have a commandline parameter to start it minimized?
Posted Image

#30
lee911

lee911
  • Member
  • 2 posts
  • OS:Vista Home x86
  • Country: Country Flag
@MagicAndre1981: I wouldn't even know where to look for that?

#31
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,951 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

look at the Active Home Pro documenation
Posted Image

#32
ggbal

ggbal
  • Member
  • 2 posts
  • OS:none specified
  • Country: Country Flag
I followed the step. But still the standard user gets the UAC prompt saying the publisher is unverified. Here is the task xml.

Please help.

<?xml version="1.0" encoding="UTF-16" ?>
- <Task version="1.2" xmlns="http://schemas.micro...4/02/mit/task">
- <RegistrationInfo>
<Date>2010-10-07T22:37:54.9815795</Date>
<Author>MyDomain\User</Author>
</RegistrationInfo>
<Triggers />
- <Principals>
- <Principal id="Author">
<UserId>MyDomain\User</UserId>
<LogonType>InteractiveToken</LogonType>
<RunLevel>HighestAvailable</RunLevel>
</Principal>
</Principals>
- <Settings>
<MultipleInstancesPolicy>IgnoreNew</MultipleInstancesPolicy>
<DisallowStartIfOnBatteries>true</DisallowStartIfOnBatteries>
<StopIfGoingOnBatteries>true</StopIfGoingOnBatteries>
<AllowHardTerminate>true</AllowHardTerminate>
<StartWhenAvailable>false</StartWhenAvailable>
<RunOnlyIfNetworkAvailable>false</RunOnlyIfNetworkAvailable>
- <IdleSettings>
<StopOnIdleEnd>true</StopOnIdleEnd>
<RestartOnIdle>false</RestartOnIdle>
</IdleSettings>
<AllowStartOnDemand>true</AllowStartOnDemand>
<Enabled>true</Enabled>
<Hidden>false</Hidden>
<RunOnlyIfIdle>false</RunOnlyIfIdle>
<WakeToRun>false</WakeToRun>
<ExecutionTimeLimit>P3D</ExecutionTimeLimit>
<Priority>7</Priority>
</Settings>
- <Actions Context="Author">
- <Exec>
<Command>"C:\Tools (x86)\BJ\TdxW\TdxW.exe"</Command>
</Exec>
</Actions>
</Task>

Thanks,

GG

#33
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,951 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

this is correct. Standard suers have no 2 tokens, so <RunLevel>HighestAvailable</RunLevel> is user rights adnd you get the UAC prompt. This workaround only works for users which are part of the admin group.
Posted Image

#34
ggbal

ggbal
  • Member
  • 2 posts
  • OS:none specified
  • Country: Country Flag
Thanks for the quickly reply. So for standard user, is there any solution for this problem?

#35
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,951 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

no
Posted Image

#36
RD9678

RD9678
  • Member
  • 1 posts
  • OS:none specified
  • Country: Country Flag
I have followed your steps. When I log in with the account with Admin Privileges this works. When I log in with the standard user privileges and get to the Actions Tab step, click on OK, and I see "Task schedule cannot create the task. The user account is unknown, the password is incorrect, or the user account does not have permission to create this task". I have switched to the admin account with the Create Task window and still get the same error. I try importing the task from the windows scheduler where I created the initial autoElevate task, and it imports until I get to the step to click OK, and then I get the same error message as above. I seem to be doing something incorrectly.

#37
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,951 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

When you run with standard user rights, this doesn't work, because only admin have the 2 tokens. You can select "Run whether the user is logged on or not" and pick the admin account. With this you can run programs, but you don't see the GUI. So this is only helpful for background tasks.
Posted Image

#38
Chip

Chip
  • Member
  • 2 posts
  • OS:none specified
  • Country: Country Flag
Andre, thanks for this information!! This is very useful!

I used this procedure successfully for one of my own programs. However, I have another 3rd-party program that I would like to add. That program expects an ini file to be in the program's startup directory. Presently, the shortcut says that my startup directory is "C:\WINDOWS\SYSTEM32". Right-clicking on the startup icon and changing the startup directory doesn't seem to do the job. I prefer not to copy the ini file to the System32 directory unless I have to. Any suggestions?


------------------------

Never mind!! Ignore my question and please ignore the duplicate "ignore me" post. I just joined the forum.

I found the location in the MMC Taskscheduler where I can set the startup directory.

Thanks again for this very helpful post!


Chip

Edited by Chip, 16 June 2011 - 03:36 PM.


#39
Chip

Chip
  • Member
  • 2 posts
  • OS:none specified
  • Country: Country Flag
Never mind!! Ignore my question.

I found the location in the MMC Taskscheduler where I can set the startup directory.

Thanks again for this very helpful post.

Chip

-----------
Is there a way to delete a duplicate posting?

Edited by Chip, 16 June 2011 - 03:37 PM.


#40
Zilver

Zilver
  • Member
  • 4 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Thanks a ton, this was very useful to me :thumbup

#41
aliceccentric

aliceccentric
  • Member
  • 1 posts
  • OS:Vista Home Premium x64
  • Country: Country Flag
Awesome tip. Thanks; it worked beautifully!

#42
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,951 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

you're welcome :)
Posted Image

#43
anotherusername

anotherusername
  • Member
  • 1 posts
  • OS:Windows 7 x64
  • Country: Country Flag
This doesn't work at all on my computer. I followed every step and it doesn't make any difference. You still have to answer the question about allowing programs to run.

I don't know what else to post here. Is there some kind of log or something I can post that would show what's going on?

#44
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,951 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

don't run the original program. run it with the schtask command.
Posted Image

#45
Incriminate

Incriminate
  • Member
  • 1 posts
  • OS:Windows 7 x64
  • Country: Country Flag
This has been annoying me for a long time, while it takes a little time to set up. It means no more UAC for me :)

Thanks André

And for the guy that didn't know how to write the "é", press Alt Gr + E :D

#46
WalkWaldo

WalkWaldo
  • Member
  • 1 posts
  • OS:Windows 7 x64
  • Country: Country Flag

this workaround only works for accounts who are inside the administrator group.

How do I allow a non-admin (restricted) user to launch an application that, only under Windows 7, requires admin privs?

This application runs fine under XP Pro i386 and XP Pro x64 WITHOUT admin privs. But it does not run without admin creds being entered under W-7.

#47
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,951 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

This doesn't for for normal/standard users :(

Try to find out why it only runs with admin rights in Win7. The Application Compatibility Toolkit (ACT) is what you need to detect what's wrong with the app.
Posted Image

#48
wasabi

wasabi
  • Member
  • 2 posts
  • OS:Windows 7 x86
  • Country: Country Flag

Sorry for necroposting, but I'm having an odd issue with this. I've created the task, created the shortcut running through the taskscheduler and the program no longer requires the UAC window. However, the TaskScheduler itself does!

 

8chr.png
 

That's in Portuguese (I live in Brazil), but it's talking about the Task Scheduler. Should I click yes, I don't get a UAC request for the program itself, so I'm guessing that's working. I am in an admin account on Win7 x86. 


Edited by wasabi, 07 August 2013 - 07:13 AM.


#49
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,951 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

don't rightclick and select "Run as admin" for the schtasks.exe. Simply double click it.


Posted Image

#50
wasabi

wasabi
  • Member
  • 2 posts
  • OS:Windows 7 x86
  • Country: Country Flag

That's what I did. Also, there is no "run as Admin" set in the properties. Very odd.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN