MikeD

Integration of AMD / ATI SB7XX textmode RAID / AHCI drivers on an XP

308 posts in this topic

Does that mean they will not work in AHCI mode on XP x86? Like I mentioned in post #130, they do work on a live system.
Although AMD has named these Windows XP drivers "RAID Drivers", they probably will support the AHCI features like NCQ even while running in RAID mode.

Furthermore these "RAID Drivers" do support the following AMD SATA Controllers, which have been set to "AHCI" mode within the BIOS:

  1. DEV_4391 (SB7xx series) and
  2. DEV_7801 (SB8xx series)

Users with other DeviceID's (e.g. DEV_4394) will probably not be able to get XP installed onto a SATA hdd, which has been set to "AHCI" mode, because the required AHCI driver is only available for Vista and Windows 7 and the related driverpack doesn't contain any TEXTSETUP.OEM file.

Regards

Fernando

Edited by Fernando 1
0

Share this post


Link to post
Share on other sites

Good news, then, because from what I know, that PC has a DEV_4391 SB750.

And to clear up the mess, you can't remember how you got the drivers

The AMD textmode drivers v3.2.1548.37 for Windows XP (32/64bit) are dated 04/06/2010, but I don't remember in which Catalyst package I found these drivers.
because I provided them; see post #100 of this same topic. They were from a driver CD that came with a notebook that a friend bought. Don't hate me for not remembering the notebook model or the versions.

Cheers

0

Share this post


Link to post
Share on other sites

@ Sp0iLedBrAt:

Thanks for clearing up the origin of the AMD RAID drivers v3.2.1548.37. You are right: It was you, who gave me the link.

So none of the Catalyst versions ever contained these special AMD RAID drivers for Windows XP (32/64bit).

Interesting detail regarding the version number of these drivers containing "1548" instead of the usual and still actual "1540": Either the AMD driver development stuff gave them a wrong version number or the driver version belonged to a new driver development line, which has not been continued by AMD.

Kind regards

Fernando

Edited by Fernando 1
0

Share this post


Link to post
Share on other sites

Thanks Fernando.

I will try and slipstream it into my XP Pro SP3 this weekend if I have time and probably format whenever I get some more spare time.

I am running in IDE mode now and just want to run in SATA mode with ahci (non-raid). I read I can do it by editing the registry and then changing the option in the BIOS. But it's due for a format anyway and then this will save the F6 load the sata driver hassle.

Cheers

0

Share this post


Link to post
Share on other sites

Well, under the Windows 7 tab it says they are for SB8xx, but no info under the Vista and XP tab. I'm downloading the XP package now and will take a look.

Edit: It contains versions for SB6xx, SB7xx and SB8xx, but no changes here. The newest is for SB8xx, and it is the one from post #134, namely 3.3.1540.13.

Cheers

Edited by Sp0iLedBrAt
0

Share this post


Link to post
Share on other sites
It contains versions for SB6xx, SB7xx and SB8xx, but no changes here.

Yes, that's strange.

SB8xx folder contains a txtsetup.oem. Contrary there is no txtsetup.oem at SB6xx, SB7xx.

SB8xx txtsetup.oem refers to:

PCI\VEN_1002&DEV_4392&CC_0104

PCI\VEN_1002&DEV_4391&CC_0106

PCI\VEN_1002&DEV_4393&CC_0104

PCI\VEN_1022&DEV_7802&CC_0104

PCI\VEN_1022&DEV_7801&CC_0106

PCI\VEN_1022&DEV_7803&CC_0104

PNP driver file SBDrv\SB7xx\RAID\XP\ahcix86.inf refers e.g.

PCI\VEN_1002&DEV_4380&SUBSYS_280A103C

AMD dosn't provide XP textmode drivers for PCI\VEN_1002&DEV_4380&SUBSYS_* and PCI\VEN_1002&DEV_4381&SUBSYS_*

What's going on?

0

Share this post


Link to post
Share on other sites
More new amd drivers, and its getting more confusing.

http://support.amd.com/us/gpudownload/windows/Pages/raid_windows.aspx#1

The new Catalyst driverpacks 11-6 do not contain any new AMD SATA driver, but I agree with the second part of your message: The composition of the AMD RAID and AHCI driver packages and especially their subfolders for the different AMD Southbridges is very confusing for the users, who are searching for an actual AHCI or RAID driver, which is fully supporting their special AMD Southbridge.

@ all:

Since AMD does not offer any actual AHCI or RAID driver for SB6xx and SB7xx chipsets, which can be used for a fresh installation of Windows XP (32/64bit), I have customized the INF and OEM files of the latest AMD RAID driverpacks v3.3.1540.13 for Windows XP (32/64bit), which are offered by AMD just for SB8xx chipsets. The drivers themselves (= SYS files) have been untouched by my modification. I simply added the DeviceID's of several SB6xx and SB7xx AHCI/RAID Controllers to make the driver usable with SB6xx and SB7xx chipsets too. Nevertheless I am not yet sure, if these "modded" textmode drivers really will work with SB6xx and SB7xx chipsets.

Since I don't have any AMD chipset pc/notebook myselve, I need your feedback regarding the function of these "modded" AMD RAID drivers v3.3.1540.13 with SB6xx and SB7xx chipset systems running in AHCI or RAID mode.

Unfortunately I had done a mistake while modifying the TXTSETUP.OEM file entries of the "modded" 32bit driverpack, when I published it the first time within >this< post. Meanwhile I have corrected the mistake (for details look into the EDIT2 text of the linked post).

Just to prevent any further confusion regarding the usability of my "modded" AMD RAID drivers v3.3.1540.13 dated 03/15/2011, here are the actual download links to the corrected driverpacks again:

>32bit AMD SBxxx Textmode Driver v3.3.1540.13 for Windows XP mod by Fernando<

>64bit AMD SBxxx Textmode Driver v3.3.1540.13 for Windows XP x64 mod by Fernando<

Users, who are able and willing to test one of these modified driver sets, should report here about their test results. Please don't forget to mention the Southbridge specification of your system. Even better would be, if you can post the Device Identification Code (DEV_xxxx), which is layed down within the HardwareID's of the in-use "AMD AHCI Compatible RAID Controller" (open the Device Manager, search for the device, do a right click onto it > "Properties" > "Details" > "Property" > "HardwareID's").

Thanks in advance!

Regards

Fernando

0

Share this post


Link to post
Share on other sites

Copy file ahcix86.sys to system32\drivers. Import this reg settings

REGEDIT4

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_1002&cc_0106]
"Service"="ahcix86"
"ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ahcix86]
"Type"=dword:00000001
"Start"=dword:00000000
"ErrorControl"=dword:00000001
"Tag"=dword:00000021
"ImagePath"="system32\\drivers\\ahcix86.sys"
"Group"="SCSI Miniport"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ahcix86\Parameters\PnpInterface]
"5"=dword:00000001

Goto BIOS, set AHCI. Reboot.

it's doesn't work for me :(

i used xp sp3

780G Chipset (ECS A780GM-A Ultra)

0

Share this post


Link to post
Share on other sites
780G Chipset (ECS A780GM-A Ultra)

Which ahcix86.sys version do you use?

Which BIOS setting do you use?

0

Share this post


Link to post
Share on other sites

Hello there, Missel here! I'm from Mexico & just wanted to say that I tested the last Fernando's drivers & they worked like a charm!, well I tested them on a HP Pavilion 2014la it comes with a SB750 southbridge; actually I just had done this but with an ICH9 & it also worked, just wanted to thank Fernando for his priceless kindess & now I could make my new Win XP SP3 CD with any kind of chipset so it seems that now I can beat any laptop!

0

Share this post


Link to post
Share on other sites

Thanks Fernando. Very Good...

Edited by dstk
0

Share this post


Link to post
Share on other sites

AMD 11.8 Raid in SB800 Textmode Driver v3.3.1540.17 for Windows XP Release.

AMD SBxxx Textmode Driver v3.3.1540.17 for Windows XP Fernando ?

0

Share this post


Link to post
Share on other sites
AMD SBxxx Textmode Driver v3.3.1540.17 for Windows XP Fernando ?
Here are the requested freshly modded drivers:

>32bit AMD SBxxx Textmode Driver v3.3.1540.17 for Windows XP mod by Fernando<

>64bit AMD SBxxx Textmode Driver v3.3.1540.17 for Windows XP x64 mod by Fernando<

Users with an AMD SB6xx/7xx/8xx AHCI or RAID system may use them at own risk.

Any feedback is much appreciated.

Regards

Fernando

Edited by Fernando 1
0

Share this post


Link to post
Share on other sites
Users with an AMD SB6xx/7xx/8xx AHCI or RAID system may use them at own risk.

They are not working on a live system, SB750 or SB780, not sure at the moment. The previous ones have always worked on a live system as well.

The line in the ahcix86.inf file is correct

%NapaDesc%=Napa_Inst,PCI\VEN_1002&DEV_4391&CC_0106

, but it says a better hardware was not found.

I'll check out the actual file from the AMD package and report.

Cheers

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.