Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Integration of AMD / ATI SB7XX textmode RAID / AHCI drivers on an XP

- - - - -

  • Please log in to reply
294 replies to this topic

#126
prophase

prophase
  • Member
  • 3 posts
  • Joined 28-December 10
  • OS:none specified
  • Country: Country Flag
Thank you for that info! I have started to give some serious thought to upgrading to Windows 7, for me fresh install will be followed by hours of reinstalling my applications. I figure at that point might as well. That was the primary reason for simply changing my current install to RAID mode.


How to remove advertisement from MSFN

#127
Sp0iLedBrAt

Sp0iLedBrAt

    MSFN Addict

  • MSFN Sponsor
  • 1,727 posts
  • Joined 19-March 09
  • OS:XP Pro x86
  • Country: Country Flag
As a reply (and result) to post #101, I'm happy to report that the modded 32bit AMD SBxxx textmode driver v3.2.1548.37is working like a charm.

Cheers

#128
AlfaRomeo865

AlfaRomeo865

    Newbie

  • Member
  • 17 posts
  • Joined 14-January 11
  • OS:XP Pro x86
  • Country: Country Flag

As a reply (and result) to post #101, I'm happy to report that the modded 32bit AMD SBxxx textmode driver v3.2.1548.37is working like a charm.

Cheers


Thank you sb. But the above specifically mentions that these are _not_ meant for SB600.
On that note, I have been searching all over the internet about anyone else facing the same issue with an SB600 ATI southbridge and yes, this specific southbridge definitely has something against Windows XP (or vice versa).

SO i gave up on XP+SB600+AHCI... I'm using Windows 7 for my AHCI dreams (and any benefits that I was looking for)... Win7 had in-built AHCI support for my mobo and it works like a charm.

T y v m :)
-Alfa
---------
My Rig: AMD 64 Athlon-II 240 | MSI-7368 BIOS v1.9 | RS690G+SB600 | 2x Corsair XMS 1024 | 1x Radeon x1950pro 512MB | 250GB WD | 440w True PSU

#129
anotherengineer

anotherengineer
  • Member
  • 5 posts
  • Joined 29-May 11
  • OS:XP Pro x86
  • Country: Country Flag

I found this today by chance, and it is the latest (non-modified) version, so I'm attaching it here.

Thanks for your searching, finding and uploading these new AMD AHCI/RAID textmode drivers for Windows XP/XPx64 dated 04/06/2010 (32bit) resp. 03/24/2010 (64bit).
Since the original AMD textmode drivers v3.2.1548.37
  • only will support AMD SB7xx AHCI/RAID and AMD SB8xx RAID systems and
  • have some needless entries within the TXTSETUP.OEM files, which may cause error messages regarding "missing files" while installing the OS,
I have customized them.

Here are the download links to the original and WHQL certified drivers, where I have just cleaned the TXTSETUP.OEM files:
>32bit AMD SB7xx & SB8xx AHCI/RAID driver v3.2.1548.37 prepared for the XP integration<
>64bit AMD SB7xx & SB8xx AHCI/RAID driver v3.2.1548.37 prepared for the XP x64 integration<
Attention:
  • These drivers will not work with AMD SB6xx chipsets, because the HardwareID's are missing!

Users with an AMD SB6xx chipset mainboard, who want to use these newest AMD textmode drivers for Windows XP (32/64bit), may try one of these drivers, which have been customized by me:
>32bit AMD SBxxx textmode driver v3.2.1548.37 for XP mod by Fernando<
>64bit AMD SBxxx textmode driver v3.2.1548.37 for XPx64 mod by Fernando<
Attention:
  • These packages do contain the original 32/64bit AMD driver. I have only customized the associated text files with the suffix ".OEM" and ".INF".
  • Due to the customization the driver has lost the WHQL stamp, but this doesn't have any effect on the function of the driver.
  • Although I have done my very best, I cannot guarantee, that they will work for your system.
  • You may try them at own risk.
Good luck!
Fernando


Great thread, I registered and revived it, for I need some guidance.

I see amd's newest driver raid (ahci) cat 11-5 has SB850 03/14/2011 (3.3.1540.13) in it and the SB750 is 03/17/2009 (3.1.1540.127) Whereas Fernando's SBxxx mod is 3.2.1548.37 - from catalyst #??

I currently dual boot xp pro x86 and w7 pro x64 (separate hdds) I currently run a gigabyte MA790GP-UD4H (790GX and SB750) and I am going to put in an SSD in the near future for the w7 drive and I will be reformatting the XP drive also as I will be changing from ide to sata mode in BIOS and would like to slipstream the drivers into my SP3 cd.

I am just wondering if I should use Fernando's old 'above' mod, or try to slipstream the newer AMD drivers?? Fernando, does your mod support both the SB7xx and SB8xx?? I also plan a mobo upgrade to SB850 in the future also.

Can you do another driver mod for nlite Fernando or is that too much work/time?

Thanks for the help.

#130
Sp0iLedBrAt

Sp0iLedBrAt

    MSFN Addict

  • MSFN Sponsor
  • 1,727 posts
  • Joined 19-March 09
  • OS:XP Pro x86
  • Country: Country Flag

I am just wondering if I should use Fernando's old 'above' mod, or try to slipstream the newer AMD drivers?? Fernando, does your mod support both the SB7xx and SB8xx?


It does support SB7xx, but a user in another topic reported it wasn't working for SB850 http://www.msfn.org/...d-raid-drivers/ I can report 3.3.1540.13 works on SB750 if you install it on a live system, but I can't tell about CD integration. Anyway, download the 3.2.1548.37 drivers, open ahcix86.inf or TXTSETUP.OEM and compare the Hardware IDs to your controller (in Device Manager), especially DEV_438x or DEV_439x. If they match, you should be good to go.

Cheers

Edited by Sp0iLedBrAt, 30 May 2011 - 01:31 AM.


#131
Fernando 1

Fernando 1

    Easy RAIDer

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,021 posts
  • Joined 03-June 05
  • OS:Windows 7 x64

I am just wondering if I should use Fernando's old 'above' mod, or try to slipstream the newer AMD drivers?? Fernando, does your mod support both the SB7xx and SB8xx?? I also plan a mobo upgrade to SB850 in the future also.

Can you do another driver mod for nlite Fernando or is that too much work/time?

Currently I am making holidays in a foreign country and only am able to join an Internet Café. I will present freshly modded RAID and Intel driver from AMD when I am back home.

Rgards
Fernando
My current system:
ASUS P8Z68-V | Intel Core i5 2500K | 2x4 GB Corsair XMS3 DDR3-1600 | 2x128GB Crucial M4 SSD as RAID0 in SATA3 mode | Seasonic M12II-520 Modular 520W | ATI Radeon HD6850 1 GB GDDR5
My old system:
DFI nF4 Ultra-D (BIOS: 2006/04/06) | AMD Athlon64 4000+ San Diego | 2x512 MB OCZ PC3200 CL2 Rev.2 Platinum | 2x200 GB Samsung S-ATA II as Raid0 | beQuiet!Titan BQT P5-470W-S1.3 | MSI GeForce NX6600GT-TD128E

#132
anotherengineer

anotherengineer
  • Member
  • 5 posts
  • Joined 29-May 11
  • OS:XP Pro x86
  • Country: Country Flag

I am just wondering if I should use Fernando's old 'above' mod, or try to slipstream the newer AMD drivers?? Fernando, does your mod support both the SB7xx and SB8xx?


It does support SB7xx, but a user in another topic reported it wasn't working for SB850 http://www.msfn.org/...d-raid-drivers/ I can report 3.3.1540.13 works on SB750 if you install it on a live system, but I can't tell about CD integration. Anyway, download the 3.2.1548.37 drivers, open ahcix86.inf or TXTSETUP.OEM and compare the Hardware IDs to your controller (in Device Manager), especially DEV_438x or DEV_439x. If they match, you should be good to go.

Cheers


Thanks for the quick reply and info.

I am currently running XP in IDE mode, and plan to run SATA mode on my upcoming format, so there wasn't really much info in the device manager, since it only showed the IDE channel in device manager and no sata/scsi.

I have extracted and read though several amd drivers now, one thing I noticed is that they don't update the ahci driver very much. As for all the numbers and stuff, I don't really know what all the dev stuff is, as I don't have much experience with software coding.

#133
anotherengineer

anotherengineer
  • Member
  • 5 posts
  • Joined 29-May 11
  • OS:XP Pro x86
  • Country: Country Flag
[/quote]Currently I am making holidays in a foreign country and only am able to join an Internet Café. I will present freshly modded RAID and Intel driver from AMD when I am back home.

Rgards
Fernando
[/quote]

Wow Awesome!! Thanks Fernando!! Enjoy your holidays.

I look forward to your AMD AHCI XP slipstream driver!!

Sorry for double post.

#134
Fernando 1

Fernando 1

    Easy RAIDer

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,021 posts
  • Joined 03-June 05
  • OS:Windows 7 x64
@ anotherengineer:

Here are my answers to your questions:

I see amd's newest driver raid (ahci) cat 11-5 has SB850 03/14/2011 (3.3.1540.13) in it and the SB750 is 03/17/2009 (3.1.1540.127) Whereas Fernando's SBxxx mod is 3.2.1548.37 - from catalyst #??

The AMD textmode drivers v3.2.1548.37 for Windows XP (32/64bit) are dated 04/06/2010, but I don't remember in which Catalyst package I found these drivers.

I am just wondering if I should use Fernando's old 'above' mod, or try to slipstream the newer AMD drivers??

It depends on the special Southbridge version of your mainboard and the mode of your AMD SATA Controller (AHCI or RAID). Maybe the WHQL certified driver v3.3.1540.13, which is part of the actual Catalyst 11-5, will work with your SB7xx system, although these drivers were only designed by AMD for SB8xx Southbridges.
If the WHQL driver should not detect your SATA hdd while trying to get Windows XP SP3 installed, you may use the AMD textmode driver v3.3.1540.13, which has been modified by me (see below).

Fernando, does your mod support both the SB7xx and SB8xx?? I also plan a mobo upgrade to SB850 in the future also.

The modded driver will definitively support AMD SB8xx Southbridges, the only question is, if they will support SB6xx and SB7xx Southbridges too.
Although I have added all known HardwareID's of these older Southbridges into the INF and OEM files, I am not sure, that the driver itself (that is the file named ahcix86.sys resp. ahcix64.sys) will support these older AMD SATA Controllers.

Can you do another driver mod for nlite Fernando or is that too much work/time?

I have done it for you and other interested users with an AMD RAID system (see below).


@ all users with an AMD SB7xx or SB6xx Southbridge, who want to install Windows XP or XP x64 onto a SATA hdd running in RAID mode:

Here are the download links to the requested modified AMD textmode drivers on the basis of the newest AMD RAID drivers v3.3.1540.13 for Windows XP (32/64bit) dated 03/15/2011:
>32bit AMD SBxxx Textmode Driver v3.3.1540.13 mod by Fernando<
>64bit AMD SBxxx Textmode Driver v3.3.1540.13 mod by Fernando<

Important remarks:
  • These drivers have been customized by me for being usable with all AMD Southbridges from SB6xx up. Nevertheless I am not sure, if they will work with all SB6xx and SB7xx RAID systems.
  • Only the text files with the suffix .INF and .OEM have been modified by adding the needed HardwareID's, whereas the original AMD drivers (= SYS files) were not touched at all.
  • Due to the customization the driver has lost the WHQL stamp, but this has no negative effect on the integration or the function of the drivers.
  • You may download and use these modified drivers at own risk.
  • Please report here, if the XP resp. XPx64 installation succeeded with these customized drivers.
    Don't forget to mention your special AMD Southbridge. If possible, please post the special HardwareID's of your AMD SATA Controller. You will get them this way:
  • Open the Device Manager and search for a Device named "AMD AHCI Compatible RAID Controller".
  • Then do a right click onto it > "Properties" > "Details" > "Property" > "HardwareID's".
Good luck!
Regards
Fernando

EDIT1:
Meanwhile I found HardwareID's of several OEM systems, which have not been regarded by me, when I started to modify the INF and OEM text files. That is why I have replaced the linked modded 32/64bit AMD SBxxx AHCI and RAID driverpacks v3.3.1540.13 by new ones at 06/06. So it may be possible, that these drivers now are usable with even more AMD chipset AHCI/RAID systems.

Important EDIT2:
Recently I have realized, that the TXTSETUP.OEM file of the linked modded 32bit AMD SBxxx AHCI and RAID driver v3.3.1540.13 (see above) had some wrong entries, which may have prevented a proper integration of the related 32bit driver into a Windows XP CD for users with some special AMD SATA Controllers. I am sorry about that.
As a consequence I have now corrected the TXTSETUP.OEM entries and repacked, reuploaded and relinked the modified 32bit version of the AMD SBxxx AHCI and RAID driver v3.3.1540.13 at 06/16/2011. After having done that, I hope, that this actual driver now can be integrated into a Windows XP-CD without any problems with nearly all SBxxx AHCI and RAID systems.
Users, who had already downloaded the previous (uncorrect) 32bit driver version, should download this actual version again, because the mistake within the TXTSETUP.OEM of the earlier presented package may have been responsable for the failure of the XP installation onto the AMD chipset system running in AHCI or RAID mode.
The 64bit version of the driver was not affected at all and has not been replaced.

Edited by Fernando 1, 17 June 2011 - 03:49 AM.

My current system:
ASUS P8Z68-V | Intel Core i5 2500K | 2x4 GB Corsair XMS3 DDR3-1600 | 2x128GB Crucial M4 SSD as RAID0 in SATA3 mode | Seasonic M12II-520 Modular 520W | ATI Radeon HD6850 1 GB GDDR5
My old system:
DFI nF4 Ultra-D (BIOS: 2006/04/06) | AMD Athlon64 4000+ San Diego | 2x512 MB OCZ PC3200 CL2 Rev.2 Platinum | 2x200 GB Samsung S-ATA II as Raid0 | beQuiet!Titan BQT P5-470W-S1.3 | MSI GeForce NX6600GT-TD128E

#135
Sp0iLedBrAt

Sp0iLedBrAt

    MSFN Addict

  • MSFN Sponsor
  • 1,727 posts
  • Joined 19-March 09
  • OS:XP Pro x86
  • Country: Country Flag

@ all users with an AMD SB7xx or SB6xx Southbridge, who want to install Windows XP or XP x64 onto a SATA hdd running in RAID mode:
Here are the download links to the requested modified AMD textmode drivers on the basis of the newest AMD RAID drivers v3.3.1540.13 for Windows XP (32/64bit) dated 03/15/2011


Does that mean they will not work in AHCI mode on XP x86? Like I mentioned in post #130, they do work on a live system.

Cheers

#136
Fernando 1

Fernando 1

    Easy RAIDer

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,021 posts
  • Joined 03-June 05
  • OS:Windows 7 x64

Does that mean they will not work in AHCI mode on XP x86? Like I mentioned in post #130, they do work on a live system.

Although AMD has named these Windows XP drivers "RAID Drivers", they probably will support the AHCI features like NCQ even while running in RAID mode.
Furthermore these "RAID Drivers" do support the following AMD SATA Controllers, which have been set to "AHCI" mode within the BIOS:
  • DEV_4391 (SB7xx series) and
  • DEV_7801 (SB8xx series)
Users with other DeviceID's (e.g. DEV_4394) will probably not be able to get XP installed onto a SATA hdd, which has been set to "AHCI" mode, because the required AHCI driver is only available for Vista and Windows 7 and the related driverpack doesn't contain any TEXTSETUP.OEM file.

Regards
Fernando

Edited by Fernando 1, 05 June 2011 - 06:17 AM.

My current system:
ASUS P8Z68-V | Intel Core i5 2500K | 2x4 GB Corsair XMS3 DDR3-1600 | 2x128GB Crucial M4 SSD as RAID0 in SATA3 mode | Seasonic M12II-520 Modular 520W | ATI Radeon HD6850 1 GB GDDR5
My old system:
DFI nF4 Ultra-D (BIOS: 2006/04/06) | AMD Athlon64 4000+ San Diego | 2x512 MB OCZ PC3200 CL2 Rev.2 Platinum | 2x200 GB Samsung S-ATA II as Raid0 | beQuiet!Titan BQT P5-470W-S1.3 | MSI GeForce NX6600GT-TD128E

#137
Sp0iLedBrAt

Sp0iLedBrAt

    MSFN Addict

  • MSFN Sponsor
  • 1,727 posts
  • Joined 19-March 09
  • OS:XP Pro x86
  • Country: Country Flag
Good news, then, because from what I know, that PC has a DEV_4391 SB750.
And to clear up the mess, you can't remember how you got the drivers

The AMD textmode drivers v3.2.1548.37 for Windows XP (32/64bit) are dated 04/06/2010, but I don't remember in which Catalyst package I found these drivers.

because I provided them; see post #100 of this same topic. They were from a driver CD that came with a notebook that a friend bought. Don't hate me for not remembering the notebook model or the versions.

Cheers

#138
Fernando 1

Fernando 1

    Easy RAIDer

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,021 posts
  • Joined 03-June 05
  • OS:Windows 7 x64
@ Sp0iLedBrAt:

Thanks for clearing up the origin of the AMD RAID drivers v3.2.1548.37. You are right: It was you, who gave me the link.
So none of the Catalyst versions ever contained these special AMD RAID drivers for Windows XP (32/64bit).

Interesting detail regarding the version number of these drivers containing "1548" instead of the usual and still actual "1540": Either the AMD driver development stuff gave them a wrong version number or the driver version belonged to a new driver development line, which has not been continued by AMD.

Kind regards
Fernando

Edited by Fernando 1, 05 June 2011 - 06:36 AM.

My current system:
ASUS P8Z68-V | Intel Core i5 2500K | 2x4 GB Corsair XMS3 DDR3-1600 | 2x128GB Crucial M4 SSD as RAID0 in SATA3 mode | Seasonic M12II-520 Modular 520W | ATI Radeon HD6850 1 GB GDDR5
My old system:
DFI nF4 Ultra-D (BIOS: 2006/04/06) | AMD Athlon64 4000+ San Diego | 2x512 MB OCZ PC3200 CL2 Rev.2 Platinum | 2x200 GB Samsung S-ATA II as Raid0 | beQuiet!Titan BQT P5-470W-S1.3 | MSI GeForce NX6600GT-TD128E

#139
anotherengineer

anotherengineer
  • Member
  • 5 posts
  • Joined 29-May 11
  • OS:XP Pro x86
  • Country: Country Flag
Thanks Fernando.

I will try and slipstream it into my XP Pro SP3 this weekend if I have time and probably format whenever I get some more spare time.

I am running in IDE mode now and just want to run in SATA mode with ahci (non-raid). I read I can do it by editing the registry and then changing the option in the BIOS. But it's due for a format anyway and then this will save the F6 load the sata driver hassle.

Cheers

#140
anotherengineer

anotherengineer
  • Member
  • 5 posts
  • Joined 29-May 11
  • OS:XP Pro x86
  • Country: Country Flag
More new amd drivers, and its getting more confusing.

http://support.amd.c..._windows.aspx#1

Fun times!

#141
Sp0iLedBrAt

Sp0iLedBrAt

    MSFN Addict

  • MSFN Sponsor
  • 1,727 posts
  • Joined 19-March 09
  • OS:XP Pro x86
  • Country: Country Flag
Well, under the Windows 7 tab it says they are for SB8xx, but no info under the Vista and XP tab. I'm downloading the XP package now and will take a look.

Edit: It contains versions for SB6xx, SB7xx and SB8xx, but no changes here. The newest is for SB8xx, and it is the one from post #134, namely 3.3.1540.13.

Cheers

Edited by Sp0iLedBrAt, 16 June 2011 - 03:33 AM.


#142
cdob

cdob

    MSFN Expert

  • Member
  • PipPipPipPipPipPip
  • 1,000 posts
  • Joined 29-September 05

It contains versions for SB6xx, SB7xx and SB8xx, but no changes here.

Yes, that's strange.

SB8xx folder contains a txtsetup.oem. Contrary there is no txtsetup.oem at SB6xx, SB7xx.

SB8xx txtsetup.oem refers to:

PCI\VEN_1002&DEV_4392&CC_0104
PCI\VEN_1002&DEV_4391&CC_0106
PCI\VEN_1002&DEV_4393&CC_0104
PCI\VEN_1022&DEV_7802&CC_0104
PCI\VEN_1022&DEV_7801&CC_0106
PCI\VEN_1022&DEV_7803&CC_0104


PNP driver file SBDrv\SB7xx\RAID\XP\ahcix86.inf refers e.g.

PCI\VEN_1002&DEV_4380&SUBSYS_280A103C


AMD dosn't provide XP textmode drivers for PCI\VEN_1002&DEV_4380&SUBSYS_* and PCI\VEN_1002&DEV_4381&SUBSYS_*

What's going on?

#143
Fernando 1

Fernando 1

    Easy RAIDer

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,021 posts
  • Joined 03-June 05
  • OS:Windows 7 x64

More new amd drivers, and its getting more confusing.
http://support.amd.c..._windows.aspx#1

The new Catalyst driverpacks 11-6 do not contain any new AMD SATA driver, but I agree with the second part of your message: The composition of the AMD RAID and AHCI driver packages and especially their subfolders for the different AMD Southbridges is very confusing for the users, who are searching for an actual AHCI or RAID driver, which is fully supporting their special AMD Southbridge.

@ all:
Since AMD does not offer any actual AHCI or RAID driver for SB6xx and SB7xx chipsets, which can be used for a fresh installation of Windows XP (32/64bit), I have customized the INF and OEM files of the latest AMD RAID driverpacks v3.3.1540.13 for Windows XP (32/64bit), which are offered by AMD just for SB8xx chipsets. The drivers themselves (= SYS files) have been untouched by my modification. I simply added the DeviceID's of several SB6xx and SB7xx AHCI/RAID Controllers to make the driver usable with SB6xx and SB7xx chipsets too. Nevertheless I am not yet sure, if these "modded" textmode drivers really will work with SB6xx and SB7xx chipsets.
Since I don't have any AMD chipset pc/notebook myselve, I need your feedback regarding the function of these "modded" AMD RAID drivers v3.3.1540.13 with SB6xx and SB7xx chipset systems running in AHCI or RAID mode.

Unfortunately I had done a mistake while modifying the TXTSETUP.OEM file entries of the "modded" 32bit driverpack, when I published it the first time within >this< post. Meanwhile I have corrected the mistake (for details look into the EDIT2 text of the linked post).

Just to prevent any further confusion regarding the usability of my "modded" AMD RAID drivers v3.3.1540.13 dated 03/15/2011, here are the actual download links to the corrected driverpacks again:
>32bit AMD SBxxx Textmode Driver v3.3.1540.13 for Windows XP mod by Fernando<
>64bit AMD SBxxx Textmode Driver v3.3.1540.13 for Windows XP x64 mod by Fernando<

Users, who are able and willing to test one of these modified driver sets, should report here about their test results. Please don't forget to mention the Southbridge specification of your system. Even better would be, if you can post the Device Identification Code (DEV_xxxx), which is layed down within the HardwareID's of the in-use "AMD AHCI Compatible RAID Controller" (open the Device Manager, search for the device, do a right click onto it > "Properties" > "Details" > "Property" > "HardwareID's").

Thanks in advance!

Regards
Fernando
My current system:
ASUS P8Z68-V | Intel Core i5 2500K | 2x4 GB Corsair XMS3 DDR3-1600 | 2x128GB Crucial M4 SSD as RAID0 in SATA3 mode | Seasonic M12II-520 Modular 520W | ATI Radeon HD6850 1 GB GDDR5
My old system:
DFI nF4 Ultra-D (BIOS: 2006/04/06) | AMD Athlon64 4000+ San Diego | 2x512 MB OCZ PC3200 CL2 Rev.2 Platinum | 2x200 GB Samsung S-ATA II as Raid0 | beQuiet!Titan BQT P5-470W-S1.3 | MSI GeForce NX6600GT-TD128E

#144
winterwinds

winterwinds
  • Member
  • 1 posts
  • Joined 28-June 11
  • OS:Windows 7 x64
  • Country: Country Flag

Copy file ahcix86.sys to system32\drivers. Import this reg settings

REGEDIT4

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_1002&cc_0106]
"Service"="ahcix86"
"ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ahcix86]
"Type"=dword:00000001
"Start"=dword:00000000
"ErrorControl"=dword:00000001
"Tag"=dword:00000021
"ImagePath"="system32\\drivers\\ahcix86.sys"
"Group"="SCSI Miniport"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ahcix86\Parameters\PnpInterface]
"5"=dword:00000001
Goto BIOS, set AHCI. Reboot.


it's doesn't work for me :(

i used xp sp3

780G Chipset (ECS A780GM-A Ultra)

#145
cdob

cdob

    MSFN Expert

  • Member
  • PipPipPipPipPipPip
  • 1,000 posts
  • Joined 29-September 05

780G Chipset (ECS A780GM-A Ultra)

Which ahcix86.sys version do you use?
Which BIOS setting do you use?

#146
MiclO12

MiclO12
  • Member
  • 1 posts
  • Joined 14-August 11
  • OS:Windows 7 x86
  • Country: Country Flag
Hello there, Missel here! I'm from Mexico & just wanted to say that I tested the last Fernando's drivers & they worked like a charm!, well I tested them on a HP Pavilion 2014la it comes with a SB750 southbridge; actually I just had done this but with an ICH9 & it also worked, just wanted to thank Fernando for his priceless kindess & now I could make my new Win XP SP3 CD with any kind of chipset so it seems that now I can beat any laptop!

#147
dstk

dstk

    Newbie

  • Member
  • 25 posts
  • Joined 03-September 07
Thanks Fernando. Very Good...

Edited by dstk, 17 August 2011 - 06:51 PM.


#148
dstk

dstk

    Newbie

  • Member
  • 25 posts
  • Joined 03-September 07
AMD 11.8 Raid in SB800 Textmode Driver v3.3.1540.17 for Windows XP Release.

AMD SBxxx Textmode Driver v3.3.1540.17 for Windows XP Fernando ?

#149
Fernando 1

Fernando 1

    Easy RAIDer

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,021 posts
  • Joined 03-June 05
  • OS:Windows 7 x64

AMD SBxxx Textmode Driver v3.3.1540.17 for Windows XP Fernando ?

Here are the requested freshly modded drivers:
>32bit AMD SBxxx Textmode Driver v3.3.1540.17 for Windows XP mod by Fernando<
>64bit AMD SBxxx Textmode Driver v3.3.1540.17 for Windows XP x64 mod by Fernando<
Users with an AMD SB6xx/7xx/8xx AHCI or RAID system may use them at own risk.
Any feedback is much appreciated.

Regards
Fernando

Edited by Fernando 1, 19 August 2011 - 01:35 PM.

My current system:
ASUS P8Z68-V | Intel Core i5 2500K | 2x4 GB Corsair XMS3 DDR3-1600 | 2x128GB Crucial M4 SSD as RAID0 in SATA3 mode | Seasonic M12II-520 Modular 520W | ATI Radeon HD6850 1 GB GDDR5
My old system:
DFI nF4 Ultra-D (BIOS: 2006/04/06) | AMD Athlon64 4000+ San Diego | 2x512 MB OCZ PC3200 CL2 Rev.2 Platinum | 2x200 GB Samsung S-ATA II as Raid0 | beQuiet!Titan BQT P5-470W-S1.3 | MSI GeForce NX6600GT-TD128E

#150
Sp0iLedBrAt

Sp0iLedBrAt

    MSFN Addict

  • MSFN Sponsor
  • 1,727 posts
  • Joined 19-March 09
  • OS:XP Pro x86
  • Country: Country Flag

Users with an AMD SB6xx/7xx/8xx AHCI or RAID system may use them at own risk.



They are not working on a live system, SB750 or SB780, not sure at the moment. The previous ones have always worked on a live system as well.

The line in the ahcix86.inf file is correct
%NapaDesc%=Napa_Inst,PCI\VEN_1002&DEV_4391&CC_0106
, but it says a better hardware was not found.

I'll check out the actual file from the AMD package and report.

Cheers




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users