Tihiy

GDI Heap Extender

171 posts in this topic

...One way to reproduce the DIBENG crash of IE is to navigate to http://www.microangelo.us/welcomet.asp and then click "enter"..

...

You try http://web.3zscv.cz/~mliska/hodiny/clock.swf - error on IE: flashplayer for IE, not "click enter".

dibeng.dll (4.10.1998) and any files in my system (czech windows 98 SE) original - GDI.exe 4.10.2225 (system without RP).

Edited by Philco
0

Share this post


Link to post
Share on other sites

I played StarCraft for a few hours, all worked fine, and I started to notice REALLY wierd graphical glitches afterwards. My guess is that the program is reclaiming GDI/USER resources from explorer since it determines them to not be in use while the game is up, and then they are just magically missing cuz explorer doesn't understand that they're gone or how to put them back.

I took quite a few screenshots for you to troubleshoot with:

http://rapidshare.de/files/47895770/bitmapfailures.rar.html

0

Share this post


Link to post
Share on other sites

here are my test results

1. Spybot updater (1.62) couldn't work before GDI_HE loosing ~50% GDI resources (WATSON_sb.WLG).

With GDI Heap Extender on GDI resources increases about 5-7% and SPYBOT and its updater works loosing 26-34% GDI resources.rolleyes.gif

2. WINAMP crashes (dibeng.dll) (WATSON_wa.WLG) :wacko:

http://rapidshare.de/files/47898582/watson.7z.html

0

Share this post


Link to post
Share on other sites

Played a long game of SC again and didn't have any missing bitmap issues in explorer like last time. Don't know. No other problem/issues yet.

Networking went wonky for a bit afterwards, but I think it was unrelated. Release/renew and running Opera fixed it. (Yes, running Opera helped - don't ask me why, but FF and IE didn't work after the renew until AFTER I ran Opera)

Edit: spoke a bit too soon, the 98 logo is missing from the start menu now like before. I'm going to reboot - documenting the same problem isn't going to help.

On the bright side, about 10 hours of uptime with no instability (as long as I stayed away from IE, and I did, lol)

Edited by EyesOfARaven
0

Share this post


Link to post
Share on other sites
QUOTE (EyesOfARaven @ Jul 19 2009, 04:16 PM) *

...One way to reproduce the DIBENG crash of IE is to navigate to http://www.microangelo.us/welcomet.asp and then click "enter"..

...

You try http://web.3zscv.cz/~mliska/hodiny/clock.swf - error on IE: flashplayer for IE, not "click enter".

dibeng.dll (4.10.1998) and any files in my system (czech windows 98 SE) original - GDI.exe 4.10.2225 (system without RP).

EDIT: It crashed firefox (Which was also open viewing another page) after I closed IE after viewing the link(Strange?). Firefox caused an error in DIBENG.DLL, and that hung my computer....

Edited by sp193
0

Share this post


Link to post
Share on other sites

Yo Tihiy,

Just wanted to encourage you on this project......I have been toying with this for awhile now.

I am noticing reduction in resource usage in programs that are normally real resource hogs....depending on what else is running, I have one program that simultaneously opens about 20 jet databases and It can range from 2% to 5% more available resources....I really did not expect this.

Thanks for all your hard work .... :hello:

Jake

0

Share this post


Link to post
Share on other sites

the program process explorer from system internals tends to use up the rescources each time you minimize and maximize

and some times, it uses up the resources completely....

alpha 1 did not help

although Opera runs much better!

keep up the good work!

Edited by sparky4
0

Share this post


Link to post
Share on other sites

Okay, i've fixed crashing issues. Next alpha would be combined with RP9 (since it's not possible to hijack APIs once KernelEx is started, and asking you to disable both RP9 and kex is too much hassle).

The only thing that bothers me - no reports from DBCS 9x systems ITT.

0

Share this post


Link to post
Share on other sites
Okay, i've fixed crashing issues. Next alpha would be combined with RP9 (since it's not possible to hijack APIs once KernelEx is started, and asking you to disable both RP9 and kex is too much hassle).

The only thing that bothers me - no reports from DBCS 9x systems ITT.

Tihiy...what about uberskin?, does it need disabled?

oops....nevermind, I mis-understood your post.... :blushing:

Edited by triger49
0

Share this post


Link to post
Share on other sites

Graphic trash-up occurs regularly in Opera when running the expander. Usually affects the content of one tab only, or the content of one tab and the toolbar graphics. I am sure you are aware of it but in case you aren't give a whistle and I'll pass you some screenshots.

0

Share this post


Link to post
Share on other sites
I am sure you are aware of it
:whistle:

It happens when other app exits or all by itself?

0

Share this post


Link to post
Share on other sites

My experience:

Install startrpx and gives me the error:

STARTRPX caused an invalid page fault in

module KERNEL32.DLL at 016f:bff7ce80.

Registers:

EAX=00000000 CS=016f EIP=bff7ce80 EFLGS=00010202

EBX=8171b3b0 SS=0177 ESP=0063faac EBP=0063fabc

ECX=ce3667a0 DS=0177 ESI=0000002c FS=28f7

EDX=00000000 ES=0177 EDI=0000000b GS=0000

Bytes at CS:EIP:

66 ff 40 02 c2 04 00 ff 74 24 04 6a 00 ff 35 04

Stack dump:

bff7daef 00000000 8171b3a0 0000002c 0063fae4 bff95a6a 8171b448 0000002c 00000000 00000000 8269f228 bfb7984a 0063fd10 00000000 0063fd90 004018f7

I use Win98SE, SP3.0b3, 98se2me.

I had previously uninstalled RP9.

My DLL version:

kernel32.dll v.4.10.2226

gdi32.dll 4.90.3003

Thanks for all your hard work!

Bye.

Mcv'93

0

Share this post


Link to post
Share on other sites
The only thing that bothers me - no reports from DBCS 9x systems ITT.

Confirm Alpha 1 loaded in Simplified and Traditional Chinese Win98SE (with KernelEX 4.0 Final). Opera resource usage was improved. There were crashes with IE

0

Share this post


Link to post
Share on other sites
I am sure you are aware of it
:whistle:

It happens when other app exits or all by itself?

Haha, interesting question. All by itself I would say but I may have closed apps before it happens. I'll try to browse the web without closing any app and will tell you if it still does occur in those conditions. Screenie in the meantime :

snap1736.png

Generally I can get rid of toolbar graphics corruption by switching briefly to another skin but I can't get rid of tab content corruption even if I close the tab and reopen the same website, only closing and reopening Opera clears it all up.

0

Share this post


Link to post
Share on other sites

It does not seem to happen if I do not open/close apps while it is running.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.