Sign in to follow this  
Followers 0
bigheart

boot os selection after install xp

11 posts in this topic

Hi,

i just got my nlite winxp installed via USB stick. the usb stick was prepared by WinSetupFromUSB.

the installation is smooth but i found when it boot up it shows a OS selection menu ...

the menu has option to press F8 to advence feature ...

i don't know where and why this menu come up but i want to remove or skip this OS selection.

what can i do?

thanks for your help!!

bigheart

0

Share this post


Link to post
Share on other sites

Control Panel > System > Advanced > Startup and Recovery, Settings > System Startup

Uncheck or set to 0 "Time to display list of operating systems"

or

Edit your %SystemDrive%\boot.ini

0

Share this post


Link to post
Share on other sites

i think i got a very strangth problem,

i checked my boot.ini

[boot loader]

timeout=30

default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

[operating systems]

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

i think they are pointing exactly the same place but the default is not work!?

when i select default, system said it cannot locate the hal.dll something like that ...

another strength thing is i hv another xp which boot.ini is exactly the same, therefore the timeout=30 but it will enter to correct windows in no time when boot up ...................

i really don't udnerstand ....

pls. help!!

0

Share this post


Link to post
Share on other sites

Yeah, if you only have 1 entry you shouldn't get the OS selector screen.

So now it's not working or only "when i select default"?

0

Share this post


Link to post
Share on other sites

it is working if i select "microsoft windows Xp professional" ... the windows boot normallly ...

the WINDOW directory is in C:

is that related to the installation from USB?

Edited by bigheart
0

Share this post


Link to post
Share on other sites

Strange problem. I don't know if it's related to installation from USB. Hopefully someone will come along that has some ideas.

0

Share this post


Link to post
Share on other sites

Let's start from the beginning all right?

WHERE is that BOOT.INI? (I mean are you talking about the BOOT.INI on the USB device or on your internal hard disk)?

And if the latter, on WHICH partition is it? (i.e. on First, Primary, Active partition)?

Are you using a bootmanager of some sort? (I mean before NTLDR)

A BOOT.INI with this content:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

is a "perfectly normal" one, and, since it has ONLY 1 entry, it WON'T allow you to see any choice (as there is actually NO choice).

To make sure you are looking at/editing the same BOOT.INI that is actually loaded during the boot process, add a "fake" entry to it, i.e. change it as follows:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
c:\somefile="Fake menu entry"

Can you choose now between "Microsoft Windows XP Professional" and "Fake menu entry" ?

If not, you are editing ANOTHER BOOT.INI, that is not loaded during booting.

Report what happens.

jaclaz

0

Share this post


Link to post
Share on other sites

Hi i

i have only 1 HDD installed and i partition it into 2 partitions.

windows was installed in the first partition.

i am pretty sure that i edited the correct boot.ini file as i turn the timeout =0 it will not let me to choose.

i need to insert the USB stick and when the USB stick boot up it show some winodws option to select, and then i can select to boot the windows installed in HDD....

anyway, i had already erase my installation and use a CD instead... after install it just boot up normally as others. . can't see the menu anymore. .

0

Share this post


Link to post
Share on other sites
i need to insert the USB stick and when the USB stick boot up it show some winodws option to select, and then i can select to boot the windows installed in HDD....

Are you saying you used a USB stick to boot the OS on the hard drive?

0

Share this post


Link to post
Share on other sites

yes, i did it once when i set the timeout to 0, i cannot get the windows installed in HDD to boot up correctly. after i boot up the windows and set the timeout back to 30, windows can boot up and shown the OS selection menu.

0

Share this post


Link to post
Share on other sites

I'm having trouble understanding you. Please answer jaclaz's questions.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.