Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Windows 7 x64 vLite "extreme removal"

- - - - -

  • Please log in to reply
220 replies to this topic

#26
Jedi-to-be

Jedi-to-be

    Newbie

  • Member
  • 13 posts
  • Joined 21-July 07
Jeronimo does your stuff suport N-edition? I think, i'd be good.


How to remove advertisement from MSFN

#27
Jedi-to-be

Jedi-to-be

    Newbie

  • Member
  • 13 posts
  • Joined 21-July 07
Jeronimo
Now I have instal.wim within UltimateN 7600.16385 x86. It has the one and only index 1. Please, give a guide, how to remove most of drivers (wireless, ATI\Nvidia graphics ando the) from it with help od you stuff. I want to keep only storage controlers and universal drivers for videoadapters.

Edited by Jedi-to-be, 11 August 2009 - 03:19 AM.


#28
Jedi-to-be

Jedi-to-be

    Newbie

  • Member
  • 13 posts
  • Joined 21-July 07
Jeronimo
What breakes Windows feauters?
I kept Help, Fax Support, Windows Search
I is seem workable, but after first use Windows feauters dies and Windows Search too

#29
dcatcher

dcatcher

    Newbie

  • Member
  • 15 posts
  • Joined 28-March 08
Is there any easier way to solve the "Access is denied" error when cleanup?

#30
awalraja

awalraja

    Newbie

  • Member
  • 17 posts
  • Joined 02-August 09

@awalraja: mentioning of files required means you add files to the "protect files" in vLite yourself. Windows picture viewer was also broken for me, I could not find out what component or pacakge it was

i found it, it was caused by "PhotoPremiumPackage".

#31
Junior2613

Junior2613

    Member

  • Member
  • PipPip
  • 200 posts
  • Joined 21-June 09
Sorry for late reply. I'm running windows 7 Ultimate x64 I get the error towards the end of the installation saying it couldn't configure some services and stuff. The removal.bat I use is attached to this post :)

Attached Files



#32
awalraja

awalraja

    Newbie

  • Member
  • 17 posts
  • Joined 02-August 09

Sorry for late reply. I'm running windows 7 Ultimate x64 I get the error towards the end of the installation saying it couldn't configure some services and stuff. The removal.bat I use is attached to this post :)

you are using Ultimate and check this, it is in your batch file
REM Image Index (pre-vLite: 1 HomeStarter, 2 Home Premium, 3 Professional, 4 Ultimate)
set II=2

Edited by awalraja, 11 August 2009 - 12:29 PM.


#33
Junior2613

Junior2613

    Member

  • Member
  • PipPip
  • 200 posts
  • Joined 21-June 09
Yep, thats in there :) Here is the first part of the .bat

REM Initialising environment variables (check for your usage)
REM ----------------------------------------------------------------------------
REM Windows codebase: amd64 or x86
set cb=amd64
REM Windows 7 build
set build=7600
REM Sub version
set svn=16385
REM Pre-part (the same for all Windows 7 builds?)
set pre=31bf3856ad364e35
REM Image Index (pre-vLite: 1 HomeStarter, 2 Home Premium, 3 Professional, 4 Ultimate)
set II=2
REM Image edition (H for HomePremium, P for Professional or U for Ultimate/Enterprise)
set edition=U

set PATH=%PATH%;%cd%
set version=6.1.%build%.%svn%
set IEver=8.0.%build%.%svn%

#34
dcatcher

dcatcher

    Newbie

  • Member
  • 15 posts
  • Joined 28-March 08
Finally, a working vlited x86 win 7.

iso size 1.1g
install size 3.2g. including 1.0g pagefile.

This is the best I can do.

The only problem is that I have to take ownership of winsxs to do cleanup step.
After installation, the owner of winsxs folder is not TrustedInstaller anymore, but some strange string, which is not surprising because the owner doesn't exist any more.

However, windows update works well. I will try install it on real machine later.

#35
Junior2613

Junior2613

    Member

  • Member
  • PipPip
  • 200 posts
  • Joined 21-June 09
Haha now I see my issue :P awalraja just rubbed it in my face and I didn't notice :P I'm on ultimate not home premium, So Where II = 2, 2 = Home Premium so I need to make II = 4 because 4 = Ultimate .

And I will follow dcatcher's advice to take ownership of the winsxs folder. By the way what is the file location for the winsxs folder ??

Edited by Junior2613, 11 August 2009 - 01:20 PM.


#36
Jeronimo

Jeronimo

    vLite user

  • Member
  • PipPipPip
  • 395 posts
  • Joined 26-October 03
@Jedi-to-be: Should work right away, although you might get some errors on none removable packages and non-existing files. For drivers see the removal.bat and remove the appropriate sections. With my guide you would not need Windows features anymore, that is part of the idea. What I would like to know about the N-edition is weither you can use the IE-tab plugin within Firefox. If so I would most definetely want that one. I know what it is supposed to be "missing", however I have not heard any news on an N-edition for Windows 7, only on the E-edition with the Browser-selection.

@awalraja/Junior2613: with the old removal.bat yes, but see the new one, use edition.

@dcatcher: I have heard others before about this, but the only issues I am having with access denied is with the folders under Users\Public\Documents. I have no UAC activated, so I need not use the elevated prompt, not usre if that might be an issue.

Edited by Jeronimo, 11 August 2009 - 02:44 PM.


#37
Jedi-to-be

Jedi-to-be

    Newbie

  • Member
  • 13 posts
  • Joined 21-July 07
Here is packages list of UltimaiteN
You should see this, Jeronimo

Attached Files



#38
dcatcher

dcatcher

    Newbie

  • Member
  • 15 posts
  • Joined 28-March 08
@Jeronimo, this is strange. I run removal.bat on windows 7 x86, and vlite the image on windows server 2003 x86 then back into windows 7 to do cleanup. Both os have no UAC.

I can delete Users\Public\*.* with no problem, only those in winsxs folder must be taken care of.

One more thing, I use only dism to mount and remove packages.

#39
Jeronimo

Jeronimo

    vLite user

  • Member
  • PipPipPip
  • 395 posts
  • Joined 26-October 03
@Jedi-to-be: wow that are 29 packages less out of the box and still the IE package related to html-support present. WOuld love to get my hands on that version

@dcatcher: I only tried x64 with imagex under Windows 7, I could include an ownership of the files if it is just winsxs try adding the following just after mount of image under cleanup:
takeown /f "%mount%\Windows\winsxs\Manifests\*" >nul
takeown /f "%mount%\Windows\winsxs\%cb%_*" /r >nul
icacls "%mount%\Windows\winsxs\Manifests\*" /grant Administrators:F /q >nul
icacls "%mount%\Windows\winsxs\%cb%_*" /grant Administrators:F /q /t >nul

This might take quite a bit more time, but check if this resolves your issues. I might ad it as an option later on.

Edited by Jeronimo, 11 August 2009 - 11:15 PM.


#40
Junior2613

Junior2613

    Member

  • Member
  • PipPip
  • 200 posts
  • Joined 21-June 09
I'm currently running the whole guide again with the new removal.bat and other files. I have changed the edition to ultimate and I will run vlite with Jeronimo's Stock Preset to make sure I don't get ahead of myself :) I also added the takeownership instruction from Jeronimo and placed it in the correct part of the .bat :) .

Only one error so far when it tried to remove the internet explorer optionals package.

#41
Junior2613

Junior2613

    Member

  • Member
  • PipPip
  • 200 posts
  • Joined 21-June 09
your take ownership doesn't seem to work it makes cleanup not work it won't even mount

Attached Files


Edited by Junior2613, 12 August 2009 - 04:14 AM.


#42
Junior2613

Junior2613

    Member

  • Member
  • PipPip
  • 200 posts
  • Joined 21-June 09
Ok I've got Windows 7 installed and working now :) My problem was that I was leaving game explorer in. Install size = 3gb without page file :)

Edited by Junior2613, 12 August 2009 - 12:13 PM.


#43
Jedi-to-be

Jedi-to-be

    Newbie

  • Member
  • 13 posts
  • Joined 21-July 07
Jeronimo I've got lots of "access denied" when i tried to cleanup useless drivers.
Is install_wim_tweak needed for granting access?

Edited by Jedi-to-be, 12 August 2009 - 10:09 AM.


#44
Jeronimo

Jeronimo

    vLite user

  • Member
  • PipPipPip
  • 395 posts
  • Joined 26-October 03
@Jedi-to-be: the tweak needs to be run only once per image id and judging by the short time it runs I doubt it handles access for all files. However with the commands I gave you the files in winsxs are made available, I thought this was the issue you and dcatcher had. If you can provide more explicit information on which files (or folders) give access denied, then I can provide a better solution (or use the commands on the complete image). Do this without my previous solution, because I would like to know which folders are an issue, for the sake of performance and reliability I do not want to handle every file/folder in the image.

#45
Junior2613

Junior2613

    Member

  • Member
  • PipPip
  • 200 posts
  • Joined 21-June 09
Jeronimo it seems the access denied stuff doesn't really have much of a negative effect. It seems to work even with the access denied stuff.

#46
Jeronimo

Jeronimo

    vLite user

  • Member
  • PipPipPip
  • 395 posts
  • Joined 26-October 03
Access denied means the operation cannot be performed. Considering we aer trying to remove redundant files, I am not sure they are all removed. But if you are happy, then I am happy. I have no issues with removing files, just trying to help you guys out.

Edited by Jeronimo, 12 August 2009 - 02:50 PM.


#47
Jedi-to-be

Jedi-to-be

    Newbie

  • Member
  • 13 posts
  • Joined 21-July 07
Jeronimo
Packages does not cause any errors. But the next stage cleanup makes lots of 'access denied'
Here is a part of list of errors, that I've got on cleanup.

Attached Files


Edited by Jedi-to-be, 13 August 2009 - 04:03 AM.


#48
Jedi-to-be

Jedi-to-be

    Newbie

  • Member
  • 13 posts
  • Joined 21-July 07

@dcatcher: I only tried x64 with imagex under Windows 7, I could include an ownership of the files if it is just winsxs try adding the following just after mount of image under cleanup:

takeown /f "%mount%\Windows\winsxs\Manifests\*" >nul
takeown /f "%mount%\Windows\winsxs\%cb%_*" /r >nul
icacls "%mount%\Windows\winsxs\Manifests\*" /grant Administrators:F /q >nul
icacls "%mount%\Windows\winsxs\%cb%_*" /grant Administrators:F /q /t >nul

with this solution I've got another error list.

Attached Files



#49
Jeronimo

Jeronimo

    vLite user

  • Member
  • PipPipPip
  • 395 posts
  • Joined 26-October 03
@Jedi-to-be: could you use an image after vLite component removal, remove the "@echo off line"/ownership-commands (takeown/icacls) in removal.bat and run the cleanup stage for me as following?
removal.bat cleanup > errors3.txt 2>&1

Zip the file errors3.txt and post it here if you can.

Edited by Jeronimo, 13 August 2009 - 01:33 PM.


#50
trickstar

trickstar

    Newbie

  • Member
  • 21 posts
  • Joined 16-September 05
@Jeronimo

why not add this to the removal list.

ProgramData\Microsoft\Network\Downloader\qmgr*.dat




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users