Sign in to follow this  
Followers 0
justusiv

Sysprep before adding drivers via DISM

2 posts in this topic

Hello all,

I am trying to figure out the correct way to add all my supported models drivers into my image.

It appears to work if i add them via dism before sysprep but that seems like a pain. I tried adding them after i syspreped and it gave errors.

Ideas?

0

Share this post


Link to post
Share on other sites

I haven't tried doing it after sysprep myself, but why do you say adding them with DISM is a pain? Seeing as you can add any number of drivers (and patches while you're at it) in one fell swoop thanks to the possibility of recursing all the folders, I'm not sure why you refer it as a pain to do so.

I'm still in the "early" stages of developping an image for my department, but one thing I've done a LOT is having to recreate the .WIM file from scratch a lot, because of too much tampering and errors on my part. I've got 2 big folders; 1 for drivers & 1 for patches/other packages and with 2 DISM commands (/add-package & /add-driver) over 20 items get added in no time recursively.

Hopefully, it's just that you don't know of the /recurse switch, like me back then (lack of documentation for that switch). If that's not the case, I've never tried to add drivers after sysprep, so can't help you there.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.