Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

DISM issues


  • Please log in to reply
18 replies to this topic

#1
shaun.murray

shaun.murray

    Newbie

  • Member
  • 21 posts
I keep failing! I can't seem to figure out why either. Very frustrating. Its one thing to not let me install the feature RemoteServerAdministrationTools-ServerManager but not let me install Solitare is just RUDE! ;]~

Whats really confusing, is that it let me install the feature RemoteServerAdministrationTools-Roles-AD-DS just fine. I've tried the whole google thing on Error: 1603 but can't seem to come up with anything. Any help in this would be greatly appreciated.

The command...
C:\>dism /online /enable-feature /featurename:RemoteServerAdministrationTools-ServerManager

Deployment Image Servicing and Management tool
Version: 6.1.7600.16385

Image Version: 6.1.7600.16385

Enabling feature(s)
[===========================99.5%========================= ]

Error: 1603

Fatal error during installation.

The DISM log file can be found at C:\Windows\Logs\DISM\dism.log



Checking the error logs:
C:\Windows\Logs\DISM\dism.log
2009-08-17 14:22:48, Info				  DISM   DISM Package Manager: PID=6116 Encountered the option "featurename" with value "RemoteServerAdministrationTools-ServerManager" - CPackageManagerCLIHandler::Private_GetPackagesFromCommandLine
2009-08-17 14:22:48, Info				  DISM   DISM Package Manager: PID=6116 Encountered an unknown option "featurename" with value "RemoteServerAdministrationTools-ServerManager" - CPackageManagerCLIHandler::Private_GetPackagesFromCommandLine
2009-08-17 14:22:48, Info				  DISM   DISM Package Manager: PID=6116 Initiating Changes on Package with values: 5, 7 - CDISMPackage::Internal_ChangePackageState
2009-08-17 14:24:16, Info				  DISM   DISM Package Manager: PID=6116  Error in operation: (null) (CBS HRESULT=0x80070643) - CCbsConUIHandler::Error
2009-08-17 14:24:16, Error				 DISM   DISM Package Manager: PID=6116 Failed finalizing changes. - CDISMPackageManager::Internal_Finalize(hr:0x80070643)
2009-08-17 14:24:16, Error				 DISM   DISM Package Manager: PID=6116 Failed processing package changes - CDISMPackageManager::ProcessChanges(hr:0x80070643)
2009-08-17 14:24:16, Error				 DISM   DISM Package Manager: PID=6116 Failed ProcessChanges. - CPackageManagerCLIHandler::Private_ProcessFeatureChange(hr:0x80070643)
2009-08-17 14:24:16, Error				 DISM   DISM Package Manager: PID=6116 Failed while processing command enable-feature. - CPackageManagerCLIHandler::ExecuteCmdLine(hr:0x80070643)
2009-08-17 14:24:16, Info				  DISM   DISM Package Manager: PID=6116 Further logs for online package and feature related operations can be found at %WINDIR%\logs\CBS\cbs.log - CPackageManagerCLIHandler::ExecuteCmdLine
2009-08-17 14:24:16, Error				 DISM   DISM.EXE: DISM Package Manager processed the command line but failed. HRESULT=80070643

C:\Windows\Logs\CBS\CBS.log
2009-08-17 14:24:16, Info				  CBS	Setting ExecuteState key to: ExecuteStateNone
2009-08-17 14:24:16, Info				  CBS	Setting RollbackFailed flag to 0
2009-08-17 14:24:16, Info				  CBS	Clearing HangDetect value
2009-08-17 14:24:16, Info				  CBS	Saved last global progress. Current: 0, Limit: 1, ExecuteState: ExecuteStateNone
2009-08-17 14:24:16, Info				  CBS	Exec: Cancelled pending transactions after rollback. [HRESULT = 0x00000000 - S_OK]
2009-08-17 14:24:16, Error				 CBS	Exec: An error occurred while committing the transaction, the transaction has been rolled back. [HRESULT = 0x80070643 - ERROR_INSTALL_FAILURE]
2009-08-17 14:24:16, Info				  CSI	00000373@2009/8/17:19:24:16.160 CSI Transaction @0x328260 destroyed
2009-08-17 14:24:16, Info				  CBS	Perf: InstallUninstallChain complete.
2009-08-17 14:24:16, Info				  CBS	Failed to execute execution chain. [HRESULT = 0x80070643 - ERROR_INSTALL_FAILURE]
2009-08-17 14:24:16, Error				 CBS	Failed to process single phase execution. [HRESULT = 0x80070643 - ERROR_INSTALL_FAILURE]
2009-08-17 14:24:16, Info				  CBS	WER: Generating failure report for package: Microsoft-Windows-Foundation-Package~31bf3856ad364e35~x86~~6.1.7600.16385, status: 0x80070643, failure source: Execute, start state: Installed, target state: Installed, client id: DISM Package Manager Provider
2009-08-17 14:24:16, Info				  CBS	Failed to query DisableWerReporting flag.  Assuming not set... [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
2009-08-17 14:24:16, Info				  CBS	Failed to add %windir%\winsxs\pending.xml to WER report because it is missing.  Continuing without it...
2009-08-17 14:24:16, Info				  CBS	Failed to add %windir%\winsxs\pending.xml.bad to WER report because it is missing.  Continuing without it...
2009-08-17 14:24:16, Info				  CBS	Reboot mark refs: 0
2009-08-17 14:24:16, Info				  CBS	SQM: Reporting selectable update change for package: Microsoft-Windows-RemoteServerAdministrationTools-Package~31bf3856ad364e35~x86~~6.1.7600.16385, update: RemoteServerAdministrationTools-ServerManager, start: Staged, applicable: Installed, target: Installed, client id: DISM Package Manager Provider, initiated offline: False, execution sequence: 55, first merged sequence: 55
2009-08-17 14:24:16, Info				  CBS	SQM: Upload requested for report: UpdateChange_RemoteServerAdministrationTools-ServerManager_Microsoft-Windows-RemoteServerAdministrationTools-Package~31bf3856ad364e35~x86~~6.1.7600.16385, session id: 142860, sample type: Standard
2009-08-17 14:24:16, Info				  CBS	SQM: Ignoring upload request because the sample type is not enabled: Standard
2009-08-17 14:24:16, Info				  CBS	SQM: Reporting package change for package: Microsoft-Windows-RemoteServerAdministrationTools-Package~31bf3856ad364e35~x86~~6.1.7600.16385, current: Installed, pending: Default, start: Installed, applicable: Installed, target: Installed, limit: Installed, hotpatch status: DisabledBecauseNoHotpatchPackagesInitiated, status: 0x0, failure source: Execute, reboot required: False, client id: DISM Package Manager Provider, initiated offline: False, execution sequence: 55, first merged sequence: 55
2009-08-17 14:24:16, Info				  CBS	SQM: Upload requested for report: PackageChangeBegin_Microsoft-Windows-RemoteServerAdministrationTools-Package~31bf3856ad364e35~x86~~6.1.7600.16385, session id: 142859, sample type: Standard
2009-08-17 14:24:16, Info				  CBS	SQM: Ignoring upload request because the sample type is not enabled: Standard
2009-08-17 14:24:16, Info				  CBS	SQM: Reporting package change completion for package: Microsoft-Windows-RemoteServerAdministrationTools-Package~31bf3856ad364e35~x86~~6.1.7600.16385, current: Installed, original: Installed, target: Installed, status: 0x80070643, failure source: Execute, failure details: "(null)", client id: DISM Package Manager Provider, initiated offline: False, execution sequence: 55, first merged sequence: 55
2009-08-17 14:24:16, Info				  CBS	SQM: execute time performance datapoint is invalid. [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
2009-08-17 14:24:16, Info				  CBS	SQM: Upload requested for report: PackageChangeEnd_Microsoft-Windows-RemoteServerAdministrationTools-Package~31bf3856ad364e35~x86~~6.1.7600.16385, session id: 142862, sample type: Standard
2009-08-17 14:24:16, Info				  CBS	SQM: Ignoring upload request because the sample type is not enabled: Standard



How to remove advertisement from MSFN

#2
shaun.murray

shaun.murray

    Newbie

  • Member
  • 21 posts
Features that won't install:
+TelnetClient
+InboxGames (Can't install any other games until InboxGames installs fine.)
+SUA
+RemoteServerAdministrationTools-ServerManager
+RemoteServerAdministrationTools-Roles-AD-DS-SnapIns


On another note. I had noticed that I had 29-days left to activate. I activated, rebooted, and tried the ServerManager one again, still failing. GAH!!!!!! =[

#3
cluberti

cluberti

    Gustatus similis pullus

  • Supervisor
  • 11,252 posts
  • OS:Windows 8.1 x64
  • Country: Country Flag
Error 1063 says "Error_Install_Failure", specifically that the feature named "RemoteServerAdministrationTools-ServerManager" wasn't found when it walked the feature tree:

2009-08-17 14:22:48, Info				  DISM   DISM Package Manager: PID=6116 Encountered an unknown option "featurename" with value "RemoteServerAdministrationTools-ServerManager"

Is this the RSAT RTM package on Win7 RTM, or are either of these the release candidate versions?
MCTS Windows Internals, MCITP Server 2008 EA, MCTS MDT/BDD, MCSE/MCSA Server 2003, Server 2012, Windows 8
--------------------
Please read the rules before posting!
Please consider donating to MSFN to keep it up and running!

#4
shaun.murray

shaun.murray

    Newbie

  • Member
  • 21 posts
Erm.... You kinda lost me there. I'm still trying to get used to Windows 7.

I downloaded and ran the x86 version from Microsoft.
http://www.microsoft...05-4e344e43997d

That installed KB958830 and gave me the options in "Turn Windows features on or off" to turn them on, but opted to do the dism.exe within CMD.

#5
shaun.murray

shaun.murray

    Newbie

  • Member
  • 21 posts
Unsure why this was moved to "Unattended Windows 7" since my OS is already installed, and I'm trying to make changes to it now. But... If this gets me the help... WOOT WOOT!!! =D

#6
cluberti

cluberti

    Gustatus similis pullus

  • Supervisor
  • 11,252 posts
  • OS:Windows 8.1 x64
  • Country: Country Flag
I moved it here because the section is more for unattended installations, but can be used for using the tools for in-OS scripting unattended work as well (same tools), so the best knowledge will be here.

Anyway, that's the RTM version of the RSAT tools - is this also an RTM Windows 7 install, or the RC1 build (7100)?
MCTS Windows Internals, MCITP Server 2008 EA, MCTS MDT/BDD, MCSE/MCSA Server 2003, Server 2012, Windows 8
--------------------
Please read the rules before posting!
Please consider donating to MSFN to keep it up and running!

#7
shaun.murray

shaun.murray

    Newbie

  • Member
  • 21 posts
Hmmm... Good question, how would I tell? As far as I can tell, its NOT the RC1 install. Going to the "Advanced System Information" doesn't really tell me either way.

#8
cluberti

cluberti

    Gustatus similis pullus

  • Supervisor
  • 11,252 posts
  • OS:Windows 8.1 x64
  • Country: Country Flag
Take a look at the properties of kernel32.dll in %windir%\system32. On the details tab, check the File version line - RTM is 6.1.7600.16385.
MCTS Windows Internals, MCITP Server 2008 EA, MCTS MDT/BDD, MCSE/MCSA Server 2003, Server 2012, Windows 8
--------------------
Please read the rules before posting!
Please consider donating to MSFN to keep it up and running!

#9
shaun.murray

shaun.murray

    Newbie

  • Member
  • 21 posts
Excellent! Thats what I have. Does that mean that I installed the wrong version of RSAT tools?

http://www.microsoft...05-4e344e43997d

Thats the link that I used.... Thanks again for all your help cluberti!!

#10
Dechy

Dechy

    Newbie

  • Member
  • 41 posts
Holy hell, my RSAT tools I downloaded for the RC are 24MB!!! They work perfectly with the RTM too. I had found them just by doing a search for "Windows RSAT" on Google and most websites pointed me to what I have now... (which was a direct download from MS)

I do the same now and the links are either dead or send me to that insanely massive download. Really don't understand why it's so big... going to have to download those and test... here's hoping I won't get the same error you are, but I use DISM to modify an offline image and then use the MS-Foundation package in WSIM to enable the features. Works great.

There a particular reason why you want to use DISM to enable stuff on a running OS instead of just doing it through the Programs Add/Remove Features? (aside from curiosity)

#11
fizban2

fizban2

    MSFN Addict

  • Super Moderator
  • 1,900 posts
  • OS:Windows 7 x64
  • Country: Country Flag
those are the RTM tools, but we need to know if you are running the RC or RTM of windows 7, check the dll cluberti listed and let us know the version, the RTM tools may not work properly on the RC version of windows if that is what you have installed

#12
shaun.murray

shaun.murray

    Newbie

  • Member
  • 21 posts
I've tried both. Using DISM just seems to give me the fail quicker, were using the Add/Remove it prompts me to reboot, then goes thru the motion, failes, then rolls back the changes. This is just so frustrating. I mean, really.... Its just solitare!!! (Kidding, of course, I do need the remote server management tools....)

#13
shaun.murray

shaun.murray

    Newbie

  • Member
  • 21 posts

Excellent! Thats what I have. Does that mean that I installed the wrong version of RSAT tools?


I have 6.1.7600.16385

I'm going to feel like a HUGE moron if I've got the wrong one installed. =[ But, better to feel like a huge moron, and ask you guys, then continue not working, right? I hope.... heh

#14
fizban2

fizban2

    MSFN Addict

  • Super Moderator
  • 1,900 posts
  • OS:Windows 7 x64
  • Country: Country Flag
so we have RTM and RTM, if you check the event logs, what error is being dropped for the failed installation?

#15
shaun.murray

shaun.murray

    Newbie

  • Member
  • 21 posts
It spits out these three errors in the Application log. This what you are looking for? Again... Thanks for ALL the help! =D

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Windows Error Reporting" /> 
  <EventID Qualifiers="0">1001</EventID> 
  <Level>4</Level> 
  <Task>0</Task> 
  <Keywords>0x80000000000000</Keywords> 
  <TimeCreated SystemTime="2009-08-18T17:06:33.000000000Z" /> 
  <EventRecordID>43245</EventRecordID> 
  <Channel>Application</Channel> 
  <Computer>4400SDM.canopyfi.com</Computer> 
  <Security /> 
  </System>
- <EventData>
  <Data>652013287</Data> 
  <Data>5</Data> 
  <Data>CbsPackageServicingFailure2</Data> 
  <Data>Not available</Data> 
  <Data>0</Data> 
  <Data>6.1.7600.16385</Data> 
  <Data>Microsoft-Windows-Foundation-Package</Data> 
  <Data>6.1.7600.16385</Data> 
  <Data>x86</Data> 
  <Data>unknown</Data> 
  <Data>80070643</Data> 
  <Data>Execute</Data> 
  <Data>Installed</Data> 
  <Data>Installed</Data> 
  <Data>DISM Package Manager Provider</Data> 
  <Data /> 
  <Data>C:\ProgramData\Microsoft\Windows\WER\ReportArchive\Critical_6.1.7600.16385_53c9d8dd57efdadbfc5f103e7637f0eeafb28953_16a87957</Data> 
  <Data /> 
  <Data>0</Data> 
  <Data>770c1fc9-8c19-11de-b7b8-002170d9b6cf</Data> 
  <Data>0</Data> 
  </EventData>
  </Event>

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Windows Error Reporting" /> 
  <EventID Qualifiers="0">1001</EventID> 
  <Level>4</Level> 
  <Task>0</Task> 
  <Keywords>0x80000000000000</Keywords> 
  <TimeCreated SystemTime="2009-08-18T17:06:27.000000000Z" /> 
  <EventRecordID>43244</EventRecordID> 
  <Channel>Application</Channel> 
  <Computer>4400SDM.canopyfi.com</Computer> 
  <Security /> 
  </System>
- <EventData>
  <Data /> 
  <Data>0</Data> 
  <Data>CbsPackageServicingFailure2</Data> 
  <Data>Not available</Data> 
  <Data>0</Data> 
  <Data>6.1.7600.16385</Data> 
  <Data>Microsoft-Windows-Foundation-Package</Data> 
  <Data>6.1.7600.16385</Data> 
  <Data>x86</Data> 
  <Data>unknown</Data> 
  <Data>80070643</Data> 
  <Data>Execute</Data> 
  <Data>Installed</Data> 
  <Data>Installed</Data> 
  <Data>DISM Package Manager Provider</Data> 
  <Data>C:\Windows\Logs\CBS\CbsPersist_20090817215536.cab C:\Windows\Logs\CBS\CBS.log C:\Windows\servicing\Sessions\Sessions.xml C:\Windows\winsxs\poqexec.log C:\Windows\inf\setupapi.dev.log</Data> 
  <Data /> 
  <Data /> 
  <Data>0</Data> 
  <Data>770c1fc9-8c19-11de-b7b8-002170d9b6cf</Data> 
  <Data>0</Data> 
  </EventData>
  </Event>

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Windows Error Reporting" /> 
  <EventID Qualifiers="0">1001</EventID> 
  <Level>4</Level> 
  <Task>0</Task> 
  <Keywords>0x80000000000000</Keywords> 
  <TimeCreated SystemTime="2009-08-18T17:06:27.000000000Z" /> 
  <EventRecordID>43243</EventRecordID> 
  <Channel>Application</Channel> 
  <Computer>4400SDM.canopyfi.com</Computer> 
  <Security /> 
  </System>
- <EventData>
  <Data /> 
  <Data>0</Data> 
  <Data>CbsPackageServicingFailure2</Data> 
  <Data>Not available</Data> 
  <Data>0</Data> 
  <Data>6.1.7600.16385</Data> 
  <Data>Microsoft-Windows-Foundation-Package</Data> 
  <Data>6.1.7600.16385</Data> 
  <Data>x86</Data> 
  <Data>unknown</Data> 
  <Data>80070643</Data> 
  <Data>Execute</Data> 
  <Data>Installed</Data> 
  <Data>Installed</Data> 
  <Data>DISM Package Manager Provider</Data> 
  <Data /> 
  <Data>C:\ProgramData\Microsoft\Windows\WER\ReportQueue\Critical_6.1.7600.16385_53c9d8dd57efdadbfc5f103e7637f0eeafb28953_0f5c63c4</Data> 
  <Data /> 
  <Data>0</Data> 
  <Data>770c1fc9-8c19-11de-b7b8-002170d9b6cf</Data> 
  <Data>4</Data> 
  </EventData>
  </Event>


#16
shaun.murray

shaun.murray

    Newbie

  • Member
  • 21 posts
Also, I tried that last install using the command line, and not Add/Remove features. HTH's!

#17
Dechy

Dechy

    Newbie

  • Member
  • 41 posts
Well, I just took my modified WIM, removed the RC RSAT, added the RTM RSAT and re-installed after re-doing the Foundation package in my autounattend.xml and everything works perfectly fine.

I don't want to accuse anybody of anything, but you did get your RTM off MS's website right? Not some leaked torrent?

Did you customize something on your image? Have you tried on a clean install of an unmodified image? Simply can't recreate the problem.

#18
shaun.murray

shaun.murray

    Newbie

  • Member
  • 21 posts
BOO! I gotta reinstall again?? LoL! Thankfully, I'm backing up my media on another partition, and not backing up across the network.

But no, its a legit copy. =] Its our company's copy, as far as I know, it was obtained via MSDN subscription. We have a 64-bit and 32-bit version, I tried the 64-bit, but found out that our email hosting company doesn't support 64-bit Office applications, and had to revert, talk about frustrating.

I guess my next step is contact Microsoft, and see what they say. Just annoying contacting them, cuz it takes FOREVER to get any answers out of them. Thanks again for everyone's help. *cheers*

#19
cluberti

cluberti

    Gustatus similis pullus

  • Supervisor
  • 11,252 posts
  • OS:Windows 8.1 x64
  • Country: Country Flag
I have a Win7 Ultimate RTM box here, and I just installed the RTM RSAT tools and the RTM WAIK, and the command seems to work fine. Not sure why it's failing for you, but it does work as it's supposed to here. Seems like perhaps your install is ... behaving oddly?
MCTS Windows Internals, MCITP Server 2008 EA, MCTS MDT/BDD, MCSE/MCSA Server 2003, Server 2012, Windows 8
--------------------
Please read the rules before posting!
Please consider donating to MSFN to keep it up and running!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN