wazer

Quick Launch Classic 7 Tool 1.0.5

201 posts in this topic

Well just done a new install and cleanup added the QL and 1 other toolbar I have. When it rebooted neither was there

Possible reason is why is this killing Explorer?. Don't think that is needed and reg writes where it will save won't get written correctly

Yes, I think that Killing Explorer isn't really needed. I will make some changes and I will give you a new 7QuickLaunch after some tests!

0

Share this post


Link to post
Share on other sites

When you write to registry it also writes to your current user profile same things. If you close explorer then you lose them. This save when you logoff or reboot

EX: Place new file on desktop and drag to far right. Restart explorer you lose position.

TASKKILL /F /IM explorer.exe
Timeout 2
start explorer.exe

Edited by maxXPsoft
0

Share this post


Link to post
Share on other sites

Sorry for the delay.

I've had some problems with my HDD = Dammaged clusters and Windows won't boot....I need to format the HDD!

No other toolbar sould be present.

Here is the new file 7QuickLaunchClassic_V1.05 without silent switches and deleted some files about refresh explorer:

http://www.mediafire.../?s1tt4383wcjo8

Regards

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

That one didn't work for me, it didn't slide QL back to left. Tried from desktop where there was no other folders open. I have nothing on Taskbar

This one work's here and is one I add to tool's folder

7QuickLaunch.au3

0

Share this post


Link to post
Share on other sites

That one didn't work for me, it didn't slide QL back to left. Tried from desktop where there was no other folders open. I have nothing on Taskbar

This one work's here and is one I add to tool's folder

Thanks maxXPsoft! :rolleyes:

I think at this time we can keep this file because working fine, also for me!

Regards

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Just tested here & will include it in my UA W64 install.:thumbup

0

Share this post


Link to post
Share on other sites

Just included in my latest silent install as a first logon.cmd in my W7x64 xml & the install hangs @ oobe whilst trying to execute the app?

Any possible reason for this behavior?

0

Share this post


Link to post
Share on other sites

I don't do it that early so not sure. I run mine in cleanup.cmd that run's very last.

0

Share this post


Link to post
Share on other sites

I think i might be back soon, so we can finish this project, i my self have had some problems with @ oobe like maverik, at first logon. I dont know what it is yet that makes it fail.

0

Share this post


Link to post
Share on other sites

2.00 beta RC1 :)

With thanks to wazer and everyone, a fairly major upgrade attempt for enjoyment!

Please check it carefully and improve where you can (I don't have access to multilanguage systems and can't test all its features; no reason to believe they don't work but there's surely some rough edges to discover. "Works for me" and may resolve points that others want or like :)

Changelog

  • Full Localisation
  • Full Help at command line (including backlink here)
  • Extra options:
    /LOCKED and /UNLOCKED to set locked or unlocked Taskbar on exit
    /COPYICONS <folder> [/DISABLEOVERWRITE] to auto-copy existing icons into the QL bar at the same time. Optional switch to disable overwrite of existing icons if there's a conflict
    /WIDTH n to set QL bar width (in pixels, default as before is 150)
  • Cleaner and faster window handling - several unnecessary delays removed, popup dialog now hidden, non critical mouse moves are instant
  • Options that should act at specific points (regardless of command line position) were executed in sequence with other parameters. Especially:
    If /? is specified then other options now won't be executed
    /EXPLORER now only executes after all registry items complete
  • User control of mouse/keyboard blocked at key points to prevent errors (with override instructions displayed)
  • Explorer was always closed even when not necessary - now not needed, only closes when requested
  • Several places improved where the 1.05 code had loopholes or assumptions which could conceivably cause issues for some users
  • More complete checking for success or fail on various operations with full error reporting to user
  • Better information (countdown, update messages via tray, etc)
  • Windows properly restored following activity (AutoIt's WinMinimizeAllUndo() doesn't always undo all when there has been intervening activity such as popups)
  • Unnecessary taskbar unlock/relock activity removed
  • Replaced window titles by window handles in several functions
  • #RequireAdmin is needed to manipulate mouse/kbd during BlockInput (AutoIt:Help:BlockInput). This is safer, but may cause a UAC prompt on some machines. The executable's properties should probably be set to "Run as Administrator" I guess (it will ask if needed, if you don't)

Known issues and usage notes:

  • Translation file needs fixing, and existing localisations need testing. Translation is direct from Google Translate with some minor fixes and therefore probably horrible :)
  • Localisation in any language needs to know the Microsoft dialog title for "add new toolbar...". The localisation file is self-obvious and compiling's easy (by anyone) - please feel free to suggest other languages but the dialog title is needed first for any of them. If this can be changed (by reliably identifying the dialog by class??) then it would not be necessary to localise the core code to work with regional dialog titles
  • Further testing, including testing language bar behavior, is needed. Right now "works for me" but every system is different and a lot is new or changed. General checking and improvements appreciated!
  • TAKE CARE WHEN ADDING TO A WINDOWS INSTALL IMAGE! This code requires the desktop to already be displayed (to find the taskbar). Solutions include adding it to Startup items, or running it via a script that only launches this once the desktop's loaded. Just adding it to "Synchronous Commands" or even "First Logon Commands" and nothing else is UNLIKELY TO WORK. (see /WAITDESKTOP in RC1.01 below)

Coding notes:

  • WinMinimizeAllUndo() isn't reliable here, it can forget what windows need restore. So it's done a different way.
  • Traytips only last 10 - 30 seconds, and vanishes upon some kinds of window manipulation. To prevent flicker the "working" tip is redrawn quite often.
  • "Don't press anything! (Esc to cancel)" self-conflicts but I figure people can work out what's meant :)

Hopefully helpful- let me know!

(And hopefully wazer will approve .... maybe :ph34r: )

QuickLaunchClassic_v2.00_RC1.zip

Edited by Stilez
0

Share this post


Link to post
Share on other sites

Update - v2.00 RC1.01

Changelog

  • /WAITDESKTOP - this option causes it to WAIT until both explorer.exe and the main taskbar exist before continuing. This means it will be able to work even if started by some method which causes it to execute before the desktop is created, a common issue for unattended use or slow starting sessions. Due to circumstances this will be used, it does not timeout during the time it's waiting for the desktop.
  • "LeftToRight" or "RightToLeft" language option in Locale file (handled in "help" but not yet anywhere else)
  • /? no longer uses MsgBox, it was getting too long
  • Help file updates

Quick Launch Classic v2.00 RC1.01.zip

Edited by Stilez
0

Share this post


Link to post
Share on other sites

And one last update, v2.00 RC 1.02

This update contains all the "loose ends".

Changelog:

  • Active window now usually restored afterwards. This is generally useful, in particular if the active window was something like WPI which may be showing important status information.
  • Help now fully uses RTF and proper dialog, which makes the help easy to edit and allows it to contain and display full formatting, screenshots, and other images.
  • Old Msgbox() calls cleaned up, old timeouts removed etc.
  • F1 = help now (see traytip). So help is easy to get in the app, not just using command line or source files.
  • Help files updated a lot, complete update of all text and translations.
  • Extra user information, "how to localize", and coder information in a text file (included).

The RC is about complete for me, except for bugs and improved localisation. Hope it's useful! Wazer, hope you like!

Download from MediaFire / FileFactory / DepositFiles

Edited by Stilez
0

Share this post


Link to post
Share on other sites

Thank you stilez for doing the time with us, im very glad that others can contribute to it, as of now i simply dont have the time for it. Ill update the front page with the files you have modifiede, just remember to include source as i want it to stay opensource, if you havnt already done that. i'll check back soon to see if everythings works really well mate :)

0

Share this post


Link to post
Share on other sites
just remember to include source as i want it to stay opensource, if you havnt already done that.

Source all included :) and free licensed CC-by-SA for anything I've added. Check out the "help" page, play round, check the instructions are clear (try compiling it yourself) and see what you think

0

Share this post


Link to post
Share on other sites

The first things i just noted was that you tryed to translate all the languages that i have already added, could you perhaps change them all to english text,(Then ill ask the rest to translate from english to their country) in tray and add the following i already had translated for those languages.

Those here is already translated properly

For

CLASS:MSTaskListWClass; TEXT:

and new toolbar/folder as seen below.

;Case $Lang = English

Case $Lang = "en-US"

$title = "New Toolbar - Choose a folder"

$programs = "[CLASS:MSTaskListWClass; TEXT:Running applications]"

;Case $Lang = French

Case $Lang = "fr-FR"

$title = "Nouvelle barre d’outils - Choisir un dossier"

$programs = "[CLASS:MSTaskListWClass; TEXT:Applications en cours d’exécution]"

;Case $Lang = Dutch

Case $Lang = "nl-NL"

$title = "Nieuwe werkbalk - Selecteer een map"

$programs = "[CLASS:MSTaskListWClass; TEXT:Actieve toepassingen]"

;Case $Lang = Danish

Case $Lang = "da-DK"

$title = "Ny værktøjslinje - vælg en mappe"

$programs = "[CLASS:MSTaskListWClass; TEXT:Programmer, der kører]"

;Case $Lang = Swedish

Case $Lang = "se-SE"

$title = "Nytt verktygsfält - välj en mapp"

$programs = "[CLASS:MSTaskListWClass; TEXT:Program som körs]"

;Case $Lang = Norwegian

Case $Lang = "nb-NO"

$title = "Ny verktøylinje - velg en mappe"

$programs = "[CLASS:MSTaskListWClass; TEXT:Kjører programmer]"

;Case $Lang = German

Case $Lang = "de-DE"

$title = "Neue Symbolleiste - Ordner auswählen"

$programs = "[CLASS:MSTaskListWClass; TEXT:Ausgeführte Anwendungen]"

Im on 10.1 laptop im moving to another place so its annoying todo it on this machine to freaking little :)

Edited by wazer
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.