Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

COM1 not currently available

- - - - -

  • Please log in to reply
1 reply to this topic

#1
bizzybody

bizzybody

    Advanced Member

  • Member
  • PipPipPip
  • 349 posts
  • Joined 08-May 05
I've checked all the BIOS and other settings. There are NO conflicts with anything on COM1. This PC only has one COM port, there's not a COM2, no pin header on the board for one. ONLY ONE COM PORT - PERIOD. No BIOS setting for a second one.

I was using an external Sportster 56K modem before getting DSL. I REMOVED THE DRIVER FOR IT.

I'm attempting to get an old HP 7470A 2-color pen plotter (rebadged as an IBM 7371) working on COM1. I've installed XP's HP-GL plotter driver. I've made sure the driver settings and plotter DIP switches match. (I've had a bag of red HP plotter pens for years, got them free. The plotter cost me a whole dollar.)

HP's website says the plotter can be tested by sending this command from DOS or a command prompt.

MODE COM1: 9600,N, 8,1,P (sets the port)

ECHO IN; SP1; PA0, 0;PD1000, 1000;SP0; PG;>COM1 (makes the plotter draw a diagonal line)

The first command worked ONE TIME. I'd removed the plotter driver while trying to get some response from the plotter and forgot it was removed when I tried the second line.

Since then all I get is the "Device COM1 is not currently available" message when I try a MODE command. I get access is denied when I try the test command.

I've disabled the port, rebooted then re-enabled the port and rebooted (flashback to Win9x and changing anything on network settings) and tried removing COM1 then rebooting and letting XP reinstall it.

I am logged in as a user with Administrator rights.

Nothing will pry loose whatever it is XP has "using" COM1. Is there something like an Unlocker type utility to force Windows to let go of COM ports that aren't really being used?

Edit: I tried making a direct connection to COM1 with HyperTerminal. That says another program is using COM1. There shouldn't be. It was available right up until I ran that MODE command.

Edit2: Found a post on another forum that said to use Process Explorer and search for serial1 Results? NOTHING. The OP on that thread found it was ActiveSync hogging his port. Apparently I have nothing using COM1, but XP thinks *something* is. (Another button for Sledgehammer For Windows: "Force Windows to let go of COM# port! It's NOT in use, biatch!"")

Edited by bizzybody, 16 September 2009 - 12:16 AM.



How to remove advertisement from MSFN

#2
bizzybody

bizzybody

    Advanced Member

  • Member
  • PipPipPip
  • 349 posts
  • Joined 08-May 05
Figured out it needed a null modem type cable, so I scrounged up a 25 pin serial and 25 pin parallel backplate connectors and soldered one together.

Now I'm able to make the plotter do things using the Roland driver I've seen mentioned many places working great with old HP HPGL/1 plotters, but so far it's not plotting correctly what's on screen in Dr. Stika.

That driver has no pre-sets for US Letter! When I manually add that, Dr. Sticka's print setup doesn't allow the custom media size to be selected. Bleah.

At least I have the thing communicating.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users