blue4603

7Customizer - a Windows 7 Customization and Deployment tool

1,630 posts in this topic

Just DL your tool, running on W7 x86 can multiple updates be managed or single only?

0

Share this post


Link to post
Share on other sites
Just DL your tool, running on W7 x86 can multiple updates be managed or single only?

Multiple updates and languages can be installed.

Regards

Edited by blue4603
0

Share this post


Link to post
Share on other sites

Just tried would only allow single msu & not multiple?

Also received below screen error when applying.

Edited by MAVERICKS CHOICE
0

Share this post


Link to post
Share on other sites
Just tried would only allow single msu & not multiple?

Also received below screen error when applying.

WOW , the first bug :rolleyes:

Thanks for posting this. I will look in that tomorrow since it is midnight now and I need to sleep.

Regards

0

Share this post


Link to post
Share on other sites
I could possibly help out, what language are you programming in.

As for the removal of packages, have an idea for that, but don't think Install_WIM_Tweak.exe is working with DISM currently, so we would either have to mount/unmount with the Vista WAIK imagex, or need re-write a new Install_WIM_Tweak.exe to work with DISM

Basic idea was populate a simple tree-view / Check Box control just like vLite or WUD with the package listing from DISM /GET-PACKAGES command.

What do you think ?

I am using C#.

To mount and and commit and service the image, I use imagex and dism from the windows 7 WAIK. That means this program should not work on XP since WAIK for 7 does not support XP (Sorry this problem is from Microsoft).

Regarding the packages I think we could look into that later. Because I want to finish these functions:

1. Integrate Language (Done)

2. Integrate Updates (Done)

3. Basic Unattended

The tool should know what updates and languages are already installed (You could call this a function two)

After that I will give the program to the people to test it and then implement other functions

@Chester^,@1to1,@filmbot,@TheWalrus

Thanks for your interest

Regards

hi im new here i have been trying to learn C# but i pretty much stopped after 6 weeks because MS dropped support for my Zune 120 i kno im one of a dozen people with a zune but any who i have an old piece of s*** computer and when i try to have my realtek drivers automatically installed with vlite it pops up about 25 times and takes about half an hour to get past that so if you could somehow make it not do that that would be awesome if thats even possible

if you cant its not a big deal but yeah im testing right now

-EDIT-

i just tested it it vlited it down to 1.3gb for the install.wim and only the ulimate version is in there and it says please select a version from the list and there is no list

Edited by marcusj0015
0

Share this post


Link to post
Share on other sites
glad to hear a tool like this is in development. i cant wait to test.

You can start now because there is a test build.

hi im new here i have been trying to learn C# but i pretty much stopped after 6 weeks because MS dropped support for my Zune 120 i kno im one of a dozen people with a zune but any who i have an old piece of s*** computer and when i try to have my realtek drivers automatically installed with vlite it pops up about 25 times and takes about half an hour to get past that so if you could somehow make it not do that that would be awesome if thats even possible

if you cant its not a big deal but yeah im testing right now

-EDIT-

i just tested it it vlited it down to 1.3gb for the install.wim and only the ulimate version is in there and it says please select a version from the list and there is no list

That's some quite odd story you have there. Anyways, integrating drivers will come later.

Regarding your issue, the program builds only one image ( the one you select in the beginning).

Regarding not showing any version in the list, if you could attach a screen-shot and provide more info, that would be more helpful.

Regards

0

Share this post


Link to post
Share on other sites

How do you check for ImageX.exe?

reason i ask, it looks like the program only checks at drive C: and my system(windows installation and program files folder) drive is G: and it does not find it...

post-39954-1256648494_thumb.png

i tried running the program from G: and C: same results. Win7 x64

0

Share this post


Link to post
Share on other sites
How do you check for ImageX.exe?

reason i ask, it looks like the program only checks at drive C: and my system(windows installation and program files folder) drive is G: and it does not find it...

i tried running the program from G: and C: same results. Win7 x64

yes it checks at drive C: only

I think I will let the user choose where is imagex and dism are located

Thanks for the feedback

Regards

0

Share this post


Link to post
Share on other sites

thnx for creating this masterpiece B) ! just downloaded the tool

butttttt i forgot to install aik :sneaky:

in a few minutes i hope that i can give you some feedback

Edited by TripNRaVeR
0

Share this post


Link to post
Share on other sites
thnx for creating this masterpiece cool.gif ! just downloaded the tool

butttttt i forgot to install aik shifty.gif

in a few minutes i hope that i can give you some feedback

Do not forget to grab the latest build.

Thanks for helping

Regards

1

Share this post


Link to post
Share on other sites

DL the latest release found paths ok, lang ok, picked up the updates one @ a time ok. Hit apply but prog doesn't seem to mount the image & done appears?

0

Share this post


Link to post
Share on other sites
DL the latest release found paths ok, lang ok, picked up the updates one @ a time ok. Hit apply but prog doesn't seem to mount the image & done appears?

Could you provide more info?

0

Share this post


Link to post
Share on other sites

cant get it to work.. it keeps complaining s*** about batch is being used by another process

fatal error :ph34r:

************** Tekst van uitzondering **************

System.IO.IOException: Kan geen toegang krijgen tot het bestand C:\Users\Noeri\Documents\7Customizer\work\batch.bat omdat het wordt gebruikt door een ander proces.

bij System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)

bij System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy)

bij System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy)

bij System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options)

bij System.IO.StreamWriter..ctor(String path, Boolean append, Encoding encoding, Int32 bufferSize)

bij System.IO.StreamWriter..ctor(String path)

bij _7Customizer.Form1.startBtn_Click(Object sender, EventArgs e)

bij System.Windows.Forms.Control.OnClick(EventArgs e)

bij System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)

bij System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)

bij System.Windows.Forms.Control.WndProc(Message& m)

bij System.Windows.Forms.ButtonBase.WndProc(Message& m)

bij System.Windows.Forms.Button.WndProc(Message& m)

bij System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)

bij System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

0

Share this post


Link to post
Share on other sites
DL the latest release found paths ok, lang ok, picked up the updates one @ a time ok. Hit apply but prog doesn't seem to mount the image & done appears?

Could you provide more info?

Once I press the "apply" button the program quickly gives a progress "Done" button. Image not mounted or touched.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.