blue4603

7Customizer - a Windows 7 Customization and Deployment tool

1,630 posts in this topic

All my files inc your program are in the root of my "C" drive.

Then I suggest you wait for the next release.

Regards

0

Share this post


Link to post
Share on other sites

Hi Blue,

I've been using your tool very successfully.

One thing I would really like is a command line interface so I can apply updates from a batch file, perhaps even specify a folder where update files are (this would be useful in the GUI too).

Do you want logs from successful integrations? I am at work at the moment but can post logs later if you wish.

Thanks,

Rich

0

Share this post


Link to post
Share on other sites
Hi Blue,

I've been using your tool very successfully.

One thing I would really like is a command line interface so I can apply updates from a batch file, perhaps even specify a folder where update files are (this would be useful in the GUI too).

Do you want logs from successful integrations? I am at work at the moment but can post logs later if you wish.

Thanks,

Rich

Thanks Rich for the feedback. Glad it worked for you.

Yes it would be great if you post the log, if you do not mind. Successful logs will clear some of the doubts for me.

Regarding your suggestion, this could be developed later. Because this is like a bonus feature not an essential one.

Regards

0

Share this post


Link to post
Share on other sites

Blue, it seems the problem with the folder name is not fixed.

I changed the folder where my source file are kept from 'win' to 'win7 pro' then i recieved this error.

=== 7Customizer Started===
7Customizer Verion: 0.1.7
OS: Microsoft Windows NT 6.1.7600.0
OS Architecture: AMD64
Work folder found: True
Mount folder found: True
Extract utility found: True
Configuration File found: True
Getting drive info
Getting drive info: Done
Windows Source Path Selected
Sources Folder Found
install.wim Found
Starting imagex
Imagex created imagesinfo.xml Successfully
Reading images information from imagesinfo.xml
Unexpected Error: Data at the root level is invalid. Line 2, position 1.
at System.Xml.XmlTextReaderImpl.Throw(Exception e)
at System.Xml.XmlTextReaderImpl.ParseRootLevelWhitespace()
at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
at System.Xml.XmlDocument.Load(XmlReader reader)
at System.Xml.XmlDocument.Load(String filename)
at _7Customizer.Form1.selectImagePathBtn_Click(Object sender, EventArgs e)

log.txt

Renamed the source folder back to 'win'. An it works fine :rolleyes:

I'll upload a successful.log as well in a mo

**EDIT**

When I click 'Skip creating user' the username an password box highlights. It should be the other way around ;-)

Suggestion -

in the apply windows, any chance there can be a progress bar added or text box with a log of whats happening?

**EDIT**

Here is the sucess log -

successlog.txt

Edited by SheepyDaz
0

Share this post


Link to post
Share on other sites
When I click 'Skip creating user' the username an password box highlights. It should be the other way around ;-)

No this is the way it should. When you skip user creation, you create a user to autologon to the system. Also, I could not find a way to autologon as administrator .

Suggestion -

in the apply windows, any chance there can be a progress bar added or text box with a log of whats happening?

It is already showing you the progress in the command window.

Thanks for the feedback.

Regards

0

Share this post


Link to post
Share on other sites
Hi Blue,

I've been using your tool very successfully.

One thing I would really like is a command line interface so I can apply updates from a batch file, perhaps even specify a folder where update files are (this would be useful in the GUI too).

Do you want logs from successful integrations? I am at work at the moment but can post logs later if you wish.

Thanks,

Rich

Thanks Rich for the feedback. Glad it worked for you.

Yes it would be great if you post the log, if you do not mind. Successful logs will clear some of the doubts for me.

Regarding your suggestion, this could be developed later. Because this is like a bonus feature not an essential one.

Regards

I understand you want to get it more stable etc first, just thought i'd share my views seeing as it does exactly what I want, and it works, already :thumbup

I have attached my successful log.

Thanks again,

Rich

log.txt

0

Share this post


Link to post
Share on other sites

@richy759

Thanks for the feedback. Although it is working fine for you some members still having trouble.

Glad it worked for you.

Regards

0

Share this post


Link to post
Share on other sites

Look not disputing the authenticity of Richy's log. though isn't a whole lot different to mine when in fact did not integrate any hotfixes correctly @ all?

0

Share this post


Link to post
Share on other sites
Look not disputing the authenticity of Richy's log. though isn't a whole lot different to mine when in fact did not integrate any hotfixes correctly @ all?

On the contrary, he added some updates (6 of them to be exact).

Regards

0

Share this post


Link to post
Share on other sites

Heres my log.

Your very fast with a new version thats great :).. Dont afraid that people wont come in here and give feedback.

You just have to give them some time its not all that got alot of sparetime you know the "important jobs the housewifes & kids etc etc."

im sure theres alot in here theres willing to test all new version quick as possible, including my self.

For now your doing a great job and I appriciate it, im sure the rest does aswell :)

Keep up the good coding mate.

0

Share this post


Link to post
Share on other sites
Heres my log.

Your very fast with a new version thats great smile.gif.. Dont afraid that people wont come in here and give feedback.

You just have to give them some time its not all that got alot of sparetime you know the "important jobs the housewifes & kids etc etc."

im sure theres alot in here theres willing to test all new version quick as possible, including my self.

For now your doing a great job and I appriciate it, im sure the rest does aswell smile.gif

Keep up the good coding mate.

Thanks man for the advice and the feedback.

I requested that because when people provide feedback, it motivates you. Now, I am dealing with simple features (adding updates, languages ..etc). Later on it will become harder and it will needs more people feedback. If people provide more feedback, this will help me producing better client and it will help them getting an error free toll with more features.

Glad 7Customizer worked for you and I appreciate your cooperation and enthusiasm.

Regards

0

Share this post


Link to post
Share on other sites

Nice work you're doing blue :thumbup

I currently use this guide HERE, to slim down windows 7

How will the removal components part in your program work ? Will it it use dism/imagex commands like on the link above but with a GUI ?

Edited by dridzz
0

Share this post


Link to post
Share on other sites
Nice work you're doing blue thumbup.gif

I currently use this guide HERE, to slim down windows 7

How will the removal components part in your program work ? Will it it use dism/imagex commands like on the link above but with a GUI ?

Thanks for the link.

yes it will use imagex an dism of course and with a GUI. It will be similar to vlite. However, removing components will come later. The focus now is on debugging errors and adding drivers and applications. Then, I think tweaks will come. After that the removing components part. That is my plan.

Thanks for the feedback.

Regards

0

Share this post


Link to post
Share on other sites

sounds good :D

im getting an error after selecting the imagepath

here is my log file.

=== 7Customizer Started===
7Customizer Verion: 0.1.7
OS: Microsoft Windows NT 6.1.7600.0
OS Architecture: AMD64
Work folder found: True
Mount folder found: True
Extract utility found: True
Configuration File found: True
Getting drive info
Getting drive info: Done
Windows Source Path Selected
Sources Folder Found
install.wim Found
Starting imagex
Imagex created imagesinfo.xml Successfully
Reading images information from imagesinfo.xml
Unexpected Error: Object reference not set to an instance of an object.
at _7Customizer.Form1.selectImagePathBtn_Click(Object sender, EventArgs e)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.