blue4603

7Customizer - a Windows 7 Customization and Deployment tool

1,630 posts in this topic

=== 7Customizer Started===

7Customizer verion: 0.4.4

7Customizer path: C:\Archive Temp\7Customizer_0.4.4\7Customizer.exe

Current directory: C:\Archive Temp\7Customizer_0.4.4

OS: Microsoft Windows NT 6.1.7600.0

OS architecture: x86

@jslegers

I think it's better to expand "7Customizer_0.4.4.rar" on a partition (C:\; H:\; F:\,...) and not on a temp folder.

Regards

Well archive temp is a folder but the spacing isnt good..

0

Share this post


Link to post
Share on other sites

@ blue

I have one question for the integration of Wallpapers.

Is not it possible that you can replace the original wallpaper directly ?

I think that is integrating the user their own, do not need the original wallpaper.

Is this just be an idea to me.

Especially the new wallpaper then present directly after the Windows 7 installation.

Otherwise, many thanks :thumbup for the new version and the integration of languages

@ All

What do you think about it?

beatmaster

Im pretty sure he can make a checkbox called "default wallpaper" or something like that, its not impossible ofcourse:)

0

Share this post


Link to post
Share on other sites

His problem is that he picked x64 for DISM; Imagex and oscdimg when he's using an 32bit OS


OS architecture: x86
ImageX Path: C:\Program Files\Windows AIK\Tools\amd64\imagex.exe
Dism Path Selected
Dism Path: C:\Program Files\Windows AIK\Tools\amd64\Servicing\Dism.exe
Oscdimg Path Selected
oscdimg Path: C:\Program Files\Windows AIK\Tools\amd64\oscdimg.exe

On the first page:


4. When choosing the path for ImageX and DISM, make sure you choose the same exe architecture (x86 or amd64) as your Windows.
eg when using Windows 7 x64 choose the ImageX located in amd64 inside the WAIK installation

This was indeed the issue. Thanks for the help. Great tool. Is this from the same developer as nLite?

0

Share this post


Link to post
Share on other sites

@ netwave

Tinkering with build 0.4.4,

Blue is there any chance you could add a remove button to both themes & wallpapers, luckily I saved my custom presets so didnt have to entirly restart from scratch.

Thanks

Yeah that could be done.

@ pedilover

Hi Blue,

thanks for 0.4.4 with language support from Beatmaster of german win-lite forum.

I have integrated many updates again. Also many drivers and themes. All these are really integrated and I can chose my theme which I want to see.

Of course I have made it on a running 64-bit-system !So the 64-bit drivers are integrated!

I used always the same environment (always 64-bit!).

Thanks for your feedback. I have one question for you.

Is your host OS localized or not?

@ beatmaster

@ blue

I have one question for the integration of Wallpapers.

Is not it possible that you can replace the original wallpaper directly ?

I think that is integrating the user their own, do not need the original wallpaper.

Is this just be an idea to me.

Especially the new wallpaper then present directly after the Windows 7 installation.

Otherwise, many thanks :thumbup for the new version and the integration of languages

@ All

What do you think about it?

beatmaster

As grabben mentioned, I will put a check to set the default wallpaper.

Thanks guys for the feedback

Regards

0

Share this post


Link to post
Share on other sites

@Blue

I have a localiced Win 7 64-bit prof.: only german. I did not integrade language-packs.

Now everything I have tested so far, runs very good.

If it is possible to integrated wallpapers which run at the first start without selection ,like Beatmaster has proposed, this would be a great feature.

Edited by pedilover
0

Share this post


Link to post
Share on other sites

Hello Blue. :rolleyes:

Thank you very much for your good and nice software.

I see the command line inside the batch works fine and "Everyone" is translated in my computer in french language "Tout le monde":

echo ==Integrating themes==

mkdir "work\mount\Users\Default\AppData\Local\Microsoft\Windows\Themes"

cacls "work\Themes" /e /t /p "Tout le monde":Fmove /y "work\themes\CustomTheme0" "work\mount\Users\Default\AppData\Local\Microsoft\Windows\Themes"

move /y "work\themes\CustomTheme1" "work\mount\Users\Default\AppData\Local\Microsoft\Windows\Themes"

rd /s /q "work\Themes"

md "work\Themes"

However, I think the commands "rd" and "md" are working fine if I launch these one in my computer but not when some programs are running for theirs installations. However the folders inside "Themes" are really deleeted and all is fine!

But I've made the experience and it's work fine if I change to:

RMDIR /S /Q "work\Themes"

MKDIR "work\Themes"

I see just a little detail, inside the window when you click the tab Tweaks\Services at the top, in the left pane inside the word "serice" the letter v is missing.

Regards

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Blue,

Ive been adding today's win updates to a new 7.ISO image

Loaded my "saved presets" but noticed in Tweaks/Sevices my settings were not saved? All other custom settings appeared to have reloaded as expected!

This applies to build 0.4.4

Could an option be added to save custom settings for services please?

:thumbup

0

Share this post


Link to post
Share on other sites

@ pedilover

@Blue

I have a localiced Win 7 64-bit prof.: only german. I did not integrade language-packs.

Now everything I have tested so far, runs very good.

If it is possible to integrated wallpapers which run at the first start without selection ,like Beatmaster has proposed, this would be a great feature.

Yeah. That is on the to do list.

Thanks for the feedback.

However, I think the commands "rd" and "md" are working fine if I launch these one in my computer but not when some programs are running for theirs installations. However the folders inside "Themes" are really deleeted and all is fine!

Hmmm. If the folders inside the themes are deleted then everything is fine.

But I've made the experience and it's work fine if I change to:

RMDIR /S /Q "work\Themes"

MKDIR "work\Themes"

rmdir is exactly the same as rd

mkdir is exactly the same as md

You could use either of them

I see just a little detail, inside the window when you click the tab Tweaks\Services at the top, in the left pane inside the word "serice" the letter v is missing.

Thanks for reporting I will fix it in the next release.

@ netwave

Blue,

Ive been adding today's win updates to a new 7.ISO image

Loaded my "saved presets" but noticed in Tweaks/Sevices my settings were not saved? All other custom settings appeared to have reloaded as expected!

This applies to build 0.4.4

Could an option be added to save custom settings for services please?

The services are already saved in the preset. if it did not work for you, post your preset file.

Thanks guys for the feedback.

Regards

0

Share this post


Link to post
Share on other sites

@Blue

I have yet a problem which is not solved. The Marvell Yukon Ethernet Driver v11.24.5.3 is not integrated. Your tool does not report any problems while it works. Have you any idea ? All other drivers are integrates without probs.

DISM does not cooperate with this Driver ? I have extract the files with 7zip.

0

Share this post


Link to post
Share on other sites

@ pedilover

have yet a problem which is not solved. The Marvell Yukon Ethernet Driver v11.24.5.3 is not integrated. Your tool does not report any problems while it works. Have you any idea ? All other drivers are integrates without probs.

DISM does not cooperate with this Driver ? I have extract the files with 7zip.

As I mentioned in the first post. If a driver is not integrated, then it is a problem with dism not 7Customizer

Regards

0

Share this post


Link to post
Share on other sites

I noticed on Twitter that you started playing around with components removal. I am greatly impressed! Can't wait for test version :)

0

Share this post


Link to post
Share on other sites

Hello Blue :rolleyes:

Thanks for your answers. But it's not possible to modify the batch file during the exécution of this one because 7Customizer is running! Maybe there is a possibility to make changes? But at this time this is not an issue!

Regards

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

@ TheWalrus

I noticed on Twitter that you started playing around with components removal. I am greatly impressed! Can't wait for test version

You will be impressed more by the way of how I am doing it. Regarding a test version, I might be able to make one by the end of the day (it is 10 in the morning now). If it isn't done by today, then you will have to wait until Saturday (Thursday and Friday are weekends here in Saudi Arabia).

@ myselfidem

Thanks for your answers. But it's not possible to modify the batch file during the exécution of this one because 7Customizer is running! Maybe there is a possibility to make changes? But at this time this not an issue!

Regards

Hmmmmm. I think it could be done. However, I will look at it later.

Regards

Edited by blue4603
0

Share this post


Link to post
Share on other sites
Hmmmmm. I think it could be done. However, I will look at it later.

Regards

Thanks Blue. :rolleyes:

0

Share this post


Link to post
Share on other sites

Already started testing component removal ? :o awesome:)

How do you make 7C? in what program ?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.