maxXPsoft

Ask your Seven xml ? here

616 posts in this topic

Ok I can confirm it installs ok even in the original format <CommandLine>cmd /c start /wait %systemdrive%\TEMP\systemupdate401-2011-07-25.exe -s -a /s /v"/qn"</CommandLine>

IF the command is run FIRST. It doesn't for otherwise for me. What's the deal here??

0

Share this post


Link to post
Share on other sites

Ok I can confirm it installs ok even in the original format <CommandLine>cmd /c start /wait %systemdrive%\TEMP\systemupdate401-2011-07-25.exe -s -a /s /v"/qn"</CommandLine>

IF the command is run FIRST. It doesn't for otherwise for me. What's the deal here??

Try running the previous command with the /wait. It is possible that the your EXE needs to use a process that is locked by a previous command. While it may add some extra time, I've learned to run all my commands with a wait on it.

0

Share this post


Link to post
Share on other sites

Unfortunately it's not the case. I had the /wait parameter specified in all the commands until yesterday and it didn't work anyway. Real mystery this...

0

Share this post


Link to post
Share on other sites

Ok I can confirm it installs ok even in the original format <CommandLine>cmd /c start /wait %systemdrive%\TEMP\systemupdate401-2011-07-25.exe -s -a /s /v"/qn"</CommandLine>

IF the command is run FIRST. It doesn't for otherwise for me. What's the deal here??

Maybe the problem may be due to lack of space in the % temp% folder to deploy the application and install it. And happy to see it works by installing it first!

0

Share this post


Link to post
Share on other sites

I am not happy at all because this program is really dodgy and seems to live a life of its own :P

There is no logical explanation for its behaviour.

Plenty of space on the disk so not a problem there...

In the end I gave up and just install it manually. And you know what? It doesn't even work - it crashes as soon as I try to check for updates :P Gotta love Lenovo. Their products are weird at least.

0

Share this post


Link to post
Share on other sites

I have some problem with my xml, please help me MaxXPoft or myselfidem, I have taken myselfidem's autounattend.xml and modified it, but I am still facing some problem, please help me with following issues;

1. EULA window is still appearing, I can't post screenshot as it is only appearing on actual machine but not in virtual machine.

2. I see a Blank window just after OOBE animation for about 15-20 secs

3. I have used autologon but after installation when I set the password for Administrator and reboot, it again try to login automatically, and then I see a msg, of "The username of password is incorrect". How can I rectify my xml so that once I set the password it should not try to login automatically and wait at logon screen for me to enter password, instead for trying to login automatically.

My xml is attached herewith.

Autounattend.xml

0

Share this post


Link to post
Share on other sites

Inside your Autounattend.xml file!

1. <AcceptEula> wasn't at the good place move to <UserData>

2. <DynamicUpdate> value change to <WillShowUI>Never</WillShowUI>

I'm guessing a blank window appears because the value was <WillShowUI>Always</WillShowUI> and <Enable>false</Enable>

3. Add for <AutoLogon> value: <LogonCount>3</LogonCount>

Like this you need to enter your password after 3 times AutoLogon!

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Thanks mate, If I set Autologon value to 3 it will not try to log on automatically after 3 times, you have set this value to 3 because OS reboot for 3 times during the entire installation?

And regarding key, can I use "/image/index" at the both the places i.e. in user data of International-core-winpe and product key in user data, as I have already integrated the key in the wim itself.

Edited by nice_guy75
0

Share this post


Link to post
Share on other sites

Yes 2 or 3 times...It's better to use 3 times, or you can use 10 times!

Try the Autounattend.xml file attached and let me know the result, please...And use the same password!

Regards

*Edit: Remove this seetiings, if the key is already integrated:

<settings pass="windowsPE"> inside: <UserData>


<ProductKey>
<WillShowUI>OnError</WillShowUI>
<Key>XXXXX-XXXXX-XXXXX-XXXXX-XXXXX</Key>
</ProductKey>

And inside <settings pass="specialize">:


<ProductKey>XXXXX-XXXXX-XXXXX-XXXXX-XXXXX</ProductKey>

>/IMAGE/INDEX< = is for the OSImage installation only!


<ImageInstall>
<OSImage>
<InstallFrom>
<MetaData wcm:action="add">
<Key>/IMAGE/INDEX</Key>
<Value>1</Value>
</MetaData>
</InstallFrom>
<WillShowUI>OnError</WillShowUI>
<InstallToAvailablePartition>true</InstallToAvailablePartition>
</OSImage>
</ImageInstall>

Your new Autounattend.xml file without key.

Autounattend.xml

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Problem:

**** Customer experience improvement program is still enabled despite having

<component name="Microsoft-Windows-SQMApi" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<CEIPEnabled>0</CEIPEnabled>
</component>

in my unattended file.

Help! What else do I need to disable it? Documentation doesn't mention anything in addition to this simple setting.

Edited by TheWalrus
0

Share this post


Link to post
Share on other sites

Have you set this value on setting pass specialize ?

However:

This setting has no effect on Server Core installations of Windows Server 2008.

And I can read also another value:

XML Example

The following XML output shows how to enable Windows CEIP.

<CEIPEnabled>true</CEIPEnabled>

Maybe you can also try the value: false ?

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Yes...Weird...And we can also read here:

Microsoft-Windows-SQMAPI

<CEIPEnabled>true</CEIPEnabled>

Maybe that can help you :

Allow Microsoft to collect information about how I use Lync

Look at this link also:

Windows Customer Experience Improvement Program

Maybre you can use this reg file:

Disable_CEIP.reg


Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SQMClient\Windows]
"CEIPEnable"=dword:00000000

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.