Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

TakeOwnership / Windows 7 / TrustedInstaller Issues


  • Please log in to reply
5 replies to this topic

#1
MrJinje

MrJinje

    Tool™ Developer

  • Developer
  • 1,067 posts
  • Joined 14-October 09
  • OS:Server 2012R2
  • Country: Country Flag
How come TakeOwnership reg hack is not working for everyone. It works for some, but many readers reporting it doesn't work for them at all :realmad:

Why would some users have no problem taking ownership of TrustedInstaller files but others report they can't do it with the reg-hack, or manually from an Elevated Command prompt. Since we know the reg-hack runs elevated this can't be a user mistake or command line typo, it's gotta be a settings issue.

Any ideas. Currently have Defender and UAC disabled, (via vLite tweak) maybe that is why it works for me, anyone currently having problems want to test this for us and report back.

Edited by MrJinje, 16 November 2009 - 10:04 AM.



How to remove advertisement from MSFN

#2
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,127 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

The takeown /grant command uses localized names for the groups. On an English windows it is administrators. On a German Windows the name of the group administrators is Administratoren. Use the following fix I've submitted to XPero's tool "TakeControl":

http://www.msfn.org/...p...st&p=667868

This will work for all languages.
Posted Image

#3
MrJinje

MrJinje

    Tool™ Developer

  • Developer
  • 1,067 posts
  • Joined 14-October 09
  • OS:Server 2012R2
  • Country: Country Flag
If language is the problem, this is easy fix. Maybe I can Re-write it multi-lingual using the Well Known SID. Let me get someone to test it for me, and I will post it back here.

Attached Files


Edited by MrJinje, 16 November 2009 - 03:17 PM.


#4
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,127 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

my fix works. It is included in the Tool from XPero. You can use it and it will work.
Posted Image

#5
MrJinje

MrJinje

    Tool™ Developer

  • Developer
  • 1,067 posts
  • Joined 14-October 09
  • OS:Server 2012R2
  • Country: Country Flag

my fix works. It is included in the Tool from XPero. You can use it and it will work.

Sorry, Xpero's links were dead, never saw it. No worries, once you mentioned it was language issue, I knew the answer straight away.

http://www.xpize.net...keControlb2.zip

Server Error
404 - File or directory not found.
The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

For future reader's use this reference to create your own multi-lingual safe batch scripts.

http://support.microsoft.com/kb/243330

#6
MrJinje

MrJinje

    Tool™ Developer

  • Developer
  • 1,067 posts
  • Joined 14-October 09
  • OS:Server 2012R2
  • Country: Country Flag

and here is the reverse setting, forcing ownership back to TrustedInstaller language independently.  Useful if you have taken ownership of a system file and have some unknown reason to set it back.

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\runas]
@="Force Ownership"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\*\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant *S-1-5-80-956008885-3418522649-1831038044-1853292631-2271478464:F"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant *S-1-5-80-956008885-3418522649-1831038044-1853292631-2271478464:F"

[HKEY_CLASSES_ROOT\Directory\shell\runas]
@="Force Ownership"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\Directory\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant *S-1-5-80-956008885-3418522649-1831038044-1853292631-2271478464:F /t"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant *S-1-5-80-956008885-3418522649-1831038044-1853292631-2271478464:F /t"

Attached File  forceownership_trustedinstaller.reg   858bytes   7 downloads


Edited by MrJinje, 29 September 2013 - 04:43 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users