stefanRTR

stefanRTR's Win Integrator

229 posts in this topic

@ Alex

Aaah, well that might work, never thougt of that :P

Working on the component section is very important but i say taking care of all other and also unattended is fare more important, just like 7C.

So Stefan, when is the next version coming :P..

0

Share this post


Link to post
Share on other sites

Hey

Great tool.....Is there a "how to" somewhere....?

Can not add drivers when they still are rar'ed. :blushing:

Do I need to unpack all drivers, after dowloading them.... :huh:

When I tried to search for *.inf and add all "findings"....>error

Edited by Floppy
0

Share this post


Link to post
Share on other sites
Hey

Great tool.....Is there a "how to" somewhere....?

Can not add drivers when they still are rar'ed. :blushing:

Do I need to unpack all drivers, after dowloading them.... :huh:

When I tried to search for *.inf and add all "findings"....>error

This tool cant be moer simple to use. just look and click..

Why should u be able to integrate drivers when they're .rar'ed ? unpack them all and then integrate.

0

Share this post


Link to post
Share on other sites
This tool cant be moer simple to use. just look and click..

I was asking because ther might be more to it!

Why should u be able to integrate drivers when they're .rar'ed ? unpack them all and then integrate.

Iam used to DriverPack (You can find it here-->http://forum.driverpacks.net) using it for WinXp.

If this tool could integrate drivers without expanding the pack's....well that would be great. :thumbup

When I tried to search for *.inf and add all "findings"....>error

If i split the "add drivers"(from the search list) i two, it's ok....

Edited by Floppy
0

Share this post


Link to post
Share on other sites
Iam used to DriverPack (You can find it here-->http://forum.driverpacks.net) using it for WinXp.

If this tool could integrate drivers without expanding the pack's....well that would be great. :thumbup

When I tried to search for *.inf and add all "findings"....>error

If i split the "add drivers"(from the search list) i two, it's ok....

But really, why would you want to add 100 drivers you don't need? Thats what those packs do. If you setting up on 10 different PC's then maybe so.

Use driver magician Free if you are on Win 7 and you are done, works also with Vista drivers on 7. 7 is pretty good about drivers for most part

0

Share this post


Link to post
Share on other sites
If you setting up on 10 different PC's then maybe so.

Use driver magician Free if you are on Win 7 and you are done, works also with Vista drivers on 7. 7 is pretty good about drivers for most part

Iam setting up 20-25 Pc a week.....I hate looking for drivers.....

0

Share this post


Link to post
Share on other sites
Iam setting up 20-25 Pc a week.....I hate looking for drivers.....

but I doubt very seriously you are setting up 20 different models. we use mostly dell at work, 4 diferent types so it's pretty straight forward what to include

0

Share this post


Link to post
Share on other sites

it has support, but only for Integrating MUIs and updates. Removing only works with Windows 7, because of DISM Limitations.

Edited by MagicAndre1981
0

Share this post


Link to post
Share on other sites

will it integrate drivers also? can vlite integrate drivers into 7? i am going to be switching to 7 here shortly and want to integrate some drivers into it. also, is there solution for unattended yet? i want to integrate my key too.

0

Share this post


Link to post
Share on other sites

oops, sorry about that :blushing:

Edited by hclarkjr
0

Share this post


Link to post
Share on other sites

you want to know if Win Integrator runs on Vista Sp2? Yes! But you have to install the WAIK for Windows 7.

0

Share this post


Link to post
Share on other sites

ok, tried to run this on vista service pack 2 machine and got this error -

9:24:41 AM.252:Thread:1: Starting WinIntegrator, Version=1.0.2.0, Culture=neutral, PublicKeyToken=861173525dbe9e68

9:24:41 AM.268:Thread:1: Running on Microsoft Windows NT 6.0.6002 Service Pack 2 x64, ProcessorCount=4

9:24:41 AM.268:Thread:1: Privileges:

IncreaseQuota => Disabled

Security => Enabled

TakeOwnership => Enabled

LoadDriver => Disabled

SystemProfile => Disabled

SystemTime => Disabled

ProfileSingleProcess => Disabled

IncreaseBasePriority => Disabled

CreatePageFile => Disabled

Backup => Enabled

Restore => Enabled

Shutdown => Disabled

Debug => Enabled

SystemEnvironment => Disabled

ChangeNotify => EnabledByDefault, Enabled

RemoteShutdown => Disabled

Undock => Disabled

ManageVolume => Disabled

Impersonate => EnabledByDefault, Enabled

CreateGlobal => EnabledByDefault, Enabled

IncreaseWorkingSet => Disabled

TimeZone => Disabled

CreateSymbolicLink => Disabled

9:24:41 AM.268:Thread:1: Using WIMGAPI from C:\Program Files (x86)\stefanRTR\Win Integrator\wimgapi.dll

9:25:01 AM.199:Thread:1: Wim selected:D:\windows 7 setup\sources\install.wim

9:25:01 AM.258:Thread:1: WimImageInfo Loaded:Windows 7 Home Basic_6.1.7600.16385_x64_en-US

9:25:01 AM.258:Thread:1: WimImageInfo Loaded:Windows 7 Home Premium_6.1.7600.16385_x64_en-US

9:25:01 AM.258:Thread:1: WimImageInfo Loaded:Windows 7 Professional_6.1.7600.16385_x64_en-US

9:25:01 AM.258:Thread:1: WimImageInfo Loaded:Windows 7 Ultimate_6.1.7600.16385_x64_en-US

9:25:05 AM.505:Thread:1: WimImage selected:Windows 7 Ultimate_6.1.7600.16385_x64

9:25:05 AM.542:Thread:3: WimImageInfo Loaded:Microsoft Windows PE (x64)_6.1.7600.16385_x64_en-US

9:25:05 AM.542:Thread:3: WimImageInfo Loaded:Microsoft Windows Setup (x64)_6.1.7600.16385_x64_en-US

9:25:05 AM.882:Thread:3: EXCEPTION: LoadPackages2 Unable to find an entry point named 'WIMExtractImagePath' in DLL 'wimgapi.dll'.

LoadPackages2 Unable to find an entry point named 'WIMExtractImagePath' in DLL 'wimgapi.dll'.

--- EXCEPTION #1/2 [EntryPointNotFoundException]

Message = “Unable to find an entry point named 'WIMExtractImagePath' in DLL 'wimgapi.dll'.”

ExceptionPath = Root.InnerException

ClassName = System.EntryPointNotFoundException

HResult = -2146233053

Source = stefanRTR.Base

StackTraceString = “

at stefanRTR.WimImage.Native.thfl5yGxf(IntPtr , String , String , UInt32 )

at stefanRTR.WimImage.Native.ExtractImagePath(IntPtr handle, String imagePath, String destinationPath)

at stefanRTR.WimImage.SevenImage.QaiUv6ciCIl823GL06.2tyPfN6UM()

at stefanRTR.ErrorHandling.Catch(String comment, Action action)

--- Outer ---

--- EXCEPTION #2/2 [ArgumentException]

Message = “LoadPackages2 Unable to find an entry point named 'WIMExtractImagePath' in DLL 'wimgapi.dll'.”

ExceptionPath = Root

ClassName = System.ArgumentException

InnerException = “Exception #1 at Root.InnerException”

HResult = -2147024809

i installed the windows 7 WAIK and net framework 4 beta.

0

Share this post


Link to post
Share on other sites

which fileversion does the wimgapi.dll in C:\Program Files (x86)\stefanRTR\Win Integrator\ have? Is it really the Windows 7 version?

0

Share this post


Link to post
Share on other sites

6.0.6001.18000 is the file version, that is the vista one correct? i uninstalled the vista WAIK then installed the 7 one too

0

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.