stefanRTR

stefanRTR's Win Integrator

229 posts in this topic

Stefan,

I'm probably doing something very basic wrong, but I cant see what.. This is de error I get:

Win Integrator Version=1.0.2.6
Unable to open/create .wim file D:\sources\install.wim. Error = 27

--- EXCEPTION #1/1 [InvalidOperationException]
Message = “Unable to open/create .wim file D:\sources\install.wim. Error = 27”
ExceptionPath = Root
ClassName = System.InvalidOperationException
HResult = -2146233079
Source = stefanRTR.Base
StackTraceString = “
at stefanRTR.WimImage.Native.CreateFile(String imageFile, AccessFlags access, Disposition mode, ActionFlags flagsAndAttributes, CompressionType compressionType, CreationResult& result)
at stefanRTR.WimImage.WimInfo..ctor(String wimPath)
at WinIntegrator.Start.iOPIpbGG6WubARTpJV.VAlbMBnRq()
at stefanRTR.ErrorHandling.Catch(String comment, Action action)

I've selected the root of my Win 7 dvd and this is the error. Running on win7 x64.

TIA

0

Share this post


Link to post
Share on other sites

Ran version 1.0.2.x, but I have been getting error while integrating multidirectory ATI drivers.

I checked off ATI drivers and everything went on fine!

btw any idea as to how should one delete the tmp directory files and source files/directories as once error has occurred the permissions to delete these files/directory are also lost. Taking ownership doesn't help, but after several attempts to change the permission this can be done, but it certainly is cumbersome and irritating! Any ideas how to delete this junk evolved out of error ?

0

Share this post


Link to post
Share on other sites
Ran version 1.0.2.x, but I have been getting error while integrating multidirectory ATI drivers.
What is a "multidirectory" ATI driver?

If you mean the multilingual ATI Catalyst graphics driver, you have to expand all compressed files, before you integrate the driver.

btw any idea as to how should one delete the tmp directory files and source files/directories as once error has occurred the permissions to delete these files/directory are also lost. Taking ownership doesn't help, but after several attempts to change the permission this can be done, but it certainly is cumbersome and irritating! Any ideas how to delete this junk evolved out of error ?
As soon as you have shut the WinIntegrator and all open processes related to it, you can easily delete the whole C:\tmp directory without any problem.
0

Share this post


Link to post
Share on other sites

Now I'm getting the following problem. All I am doing to an unmodified image is enabling the pre-included games (Chess, etc...) to the Windows 7 Professional image. Again, I have installed WAIK for Windows 7 and the most recent .net 4 Beta. My host computer is running Vista SP1.

Log file:

WinIntegrator.2009_11_28T21_04_24.txt

Windows Integrator Error:

post-158493-1259417834_thumb.jpg

Servicing Directory Screenshot in WAIK:

post-158493-1259417854_thumb.jpg

Anyone provide any insight on this one?

0

Share this post


Link to post
Share on other sites

@radigast

You get the following error while enabling Chess:

//

// MessageId: ERROR_FLT_INVALID_NAME_REQUEST

//

// MessageText:

//

// An invalid name request was made. The name requested cannot be retrieved at this time.

//

#define ERROR_FLT_INVALID_NAME_REQUEST _HRESULT_TYPEDEF_(0x801F0005L)

0

Share this post


Link to post
Share on other sites

Hi Alex,

could you please post the errors from the CBS.log?

0

Share this post


Link to post
Share on other sites

Hi, MagicAndre1981!

Errros mostly for IIS though I left it ubchecked... Maybe the log can help.

Alex

CBS.rar

0

Share this post


Link to post
Share on other sites
What is a "multidirectory" ATI driver?

If you mean the multilingual ATI Catalyst graphics driver, you have to expand all compressed files, before you integrate the driver.

What I mean is if the inf file of drivers is at root, the drivers and few other files are located in more than two multilevel folders. This is more like creative drivers, which have inf files pointing out various subdirectories for associated files!

As soon as you have shut the WinIntegrator and all open processes related to it, you can easily delete the whole C:\tmp directory without any problem.

No this doesn't help, even reboot doesn't help! In fact, it is related to termination of program and simultaneous lack of unmounting of image and also the wim file. A flawless exit of program or manual exit of program ensures proper dismounting of the mounted files, otherwise they remain mounted and cannot be accessed that way. Only way out is to change permission by allowing all operations. Little cumbersome but works after few efforts.

0

Share this post


Link to post
Share on other sites

@ clavicle:

If you want to integrate the newest ATI Catalyst 9-11, you may take the drivers I have already prepared for this procedure (all compressed files have been expanded).

Here are the download links:

32bit ATI Catalyst driver 9-11 for Win7 x86 (prepared for integration)

64bit ATI Catalyst driver 9-11 for Win7 x64 (prepared for integration)

Edited by Fernando 1
0

Share this post


Link to post
Share on other sites
If you want to integrate the newest ATI Catalyst 9-11, you may take the drivers I have already prepared for this procedure (all compressed files have been expanded).

@Fernando 1

Thanks for these, I've been searching, trying to find a way to do this.

I get this error on the 64bit drivers

2009-11-29 11:20:40, Error				 DISM   DISM Driver Manager: PID=3884 Failed to install the driver package 'C:\zMountDir\Drivers\graphic\C7_91527.inf'. - CDmiDriverStore::Import(hr:0x80070002)
2009-11-29 11:20:40, Error DISM DISM Driver Manager: PID=3884 Failed to install the driver package 'C:\zMountDir\Drivers\graphic\C7_91527.inf'. - CDriverPackage::InternalInstall(hr:0x80070002)
2009-11-29 11:20:40, Error DISM DISM Driver Manager: PID=3884 d:\w7rtm\base\ntsetup\opktools\dism\providers\dmiprovider\dll\driverpackage.cpp:433 - CDriverPackage::Install(hr:0x80070002)
2009-11-29 11:20:40, Info DISM DISM Driver Manager: PID=3884 Driver package C:\zMountDir\Drivers\graphic\C7_91527.inf failed to install. (hr:0x80070002). - CDriverManager::AddDriverPackagesFromCollection
2009-11-29 11:20:47, Error DISM DISM Driver Manager: PID=3884 Failed to install the driver package 'C:\zMountDir\Drivers\graphic\CH_91527.inf'. - CDmiDriverStore::Import(hr:0x80070002)
2009-11-29 11:20:47, Error DISM DISM Driver Manager: PID=3884 Failed to install the driver package 'C:\zMountDir\Drivers\graphic\CH_91527.inf'. - CDriverPackage::InternalInstall(hr:0x80070002)
2009-11-29 11:20:47, Error DISM DISM Driver Manager: PID=3884 d:\w7rtm\base\ntsetup\opktools\dism\providers\dmiprovider\dll\driverpackage.cpp:433 - CDriverPackage::Install(hr:0x80070002)
2009-11-29 11:20:47, Info DISM DISM Driver Manager: PID=3884 Driver package C:\zMountDir\Drivers\graphic\CH_91527.inf failed to install. (hr:0x80070002). - CDriverManager::AddDriverPackagesFromCollection

Edited by jbm
0

Share this post


Link to post
Share on other sites

Your program looks great! :)

Im trying it out now, just pressed apply.

Is it possible for me to translate it to swedish? I woudnt mind helping as much as i can:)

Shoudnt you and blue 4603 (Creator of 7Costumizer) work together? you could do alot of stuff :P

Edit: Uhm, im not sure wether this is on the to-do-list being able to delete versions from the win7 dvd/folder would be nice to.

Edited by tcntad
0

Share this post


Link to post
Share on other sites
@Fernando 1

Thanks for these, I've been searching, trying to find a way to do this.

I get this error on the 64bit drivers

I only tested the ATI drivers, which I had uploaded and linked, with stefanRTR's "WinIntegrator".

Which tool did you take?

0

Share this post


Link to post
Share on other sites

Ah Goodevening :P

Im trying to integrate some stuff on my win7 AIO DVD (english btw, and i picked 32bit ultimate)..

After selecting all my stuff and pressy apply.. i get the error "cannot mount image" or something similar :P

I took a look in the logfile and i found this:

12:11:43 AM.953:Thread:1: Steps = 5
00:11:43.953:Thread:8: Starting MainDoWork
00:11:43.954:Thread:8: Mounting F:\7Costumizer\DVD\sources\install.wim image index 5 to F:\7Costumizer\temp\1994md0
00:11:44.534:Thread:8: Unable to mount image F:\7Costumizer\DVD\sources\install.wim to F:\7Costumizer\temp\1994md0. Error = -1052638937
00:11:44.534:Thread:8: Image Mounted = False
00:11:46.371:Thread:8: Rebuilding
00:11:46.376:Thread:8: Rebuilding Windows 7 Ultimate
00:18:51.482:Thread:8: Result = True
00:18:52.751:Thread:8: Done

I can provide the whole log if you want but all i can see is packages etc.

0

Share this post


Link to post
Share on other sites

@fernado

Thanks for the drivers, I haven't tried them. But before using these I will have to modify the inf file to let it support my 4570 chip. I will let you know the result!

0

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.