Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

stefanRTR's Win Integrator


  • This topic is locked This topic is locked
228 replies to this topic

#26
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,124 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

could you please post the log file?
Posted Image


How to remove advertisement from MSFN

#27
stefanRTR

stefanRTR

    WinIntegrator Developer

  • Member
  • 29 posts
  • Joined 20-June 09

** EDIT**
using Version 1.0.2.4 Beta

gettin a Dism Exitcode50 error m8



I integrated some updates and I tested in VM. WU seems to be satisfied.
But when I open the image and go to remove items I see that some updates are twice listed. Why?

Posted Image


Working on both issues.

#28
TheSickman

TheSickman

    Junior

  • Member
  • Pip
  • 52 posts
  • Joined 16-July 06
Stefan, Great tool

got a few little thingies

from time to time i get mount errors
when i close program then and start it again it runs ok
log included

It also would be nice when adding drivers,
You could select a folder
or
when you wanna check them boxxes
you could choose more then one at a time (keeping shift pressed)

Posted Image

Attached Files


Edited by TheSickman, 25 November 2009 - 12:50 PM.


#29
stefanRTR

stefanRTR

    WinIntegrator Developer

  • Member
  • 29 posts
  • Joined 20-June 09

** EDIT**
using Version 1.0.2.4 Beta
gettin a Dism Exitcode50 error m8


I integrated some updates and I tested in VM. WU seems to be satisfied.
But when I open the image and go to remove items I see that some updates are twice listed. Why?



Fixed in Version 1.0.2.5.
First post updated.

Edited by stefanRTR, 25 November 2009 - 02:39 PM.


#30
bfc_xxx

bfc_xxx

    Member

  • Member
  • PipPip
  • 158 posts
  • Joined 17-May 04

** EDIT**
using Version 1.0.2.4 Beta
gettin a Dism Exitcode50 error m8


I integrated some updates and I tested in VM. WU seems to be satisfied.
But when I open the image and go to remove items I see that some updates are twice listed. Why?



Fixed in Version 1.0.2.5.
First post updated.



wow superfast. Thank you

#31
cluberti

cluberti

    Gustatus similis pullus

  • Supervisor
  • 11,252 posts
  • Joined 09-September 01
  • OS:Windows 8.1 x64
  • Country: Country Flag
Out of alpha and into beta, pinned.
MCTS Windows Internals, MCITP Server 2008 EA, MCTS MDT/BDD, MCSE/MCSA Server 2003, Server 2012, Windows 8
--------------------
Please read the rules before posting!
Please consider donating to MSFN to keep it up and running!

#32
geese howard

geese howard

    Junior

  • Member
  • Pip
  • 77 posts
  • Joined 10-May 04
Any flawless set to share?
PhenomII x4 920 Asus M3A78 4GB DDR2 Radeon 4870 HyperTX2 DVD Pioneer 112L

#33
Alex

Alex

    Member

  • Member
  • PipPip
  • 223 posts
  • Joined 08-September 04
@stefanRTR

check this out. Some lines are doubled, and winintegrator tries to remove the same packages twice. Done with 1.0.2.5. As a rezult the enable features on and off is brken.

Aleū


<Remove_Packages>
<Package Name="Microsoft-Windows-Backup-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-Shell-PremiumInboxGames-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-LocalPack-AU-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-LocalPack-CA-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-LocalPack-GB-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-LocalPack-US-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-LocalPack-ZA-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-NetFx3-OC-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-Shell-HomeGroup-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-PeerToPeer-Full-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-RemoteAssistance-Package-Client" Culture="neutral" />
<Package Name="Microsoft-Windows-RasRip-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-SNMP-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-SimpleTCP-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-Telnet-Client-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-Telnet-Server-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-TFTP-Client-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-RemoteAssistance-Package-Client" Culture="neutral" />
<Package Name="Microsoft-Windows-SimpleTCP-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-SNMP-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-WMI-SNMP-Provider-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-Anytime-Upgrade-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-Anytime-Upgrade-Results-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-RDC-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-SystemRestore-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-RecDisc-SDP-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-SearchEngine-Client-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-WMI-SNMP-Provider-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-TabletPC-OC-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-VirtualPC-USB-RPM-Package" Culture="neutral" />
<Package Name="Microsoft-Windows-VirtualPC-Licensing-Package" Culture="neutral" />
</Remove_Packages>
<Configure_Features />
</WI_Preset>

#34
shilyro

shilyro

    Junior

  • Member
  • Pip
  • 72 posts
  • Joined 15-December 07
Sovled

Edited by shilyro, 25 November 2009 - 11:08 PM.


#35
clavicle

clavicle

    Advanced Member

  • Member
  • PipPipPip
  • 454 posts
  • Joined 28-January 04
  • OS:Windows 7 x64
  • Country: Country Flag
@stefanRTR
Congrats for moving program into beta!

Earlier version couldn't get past exitcode '50'. I will try the new one immediately and post my results!

Though it must be in your mind, but could you implement autosaving of the presets?

#36
stefanRTR

stefanRTR

    WinIntegrator Developer

  • Member
  • 29 posts
  • Joined 20-June 09

Stefan, Great tool

got a few little thingies

from time to time i get mount errors
when i close program then and start it again it runs ok
log included

It also would be nice when adding drivers,
You could select a folder
or
when you wanna check them boxxes
you could choose more then one at a time (keeping shift pressed)


To add all drivers from a folder you can type inf in the searchbox of the openfiledialog.


@stefanRTR

check this out. Some lines are doubled, and winintegrator tries to remove the same packages twice. Done with 1.0.2.5. As a rezult the enable features on and off is brken.

Aleū

Fixed in Version 1.0.2.6. Can you try enable features on and off again?

Though it must be in your mind, but could you implement autosaving of the presets?

Maybe in Version 1.0.3X

@all
New Version 1.0.2.6 first post updated.

#37
d0p3y2k4

d0p3y2k4

    Junior

  • Member
  • Pip
  • 55 posts
  • Joined 03-May 05
i get this error when trying to remove dvd maker

Win Integrator Version=1.0.2.6
failed to load registry key

--- EXCEPTION #1/1 [Win32Exception]
Message = “failed to load registry key”
ExceptionPath = Root
NativeErrorCode = -2145452027
ClassName = System.ComponentModel.Win32Exception
HResult = -2147467259
Source = stefanRTR.Base
StackTraceString = “
at SZ7a5ctv4NXeS77YHn.Xou3JvUnUgfQbNt8Lf.GqpcQgjrp(String )
at stefanRTR.WimImage.SevenImage.78tgITEZRg1FR1ZlxM.Jnqc0l5ML()
at stefanRTR.ErrorHandling.Catch(String comment, Action action)


#38
Alex

Alex

    Member

  • Member
  • PipPip
  • 223 posts
  • Joined 08-September 04
@stefanRTR

Win Integrator Version=1.0.2.6


4:10:54 AM.602:Thread:4: Removeing Package : Microsoft-Windows-IIS-WebServer-AddOn-Package~31bf3856ad364e35~x86~~6.1.7600.16385
4:11:02 AM.413:Thread:4: ExitCode = -2146498555
4:11:59 AM.213:Thread:4: Removeing Package : Microsoft-Windows-NetFx3-OC-Package~31bf3856ad364e35~x86~~6.1.7600.16385
4:12:07 AM.128:Thread:4: ExitCode = -2146498555
4:14:30 AM.006:Thread:4: Removeing Package : Microsoft-Windows-WMI-SNMP-Provider-Package~31bf3856ad364e35~x86~~6.1.7600.16385
4:14:38 AM.837:Thread:4: ExitCode = -2146498555
4:15:41 AM.011:Thread:4: Removeing Package : Microsoft-Windows-MSMQ-Client-Package~31bf3856ad364e35~x86~~6.1.7600.16385
4:15:48 AM.780:Thread:4: ExitCode = -2146498555

3:30:36 AM.702:Thread:3: Removeing Package : Microsoft-Windows-RemoteAssistance-Package-Client~31bf3856ad364e35~x86~~6.1.7600.16385
3:30:44 AM.792:Thread:3: ExitCode = -2146498555
3:30:44 AM.802:Thread:3: Removeing Package : Microsoft-Windows-SimpleTCP-Package~31bf3856ad364e35~x86~~6.1.7600.16385
3:30:53 AM.041:Thread:3: ExitCode = -2146498555
3:30:53 AM.051:Thread:3: Removeing Package : Microsoft-Windows-SNMP-Package~31bf3856ad364e35~x86~~6.1.7600.16385

The same exit code is for net fx3 and media center, all drivers except printer drivers.

Alex

Edited by Alex, 26 November 2009 - 08:43 PM.


#39
stefanRTR

stefanRTR

    WinIntegrator Developer

  • Member
  • 29 posts
  • Joined 20-June 09
@Alex

Can you post the complete log file?

#40
Alex

Alex

    Member

  • Member
  • PipPip
  • 223 posts
  • Joined 08-September 04
@stefanRTR,

Full removal log and partial. Removing all drivers gives blue screen on the first boot after the begining of the installation. Partial removal of drivers works only for printer drivers.

Alex

Attached Files

  • Attached File  Logs.rar   7.79KB   10 downloads

Edited by Alex, 27 November 2009 - 07:57 PM.


#41
Fernando 1

Fernando 1

    Easy RAIDer

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,021 posts
  • Joined 03-June 05
  • OS:Windows 7 x64
@ Alex:

Oh, that is a very voluminous post!
It would have been better, if you just had attached the LOG file.

Regards
Fernando
My current system:
ASUS P8Z68-V | Intel Core i5 2500K | 2x4 GB Corsair XMS3 DDR3-1600 | 2x128GB Crucial M4 SSD as RAID0 in SATA3 mode | Seasonic M12II-520 Modular 520W | ATI Radeon HD6850 1 GB GDDR5
My old system:
DFI nF4 Ultra-D (BIOS: 2006/04/06) | AMD Athlon64 4000+ San Diego | 2x512 MB OCZ PC3200 CL2 Rev.2 Platinum | 2x200 GB Samsung S-ATA II as Raid0 | beQuiet!Titan BQT P5-470W-S1.3 | MSI GeForce NX6600GT-TD128E

#42
radigast

radigast

    Junior

  • Member
  • Pip
  • 79 posts
  • Joined 16-October 07
Your program is a great idea. However, when I used it to try and integrate updates/localpacks and enable built-in games, errors have closed the program. Kind of frustrating, as the process took about 1.5 hours before the program closed down.

I am integrating into a vanilla Windows 7 image copied directly from DVD, and have selected Windows 7 Professional as the image to update. I have installed WAIK for Windows 7, and (obviously) the latest .net4 Beta. My host machine runs Vista SP1.

I hope the attached log file helps.

Attached File  WinIntegrator.2009_11_28T09_12_42.txt   86.49KB   38 downloads

Edited by radigast, 27 November 2009 - 09:59 PM.

Only in America do we have drive up ATM's with braile on them.

#43
ricktendo

ricktendo

    Group: Banned Members

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,310 posts
  • Joined 06-June 06
  • OS:Windows 7 x64
  • Country: Country Flag
Bootcritical-Option nice...

Edited by ricktendo64, 27 November 2009 - 11:29 PM.


#44
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,124 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

@radigast

the log says, that you don't have the permissions to file E:\Temp\Windows7\Modified\sources\install_Windows 7 STARTER.clg and E:\Temp\Windows7\Modified\sources\ei.cfg. The access is denied.

And why do you integrate those leaked test updates (KB1xxxxx, 6xxxxx)? Look for the KB articles and if they fix an issue you have, request them.
Posted Image

#45
radigast

radigast

    Junior

  • Member
  • Pip
  • 79 posts
  • Joined 16-October 07

the log says, that you don't have the permissions to file E:\Temp\Windows7\Modified\sources\install_Windows 7 STARTER.clg and E:\Temp\Windows7\Modified\sources\ei.cfg. The access is denied.

I figured out why there was a problem. When I copied the folders from the DVD, they all were copied over with Read-Only permission. Prior to running Win Integrator, I had unchecked the Read-Only box for the install folder and applied this to all of its contents. However, apparently this was not enough, as a few stubborn files still retained their Read-Only status. I had to manually go into each file, and check to see if it was Read-Only. The *.elg files were a few of the culprits.

And why do you integrate those leaked test updates (KB1xxxxx, 6xxxxx)? Look for the KB articles and if they fix an issue you have, request them.

I am simply integrating an update pack I found over at WinCert (by George King). I'll check the technet articles and see what each hotfix does...but, as I haven't installed Windows 7 on my mainbox, I guess I can't really be sure of the issues it will have yet.

Thanks for the response

Edit: I wasn't even aware that KB1xxxxx and KB6xxxxx were test updates. I'll remove them from my slipstream. Again, thanks for the info!

Edited by radigast, 28 November 2009 - 06:48 AM.

Only in America do we have drive up ATM's with braile on them.

#46
Trialandterror

Trialandterror
  • Member
  • 1 posts
  • Joined 28-November 09
Stefan,

I'm probably doing something very basic wrong, but I cant see what.. This is de error I get:

Win Integrator Version=1.0.2.6
Unable to open/create .wim file D:\sources\install.wim. Error = 27

--- EXCEPTION #1/1 [InvalidOperationException]
Message = “Unable to open/create .wim file D:\sources\install.wim. Error = 27”
ExceptionPath = Root
ClassName = System.InvalidOperationException
HResult = -2146233079
Source = stefanRTR.Base
StackTraceString = “
  at stefanRTR.WimImage.Native.CreateFile(String imageFile, AccessFlags access, Disposition mode, ActionFlags flagsAndAttributes, CompressionType compressionType, CreationResult& result)
	 at stefanRTR.WimImage.WimInfo..ctor(String wimPath)
	 at WinIntegrator.Start.iOPIpbGG6WubARTpJV.VAlbMBnRq()
	 at stefanRTR.ErrorHandling.Catch(String comment, Action action)
”

I've selected the root of my Win 7 dvd and this is the error. Running on win7 x64.

TIA

#47
clavicle

clavicle

    Advanced Member

  • Member
  • PipPipPip
  • 454 posts
  • Joined 28-January 04
  • OS:Windows 7 x64
  • Country: Country Flag
Ran version 1.0.2.x, but I have been getting error while integrating multidirectory ATI drivers.

I checked off ATI drivers and everything went on fine!

btw any idea as to how should one delete the tmp directory files and source files/directories as once error has occurred the permissions to delete these files/directory are also lost. Taking ownership doesn't help, but after several attempts to change the permission this can be done, but it certainly is cumbersome and irritating! Any ideas how to delete this junk evolved out of error ?

#48
Fernando 1

Fernando 1

    Easy RAIDer

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,021 posts
  • Joined 03-June 05
  • OS:Windows 7 x64

Ran version 1.0.2.x, but I have been getting error while integrating multidirectory ATI drivers.

What is a "multidirectory" ATI driver?
If you mean the multilingual ATI Catalyst graphics driver, you have to expand all compressed files, before you integrate the driver.

btw any idea as to how should one delete the tmp directory files and source files/directories as once error has occurred the permissions to delete these files/directory are also lost. Taking ownership doesn't help, but after several attempts to change the permission this can be done, but it certainly is cumbersome and irritating! Any ideas how to delete this junk evolved out of error ?

As soon as you have shut the WinIntegrator and all open processes related to it, you can easily delete the whole C:\tmp directory without any problem.
My current system:
ASUS P8Z68-V | Intel Core i5 2500K | 2x4 GB Corsair XMS3 DDR3-1600 | 2x128GB Crucial M4 SSD as RAID0 in SATA3 mode | Seasonic M12II-520 Modular 520W | ATI Radeon HD6850 1 GB GDDR5
My old system:
DFI nF4 Ultra-D (BIOS: 2006/04/06) | AMD Athlon64 4000+ San Diego | 2x512 MB OCZ PC3200 CL2 Rev.2 Platinum | 2x200 GB Samsung S-ATA II as Raid0 | beQuiet!Titan BQT P5-470W-S1.3 | MSI GeForce NX6600GT-TD128E

#49
radigast

radigast

    Junior

  • Member
  • Pip
  • 79 posts
  • Joined 16-October 07
Now I'm getting the following problem. All I am doing to an unmodified image is enabling the pre-included games (Chess, etc...) to the Windows 7 Professional image. Again, I have installed WAIK for Windows 7 and the most recent .net 4 Beta. My host computer is running Vista SP1.

Log file:
Attached File  WinIntegrator.2009_11_28T21_04_24.txt   26.88KB   16 downloads

Windows Integrator Error:
Attached File  Win_Integrator.jpg   53.76KB   60 downloads

Servicing Directory Screenshot in WAIK:
Attached File  Servicing.jpg   44.83KB   41 downloads

Anyone provide any insight on this one?
Only in America do we have drive up ATM's with braile on them.

#50
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,124 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

@radigast

You get the following error while enabling Chess:

//
// MessageId: ERROR_FLT_INVALID_NAME_REQUEST
//
// MessageText:
//
// An invalid name request was made. The name requested cannot be retrieved at this time.
//
#define ERROR_FLT_INVALID_NAME_REQUEST _HRESULT_TYPEDEF_(0x801F0005L)


Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users