Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

stefanRTR's Win Integrator


  • This topic is locked This topic is locked
228 replies to this topic

#126
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,959 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

You fail to mount the boot.wim. Run the DISM Cleanup command and try again.
Posted Image


How to remove advertisement from MSFN

#127
morgrym

morgrym
  • Member
  • 9 posts
I really appreciate all your hard work and am "rebuilding Image" now so well see how it goes.
I had some questions;
Will there be a "services" tab to set the startup type of each service later?
I noticed a screen shot of a previous version that says something like "check the box to enable features, uncheck to disable" that is not in the new version. Better explanations for the windows would be simple and nice.
Anyone know where can I find just the important updates or hot fixes maybe in a pack?
Can I run vlite after this to modify the services startup and remove services?
Thx Mike

#128
grabben

grabben

    -Grabben

  • Member
  • PipPipPipPip
  • 601 posts
  • OS:Windows 7 x64
  • Country: Country Flag

I really appreciate all your hard work and am "rebuilding Image" now so well see how it goes.
I had some questions;
Will there be a "services" tab to set the startup type of each service later?
I noticed a screen shot of a previous version that says something like "check the box to enable features, uncheck to disable" that is not in the new version. Better explanations for the windows would be simple and nice.
Anyone know where can I find just the important updates or hot fixes maybe in a pack?
Can I run vlite after this to modify the services startup and remove services?
Thx Mike



Not sure if that'd work but you can always use 7Costumizer, which has everything besides the remove components tab.


Edit:

Hey guys and girls, im trying to integrate Vista Service Pack 2 on my Vista SP1 (AIO) DVD, but im gettin; "Dism Exitcode 50"..

Tried twice and also cleand up the mountpoints but still.. Whats wrong? :/

Edited by grabben, 18 January 2010 - 02:29 PM.


#129
Fernando 1

Fernando 1

    Easy RAIDer

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,021 posts
  • OS:Windows 7 x64

Hey guys and girls, im trying to integrate Vista Service Pack 2 on my Vista SP1 (AIO) DVD, but im gettin; "Dism Exitcode 50"..
Tried twice and also cleand up the mountpoints but still.. Whats wrong? :/

AFAIK the tool "Win Integrator" is only designed for adding/removing/tweaking things of a Windows 7 DVD and not for doing this with Vista.
My current system:
ASUS P8Z68-V | Intel Core i5 2500K | 2x4 GB Corsair XMS3 DDR3-1600 | 2x128GB Crucial M4 SSD as RAID0 in SATA3 mode | Seasonic M12II-520 Modular 520W | ATI Radeon HD6850 1 GB GDDR5
My old system:
DFI nF4 Ultra-D (BIOS: 2006/04/06) | AMD Athlon64 4000+ San Diego | 2x512 MB OCZ PC3200 CL2 Rev.2 Platinum | 2x200 GB Samsung S-ATA II as Raid0 | beQuiet!Titan BQT P5-470W-S1.3 | MSI GeForce NX6600GT-TD128E

#130
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,959 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

@Fernando

No, it also integrates Sp2 in Vista.

@grabben

use a clean MS ISO with integrated SP1.

If you use a Vista with Sp1 which was slipstreamed with vLite, you'll damage your install.wim. When you install the Vista it is broken and not installable.

All other ones fail. This is why MS disabled the slipstream option. It only works if you have a clean DVD with Sp (n-1) (where n is the SP you want to integrate. For Sp1 you can use a clean RTM (Sp0) disc, for Sp2 you need a Vista Sp1 DVD).
Posted Image

#131
grabben

grabben

    -Grabben

  • Member
  • PipPipPipPip
  • 601 posts
  • OS:Windows 7 x64
  • Country: Country Flag

@Fernando

No, it also integrates Sp2 in Vista.

@grabben

use a clean MS ISO with integrated SP1.

If you use a Vista with Sp1 which was slipstreamed with vLite, you'll damage your install.wim. When you install the Vista it is broken and not installable.

All other ones fail. This is why MS disabled the slipstream option. It only works if you have a clean DVD with Sp (n-1) (where n is the SP you want to integrate. For Sp1 you can use a clean RTM (Sp0) disc, for Sp2 you need a Vista Sp1 DVD).


Yea got that.

Im using a vista retail SP1 DVD and trying to integrate SP2 using Win Integrator, it works on my laptop (same dvd) but on computer it doesnt (and thats not the only thats not working..).

Well i just dont want to reinstall waik or win integrator, just hate that when it doesnt work properly....

Thanks for reply.

#132
Bishop

Bishop

    Newbie

  • Member
  • 34 posts
So... I've come across "dism exitcode'8' :rolleyes:

I don't have the experience or the know-how to find what the problem is. I suspect Win Integrator's last action is the one that causes the error?
In that case "KB974065" is doing something.

I have searched for the exitcode here and in the rest of the forum but I can't find any reference.
I've posted my log below. Any idea's?

Cheers.

Attached Files



#133
grabben

grabben

    -Grabben

  • Member
  • PipPipPipPip
  • 601 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Probably beacuse of driver integration or some component removal but most likely cus of integration.

#134
blueadmin7

blueadmin7
  • Member
  • 5 posts
I'm using WinIntegrator for the first time.
Downloaded everything from the first post and installed it without a problem.
I launched WI on my WIN7 ULT 64 (jp), it seems to run fine but when I push "SELECT" to nothing happens.
Just the spinning(waiting) mouse icon show up.
I was hoping a file selector window would appear but...

Anyhow I tried re-installing the all neccessary program twice but same result.
Anyone with similar behavior?

Version 1.0.2.7 Beta
Microsoft .NET Framework 4 Client Profile Beta 2 (Yes I rebooted the OS after install)
Windows Automated Installation Kit (AIK) for Windows® 7

#135
Alex

Alex

    Member

  • Member
  • PipPip
  • 223 posts
@stefanRTR

Back to winintegrator! Working great, some small adjustments:
1) though I uncheck More games option in Features they are back again then I remount lited image. This happens only with win7 ultimate version but it would take much time to find out what cuases this behaviuor.
2)Print and document services options for Ultimate are not saved in preset.

Would be nice to add language removal detailed option to remove at least biggest language files: chinesse etc.

Using winintegator on win7 ult with recapturing after install I get install.wim 1511mb. This is with netframework and homeroup left in. Removing just speech recognition with vlite drops wim size to 1200mb! Suggest you to add tjis feature too, but as far as I remember speech reoval was integrated into vista not as separate package, but as a part of core...

Great and very clean removal, flalwless integration! Thank you!

@all

never had unmount error or any other errors. Very simple. Install win 7, disable netframework 3.51, install net framework 4 beta version, waik and winintegrator. Backup drive. Test! That simple!

Pls let stefan to concentrate on removals, not on unmount problems!
If You get dism exit code 5 while integratinf the drivers, check file properties and it will get obvious why winintegtator can not integrate it. Most commonly it will be blocked file as gotten from other pc.

Cheers,

Alex

Edited by Alex, 24 January 2010 - 03:38 PM.


#136
grabben

grabben

    -Grabben

  • Member
  • PipPipPipPip
  • 601 posts
  • OS:Windows 7 x64
  • Country: Country Flag
@ Alex

Aaah, well that might work, never thougt of that :P
Working on the component section is very important but i say taking care of all other and also unattended is fare more important, just like 7C.


So Stefan, when is the next version coming :P..

#137
Floppy

Floppy

    Member

  • Member
  • PipPip
  • 124 posts
Hey

Great tool.....Is there a "how to" somewhere....?

Can not add drivers when they still are rar'ed. :blushing:
Do I need to unpack all drivers, after dowloading them.... :huh:
When I tried to search for *.inf and add all "findings"....>error

Edited by Floppy, 28 January 2010 - 06:11 AM.


#138
grabben

grabben

    -Grabben

  • Member
  • PipPipPipPip
  • 601 posts
  • OS:Windows 7 x64
  • Country: Country Flag

Hey

Great tool.....Is there a "how to" somewhere....?

Can not add drivers when they still are rar'ed. :blushing:
Do I need to unpack all drivers, after dowloading them.... :huh:
When I tried to search for *.inf and add all "findings"....>error



This tool cant be moer simple to use. just look and click..


Why should u be able to integrate drivers when they're .rar'ed ? unpack them all and then integrate.

#139
Floppy

Floppy

    Member

  • Member
  • PipPip
  • 124 posts

This tool cant be moer simple to use. just look and click..


I was asking because ther might be more to it!



Why should u be able to integrate drivers when they're .rar'ed ? unpack them all and then integrate.

Iam used to DriverPack (You can find it here-->http://forum.driverpacks.net) using it for WinXp.
If this tool could integrate drivers without expanding the pack's....well that would be great. :thumbup

When I tried to search for *.inf and add all "findings"....>error
If i split the "add drivers"(from the search list) i two, it's ok....

Edited by Floppy, 28 January 2010 - 08:57 AM.


#140
maxXPsoft

maxXPsoft

    MSFN Master

  • Developer
  • 2,880 posts
  • OS:Windows 7 x64
  • Country: Country Flag

Iam used to DriverPack (You can find it here-->http://forum.driverpacks.net) using it for WinXp.
If this tool could integrate drivers without expanding the pack's....well that would be great. :thumbup

When I tried to search for *.inf and add all "findings"....>error
If i split the "add drivers"(from the search list) i two, it's ok....

But really, why would you want to add 100 drivers you don't need? Thats what those packs do. If you setting up on 10 different PC's then maybe so.
Use driver magician Free if you are on Win 7 and you are done, works also with Vista drivers on 7. 7 is pretty good about drivers for most part
Download ++> Windows 7 + 8 Unattended DVD + App Installer + Services Disabler + Load All Button + XML Creator
Jump2Reg - Registry: - Oct 4, 2013 - Version 3.0.4 - 98, ME, NT, 2K, XP, VISTA, Seven, Windows 8+ and 32 or 64 bit

XP Unattended CD/DVD creator - Version 4.1.7
Sample xml + Setupcomplete + Add Right click .wim Windows 7 or Windows 8/8.1

#141
Floppy

Floppy

    Member

  • Member
  • PipPip
  • 124 posts

If you setting up on 10 different PC's then maybe so.
Use driver magician Free if you are on Win 7 and you are done, works also with Vista drivers on 7. 7 is pretty good about drivers for most part



Iam setting up 20-25 Pc a week.....I hate looking for drivers.....

#142
maxXPsoft

maxXPsoft

    MSFN Master

  • Developer
  • 2,880 posts
  • OS:Windows 7 x64
  • Country: Country Flag

Iam setting up 20-25 Pc a week.....I hate looking for drivers.....

but I doubt very seriously you are setting up 20 different models. we use mostly dell at work, 4 diferent types so it's pretty straight forward what to include
Download ++> Windows 7 + 8 Unattended DVD + App Installer + Services Disabler + Load All Button + XML Creator
Jump2Reg - Registry: - Oct 4, 2013 - Version 3.0.4 - 98, ME, NT, 2K, XP, VISTA, Seven, Windows 8+ and 32 or 64 bit

XP Unattended CD/DVD creator - Version 4.1.7
Sample xml + Setupcomplete + Add Right click .wim Windows 7 or Windows 8/8.1

#143
hclarkjr

hclarkjr

    Member

  • Member
  • PipPip
  • 299 posts
  • OS:none specified
  • Country: Country Flag
why no support for vista service pack 2?

Cooler master HAF932, Dell 2408WFP, Gigabyte P67A-UD4 B3 REV. 1.1, Intel core I7 2600K@ 4GHZ, XIGMATEK SD-1283 Gaia, Intel X25-M G2 160GB, 16GB DDR3 1600 Gskill Ripjaws ,XFX radeon HD6950, Pioneer BDR-205, Samsung SH-S243N 24X DVD-RW, western digital black 2TB,Antec TPQ-850 850W , windows 8.1 pro X64


#144
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,959 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

it has support, but only for Integrating MUIs and updates. Removing only works with Windows 7, because of DISM Limitations.

Edited by MagicAndre1981, 31 January 2010 - 05:11 AM.

Posted Image

#145
hclarkjr

hclarkjr

    Member

  • Member
  • PipPip
  • 299 posts
  • OS:none specified
  • Country: Country Flag
will it integrate drivers also? can vlite integrate drivers into 7? i am going to be switching to 7 here shortly and want to integrate some drivers into it. also, is there solution for unattended yet? i want to integrate my key too.

Cooler master HAF932, Dell 2408WFP, Gigabyte P67A-UD4 B3 REV. 1.1, Intel core I7 2600K@ 4GHZ, XIGMATEK SD-1283 Gaia, Intel X25-M G2 160GB, 16GB DDR3 1600 Gskill Ripjaws ,XFX radeon HD6950, Pioneer BDR-205, Samsung SH-S243N 24X DVD-RW, western digital black 2TB,Antec TPQ-850 850W , windows 8.1 pro X64


#146
hclarkjr

hclarkjr

    Member

  • Member
  • PipPip
  • 299 posts
  • OS:none specified
  • Country: Country Flag
oops, sorry about that :blushing:

Edited by hclarkjr, 31 January 2010 - 07:37 AM.

Cooler master HAF932, Dell 2408WFP, Gigabyte P67A-UD4 B3 REV. 1.1, Intel core I7 2600K@ 4GHZ, XIGMATEK SD-1283 Gaia, Intel X25-M G2 160GB, 16GB DDR3 1600 Gskill Ripjaws ,XFX radeon HD6950, Pioneer BDR-205, Samsung SH-S243N 24X DVD-RW, western digital black 2TB,Antec TPQ-850 850W , windows 8.1 pro X64


#147
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,959 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

you want to know if Win Integrator runs on Vista Sp2? Yes! But you have to install the WAIK for Windows 7.
Posted Image

#148
hclarkjr

hclarkjr

    Member

  • Member
  • PipPip
  • 299 posts
  • OS:none specified
  • Country: Country Flag
ok, tried to run this on vista service pack 2 machine and got this error -

9:24:41 AM.252:Thread:1: Starting WinIntegrator, Version=1.0.2.0, Culture=neutral, PublicKeyToken=861173525dbe9e68
9:24:41 AM.268:Thread:1: Running on Microsoft Windows NT 6.0.6002 Service Pack 2 x64, ProcessorCount=4
9:24:41 AM.268:Thread:1: Privileges:
IncreaseQuota => Disabled
Security => Enabled
TakeOwnership => Enabled
LoadDriver => Disabled
SystemProfile => Disabled
SystemTime => Disabled
ProfileSingleProcess => Disabled
IncreaseBasePriority => Disabled
CreatePageFile => Disabled
Backup => Enabled
Restore => Enabled
Shutdown => Disabled
Debug => Enabled
SystemEnvironment => Disabled
ChangeNotify => EnabledByDefault, Enabled
RemoteShutdown => Disabled
Undock => Disabled
ManageVolume => Disabled
Impersonate => EnabledByDefault, Enabled
CreateGlobal => EnabledByDefault, Enabled
IncreaseWorkingSet => Disabled
TimeZone => Disabled
CreateSymbolicLink => Disabled

9:24:41 AM.268:Thread:1: Using WIMGAPI from C:\Program Files (x86)\stefanRTR\Win Integrator\wimgapi.dll
9:25:01 AM.199:Thread:1: Wim selected:D:\windows 7 setup\sources\install.wim
9:25:01 AM.258:Thread:1: WimImageInfo Loaded:Windows 7 Home Basic_6.1.7600.16385_x64_en-US
9:25:01 AM.258:Thread:1: WimImageInfo Loaded:Windows 7 Home Premium_6.1.7600.16385_x64_en-US
9:25:01 AM.258:Thread:1: WimImageInfo Loaded:Windows 7 Professional_6.1.7600.16385_x64_en-US
9:25:01 AM.258:Thread:1: WimImageInfo Loaded:Windows 7 Ultimate_6.1.7600.16385_x64_en-US
9:25:05 AM.505:Thread:1: WimImage selected:Windows 7 Ultimate_6.1.7600.16385_x64
9:25:05 AM.542:Thread:3: WimImageInfo Loaded:Microsoft Windows PE (x64)_6.1.7600.16385_x64_en-US
9:25:05 AM.542:Thread:3: WimImageInfo Loaded:Microsoft Windows Setup (x64)_6.1.7600.16385_x64_en-US

9:25:05 AM.882:Thread:3: EXCEPTION: LoadPackages2 Unable to find an entry point named 'WIMExtractImagePath' in DLL 'wimgapi.dll'.
LoadPackages2 Unable to find an entry point named 'WIMExtractImagePath' in DLL 'wimgapi.dll'.

--- EXCEPTION #1/2 [EntryPointNotFoundException]
Message = “Unable to find an entry point named 'WIMExtractImagePath' in DLL 'wimgapi.dll'.”
ExceptionPath = Root.InnerException
ClassName = System.EntryPointNotFoundException
HResult = -2146233053
Source = stefanRTR.Base
StackTraceString = “
at stefanRTR.WimImage.Native.thfl5yGxf(IntPtr , String , String , UInt32 )
at stefanRTR.WimImage.Native.ExtractImagePath(IntPtr handle, String imagePath, String destinationPath)
at stefanRTR.WimImage.SevenImage.QaiUv6ciCIl823GL06.2tyPfN6UM()
at stefanRTR.ErrorHandling.Catch(String comment, Action action)


--- Outer ---

--- EXCEPTION #2/2 [ArgumentException]
Message = “LoadPackages2 Unable to find an entry point named 'WIMExtractImagePath' in DLL 'wimgapi.dll'.”
ExceptionPath = Root
ClassName = System.ArgumentException
InnerException = “Exception #1 at Root.InnerException”
HResult = -2147024809


i installed the windows 7 WAIK and net framework 4 beta.

Cooler master HAF932, Dell 2408WFP, Gigabyte P67A-UD4 B3 REV. 1.1, Intel core I7 2600K@ 4GHZ, XIGMATEK SD-1283 Gaia, Intel X25-M G2 160GB, 16GB DDR3 1600 Gskill Ripjaws ,XFX radeon HD6950, Pioneer BDR-205, Samsung SH-S243N 24X DVD-RW, western digital black 2TB,Antec TPQ-850 850W , windows 8.1 pro X64


#149
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,959 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

which fileversion does the wimgapi.dll in C:\Program Files (x86)\stefanRTR\Win Integrator\ have? Is it really the Windows 7 version?
Posted Image

#150
hclarkjr

hclarkjr

    Member

  • Member
  • PipPip
  • 299 posts
  • OS:none specified
  • Country: Country Flag
6.0.6001.18000 is the file version, that is the vista one correct? i uninstalled the vista WAIK then installed the 7 one too

Cooler master HAF932, Dell 2408WFP, Gigabyte P67A-UD4 B3 REV. 1.1, Intel core I7 2600K@ 4GHZ, XIGMATEK SD-1283 Gaia, Intel X25-M G2 160GB, 16GB DDR3 1600 Gskill Ripjaws ,XFX radeon HD6950, Pioneer BDR-205, Samsung SH-S243N 24X DVD-RW, western digital black 2TB,Antec TPQ-850 850W , windows 8.1 pro X64





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users



How to remove advertisement from MSFN